cmdliner 1.0.2-1 source package in Ubuntu

Changelog

cmdliner (1.0.2-1) unstable; urgency=medium

  [ Hendrik Tews ]
  * New upstream version 1.0.2
  * compat level 10, standards version 4.0.0
  * add build dependency libresult-ocaml-dev
  * update VCS fields
  * add myself to uploaders
  * updated copyright
  * update rules: remove most of the overrides, build sequential because
    ocamlbuild would otherwise fail
  * remove .doc-base file: there is no documentation any more
  * fix .docs file
  * add patch install-x for removing x-permission in make install
  * add README.Debian to point to the online documentation
  * generate documentation with dh_ocamldoc, the command line switches in
    libcmdliner-ocaml-dev.ocamldoc have been copied from a run of ``topkg doc''
  * remove README.Debian again

  [ Mehdi Dogguy ]
  * Update Vcs-* fields to target Salsa

 -- Mehdi Dogguy <email address hidden>  Fri, 11 May 2018 15:30:44 +0200

Upload details

Uploaded by:
Debian OCaml Maintainers on 2018-05-11
Uploaded to:
Sid
Original maintainer:
Debian OCaml Maintainers
Architectures:
any
Section:
misc
Urgency:
Medium Urgency

See full publishing history Publishing

Series Pocket Published Component Section
Eoan release on 2019-04-18 universe misc
Disco release on 2018-10-30 universe misc
Cosmic release on 2018-05-21 universe misc

Downloads

File Size SHA-256 Checksum
cmdliner_1.0.2-1.dsc 2.0 KiB c6c74cca34826eb9fe253f0644dbc1791903c6d936214b4211555172c2a116e3
cmdliner_1.0.2.orig.tar.bz2 46.2 KiB 414ea2418fca339590abb3c18b95e7715c1086a1f7a32713a492ba1825bc58a2
cmdliner_1.0.2-1.debian.tar.xz 2.9 KiB 5dea9963bae4ba272f21e23d7f23636ce3b1b55d703d416fceeb1e239335cde9

No changes file available.

Binary packages built by this source

libcmdliner-ocaml-dev: declarative definition of command line interfaces

 It provides a simple and compositional mechanism to convert command
 line arguments to OCaml values and pass them to your functions.
 The module automatically handles syntax errors, help messages and
 UNIX man page generation. It supports programs with single or
 multiple commands (like darcs or git) and respects most of the POSIX
 and GNU conventions.
 .
 This package contains the development modules you need to use Cmdliner
 in your programs.

libcmdliner-ocaml-dev-dbgsym: debug symbols for libcmdliner-ocaml-dev