Change log for codetools package in Ubuntu

126 of 26 results
Published in hirsute-release on 2020-11-20
Deleted in hirsute-proposed (Reason: moved to Release)
codetools (0.2-18-1) unstable; urgency=medium

  * New upstream release

 -- Dirk Eddelbuettel <email address hidden>  Wed, 04 Nov 2020 16:37:30 -0600

Available diffs

Superseded in hirsute-proposed on 2020-11-05
codetools (0.2-17-1) unstable; urgency=medium

  * New upstream release

  * debian/control: Set Build-Depends: to current R version
  * debian/control: Switch to virtual debhelper-compat (= 11)
  * debian/compat: Removed

 -- Dirk Eddelbuettel <email address hidden>  Tue, 20 Oct 2020 10:27:18 -0500
Superseded in hirsute-release on 2020-11-20
Published in groovy-release on 2020-06-26
Deleted in groovy-proposed (Reason: moved to Release)
codetools (0.2-16-2) unstable; urgency=medium

  * Rebuilt for r-4.0 transition

  * debian/control: Set Build-Depends: to current R version
  * debian/control: Set Standards-Version: to current version

 -- Dirk Eddelbuettel <email address hidden>  Fri, 15 May 2020 21:03:55 -0500

Available diffs

Superseded in groovy-release on 2020-06-26
Published in focal-release on 2019-10-18
Obsolete in eoan-release on 2020-12-29
Obsolete in disco-release on 2020-07-14
Deleted in disco-proposed (Reason: moved to release)
codetools (0.2-16-1) unstable; urgency=medium

  * New upstream release
  
  * debian/control: Set Build-Depends: to current R version 
  * debian/control: Set Standards-Version: to current version 

 -- Dirk Eddelbuettel <email address hidden>  Tue, 25 Dec 2018 15:43:04 -0600

Available diffs

Superseded in disco-release on 2018-12-26
Obsolete in cosmic-release on 2020-07-13
Deleted in cosmic-proposed on 2020-07-13 (Reason: moved to release)
codetools (0.2-15-2) unstable; urgency=medium

  * Rebuilding for R 3.5.0 transition
  
  * debian/control: Set Build-Depends: to 'debhelper (>= 10)'

  * debian/control: Switch to ${R:Depends} now that dh-r is fixed

 -- Dirk Eddelbuettel <email address hidden>  Sat, 02 Jun 2018 09:41:13 -0500
Superseded in cosmic-proposed on 2018-06-02
codetools (0.2-15-1.1build1) cosmic; urgency=medium

  * No-change rebuild for the r-api change.

 -- Matthias Klose <email address hidden>  Thu, 31 May 2018 14:24:17 +0000
Superseded in cosmic-release on 2018-06-21
Published in bionic-release on 2017-11-05
Deleted in bionic-proposed (Reason: moved to release)
codetools (0.2-15-1.1) unstable; urgency=medium

  * Non-maintainer upload.
  * That's my life: Helping out unfriendly maintainers and set at least
    debian/source/format for them and fixing very basic bugs like
    s/${shlibs:Depends}/${misc:Depends}/

 -- Andreas Tille <email address hidden>  Fri, 29 Sep 2017 17:19:40 +0200
Superseded in bionic-release on 2017-11-05
Obsolete in artful-release on 2020-07-10
Deleted in artful-proposed on 2020-07-10 (Reason: moved to release)
codetools (0.2-15-1build1) artful; urgency=medium

  * No-change rebuild to pick up r-api-3.4

 -- Graham Inggs <email address hidden>  Wed, 27 Sep 2017 08:39:11 +0000
Superseded in artful-release on 2017-10-03
Obsolete in zesty-release on 2018-06-22
Deleted in zesty-proposed on 2018-06-22 (Reason: moved to release)
codetools (0.2-15-1) unstable; urgency=medium

  * New upstream release
  
  * debian/control: Set Standards-Version: to current version 

 -- Dirk Eddelbuettel <email address hidden>  Fri, 14 Oct 2016 19:18:35 -0500

Available diffs

Superseded in zesty-release on 2016-11-03
Obsolete in yakkety-release on 2018-01-23
Deleted in yakkety-proposed on 2018-01-23 (Reason: moved to release)
codetools (0.2-14-2) unstable; urgency=medium

  * debian/compat: Created
 
  * debian/control: Set Build-Depends: to current R version
  * debian/control: Set Standards-Version: to current version 

 -- Dirk Eddelbuettel <email address hidden>  Sun, 26 Jun 2016 07:42:49 -0500

Available diffs

Superseded in yakkety-release on 2016-06-27
Published in xenial-release on 2015-10-22
Obsolete in wily-release on 2018-01-22
Deleted in wily-proposed (Reason: moved to release)
codetools (0.2-14-1) unstable; urgency=low

  * New upstream release
 
  * debian/control: Set Build-Depends: to current R version 

 -- Dirk Eddelbuettel <email address hidden>  Wed, 15 Jul 2015 11:01:30 -0500
Superseded in wily-proposed on 2015-07-22
codetools (0.2-11-1) unstable; urgency=low


  * New upstream release

  * debian/control: Set Build-Depends: to current R version 

 -- Dirk Eddelbuettel <email address hidden>  Fri, 13 Mar 2015 07:49:47 -0500
Superseded in wily-release on 2015-07-30
Obsolete in vivid-release on 2018-01-18
Deleted in vivid-proposed on 2018-01-19 (Reason: moved to release)
codetools (0.2-10-1) unstable; urgency=low


  * New upstream release
  
  * debian/control: Set Build-Depends: to current R version 
  * debian/control: Set Standards-Version: to current version 

 -- Dirk Eddelbuettel <email address hidden>  Sat, 17 Jan 2015 17:07:59 -0600

Available diffs

Superseded in vivid-release on 2015-01-18
Deleted in vivid-proposed on 2015-01-19 (Reason: moved to release)
codetools (0.2-9-1) unstable; urgency=low


  * New upstream release

  * debian/control: Set Build-Depends: to current R version 
  * debian/control: Set Standards-Version: to current version 

 -- Dirk Eddelbuettel <email address hidden>  Thu, 21 Aug 2014 06:37:44 -0500

Available diffs

Superseded in vivid-release on 2014-10-25
Obsolete in utopic-release on 2016-11-03
Published in trusty-release on 2013-10-18
Obsolete in saucy-release on 2015-04-24
Deleted in saucy-proposed (Reason: moved to release)
codetools (0.2-8-2) unstable; urgency=low


  * debian/control: Set Build-Depends: to current R version 
  * debian/control: Change Depends to ${R:Depends}
  
  * (Re-)building with R 3.0.0 (beta)

 -- Dirk Eddelbuettel <email address hidden>  Mon, 25 Mar 2013 21:13:06 -0500

Available diffs

Superseded in saucy-release on 2013-04-30
Obsolete in raring-release on 2015-04-24
Obsolete in quantal-release on 2015-04-24
Published in precise-release on 2011-10-13
Obsolete in oneiric-release on 2015-04-24
codetools (0.2-8-1) unstable; urgency=low

  * New upstream release

Available diffs

Superseded in oneiric-release on 2011-04-30
Obsolete in natty-release on 2013-06-04
codetools (0.2-6-1) unstable; urgency=low

  * New upstream release
 -- Ubuntu Archive Auto-Sync <email address hidden>   Mon,  06 Dec 2010 12:53:07 +0000

Available diffs

Superseded in natty-release on 2010-12-06
codetools (0.2-5-1) unstable; urgency=low

  * New upstream release
 -- Ubuntu Archive Auto-Sync <email address hidden>   Mon,  08 Nov 2010 09:46:19 +0000

Available diffs

Superseded in natty-release on 2010-11-08
codetools (0.2-4-1) unstable; urgency=low

  * New upstream release
  
  * debian/control: Set (Build-)Depends: to current R version
  * debian/control: Set Standards-Version: to current version 
 -- Ubuntu Archive Auto-Sync <email address hidden>   Thu,  04 Nov 2010 11:41:34 +0000

Available diffs

Superseded in natty-release on 2010-11-04
Obsolete in maverick-release on 2013-03-05
Obsolete in lucid-release on 2016-10-26
codetools (0.2-2-2) unstable; urgency=low

  * Rebuilt for R 2.10.0 to work with new R-internal help file conversion

  * debian/control: Set (Build-)Depends: to current R version
  * debian/control: Set Standards-Version: to current version 
  
  * debian/control: Changed Section: to section 'gnu-r'
 -- Ubuntu Archive Auto-Sync <email address hidden>   Tue,  17 Nov 2009 17:45:16 +0000

Available diffs

Superseded in lucid-release on 2009-11-17
Obsolete in karmic-release on 2013-03-04
codetools (0.2-2-1) unstable; urgency=low

  * New upstream release

  * debian/control: Updated (Build-)Depends to current R version

 -- Ubuntu Archive Auto-Sync <email address hidden>   Tue,  28 Apr 2009 23:00:49 +0100

Available diffs

Superseded in karmic-release on 2009-04-28
Obsolete in jaunty-release on 2013-02-28
codetools (0.2-1-2) unstable; urgency=low

  * Really build against the new upstream release 0.2.1	(Closes: #494975)
  
  * debian/control: Updated Standards-Version: to current value
  * debian/control: Updated (Build-)Depends to current version

 -- Ubuntu Archive Auto-Sync <email address hidden>   Tue,  04 Nov 2008 21:16:21 +0000

Available diffs

Superseded in jaunty-release on 2008-11-05
Obsolete in intrepid-release on 2013-02-20
codetools (0.2-1-1) unstable; urgency=low

  * New upstream release

Superseded in intrepid-release on 2008-05-03
Obsolete in hardy-release on 2015-04-24
codetools (0.1-8.3-1) unstable; urgency=low

  * New upstream release
  * Built with R 2.6.0, so setting (Build-)Depends: to 
    'r-base-(core|dev) >> 2.5.1' to prevent move to testing before R 2.6.0

  * Due to the versioning issue mentioned below, renaming 0.1-3 to 0.1-8.3
  

 -- Ubuntu Archive Auto-Sync <email address hidden>   Tue,  23 Oct 2007 15:45:38 +0100
Superseded in hardy-release on 2007-10-23
Obsolete in gutsy-release on 2011-09-16
codetools (0.1-8.2-1) unstable; urgency=low

  * New upstream release
  
  * Due to the versioning issue mentioned below, renaming 0.1-2 to 0.1-8.2

 -- Ubuntu Archive Auto-Sync <email address hidden>   Fri,  15 Jun 2007 12:25:11 +0100
Superseded in gutsy-release on 2007-06-15
Superseded in gutsy-release on 2007-05-18
codetools (0.1-8.1-1) unstable; urgency=low

  * Rebuilt with slightly increased version number: Due to an erroneous
    initial upload with version number 0.1-8 (from the sibbling package
    rcompgen), subsequent uploads (with the two changelog entries below)
    did not get into the Debian unstable archive.  This upload bumps the
    upstream version number 0.1-1 to 0.1-8.1. This will be reset as soon
    as the upstream release is larger than 0.1-8.  I prefer this over
    adding an epoch "forever".				   (Closes: #421705)

  * debian/control: Updated (Build-)Depends: to 'r-base-core (>= 2.5.0)'
  

126 of 26 results