Ubuntu

No automated icon

Reported by Bjørn Ingmar Berg on 2006-12-08
14
Affects Status Importance Assigned to Milestone
comix (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: comix

Ubuntu 6.10
Comix 3.6.1

Comix no longer creates custom file icons when I create new comic book archieves.

With the old version of Comix (3.1.3) a new archieve automagically got a custom icon based on the first image in the archieve. I updated to the newer version of Comix (3.6.1) 2006-12-02 and after that new archieves have not gotten any custom icon.

Bjørn Ingmar Berg

HerrEkberg (herrekberg) wrote :

The reason for this is changes in the Debian makefile. The deb maintainer has for some reason added the --no-mime flag to the Comix install script, which disables the thumbnails and the x-cbr, x-cbz abd x-cbt mime types (unless those where already defined).

The solution is to remove the --no-mime flag from the makefile. It is quite easy to install Comix manually from the tarball as well, but that doesn't help all the other Ubuntu/Debian users who rely on the packaging system.

Bjørn Ingmar Berg (bergcube) wrote :

The solution _sounds_ really simple.
I hope it is, and that the it gets implemented soon.

William Grant (wgrant) on 2007-04-03
Changed in comix:
importance: Undecided → Low
status: Unconfirmed → Confirmed
HerrEkberg (herrekberg) wrote :

This problem should be solved in the latest Debian package (3.6.2-3).

Félix Velasco (felix-velasco) wrote :

In the 3.6-1 package, the deb maintainer added the --no-mime flag since evince already was thumbnailing cbr's and cbz's. However, they didn't remove the gconf schema that pointed the thumbnails to comicthumb, so evince's work was undone. As a workaround, if you reinstall evince after comix gets installed, the thumbnails go back to life (delete the contents of the /home/you/.thumbnails/fail/ directory to make sure they get another chance).

In 3.6.2 the deb maintainer removed the flag and kept the gconf schema, so the thumbnailing goes back to comix and out from evince. Trouble is, that way evince and comix are "fighting" for the thumbnailing of x-cbr and x-cbz (x-cbt are not touched by evince).

Shall we go the debian way, or remove entirely the comix thumbnailing capabilities, leaving them to evince?

LaserJock (laserjock) wrote :

This appears to me to be fixed now so I'm marking it Fix Released. Feel free to reopen this bug if it's still a problem in a current release.

Changed in comix:
status: Confirmed → Fix Released
Bjørn Ingmar Berg (bergcube) wrote :

I tested this right now on a computer with Ubuntu 8.04 that hadn't previously had Comix installed. Worked like a charm! Very good.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers