Change log for commons-math package in Ubuntu

111 of 11 results
Published in disco-release on 2018-10-30
Published in cosmic-release on 2018-05-01
Published in bionic-release on 2018-02-07
Deleted in bionic-proposed (Reason: moved to release)
commons-math (2.2-7) unstable; urgency=medium

  * Team upload.
  * Use https for Format field.
  * Declare compliance with Debian Policy 4.1.3.
  * Use compat level 11.
  * Require Java 7 to build the package because source/target 1.5 is obsolete
    with OpenJDK 9.

 -- Markus Koschany <email address hidden>  Tue, 06 Feb 2018 21:53:04 +0100

Available diffs

Superseded in bionic-release on 2018-02-07
Published in artful-release on 2017-04-20
Obsolete in zesty-release on 2018-06-22
Obsolete in yakkety-release on 2018-01-23
Deleted in yakkety-proposed (Reason: moved to release)
commons-math (2.2-6) unstable; urgency=medium

  * Team upload.
  * Declare compliance with Debian Policy 3.9.8.
  * Vcs-fields: Use https.
  * Switch from cdbs to dh sequencer.
  * Add disable-testSampling-test.patch.
    Disable testSampling test that fails with a probability of 0.001.
    (Closes: #834890)

 -- Markus Koschany <email address hidden>  Fri, 26 Aug 2016 16:25:16 +0200

Available diffs

Superseded in yakkety-release on 2016-09-02
Published in xenial-release on 2015-11-06
Deleted in xenial-proposed (Reason: moved to release)
commons-math (2.2-5) unstable; urgency=medium

  * Team upload.

  [ Emmanuel Bourg ]
  * Build with maven-debian-helper (should make the build reproducible)
  * debian/copyright: Fixed the path of the files
  * Moved the package to Git

  [ tony mancill ]
  * Address lintian warning: pipe-symbol-used-as-license-disjunction
    in debian/copyright.
  * Bump Standards-Version to 3.9.6 (no changes)

 -- Emmanuel Bourg <email address hidden>  Fri, 06 Nov 2015 00:42:58 +0100

Available diffs

Superseded in xenial-release on 2015-11-06
Obsolete in wily-release on 2018-01-22
Obsolete in vivid-release on 2018-01-18
Obsolete in utopic-release on 2016-11-03
Deleted in utopic-proposed on 2018-01-22 (Reason: moved to release)
commons-math (2.2-4) unstable; urgency=medium


  * Ignore the checkMissingFastMathClasses test that fails with Java 8
  * Set the source/target level to 1.5
  * Updated Standards-Version to 3.9.5 (no changes)
  * Switch to debhelper level 9
  * debian/copyright: Updated the Format URI

 -- Emmanuel Bourg <email address hidden>  Fri, 16 May 2014 08:49:36 +0200

Available diffs

Superseded in utopic-release on 2014-05-16
Published in trusty-release on 2013-10-18
Obsolete in saucy-release on 2015-04-24
Deleted in saucy-proposed (Reason: moved to release)
commons-math (2.2-3) unstable; urgency=low


  * Added ant-junit4 to the classpath to fix the test failures (Closes: #713749)
  * Updated Standards-Version to 3.9.4 (no changes)
  * Use canonical URLs for the Vcs-* fields
  * debian/rules: the clean target now properly removes the debian/.mh directory

 -- Emmanuel Bourg <email address hidden>  Tue, 25 Jun 2013 15:09:18 +0200

Available diffs

Superseded in saucy-release on 2013-06-26
Obsolete in raring-release on 2015-04-24
Obsolete in quantal-release on 2015-04-24
Published in precise-release on 2011-12-25
commons-math (2.2-2) unstable; urgency=low

  [ Miguel Landaeta ]
  * Team upload.
  * Bump Standards-Version to 3.9.2. No changes were required.
  * Fix lintian warning with copyright file.

  [ James Page ]
  * Fix FTBFS with OpenJDK7 (LP: #888931) (Closes: #651403):
    - d/ant.properties: Specify source/target as 1.5 for javac and
      javadoc ant tasks to ensure backwards compatibility and work
      around Java 7 encoding errors.
 -- Bhavani Shankar <email address hidden>   Fri, 09 Dec 2011 20:47:07 -0430

Available diffs

Superseded in precise-release on 2011-12-25
commons-math (2.2-1ubuntu1) precise; urgency=low

  * Fix FTBFS with OpenJDK7 (LP: #888931):
    - d/ant.properties: Specify source/target as 1.5 for javac and
      javadoc ant tasks to ensure backwards compatibility and work
      around Java 7 encoding errors.
 -- James Page <email address hidden>   Thu, 08 Dec 2011 10:53:54 +0000

Available diffs

Superseded in precise-release on 2011-12-08
Obsolete in oneiric-release on 2015-04-24
commons-math (2.2-1) unstable; urgency=low

  [ Torsten Werner ]
  * Change maintainers into Maintainers.

  [ Damien Raude-Morvan ]
  * New upstream release (Closes: #617209).
  * d/control: Bump Standards-Version to 3.9.1 (no changes needed).
  * d/copyright: Refresh years, upgrade to DEP5 r166 and relicence my work
    under Apache-2.0.
  * d/ant.properties: Set junit.jar to /usr/share/java/junit4.jar
    to ensure unit tests are launched.
  * d/docs: Install upstream RELEASE-NOTES.
 -- Ubuntu Archive Auto-Sync <email address hidden>   Sat,  30 Apr 2011 12:41:28 +0000

Available diffs

Superseded in oneiric-release on 2011-04-30
Obsolete in natty-release on 2013-06-04
Obsolete in maverick-release on 2013-03-05
commons-math (2.1-1) unstable; urgency=low

  * New upstream release.
  * Bump Standards-Version to 3.8.4: no changes needed
  * Bump debhelper to >= 7
  * Switch to 3.0 (quilt) source format:
    - Remove B-D on quilt
    - Add d/source/format
    - Remove d/README.source
 -- Ubuntu Archive Auto-Sync <email address hidden>   Sun,  09 May 2010 13:46:07 +0100

Available diffs

Superseded in maverick-release on 2010-05-09
Obsolete in lucid-release on 2016-10-26
commons-math (2.0-3) unstable; urgency=low

  * Update my email address
  * Remove libcommons-discovery-java from Build-Depends and Depends
    as Commons Math 2.0 doesn't need it anymore (Closes: #548284).

Available diffs

Superseded in lucid-release on 2009-11-05
Obsolete in karmic-release on 2013-03-04
commons-math (1.2-1) unstable; urgency=low

  * Initial release. (Closes: #506987)

 -- Ubuntu Archive Auto-Sync <email address hidden>   Wed,  29 Apr 2009 16:14:22 +0100
111 of 11 results