Blue compiz for PowerPC…

Bug #58373 reported by Jib
18
Affects Status Importance Assigned to Milestone
Compiz
Fix Released
Medium
X.Org X server
Fix Released
Medium
compiz (Ubuntu)
Invalid
Undecided
Unassigned
Declined for Edgy by Sebastien Bacher
xorg-server (Debian)
Fix Released
Unknown
xorg-server (Ubuntu)
Fix Released
Undecided
Unassigned
Declined for Edgy by Sebastien Bacher

Bug Description

Binary package hint: compiz

Up-to-date edgy eft on iBook G4

Oddly, the desktop is all blue…

http://pix.nofrag.com/3a/e0/6b5aeeb717c775296f152fb5532b.html

It looks out this bug is ppc specific…

Revision history for this message
In , Jib (moramarth-deactivatedaccount) wrote :

Up-to-date Edgy Eft on iBook G4 1,07 GHz.

Initial Bug report : https://launchpad.net/distros/ubuntu/+source/compiz/+bug/58373

Oddly, the desktop is all blue…

http://pix.nofrag.com/3a/e0/6b5aeeb717c775296f152fb5532b.html

It looks out this bug is ppc specific…

Revision history for this message
Jib (moramarth-deactivatedaccount) wrote :

Added thread in freedesktop.org bugzilla https://bugs.freedesktop.org/show_bug.cgi?id=8095

Revision history for this message
In , Jib (moramarth-deactivatedaccount) wrote :

The colors seem inverted : I take a screenshot of my blue-colored compiz on ppc,
then I view it inside the same bugged environnement.
http://img385.imageshack.us/img385/1658/screenshotzy8.png
As you see, the Ubuntu's logo and Firefox' icon look out well again, respecting
their true colors…

I precise that gnome-compiz-manager has nothing to deal with that bug : I had
got this bug before gnome-compiz-manager was installed…

Revision history for this message
In , Jib (moramarth-deactivatedaccount) wrote :

I use the official Ubuntu Edgy Eft packages :
compiz-core 0.0.13.38-0ubuntu3
compiz-gnome 0.0.13.38-0ubuntu3
compiz-plugins 0.5-0ubuntu3

Revision history for this message
Jib (moramarth-deactivatedaccount) wrote :

Assigned to David Raveman, according to the parallel bug report on https://bugs.freedesktop.org/show_bug.cgi?id=8095

Revision history for this message
In , Jib (moramarth-deactivatedaccount) wrote :

Original comment from Ralph Schuengel
https://launchpad.net/distros/ubuntu/+source/compiz/+bug/58373/comments/3

I'm seeing the same problem on a G3 ibook.

Revision history for this message
Ralph (ralph-ubuntu) wrote :

I'm seeing the same problem on a G3 ibook.

Revision history for this message
Jib (moramarth-deactivatedaccount) wrote :

Please report your comments on https://bugs.freedesktop.org/show_bug.cgi?id=8095 where David Reveman care about bugs reports.

I paste yours, Ralph https://bugs.freedesktop.org/show_bug.cgi?id=8095#c3

Revision history for this message
Jib (moramarth-deactivatedaccount) wrote :

Assigned to the recently created ubuntu-desktop-effects team.

The screenshot : http://img385.imageshack.us/img385/1658/screenshotzy8.png

I hope it will be useful to solve the bug…

Changed in compiz:
assignee: nobody → ubuntu-desktop-effects
status: Unconfirmed → Confirmed
Revision history for this message
In , mambro (mambro87) wrote :
Download full text (4.9 KiB)

I've the same bug with gentoo on an ibook g4 12". I've used this overlay
http://svn.hboeck.de/xgl-overlay

That are my softwares version:
ibook mambro # emerge -av libdrm mesa xorg-server xf86-video-ati compiz

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild R ] x11-libs/libdrm-2.0.2 USE="-debug" 0 kB
[ebuild R ] media-libs/mesa-6.5.1_rc2-r20060908 USE="nptl -debug -doc -hard
ened -motif" VIDEO_CARDS="radeon -mach64 -mga -none -r128 -s3virge -savage -tdfx
 -trident" 0 kB [2]
[ebuild R ] x11-base/xorg-server-1.1.1-r2 USE="dri nptl sdl xorg -debug -dm
x -ipv6 -kdrive -minimal -xprint" INPUT_DEVICES="evdev keyboard mouse -acecad -a
iptek -calcomp -citron -digitaledge -dmc -dynapro -elo2300 -elographics -fpit -h
yperpen -jamstudio -joystick -magellan -microtouch -mutouch -palmax -penmount -s
paceorb -summa -tek4957 -ur98 -void" VIDEO_CARDS="radeon vesa -chips -cirrus -du
mmy -epson -fbdev -glint -imstt -mach64 -mga -nv -r128 -s3 -s3virge -savage -sis
usb -tdfx -trident -v4l -voodoo" 0 kB [2]
[ebuild R ] x11-drivers/xf86-video-ati-6.6.2 USE="dri -debug" 0 kB
[ebuild R ] x11-wm/compiz-0.0.13_pre20060902 USE="dbus svg" 0 kB [2]

Total size of downloads: 0 kB
Portage overlays:
 [1] /usr/local/portage
 [2] /usr/local/xgl-overlay

Would you like to merge these packages? [Yes/No]

These are my cpu information:
ibook mambro # cat /proc/cpuinfo
processor : 0
cpu : 7447A, altivec supported
clock : 1199.999000MHz
revision : 0.1 (pvr 8003 0101)
bogomips : 73.47
timebase : 18432000
platform : PowerMac
machine : PowerBook6,5
motherboard : PowerBook6,5 MacRISC3 Power Macintosh
detected as : 287 (iBook G4)
pmac flags : 0000001b
L2 cache : 512K unified
pmac-generation : NewWorld

And finally this is my emerge --info:
ibook mambro # emerge --info
Portage 2.1-r2 (default-linux/ppc/ppc32/2006.1/G4, gcc-4.1.1, glibc-2.4-r3,
2.6.17-gentoo-r7 ppc)
=================================================================
System uname: 2.6.17-gentoo-r7 ppc 7447A, altivec supported
Gentoo Base System version 1.12.4
app-admin/eselect-compiler: [Not Present]
dev-lang/python: 2.4.3-r1
dev-python/pycrypto: 2.0.1-r5
dev-util/ccache: [Not Present]
dev-util/confcache: [Not Present]
sys-apps/sandbox: 1.2.17
sys-devel/autoconf: 2.13, 2.59-r7
sys-devel/automake: 1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2
sys-devel/binutils: 2.16.1-r3
sys-devel/gcc-config: 1.3.13-r3
sys-devel/libtool: 1.5.22
virtual/os-headers: 2.6.11-r4
ACCEPT_KEYWORDS="ppc"
AUTOCLEAN="yes"
CBUILD="powerpc-unknown-linux-gnu"
CFLAGS="-mcpu=7400 -O2 -pipe -maltivec -mabi=altivec"
CHOST="powerpc-unknown-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.4/env /usr/kde/3.4/share/config
/usr/kde/3.4/shutdown /usr/kde/3.5/env /usr/kde/3.5/share/config
/usr/kde/3.5/shutdown /usr/share/X11/xkb /usr/share/config
/usr/share/texmf/dvipdfm/config/ /usr/share/texmf/dvips/config/
/usr/share/texmf/tex/generic/config/ /usr/share/texmf/tex/platex/config/
/usr/share/texmf/xdvi/"
CONFIG_PROTECT_MASK="/etc/env.d /etc/gconf /etc/revdep-rebuild /etc/terminfo"
CXXFLA...

Read more...

Revision history for this message
In , mambro (mambro87) wrote :

With mesa 6.5.1 and compiz 20060913 doesn't work yet... is someone working on
this problem? You need other information?

Revision history for this message
Kai Kasurinen (kai-kasurinen) wrote :

"It's an endianness bug in the AIGLX GLX_EXT_texture_from_pixmap
implementation." -- Michel Dänzer <email address hidden>

<http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=392453;msg=20>

Changed in xorg-server:
status: Unconfirmed → Confirmed
Changed in xorg-server:
status: Unknown → Unconfirmed
Changed in compiz:
status: Unknown → In Progress
Changed in xorg-server:
status: Unknown → In Progress
Revision history for this message
In , mambro (mambro87) wrote :

With mesa 6.5.1 xorg-server 1.1.1 and compiz 0.2.0 if I use display Depth 16 bit
(DefaultDepth 16 in the Section "Screen" of the xorg.conf) it works better but
not perfecty yet.

This is a screenshot
http://img181.imageshack.us/my.php?image=aiglxcompizwj1.png

You can see that some parts of the screen are purple/blue.

Revision history for this message
sam tygier (samtygier) wrote :
Revision history for this message
sam tygier (samtygier) wrote :

this fixes it for me

the patch needs to be applied after 012_fedora_tfp_damage.patch

Revision history for this message
sam tygier (samtygier) wrote :

here is my build with the patch applied for people to test
http://tygier.co.uk/pub/xserver-xorg-core_1.1.1-0ubuntu12_powerpc.deb

Changed in xorg-server:
status: Unconfirmed → Confirmed
Revision history for this message
In , Jib (moramarth-deactivatedaccount) wrote :

There is a patch here :
https://launchpad.net/distros/ubuntu/+source/compiz/+bug/58373 the eigth comment.

Revision history for this message
effraie (effraie) wrote :

sam, is it possible to get your source package?

Revision history for this message
Tavis J. Hampton (hamptont) wrote :

Tested on iBook G4, works perfectly!

Revision history for this message
Jib (moramarth-deactivatedaccount) wrote :

sam's package installed with gdebi from Epiphany.

All works fine now. Thanks.

Revision history for this message
sam tygier (samtygier) wrote :

effraie
i tried to make a tar.gz, but it was 200mb!?!

so use

apt-get source xorg-server
cd xorg-server-1.1.1/debian/patches/
wget http://librarian.launchpad.net/4923564/fix_glXDRIbindTexImage_for_32bpp_on_big_endian.patch
echo "fix_glXDRIbindTexImage_for_32bpp_on_big_endian.patch" >> series
cd ../..
dpkg-buildpackage -rfakeroot

Revision history for this message
effraie (effraie) wrote : Re: [Bug 58373] Re: Blue compiz for PowerPC…

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

thank you!
as usual, i'll pbuild it, and upload it on http://mental-ppc.tuxfamily.org

sam tygier a écrit :
> effraie
> i tried to make a tar.gz, but it was 200mb!?!
>
> so use
>
> apt-get source xorg-server
> cd xorg-server-1.1.1/debian/patches/
> wget http://librarian.launchpad.net/4923564/fix_glXDRIbindTexImage_for_32bpp_on_big_endian.patch
> echo "fix_glXDRIbindTexImage_for_32bpp_on_big_endian.patch" >> series
> cd ../..
> dpkg-buildpackage -rfakeroot
>
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.3 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org

iD8DBQFFP9BQDZrS/Pzxy5oRAscPAKCnMnFMIvvW5vxZmaluQMKYt1oC3QCgjXlR
IhRbwiKzYnAqYtk99wQcOmM=
=OlA9
-----END PGP SIGNATURE-----

Revision history for this message
effraie (effraie) wrote :

ok.

For those who want to use beryl on mac PPC, patched xserver-xorg-core and beryl/emerald-0.1.1 are available on http://mental-ppc.tuxfamily.org/dists/dists/edgy-mppc/

Revision history for this message
fuoco (fuoco2-deactivatedaccount) wrote :

effraie, nice. maybe add to https://wiki.ubuntu.com/BerylOnEdgy ?

Changed in xorg-server:
status: Confirmed → Fix Committed
Revision history for this message
sam tygier (samtygier) wrote :

I have been running my patched xorg-server package for nearly a month now. it seems very stable, ie no xorg crashes.

there are xorg crashes with compiz running, but these are presumebly compiz bugs.

could this be considered for edgy-updates?

Changed in xorg-server:
status: Fix Committed → Fix Released
Revision history for this message
Corey Burger (corey.burger) wrote :

Thank you for your bug report. As generic compiz as now been uploaded to Feisty (compiz-quinn is now known as beryl), we need to see if your bug is still present. If you can test the version of compiz in feisty (1:0.3.3-0ubuntu2~git2006112 or later) and tell us if you bug still exists, please do. Please make certain you are using Ubuntu's Xorg as well. We also require the make of your video card, to help debug driver issues. If you are using a newer ATI card (x1000 series or newer), please indicate so. To get this information, please attach /var/log/Xorg.0.log

Changed in compiz:
status: Confirmed → Needs Info
Revision history for this message
Jib (moramarth-deactivatedaccount) wrote :

Compiz works fine. Bug solved.

Thanks, guys :¬D !

Revision history for this message
Corey Burger (corey.burger) wrote :

Bug no longer present, as per previous commenter. Thanks for your bug report.

Changed in compiz:
assignee: ubuntu-desktop-effects → nobody
status: Needs Info → Rejected
Revision history for this message
sam tygier (samtygier) wrote :

jib, are you using feisty, or the patched xorg package for edgy?

this is not fixed in feisty (or at least not for me).

its a new version of xorg that is needed not compiz.

Revision history for this message
Jib (moramarth-deactivatedaccount) wrote :

I'm using a patched version of Xorg.

Revision history for this message
Corey Burger (corey.burger) wrote :

Can anybody reproduce this bug with stock xorg and stock compiz on Feisty?

Changed in xorg-server:
assignee: nobody → corey.burger
status: Confirmed → Needs Info
Revision history for this message
sam tygier (samtygier) wrote :

it was still doing it yesterday, on feisty.

according to
http://packages.ubuntu.com/cgi-bin/search_packages.pl?searchon=names&version=all&exact=1&keywords=xserver-xorg
xserver-xorg is at the same version in feisty as edgy

Revision history for this message
Corey Burger (corey.burger) wrote :

Reconfirming. Sam, I asked because the original reporter said he was using a non-standard xorg.

Changed in xorg-server:
assignee: corey.burger → nobody
status: Needs Info → Confirmed
Revision history for this message
Sebastien Bacher (seb128) wrote :

That should be fixed with that upload:

 xorg-server (1:1.1.1-0ubuntu13) feisty; urgency=low
 .
   * 19_revert_xkb_change_breaking_XkbGetKeyboard.patch:
     - patch from fedora (with extra Makefile.in change), revert change that
       broke XkbGetKeyboard() (Ubuntu: #58083)
   * 37_Fix-__glXDRIbindTexImage-for-32-bpp-on-big-endian-platforms.diff:
     - upstream patch copied from the Debian package, fix blue screen with
       compiz on ppc (Ubuntu: #58373)

Marking fixed, feel free to reopen if that's not the case

Changed in xorg-server:
status: Confirmed → Fix Released
Revision history for this message
Laurent Bigonville (bigon) wrote :

I cannot test with feisty now, but this patch should be backported to edgy too

Revision history for this message
In , Michel-tungstengraphics (michel-tungstengraphics) wrote :

As noted in comment #7, this was a bug in AIGLX that I fixed for X.org 7.2.

Revision history for this message
Laurent Bigonville (bigon) wrote :

Reopening this to request edgy backport

Changed in xorg-server:
status: Fix Released → Confirmed
Revision history for this message
Sebastien Bacher (seb128) wrote :

The bug is fixed, no need to reopen to request a backport, use the left column "target to release" option for that, marking fixed again

Changed in xorg-server:
status: Confirmed → Fix Released
Revision history for this message
Sebastien Bacher (seb128) wrote :

I've marked the edgy backport declined, compiz is an universe package and non-supported, there is not that many user for it and probably only a few on powerpc, backporting fixes to stable is not trivial and can't be done for every minor bug, compiz users probably want to wait for feisty to get an usable version anyway

Revision history for this message
Laurent Bigonville (bigon) wrote :

The bug is actually in xorg not compiz see debian bts

Revision history for this message
Sebastien Bacher (seb128) wrote :

I've uploaded a fixed package, are you trying to write that I don't know what package I uploaded? That's an xorg bug right, is there anything else than composite managers triggering it though? That bug seems to be faced only by people trying to use compiz, not by people using the stock desktop

Changed in compiz:
status: In Progress → Fix Released
Changed in xorg-server:
status: In Progress → Fix Released
Changed in xorg-server:
importance: Unknown → Medium
Changed in compiz:
importance: Unknown → Medium
Changed in xorg-server:
importance: Medium → Unknown
Changed in compiz:
importance: Medium → Unknown
Changed in compiz:
importance: Unknown → Medium
Changed in xorg-server:
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.