Ubuntu

compiz should not default to using screen corners

Reported by Sitsofe Wheeler on 2006-10-01
12
Affects Status Importance Assigned to Milestone
compiz (Ubuntu)
Wishlist
Unassigned

Bug Description

Description of the problem:
The corners of the screen are already being used on a default Ubuntu GNOME install so compiz should not default its effects to them.

Fitts law says that the corners are a good place to position things (infinitely deep in two dimensions - can't overshoot because the pointer becomes "trapped") and it seems that Ubuntu has taken that to heart by placing things in each of the four corners of the screen (from the top left going clockwise: main menu, log off button, recycle bin, minimize all/show desktop).

A default install of compiz on Edgy has set up various effects on these corners too, which conflicts with the buttons already there (e.g. I go to hit the log off button and wind up activating scale windows instead). The only feature that could possibly be set as default is the show desktop feature in the bottom left (as this is serving a very similar purpose to the show desktop button).

Mateusz Drożdżyński (matid) wrote :

I agree that we should consider changing the defaults here, but the changes you are requesting require more discussion and should rather be done on an appropriate mailing list or forum.

Please, make sure to leave a link to the discussion here, it will increase the chances of your suggestion being implemented.

Changed in compiz:
importance: Undecided → Wishlist
status: Unconfirmed → Needs Info
Corey Burger (corey.burger) wrote :

Thank you for your bug report. As generic compiz as now been uploaded to Feisty (compiz-quinn is now known as beryl), we need to see if your bug is still present. If you can test the version of compiz in feisty (1:0.3.3-0ubuntu2~git2006112 or later) and tell us if you bug still exists, please do. Please make certain you are using Ubuntu's Xorg as well. We also require the make of your video card, to help debug driver issues. If you are using a newer ATI card (x1000 series or newer), please indicate so. To get this information, please attach /var/log/Xorg.0.log

Stu Hood (stuhood) wrote :

Hot corners do not appear to be the default any longer, at least in Feisty.

Please re-open the bug if you are still having issues with it.

Changed in compiz:
status: Needs Info → Fix Released
Sitsofe Wheeler (sitsofe) wrote :

This is still here in Feisty's compiz. The top right (where the quit button is) still activates scale. Reopening.

Changed in compiz:
status: Fix Released → Unconfirmed
Mark Reitblatt (mark-reitblatt) wrote :

Having the scale hot-corner right by the power button seems like a huge usability no-no.

Changed in compiz:
status: Unconfirmed → Confirmed
Mika Wahlroos (mpw) wrote :

Still present in feisty.

Sitsofe Wheeler (sitsofe) wrote :

While the nature of the problem has changed slightly (scale is not activated until after you click on the top right most pixel) the problem is effectively still here. That top right most pixel is the easiest one to hit and is overloaded (I still activate scale rather than the quit button when trying to shut down the machine).

Matt Zimmerman (mdz) wrote :

This is apparently fixed in current compiz for Gutsy (confirmed here)

Changed in compiz:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers