Launch music player shortcut is hardcoded in the sources

Bug #4265 reported by Mathieu Doidy on 2005-11-12
26
Affects Status Importance Assigned to Milestone
gnome-control-center
Fix Released
Undecided
Unassigned
control-center (Ubuntu)
Medium
Ubuntu Desktop Bugs

Bug Description

Here is a part of a patch applied to the source of the control-center package :
++ case MUSIC_KEY:
++ execute ("rhythmbox", FALSE);
++ break;

It defines the application started by the Launch Music Player shortcut.
The application to use (rhythmbox) is hardcoded in the source and this is really bad since it cannot be changed without re-building the package.

Please make this configurable like, f.e. the terminal or the mail reader to use

Daniel Holbach (dholbach) wrote :

Thankf for your bug report. Which version of Ubuntu and Control Center do you use?

Changed in control-center:
assignee: nobody → gnome
assignee: nobody → gnome
Mathieu Doidy (bugs-roulaize) wrote :

Ubuntu 5.10 (Breezy)
gnome-control-center 2.12.1-0ubuntu2

T.J. (tj-kewlness) wrote :

A temporary quickfix can be acheived until the souce code problem is resolved by editing the metacity registry keys using the gconf editor.

For example:
/apps/metacity/global_keybindings/run_command_2 set to F2
/apps/metacity/keybinding_commands/command_2 set to banshee, for example.

Be sure F2 is not used in the key properties capplet, aka "Keyboard Shortcuts" or it will be overriden there.

After this is done, F2 will launch whatever command is set in the /apps/metacity/keybinding_commands/command_2 key.

Cheers!
T.J.

Changed in control-center:
assignee: gnome → desktop-bugs
status: Unconfirmed → Confirmed

Hi,

I've been quite irritated by this bug, but found an easy work around until the player to launch gets configurable: create a symlink called "rhythmbox" to your favourite player in a directory situated before /usr/bin in your path.
For example:
ln -s /usr/bin/xmms /usr/local/bin/rhythmbox
did the trick for me as I have /usr/local/bin before /usr/bin in my path.

You can then use the "media" key to launch whatever you symlinked to.

Hope this helps,

JB

Sebastien Bacher (seb128) wrote :

upstream bug about a preferred player option: http://bugzilla.gnome.org/show_bug.cgi?id=300514

Changed in control-center:
assignee: gnome → nobody
status: Unconfirmed → Unknown
Changed in control-center:
status: Unknown → Confirmed

Jean-Baptiste's thing works for me. That is like soooo cool. I really liked Rhythmbox before I saw Banshee. I did this:

ln -s /usr/bin/banshee /usr/local/bin/rhythmbox

And that works just fine!

Sebastien Bacher (seb128) wrote :
Download full text (5.0 KiB)

This upload fixes the bug:

 gnome-control-center (1:2.19.1-0ubuntu1) gutsy; urgency=low
 .
   * New upstream version:
     about-me:
     - Build fixes
     - Add image filter to file chooser
     - Plug memory leaks
     at-properties:
     - Don't require GNOME Glade library
     background:
     - Don't require GNOME Glade library
     - Don't crash if the GConf schema is missing
     - Fix initialization of the secondary colour picker
     - Replace deprecated GtkOptionMenu with GtkComboBox
     - Fix scaling for WPTYPE_ZOOM
     default applications:
     - Added widgets for default media player
     - Don't require GNOME Glade library
     - Added Seamonkey as web browser and mail reader
     - Added widgets for default accessibility applications
     display:
     - Uppercase the rotation options
     - Added 720x576 (PAL) to the list of valid resolutions
     fonts:
     - Don't require GNOME Glade library
     keybindings:
     - Fix the patch from which we'd load the keybindings
     - Prepend the directory name before loading the files
     - Remove metacity keybindings definitions
     keyboard:
     - Use a radio button instead of a chackbox to indicate the default layout
     - Use automatic instead of always scrollbar policy
     - New version of the layout chooser, comboboxentry-based (Ubuntu: #70155)
     mouse:
     - Use automatic instead of always scrollbar policy
     theme switcher:
     - Add filters for theme packages to the file chooser and mark the file
       chooser title for translation
     - Use OnlyShowIn=; to hide the theme installer from menus and menu editors
     windows:
     - Use GtkComboBox instead of GtkOptionMenu
     shell:
     - Build libslab statically, to avoid conflicts with gnome-main-menu
     settings daemon:
     - Added handler for media keybinding (Ubuntu: #4265)
     - Don't crash if DBus connection is not available
     - Don't set Emacs.mode-line.attributeBackground to avoid problems with
       emacs 22
     - Rebuild the media window if the state of composite has changed
       (Ubuntu: #83724)
     - Fix launch-app-in-terminal support
     - Started refactoring of modules
     - Also check registered directories for notification
     - Removed all settings not related to colour
     - Try to figure out the DPI value from the X server or the user's GConf
       settings
     general:
     - Rename module name to gnome-control-center
   * debian/control.in:
     - tarball is name gnome-control-center now
   * debian/capplets-data.gconf-defaults:
     - use gconf-defaults rather than the 07_default_keys.patch schemas change
   * debian/capplets-data.install:
     - updated to upstream changes
   * debian/gnome-control-center.install:
     - list the bin directory rather than every entry
     - updated to the new directory naming
   * debian/gnome-control-center.links:
     - updated for upstream naming change
   * Sync with Debian
   * debian/control.in:
     - don't use type-handling.
     - libgnome-settings-daemon-dev Conflicts,Replaces,Provides
       gnome-control-center-dev, Debian named that package diffe...

Read more...

Changed in control-center:
status: Confirmed → Fix Released
Changed in control-center:
status: New → Fix Released
status: Fix Released → Unknown
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.