gnome-sound-properties empty "Default sound card:" list

Bug #48545 reported by Nespa on 2006-06-05
10
Affects Status Importance Assigned to Milestone
control-center (Ubuntu)
Low
Martin Pitt

Bug Description

Binary package hint: gnome-control-center

cat /proc/asound/cards shows 3 sound devices, but the Default sound card in "Sound Preferences" stays empty. (up/down toggles greyed out ).
* Dapper AMD64
* no messges in /var/log when starting the Sound Preferences dialog

Changed in control-center:
assignee: nobody → pitti
Sebastien Bacher (seb128) wrote :

Thanks for your bug. What does "asoundconf list" list?

Changed in control-center:
status: Unconfirmed → Needs Info
Peter Dietz (psldietz) wrote :

I had the same problem of no indication of a default sound card in the "Sound Preferences" menu. I solved this by adding the name of the current user to the list of users in the audio group, in the file "/etc/group". Suggestion: should this not be done automatically when adding new users with "useradd"?

Martin Pitt (pitti) wrote :

useradd is not supposed to put the user into any group, it's a very low-level tool. If you add users with the 'Users and groups' gnome tool, they will get the 'desktop' profile by default which includes audio access.

Changed in control-center:
importance: Medium → Low
status: Needs Info → Confirmed
Martin Pitt (pitti) wrote :

Also, this is not an issue in Feisty any more since the default sound card selector disappeared entirely.

Changed in control-center:
status: Confirmed → Fix Released

Thanks for the info.

Peter Dietz

On Tue, 2006-12-12 at 18:10 +0000, Martin Pitt wrote:

> Also, this is not an issue in Feisty any more since the default sound
> card selector disappeared entirely.
>
> ** Changed in: control-center (Ubuntu)
> Status: Confirmed => Fix Released
>

On Tue, 2006-12-12 at 18:10 +0000, Martin Pitt wrote:

> useradd is not supposed to put the user into any group, it's a very low-
> level tool. If you add users with the 'Users and groups' gnome tool,
> they will get the 'desktop' profile by default which includes audio
> access.
>
> ** Changed in: control-center (Ubuntu)
> Importance: Medium => Low
> Status: Needs Info => Confirmed
>

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers