cups-filters 1.0.24-2ubuntu0.2 source package in Ubuntu

Changelog

cups-filters (1.0.24-2ubuntu0.2) quantal-security; urgency=medium

  * SECURITY UPDATE: arbitrary code execution via overflows in pdftoopvp
    - debian/patches/CVE-2013-647x.patch: use gmallocn and gmallocn3 in
      filter/pdftoopvp/{oprs/OPVPSplash.cxx,OPVPOutputDev.cxx}.
    - CVE-2013-6474
    - CVE-2013-6475
  * SECURITY UPDATE: arbitrary code execution via driver in pdftoopvp
    - debian/patches/CVE-2013-647x.patch: restrict driver path in
      filter/pdftoopvp/oprs/OPVPWrapper.cxx.
    - CVE-2013-6476
 -- Marc Deslauriers <email address hidden>   Tue, 11 Mar 2014 11:01:42 -0400

Upload details

Uploaded by:
Marc Deslauriers on 2014-03-11
Uploaded to:
Quantal
Original maintainer:
Ubuntu Developers
Component:
main
Architectures:
any
Section:
net
Urgency:
Medium Urgency

See full publishing history Publishing

Series Pocket Published Component Section

Downloads

File Size MD5 Checksum
cups-filters_1.0.24.orig.tar.bz2 1.1 MiB 209b11a602075cd61bb8553e55e31f95
cups-filters_1.0.24-2ubuntu0.2.debian.tar.gz 46.6 KiB ae633c79ed6ccc743d2f36cbd28b7ad8
cups-filters_1.0.24-2ubuntu0.2.dsc 2.7 KiB 9cb01e1d9873f3f942883b6e5b7849d0

View changes file

Binary packages built by this source

cups-filters: OpenPrinting CUPS Filters

 This package provides additional CUPS filters which are not provided
 by the CUPS project itself. This includes filters for a PDF based
 printing workflow.

libcupsfilters-dev: OpenPrinting CUPS Filters - Development files for the library

 Header files to develop applications (CUPS filters, printer drivers) using
 libcupsfilters.

libcupsfilters1: OpenPrinting CUPS Filters - Shared library

 This library contains functions commonly used by the CUPS filters
 in the OpenPrinting CUPS filters package, currently functions to read
 several different image formats and to convert bitmaps between different
 color spaces.

libfontembed-dev: No summary available for libfontembed-dev in ubuntu quantal.

No description available for libfontembed-dev in ubuntu quantal.

libfontembed1: No summary available for libfontembed1 in ubuntu quantal.

No description available for libfontembed1 in ubuntu quantal.