Change log for cups package in Ubuntu

175 of 437 results
Published in disco-proposed on 2018-12-14
cups (2.2.10-3) unstable; urgency=medium

  * reprotest errors; cleanup patches:
    - Remove culprit patches refused for upstream integration:
     - patch to implement PRINTER_LIST printer filtering (see #3092)
     - patch to read embedded options from postcript (see #4344)
     - patch to cope with newline in device IDs (see #4345)
    - Update no-conffile-timestamp.patch for syntax bug

 -- Didier Raboud <email address hidden>  Fri, 14 Dec 2018 12:53:56 +0100

Available diffs

Published in xenial-proposed on 2018-12-12
cups (2.1.3-4ubuntu0.7) xenial; urgency=medium

  * fix-handling-of-MaxJobTime.patch: Fix handling of MaxJobTime 0
    (LP: #1804576)

 -- Dariusz Gadomski <email address hidden>  Wed, 12 Dec 2018 08:34:26 +0100
Published in bionic-proposed on 2018-12-12
cups (2.2.7-1ubuntu2.3) bionic; urgency=medium

  * fix-handling-of-MaxJobTime.patch: Fix handling of MaxJobTime 0
    (LP: #1804576)

 -- Dariusz Gadomski <email address hidden>  Wed, 12 Dec 2018 08:31:14 +0100
Published in cosmic-proposed on 2018-12-12
cups (2.2.8-5ubuntu1.2) cosmic; urgency=medium

  * fix-handling-of-MaxJobTime.patch: Fix handling of MaxJobTime 0
    (LP: #1804576)

 -- Dariusz Gadomski <email address hidden>  Wed, 12 Dec 2018 08:27:17 +0100
Published in disco-release on 2018-12-10
Deleted in disco-proposed (Reason: moved to release)
cups (2.2.10-1) unstable; urgency=medium

  * New 2.2.10 upstream release
    - CVE-2018-4700: Linux session cookies used a predictable random number
      seed (Closes: #915909)
  * Manpage translations refresh
  * Drop superfluous dpkg-dev B-D

 -- Didier Raboud <email address hidden>  Sat, 08 Dec 2018 12:58:43 +0100

Available diffs

Superseded in disco-release on 2018-12-10
Deleted in disco-proposed on 2018-12-11 (Reason: moved to release)
cups (2.2.9-4) unstable; urgency=medium

  * Cherry-pick from upstream:
    - Fix handling of MaxJobTime 0
      (Issue #5438, LP: #1804576, Closes: #915724)

 -- Didier Raboud <email address hidden>  Thu, 06 Dec 2018 19:05:22 +0100
Superseded in disco-proposed on 2018-12-07
cups (2.2.9-3ubuntu1) disco; urgency=medium

  [ Dariusz Gadomski ]
  * Fix handling of MaxJobTime 0 (LP: #1804576)

 -- Dan Streetman <email address hidden>  Thu, 06 Dec 2018 09:14:58 +0100
Superseded in disco-proposed on 2018-12-06
cups (2.2.9-3) unstable; urgency=medium

  * debian/control cleanup:
    - Refresh thanks to `cme fix dpkg-control`
    - Drop xpp suggest
    - Bump S-V to 4.2.1 without changes needed

  * Replace revert with upstream patch to fix `lpadmin -E` regression
    (Issue #5440)

 -- Didier Raboud <email address hidden>  Wed, 05 Dec 2018 22:45:00 +0100

Available diffs

Superseded in disco-release on 2018-12-08
Deleted in disco-proposed on 2018-12-09 (Reason: moved to release)
cups (2.2.9-2) unstable; urgency=medium

  * Revert 2.2.9 lpadmin fixes to circumvent 2.2.9 regression revealed
    by autopkgtest, see https://github.com/apple/cups/issues/5440

 -- Didier Raboud <email address hidden>  Mon, 19 Nov 2018 21:53:01 +0100
Published in xenial-updates on 2018-12-10
Published in xenial-security on 2018-12-10
cups (2.1.3-4ubuntu0.6) xenial-security; urgency=medium

  * SECURITY UPDATE: predictable session cookies
    - debian/patches/CVE-2018-4700.patch: use better seed in cgi-bin/var.c.
    - CVE-2018-4700

 -- Marc Deslauriers <email address hidden>  Fri, 16 Nov 2018 14:06:39 -0500
Published in trusty-updates on 2018-12-10
Published in trusty-security on 2018-12-10
cups (1.7.2-0ubuntu1.11) trusty-security; urgency=medium

  * SECURITY UPDATE: predictable session cookies
    - debian/patches/CVE-2018-4700.patch: use better seed in cgi-bin/var.c.
    - CVE-2018-4700

 -- Marc Deslauriers <email address hidden>  Fri, 16 Nov 2018 14:07:12 -0500
Published in bionic-updates on 2018-12-10
Published in bionic-security on 2018-12-10
cups (2.2.7-1ubuntu2.2) bionic-security; urgency=medium

  * SECURITY UPDATE: predictable session cookies
    - debian/patches/CVE-2018-4700.patch: use better seed in cgi-bin/var.c.
    - CVE-2018-4700

 -- Marc Deslauriers <email address hidden>  Fri, 16 Nov 2018 14:05:42 -0500
Published in cosmic-updates on 2018-12-10
Published in cosmic-security on 2018-12-10
cups (2.2.8-5ubuntu1.1) cosmic-security; urgency=medium

  * SECURITY UPDATE: predictable session cookies
    - debian/patches/CVE-2018-4700.patch: use better seed in cgi-bin/var.c.
    - CVE-2018-4700

 -- Marc Deslauriers <email address hidden>  Fri, 16 Nov 2018 14:03:27 -0500
Superseded in disco-proposed on 2018-11-20
cups (2.2.9-1) unstable; urgency=medium

  * New 2.2.9 upstream release
    - Remove libcups{cgi1,mime1,ppdc1} packages as they are not built
      anymore upstream

 -- Didier Raboud <email address hidden>  Fri, 16 Nov 2018 21:35:17 +0100
Superseded in disco-release on 2018-11-21
Published in cosmic-release on 2018-08-20
Deleted in cosmic-proposed (Reason: moved to release)
cups (2.2.8-5ubuntu1) cosmic; urgency=high

  * do-not-locally-filter-printing-to-remote-cups-queue.patch: Avoid duplicate
    application of pdftopdf filter (locally and remotely) when printing on auto-
    discovered remote CUPS printer.

 -- Till Kamppeter <email address hidden>  Sun, 19 Aug 2018 20:36:01 +0200
Superseded in cosmic-release on 2018-08-20
Deleted in cosmic-proposed on 2018-08-21 (Reason: moved to release)
cups (2.2.8-5) unstable; urgency=high

  * CVE-2018-6553: Fix AppArmor cupsd sandbox bypass due to use of hard links
    (Closes: #903605)
  * All these were fixed in 2.2.8:
    - CVE-2018-4180 Local Privilege Escalation to Root in dnssd Backend
      (CUPS_SERVERBIN)
    - CVE-2018-4181 Limited Local File Reads as Root via cupsd.conf Include
      Directive
    - CVE-2018-4182 cups-exec Sandbox Bypass Due to Insecure Error Handling
    - CVE-2018-4183 cups-exec Sandbox Bypass Due to Profile Misconfiguration

 -- Didier Raboud <email address hidden>  Thu, 12 Jul 2018 18:48:48 +0200
Superseded in cosmic-release on 2018-08-14
Deleted in cosmic-proposed on 2018-08-15 (Reason: moved to release)
cups (2.2.7-1ubuntu3) cosmic; urgency=medium

  * SECURITY UPDATE: privilege escalation in dnssd backend
    - debian/patches/CVE-2018-418x.patch: don't allow PassEnv and SetEnv to
      override standard variables in man/cups-files.conf.man.in,
      man/cupsd.conf.man.in, scheduler/conf.c, test/run-stp-tests.sh.
    - CVE-2018-4180
  * SECURITY UPDATE: local file read via Include directive
    - debian/patches/CVE-2018-418x.patch: remove Include directive handling
      in scheduler/conf.c.
    - CVE-2018-4181
  * SECURITY UPDATE: AppArmor sandbox bypass
    - debian/local/apparmor-profile: also confine
      /usr/lib/cups/backend/mdns.
    - CVE-2018-6553

 -- Marc Deslauriers <email address hidden>  Fri, 22 Jun 2018 13:02:42 -0400

Available diffs

Published in artful-updates on 2018-07-11
Published in artful-security on 2018-07-11
cups (2.2.4-7ubuntu3.1) artful-security; urgency=medium

  * SECURITY UPDATE: scheduler crash via DBUS notifications
    - debian/patches/CVE-2017-18248.patch: validate requesting-user-name in
      scheduler/ipp.c.
    - CVE-2017-18248
  * SECURITY UPDATE: privilege escalation in dnssd backend
    - debian/patches/CVE-2018-418x.patch: don't allow PassEnv and SetEnv to
      override standard variables in man/cups-files.conf.man.in,
      man/cupsd.conf.man.in, scheduler/conf.c, test/run-stp-tests.sh.
    - CVE-2018-4180
  * SECURITY UPDATE: local file read via Include directive
    - debian/patches/CVE-2018-418x.patch: remove Include directive handling
      in scheduler/conf.c.
    - CVE-2018-4181
  * SECURITY UPDATE: AppArmor sandbox bypass
    - debian/local/apparmor-profile: also confine
      /usr/lib/cups/backend/mdns.
    - CVE-2018-6553

 -- Marc Deslauriers <email address hidden>  Fri, 22 Jun 2018 13:41:03 -0400
Superseded in bionic-updates on 2018-12-10
Superseded in bionic-security on 2018-12-10
cups (2.2.7-1ubuntu2.1) bionic-security; urgency=medium

  * SECURITY UPDATE: privilege escalation in dnssd backend
    - debian/patches/CVE-2018-418x.patch: don't allow PassEnv and SetEnv to
      override standard variables in man/cups-files.conf.man.in,
      man/cupsd.conf.man.in, scheduler/conf.c, test/run-stp-tests.sh.
    - CVE-2018-4180
  * SECURITY UPDATE: local file read via Include directive
    - debian/patches/CVE-2018-418x.patch: remove Include directive handling
      in scheduler/conf.c.
    - CVE-2018-4181
  * SECURITY UPDATE: AppArmor sandbox bypass
    - debian/local/apparmor-profile: also confine
      /usr/lib/cups/backend/mdns.
    - CVE-2018-6553

 -- Marc Deslauriers <email address hidden>  Fri, 22 Jun 2018 13:36:08 -0400
Superseded in trusty-updates on 2018-12-10
Superseded in trusty-security on 2018-12-10
cups (1.7.2-0ubuntu1.10) trusty-security; urgency=medium

  * SECURITY UPDATE: scheduler crash via DBUS notifications
    - debian/patches/CVE-2017-18248.patch: validate requesting-user-name in
      scheduler/ipp.c.
    - CVE-2017-18248
  * SECURITY UPDATE: privilege escalation in dnssd backend
    - debian/patches/CVE-2018-418x.patch: don't allow PassEnv and SetEnv to
      override standard variables in man/cups-files.conf.man.in,
      man/cupsd.conf.man.in, scheduler/conf.c.
    - CVE-2018-4180
  * SECURITY UPDATE: local file read via Include directive
    - debian/patches/CVE-2018-418x.patch: remove Include directive handling
      in scheduler/conf.c.
    - CVE-2018-4181
  * SECURITY UPDATE: AppArmor sandbox bypass
    - debian/local/apparmor-profile: also confine
      /usr/lib/cups/backend/mdns.
    - CVE-2018-6553

 -- Marc Deslauriers <email address hidden>  Fri, 22 Jun 2018 13:53:17 -0400
Superseded in xenial-updates on 2018-12-10
Superseded in xenial-security on 2018-12-10
cups (2.1.3-4ubuntu0.5) xenial-security; urgency=medium

  * SECURITY UPDATE: scheduler crash via DBUS notifications
    - debian/patches/CVE-2017-18248.patch: validate requesting-user-name in
      scheduler/ipp.c.
    - CVE-2017-18248
  * SECURITY UPDATE: privilege escalation in dnssd backend
    - debian/patches/CVE-2018-418x.patch: don't allow PassEnv and SetEnv to
      override standard variables in man/cups-files.conf.man.in,
      man/cupsd.conf.man.in, scheduler/conf.c.
    - CVE-2018-4180
  * SECURITY UPDATE: local file read via Include directive
    - debian/patches/CVE-2018-418x.patch: remove Include directive handling
      in scheduler/conf.c.
    - CVE-2018-4181
  * SECURITY UPDATE: AppArmor sandbox bypass
    - debian/local/apparmor-profile: also confine
      /usr/lib/cups/backend/mdns.
    - CVE-2018-6553

 -- Marc Deslauriers <email address hidden>  Fri, 22 Jun 2018 13:45:28 -0400
Superseded in cosmic-release on 2018-07-13
Published in bionic-release on 2018-04-10
Deleted in bionic-proposed (Reason: moved to release)
cups (2.2.7-1ubuntu2) bionic; urgency=medium

  * Fixed another crash when creating temporary queues for IPP printers
    (Issue #5290, LP: #1762476).

 -- Till Kamppeter <email address hidden>  Mon,  9 Apr 2018 21:44:01 +0200

Available diffs

Superseded in bionic-release on 2018-04-10
Deleted in bionic-proposed on 2018-04-12 (Reason: moved to release)
cups (2.2.7-1ubuntu1) bionic; urgency=medium

  * Reverted the upstrem changes for deprecation of raw queues
    - This changes the behavior of CUPS (warnings, error_log entries) and
      is not a bug fix, so not adequate for Bionic in this stage.
    - It breaks the autopkgtest of the CUPS package.

 -- Till Kamppeter <email address hidden>  Thu, 29 Mar 2018 15:13:01 +0200
Superseded in bionic-proposed on 2018-03-29
cups (2.2.7-1) unstable; urgency=medium

  * New 2.2.7 upstream release
    - NOTICE: Raw print queues are now deprecated (Issue #5269)
    - Fixed an Avahi crash bug in the scheduler (Issue #5268, LP: #1725749)
    - Systemd did not restart cupsd when configuration changes were made that
      required a restart (Issue #5263. Closes: #861470)
    - The scheduler could crash while adding an IPP Everywhere printer (Issue
      #5258, LP: #1750514)
    - The `lp` and `lpr` commands now provide better error messages when the
      default printer cannot be found (Issue #5096, Closes: #870463)
   * Add cupsHashString@Base 2.2.7 symbol
   * Add lintian override for cups.service WantedBy=printer.target

 -- Didier Raboud <email address hidden>  Tue, 27 Mar 2018 19:45:49 +0200

Available diffs

Superseded in trusty-updates on 2018-07-11
Superseded in trusty-security on 2018-07-11
cups (1.7.2-0ubuntu1.9) trusty-security; urgency=medium

  * SECURITY UPDATE: Incorrect whitelist permits DNS rebinding attacks
    - debian/patches/CVE-2017-18190.patch: Don't treat "localhost.localdomain"
      as an allowed replacement for localhost, since it isn't
    - CVE-2017-18190

 -- Chris Coulson <email address hidden>  Mon, 19 Feb 2018 17:45:40 +0000
Superseded in xenial-updates on 2018-07-11
Superseded in xenial-security on 2018-07-11
cups (2.1.3-4ubuntu0.4) xenial-security; urgency=medium

  * SECURITY UPDATE: Incorrect whitelist permits DNS rebinding attacks
    - debian/patches/CVE-2017-18190.patch: Don't treat "localhost.localdomain"
      as an allowed replacement for localhost, since it isn't
    - CVE-2017-18190

 -- Chris Coulson <email address hidden>  Mon, 19 Feb 2018 17:37:01 +0000
Superseded in bionic-release on 2018-03-30
Deleted in bionic-proposed on 2018-03-31 (Reason: moved to release)
cups (2.2.6-5) unstable; urgency=medium

  * Bump S-V to 4.1.3 without changes needed
  * Update Vcs-* fields for the move to salsa.d.o

 -- Didier Raboud <email address hidden>  Sat, 10 Feb 2018 11:14:39 +0100

Available diffs

Superseded in bionic-release on 2018-02-10
Deleted in bionic-proposed on 2018-02-12 (Reason: moved to release)
cups (2.2.6-4) unstable; urgency=medium

  * Fix CI: indexv[3,4] Braille drivers cannot print PDF

 -- Didier Raboud <email address hidden>  Sun, 31 Dec 2017 11:35:12 +0100

Available diffs

Superseded in bionic-release on 2017-12-31
Deleted in bionic-proposed on 2018-01-02 (Reason: moved to release)
cups (2.2.6-3) unstable; urgency=medium

  [ Helge Kreutzmann ]
  * Update German man page translations

  [ Didier Raboud ]
  * Bump S-V to 4.1.2 without changes needed
  * Remove trailing whitespace in d/control and d/changelog
  * Drop duplicate priority field for cups-bsd

 -- Didier Raboud <email address hidden>  Mon, 18 Dec 2017 21:52:25 +0100

Available diffs

Superseded in artful-updates on 2018-07-11
Deleted in artful-proposed on 2018-07-12 (Reason: moved to -updates)
cups (2.2.4-7ubuntu3) artful; urgency=medium

  * Fixes cupsGetNamedDest not using local default printer
    (LP: #1729910)

 -- Dariusz Gadomski <email address hidden>  Wed, 08 Nov 2017 11:31:52 +0100

Available diffs

Superseded in bionic-release on 2017-12-19
Deleted in bionic-proposed on 2017-12-21 (Reason: moved to release)
cups (2.2.6-2) unstable; urgency=medium

  * Backport upstream patch from the 2.3 branch:
    - The `lp` and `lpr` commands now provide better error messages when the
      default printer cannot be found (Issue #5096, Closes: #870463)
  * On the repository: reduce the diff to the upstream tarball to zero to
    allow uploads with dgit.

 -- Didier Raboud <email address hidden>  Fri, 03 Nov 2017 12:55:53 +0100

Available diffs

Superseded in bionic-proposed on 2017-11-04
cups (2.2.6-1) unstable; urgency=medium

  * New 2.2.6 upstream release
    - DBUS notifications could crash the scheduler (Issue #5143)
    - Added USB quirks rules for Canon MP540 and Samsung ML-2160 (Issue #5148)
    - Localization updates (Issue #5152)

  * Update manpage translations
  * Fix DEB_HOST_ARCH_OS dpkg-architecture variable setting
  * Move source local-options to options

 -- Didier Raboud <email address hidden>  Thu, 02 Nov 2017 17:54:53 +0100

Available diffs

Superseded in bionic-release on 2017-11-11
Deleted in bionic-proposed on 2017-11-12 (Reason: moved to release)
cups (2.2.5-2) unstable; urgency=medium

  [ Helge Kreutzmann ]
    * Update German man page translations

 -- Didier Raboud <email address hidden>  Tue, 17 Oct 2017 08:43:33 +0200
Superseded in bionic-release on 2017-10-28
Published in artful-release on 2017-09-26
Deleted in artful-proposed (Reason: moved to release)
cups (2.2.4-7ubuntu2) artful; urgency=medium

  * test-drivers script of autopkgtest: Skip also gen-ubrl.ppd as it is also a
    test/debug PPD for Braille embossers which does not accept PDF as
    input format. This broke the test with cups-filters 1.17.6 and later.

 -- Till Kamppeter <email address hidden>  Mon, 26 Sep 2017 09:26:01 -0400

Available diffs

Superseded in artful-release on 2017-09-26
Deleted in artful-proposed on 2017-09-28 (Reason: moved to release)
cups (2.2.4-7ubuntu1) artful; urgency=medium

  * test-drivers script of autopkgtest: Skip gen-brf.ppd as it is a
    test/debug PPD for Braille embossers which does not accept PDF as
    input format. This broke the test with cups-filters 1.17.6 and later.

 -- Till Kamppeter <email address hidden>  Mon, 25 Sep 2017 16:08:01 -0400
Superseded in artful-release on 2017-09-26
Deleted in artful-proposed on 2017-09-27 (Reason: moved to release)
cups (2.2.4-7) unstable; urgency=medium

  [ Till Kamppeter ]
  * Backport upstream fixes:
    - Fix the interactions between the "print-quality" and "cupsPrintQuality"
      options (Issue #5090)
    - Fix mapping and defaulting of print-quality/cupsPrintQuality (Issue #5090)
    - Fix for resolution list sorting in the PPD generator which caused
      segfaults when generating PPDs for driverless printing
    - The scheduler (incorrectly) woke up once per second to remove stale
      temporary queues (Issue #5100)

 -- Didier Raboud <email address hidden>  Wed, 13 Sep 2017 18:53:20 +0200
Superseded in artful-release on 2017-09-15
Deleted in artful-proposed on 2017-09-16 (Reason: moved to release)
cups (2.2.4-6ubuntu1) artful; urgency=medium

  * Backport upstream fix fr the scheduler waking up once a second to remove
    stale temporary print queues (Issue #5100).
  * Backport upstream fix for resolution list sorting in the PPD generator.
    This caused segfaults when generating PPDs for driverless printing.
  * Backport upstream patches to fix the cupsPrintQuality and
    print-quality options/arguments for driverless printing with
    auto-generated PPD files (Issue #5090)

 -- Till Kamppeter <email address hidden>  Wed, 13 Sep 2017 11:10:01 -0300
Superseded in artful-release on 2017-09-14
Deleted in artful-proposed on 2017-09-15 (Reason: moved to release)
cups (2.2.4-5) unstable; urgency=medium

  * Backport one upstream patch, thanks to Christoph Pleger
    - The CUPS library did not reuse domain sockets
      (Issue #5098, Closes: #868316)

 -- Didier Raboud <email address hidden>  Tue, 29 Aug 2017 09:21:15 +0200

Available diffs

Superseded in artful-release on 2017-08-29
Deleted in artful-proposed on 2017-08-31 (Reason: moved to release)
cups (2.2.4-4) unstable; urgency=low

  * Backport two upstream patches, thanks to Till Kamppeter
    - The IPP Everywhere PPD generator now sorts the supported resolutions
      before choosing them for draft, normal, and best quality modes
      (Issue #5091)
    - Fix an Avahi-related crash bug in the scheduler
      (Issues #5085 & #5086)

 -- Didier Raboud <email address hidden>  Mon, 28 Aug 2017 19:32:14 +0200

Available diffs

Superseded in xenial-updates on 2018-02-20
Deleted in xenial-proposed on 2018-02-22 (Reason: moved to -updates)
cups (2.1.3-4ubuntu0.3) xenial; urgency=high

  * Adding maintainer script debian/cups-daemon.prerm to deal with situations
    where "old-version" (installed package) prerm script fails. (LP: #1642966).

Superseded in artful-release on 2017-08-29
Deleted in artful-proposed on 2017-08-30 (Reason: moved to release)
cups (2.2.4-3) unstable; urgency=medium

  [ Helge Kreutzmann ]
  * Update German man page translations

 -- Didier Raboud <email address hidden>  Fri, 21 Jul 2017 15:00:58 +0200

Available diffs

Superseded in artful-proposed on 2017-07-21
cups (2.2.4-2) unstable; urgency=low

  * Cleanup patch suite to come closer to upstream:
    - Remove IPP backend from CUPS 1.4
    - Remove cupsd upstart support
    - Remove a test weakening for mips
    - Remove libcupsppdc dynamic linking for mipsen
  * Don't install the ipp14 backend
  * Drop all postinst code managing versions before the current oldoldstable
    (wheezy, 1.5.3-5)
  * Drop all postinst code managing versions before the current oldstable
    (jessie, 1.7.5-11)
  * Drop the Ubuntu-specific upstart patches and files
  * Drop Launchpad PNG_PKG_MANGLE workaround
  * Drop two unused lintian overrides
  * Allow parallel builds
  * Backport upstream patch:
    - The `cupsGetDests` function incorrectly returned an empty list of
      printers if there was no default printer (Issue #5046, Closes: #867818)

  [ Vangelis Skarmoutsos ]
  * Add Greek translation for debconf templates (Closes: #867339)

 -- Didier Raboud <email address hidden>  Mon, 10 Jul 2017 21:23:54 +0200

Available diffs

Superseded in artful-proposed on 2017-07-11
cups (2.2.4-1) unstable; urgency=medium

  * New 2.2.4 upstream release

  * Cope with upstream documentation format change to markdown
  * Migrate to debhelper compat 10
  * Add two new libcups2 symbols
  * Lintian overrides updates:
    - Update cups' override for the non-standard-executable-perm usb
      backend
    - Add source override for the libcups{,image}2-dev circular
      dependency
  * Make libcupsimage2-dev Multi-Arch: same
  * Bump Standards-Version to 4.0.0
    - Make sure to update config.{sub,guess} at build time

 -- Didier Raboud <email address hidden>  Wed, 05 Jul 2017 21:45:48 +0200

Available diffs

Superseded in artful-release on 2017-07-23
Deleted in artful-proposed on 2017-07-24 (Reason: moved to release)
cups (2.2.3-2) unstable; urgency=low

  * Migrate 2.2.3 to unstable

 -- Didier Raboud <email address hidden>  Sun, 18 Jun 2017 16:24:03 +0200

Available diffs

Superseded in artful-release on 2017-06-26
Deleted in artful-proposed on 2017-06-28 (Reason: moved to release)
cups (2.2.3-1) experimental; urgency=medium

  * New 2.2.3 upstream release
  * Cherry-pick upstream fix for regression in job file preservation

 -- Didier Raboud <email address hidden>  Tue, 18 Apr 2017 21:24:32 +0200
Superseded in artful-release on 2017-05-09
Obsolete in zesty-release on 2018-06-22
Deleted in zesty-proposed on 2018-06-22 (Reason: moved to release)
cups (2.2.2-1ubuntu1) zesty; urgency=medium

  * debian/local/apparmor-profile:
    - allow cupsd and cups-pdf to communicate via Unix sockets (LP: #1675503)
    - adjust cups-pdf log location
    - allow cups-pdf to read /etc/cups/ppd/*.ppd
    - silence noisy denials for cupsd occasionally trying to send signals to
      unconfined
    - allow capability wake_alarm (seen in LP: 1641985)

 -- Jamie Strandboge <email address hidden>  Thu, 23 Mar 2017 17:55:49 +0000
Superseded in trusty-updates on 2018-02-20
Deleted in trusty-proposed on 2018-02-22 (Reason: moved to -updates)
cups (1.7.2-0ubuntu1.8) trusty; urgency=medium

  * Fixed processing of server overrides without port numbers. (LP: #1665018)

 -- Dariusz Gadomski <email address hidden>  Wed, 15 Feb 2017 15:55:27 +0100
Deleted in xenial-updates on 2017-08-24 (Reason: causing systemd related regression -- LP #1676380)
Superseded in xenial-proposed on 2017-08-23
cups (2.1.3-4ubuntu0.2) xenial; urgency=medium

  * Make cups.path unit be part of the cups.service, since cups.path
    should stop if and when cups.service is stopped. LP: #1642966

 -- Dimitri John Ledkov <email address hidden>  Thu, 22 Dec 2016 17:08:36 +0000
Obsolete in yakkety-proposed on 2018-01-23
cups (2.2.0-2ubuntu0.1) yakkety; urgency=medium

  * Make cups.path unit be part of the cups.service, since cups.path
    should stop if and when cups.service is stopped. LP: #1642966

 -- Dimitri John Ledkov <email address hidden>  Thu, 22 Dec 2016 17:06:04 +0000
Superseded in zesty-release on 2017-03-24
Deleted in zesty-proposed on 2017-04-07 (Reason: moved to release)
cups (2.2.2-1) experimental; urgency=medium

  * New 2.2.2 upstream release
  * Refresh manpage translations
  * dpkg-source: update extend-diff-ignore to cope with the difference between
    upstream's VCS and tarball

 -- Didier Raboud <email address hidden>  Wed, 18 Jan 2017 13:48:47 +0100

Available diffs

Superseded in zesty-release on 2017-01-19
Deleted in zesty-proposed on 2017-01-20 (Reason: moved to release)
cups (2.2.1-56-ga2f30a72f-1) experimental; urgency=medium

  * New 2.2.1+ upstream snapshot
    - Updated systemd config files (Issue #4935)

  [ Didier Raboud ]
  * Merge 2.2.1-5 from unstable

  [ Till Kamppeter ]
  * Updated debian/control: CUPS does not support PPD-less printing any
    more, we do driverless printing instead

 -- Didier Raboud <email address hidden>  Sun, 15 Jan 2017 15:00:04 +0100
Superseded in zesty-release on 2017-01-18
Deleted in zesty-proposed on 2017-01-19 (Reason: moved to release)
cups (2.2.1-46-g10887d272-2) experimental; urgency=medium

  * Merge 2.2.1-4 from unstable.

 -- Didier Raboud <email address hidden>  Tue, 20 Dec 2016 09:16:41 +0100
Superseded in zesty-release on 2016-12-20
Deleted in zesty-proposed on 2016-12-22 (Reason: moved to release)
cups (2.2.1-41-g49c592936-1) experimental; urgency=medium

  * New 2.2.1+ upstream snapshot

 -- Didier Raboud <email address hidden>  Fri, 09 Dec 2016 09:57:28 +0100

Available diffs

Superseded in xenial-proposed on 2017-02-16
cups (2.1.3-4ubuntu0.1) xenial-proposed; urgency=medium

  * Removed auto-shutdown-on-idle-also-with-webinterface-on.patch
    as it causes CUPS to auto-shutdown when web interface support is
    active (LP: #1598300).

 -- Till Kamppeter <email address hidden>  Mon, 14 Nov 2016 14:38:01 -0200
Superseded in zesty-release on 2016-12-13
Deleted in zesty-proposed on 2016-12-14 (Reason: moved to release)
cups (2.2.1-2) unstable; urgency=medium

  [ Helge Kreutzmann ]
  * Several fixes to german manpages due to proofreading on
    debian-l10n-german

 -- Didier Raboud <email address hidden>  Thu, 03 Nov 2016 09:26:32 +0100
Superseded in zesty-release on 2016-11-05
Deleted in zesty-proposed on 2016-11-07 (Reason: moved to release)
cups (2.2.0-2build1) zesty; urgency=medium

  * No-change rebuild using Linaro GCC.

 -- Matthias Klose <email address hidden>  Wed, 19 Oct 2016 08:28:28 +0000
Superseded in zesty-proposed on 2016-11-03
cups (2.2.1-1) unstable; urgency=medium

  * New 2.2.1 upstream release
    - Updated man pages (PR #4885, Closes: #838854)

  [ Helge Kreutzmann ]
  * Update German man page

  [ Didier Raboud ]
  * Demote libcupsfilters{1,-dev} dependencies to recommends (Closes: #711697)
  * Remove lsb Depends from cups, bump cups-daemon's to 3.2-14~

  [ Helmut Grohne ]
  * Fix FTCBFS (Closes: #837936)
    - Build mantohtml with the build architecture compiler
    - Do not execute genstrings during build

 -- Didier Raboud <email address hidden>  Wed, 05 Oct 2016 11:32:06 +0200
Superseded in zesty-release on 2016-10-21
Obsolete in yakkety-release on 2018-01-23
Deleted in yakkety-proposed on 2018-01-23 (Reason: moved to release)
cups (2.2.0-2) unstable; urgency=medium

  * Backport upstream patch to handle partial failures when connecting
    (Closes: #838434)

 -- Didier Raboud <email address hidden>  Wed, 21 Sep 2016 09:30:58 +0200

Available diffs

Superseded in yakkety-release on 2016-09-28
Deleted in yakkety-proposed on 2016-09-29 (Reason: moved to release)
cups (2.2.0-1) unstable; urgency=medium

  * New 2.2.0 upstream release
    - http*Connect did not work on Linux when cupsd was not running
      (Issue #4870)

  [ Helge Kreutzmann ]
  * Several fixes due to proofreading on debian-l10n-german

  [ Didier Raboud ]
  * Update the manpage-po4a README

 -- Didier Raboud <email address hidden>  Mon, 19 Sep 2016 16:29:10 +0200

Available diffs

Superseded in yakkety-release on 2016-09-20
Deleted in yakkety-proposed on 2016-09-22 (Reason: moved to release)
cups (2.2~rc1-4) experimental; urgency=medium

  * Revert unintentional Ubuntu patches removal; refresh them

 -- Didier Raboud <email address hidden>  Sun, 14 Aug 2016 16:26:04 +0200
Superseded in yakkety-release on 2016-08-15
Deleted in yakkety-proposed on 2016-08-16 (Reason: moved to release)
cups (2.2~rc1-2ubuntu2) yakkety; urgency=medium

  * Revert 2.2~rc1-2 changes they are buggy and remove ubuntu patches
    wrongly which leads to a failing build, those needs to be sorted out
    but meanwhile we want the depends fix in.

 -- Sebastien Bacher <email address hidden>  Wed, 10 Aug 2016 17:06:09 +0200
Superseded in yakkety-proposed on 2016-08-10
cups (2.2~rc1-2ubuntu1) yakkety; urgency=medium

  * debian/control:
    - let libcups2-dev depends on libcupsimage2-dev since, should fix gtk
      build failing with the current version

 -- Sebastien Bacher <email address hidden>  Wed, 10 Aug 2016 15:19:35 +0200
Superseded in yakkety-proposed on 2016-08-10
cups (2.2~rc1-1) experimental; urgency=medium

  * New 2.2~rc1 upstream release
  * Refresh patches

 -- Didier Raboud <email address hidden>  Mon, 08 Aug 2016 20:35:24 +0200

Available diffs

Superseded in yakkety-release on 2016-08-10
Deleted in yakkety-proposed on 2016-08-12 (Reason: moved to release)
cups (2.1.4-4) unstable; urgency=medium

  * Patch a final lpstat call to really make the build reproducible when built
    in italian

 -- Didier Raboud <email address hidden>  Mon, 11 Jul 2016 13:19:05 +0200

Available diffs

Superseded in yakkety-release on 2016-07-11
Deleted in yakkety-proposed on 2016-07-13 (Reason: moved to release)
cups (2.1.4-3) unstable; urgency=low

  * Change the default ErrorPolicy from 'stop-printer' to 'retry-job'
    - Update documentation, manpage and manpage translations
    - Add a cups-daemon NEWS entry
    (Closes: #631025)
  * Patch another lpstat call to also make the build reproducible when built in
    italian

 -- Didier Raboud <email address hidden>  Thu, 07 Jul 2016 16:43:34 +0200

Available diffs

Superseded in yakkety-release on 2016-07-08
Deleted in yakkety-proposed on 2016-07-10 (Reason: moved to release)
cups (2.1.4-2) unstable; urgency=medium

  [ Helge Kreutzmann ]
  * Update German man page (2118t3f1u)

  [ Didier Raboud ]
  * Add patch to force LC_ALL=C on lpstat when grepping its output for
    Description; should fix the FTBFS on forced-languages reproducible builds
    environments

 -- Didier Raboud <email address hidden>  Sun, 03 Jul 2016 11:35:21 +0200

Available diffs

Superseded in yakkety-release on 2016-07-04
Deleted in yakkety-proposed on 2016-07-05 (Reason: moved to release)
cups (2.1.4-1) unstable; urgency=medium

  * New 2.1.4 upstream release

  * Update debian/watch to check for new releases on GitHub
  * Remove 3 patches backported from upstream, refresh some
  * Refresh manpage translations

 -- Didier Raboud <email address hidden>  Fri, 17 Jun 2016 09:45:39 +0200

Available diffs

Superseded in yakkety-release on 2016-06-19
Deleted in yakkety-proposed on 2016-06-20 (Reason: moved to release)
cups (2.1.3-6) unstable; urgency=medium

  [ Till Kamppeter ]
  * De-activate CUPS web interface when the files for it are not installed.
    This allows for auto-shutdown on mobile device installations.
  * Make CUPS with the Upstart support patch (Ubuntu-only) also build on
    ubuntuBSD (LP: #1582002)

  [ Helge Kreutzmann ]
  * Update German translation

  [ Didier Raboud ]
  * Backport upstream-included patch to fix malformed device-id for printers
    found by dnssd, thanks to Laurent Bigonville.
  * Bump S-V to 3.9.8 without changes needed
  * Drop duplicate 'using' word in libcups2's README.Debian

 -- Didier Raboud <email address hidden>  Wed, 08 Jun 2016 21:43:14 +0200

Available diffs

Superseded in yakkety-release on 2016-06-16
Deleted in yakkety-proposed on 2016-06-17 (Reason: moved to release)
cups (2.1.3-5) unstable; urgency=medium

  * Automatically generate debug package, B-D against debhelper >= 9.20160114
  * Convert homepage and Vcs-Browser to https urls
  * Drop the patch to allow auto-shutdown on idle with active web interface,
    this induces a regression for web-interface users (Closes: #816490)

 -- Didier Raboud <email address hidden>  Fri, 25 Mar 2016 12:01:30 +0100

Available diffs

Superseded in yakkety-release on 2016-04-29
Published in xenial-release on 2016-03-25
Deleted in xenial-proposed (Reason: moved to release)
cups (2.1.3-4) unstable; urgency=medium

  [ Till Kamppeter ]
  * Quirk rule to make Lexmark C540n work (STR #4778)
  * Quirk rule to make Xerox WorkCentre 3220 work (LP: #1406203, STR #4789)

 -- Didier Raboud <email address hidden>  Fri, 18 Mar 2016 15:24:54 +0100

Available diffs

Superseded in xenial-release on 2016-03-25
Deleted in xenial-proposed on 2016-03-27 (Reason: moved to release)
cups (2.1.3-3) unstable; urgency=medium

  * Install missing cups-snmp.8 manpage (Closes: #816316)

 -- Didier Raboud <email address hidden>  Mon, 29 Feb 2016 22:11:50 +0100
Superseded in xenial-release on 2016-03-18
Deleted in xenial-proposed on 2016-03-19 (Reason: moved to release)
cups (2.1.3-1build1) xenial; urgency=medium

  * No-change rebuild for gnutls transition.

 -- Matthias Klose <email address hidden>  Wed, 17 Feb 2016 22:24:02 +0000
Superseded in xenial-release on 2016-02-22
Deleted in xenial-proposed on 2016-02-23 (Reason: moved to release)
cups (2.1.3-1) unstable; urgency=medium

  * New 2.1.3 upstream release:
    - /admin resource files (like config files of CUPS) were not served when
      the web interface was disabled, breaking utilities like "cupsctl"
      (CUPS STR #4755)

 -- Didier Raboud <email address hidden>  Sat, 13 Feb 2016 16:35:01 +0100

Available diffs

Superseded in xenial-release on 2016-02-15
Deleted in xenial-proposed on 2016-02-16 (Reason: moved to release)
cups (2.1.2-2) unstable; urgency=medium

  [ Till Kamppeter ]
  * Add patch to avoid letting pending subscriptions prevent CUPS from
    auto-shutdown when idle (CUPS STR#4754)
  * Add patch to allow auto-shutdown when idle if the web interface is not
    turned off in the CUPS configuration, the web interface is too important
    (CUPS STR #4755)

  [ Didier Raboud ]
  * Remove libpng12-dev Build-Depends alternative to libpng-dev
    (Closes: #810183)

 -- Didier Raboud <email address hidden>  Wed, 13 Jan 2016 16:21:31 +0100

Available diffs

Superseded in trusty-updates on 2017-02-27
Superseded in trusty-security on 2018-02-20
cups (1.7.2-0ubuntu1.7) trusty-security; urgency=medium

  * Disable SSLv3 with option to turn back on.
    - debian/patches/disable-sslv3.patch: AllowSSL3 turns SSLv3
      back on and AllowRC4 turns on just the RC4 cypers. (LP: #1505328)

 -- Bryan Quigley <email address hidden>  Tue, 10 Nov 2015 21:08:44 +0000
175 of 437 results