Change log for ddd package in Ubuntu

116 of 16 results
Published in eoan-release on 2019-04-18
Published in disco-release on 2018-10-30
Published in cosmic-release on 2018-05-04
Deleted in cosmic-proposed (Reason: moved to release)
ddd (1:3.3.12-5.1build3) cosmic; urgency=medium

  * No-change rebuild for ncurses soname changes.

 -- Matthias Klose <email address hidden>  Thu, 03 May 2018 15:22:38 +0000
Superseded in cosmic-release on 2018-05-04
Published in bionic-release on 2018-04-03
Deleted in bionic-proposed (Reason: moved to release)
ddd (1:3.3.12-5.1build2) bionic; urgency=high

  * No change rebuild to pick up -fPIE compiler default

 -- Balint Reczey <email address hidden>  Tue, 03 Apr 2018 12:18:55 +0000
Superseded in bionic-release on 2018-04-03
Published in artful-release on 2017-04-20
Obsolete in zesty-release on 2018-06-22
Obsolete in yakkety-release on 2018-01-23
Published in xenial-release on 2016-02-07
Deleted in xenial-proposed (Reason: moved to release)
ddd (1:3.3.12-5.1build1) xenial; urgency=medium

  * No-change rebuild for ncurses6 transition.

 -- Matthias Klose <email address hidden>  Sun, 07 Feb 2016 15:53:07 +0000
Superseded in xenial-release on 2016-02-07
Deleted in xenial-proposed on 2016-02-08 (Reason: moved to release)
ddd (1:3.3.12-5.1) unstable; urgency=medium

  * Non-maintainer upload.
  * debian/control: Build-depends against libelf-dev instead of libelfg0-dev,
    the later doesn't seem to be maintained anymore. (Closes: #803758)

 -- Laurent Bigonville <email address hidden>  Mon, 02 Nov 2015 12:31:12 +0100

Available diffs

Superseded in xenial-release on 2015-11-03
Obsolete in wily-release on 2018-01-22
Obsolete in vivid-release on 2018-01-18
Obsolete in utopic-release on 2016-11-03
Published in trusty-release on 2013-10-18
Obsolete in saucy-release on 2015-04-24
Deleted in saucy-proposed (Reason: moved to release)
ddd (1:3.3.12-5) unstable; urgency=low


  * Switch from lesstif to motif.  Closes: #714657.
  * Use dh-autoreconf instead of the previous hand-rolled version.
  * Remove old ddd-doc.preinst which was for upgrading from older versions
    than what's in oldstable.

 -- Daniel Schepler <email address hidden>  Sat, 06 Jul 2013 12:50:28 -0700

Available diffs

Superseded in saucy-release on 2013-07-07
Obsolete in raring-release on 2015-04-24
Deleted in raring-proposed on 2015-04-27 (Reason: moved to release)
ddd (1:3.3.12-4) unstable; urgency=low


  * Remove broken ICE_MOTIF_DIALOGS_OWN_SELECTION_LIST configure test,
    which caused the configure process to thrash the swap and hang.
    Closes: #682627.

 -- Daniel Schepler <email address hidden>  Tue, 21 Aug 2012 19:10:20 -0700
Superseded in raring-release on 2012-10-29
Obsolete in quantal-release on 2015-04-24
Published in precise-release on 2011-12-14
ddd (1:3.3.12-3) unstable; urgency=low

  * Add -ltinfo to the search path for termcap libraries.  Closes: #646170.
  * Add Build-Depends on info and texinfo.
  * Remove libxp-dev from Build-Depends, and force configure script not to
    search for it.  Closes: #623640.
  * Add -Wl,--as-needed to LDFLAGS, to get rid of useless direct linking
    against SM, ICE, Xpm, Xext libraries.
 -- Ubuntu Archive Auto-Sync <email address hidden>   Wed,  14 Dec 2011 09:45:52 +0000
Superseded in precise-release on 2011-12-14
Obsolete in oneiric-release on 2015-04-24
ddd (1:3.3.12-2.1) unstable; urgency=low
  * Non-maintainer upload.  * Fix machine code window view (Closes: #597328) -- Wookey <email address hidden>  Fri, 08 Jul 2011 17:29:38 +0100
Superseded in oneiric-release on 2011-07-27
Obsolete in natty-release on 2013-06-04
Obsolete in maverick-release on 2013-03-05
ddd (1:3.3.12-2) unstable; urgency=low

  * Drop versioned lpr Build-Depends and instead force LPR=lpr in the
    configure script's environment. This will hopefully allow ddd to build
    on kfreebsd-* and migrate into testing, addressing #595849.
  * Do the same for other utilities not actually used at build time other
    than to fill out the app-defaults file.
  * Update to 3.0 (quilt) source format.
  * Install icon referenced by ddd.desktop.  Closes: #592983.
 -- Artur Rona <email address hidden>   Thu,  16 Sep 2010 17:02:09 +0000

Available diffs

Superseded in maverick-release on 2010-09-16
ddd (1:3.3.12-1ubuntu1) maverick; urgency=low

  * Merge from Debian unstable, remaining changes:
    - debian/ddd.install: Fix install .xpm file. (LP: #614766)
 -- Artur Rona <email address hidden>   Mon, 09 Aug 2010 22:04:48 +0200
Superseded in maverick-release on 2010-08-10
Obsolete in lucid-release on 2016-10-26
Obsolete in karmic-release on 2013-03-04
ddd (1:3.3.11-1ubuntu2) karmic; urgency=low

  * debian/patches/005_ftbfs.diff: Add header to fix FTBFS (LP: #434206)
    Thanks to Ilya Barygin and Martin Michlmayr for the patch.

 -- Thierry Carrez <email address hidden>   Tue, 22 Sep 2009 11:41:33 +0200
Superseded in karmic-release on 2009-09-22
Obsolete in jaunty-release on 2013-02-28
ddd (1:3.3.11-1ubuntu1) jaunty; urgency=low

  * Add .desktop file. (LP: #299066)
  * [debian.ddd.install]
    - install .desktop file;
    - install program icon.

 -- Loic Martin <email address hidden>   Fri, 30 Jan 2009 19:13:50 +0100

Available diffs

Superseded in jaunty-release on 2009-01-31
Obsolete in intrepid-release on 2013-02-20
Obsolete in hardy-release on 2015-04-24
Obsolete in gutsy-release on 2011-09-16
Obsolete in feisty-release on 2009-08-20
Obsolete in edgy-release on 2008-06-19
Obsolete in dapper-release on 2011-09-06
Superseded in dapper-release on 2006-02-03
ddd (1:3.3.11-1) unstable; urgency=low


  * New upstream release.
  * Rebuild using g++-4.0.
  * Drop obsolete Build-Depends on g++ and libstdc++5-3.3-dev.
    Closes: #300216.
  * Remove Suggests on bashdb, which no longer exists.  Closes: #294631.
  * New patch 003_data_path.diff: change default data directory to
    /usr/share/ddd, with /usr/share/ddd-$(VERSION) as an alternate,
    instead of the other way around.
  * New patch 004_userinfo.diff: add --with-userinfo option to configure
    to make it easier to override the autodetection.
  * Update to Standards-Version 3.6.2 (no changes needed).

 -- Daniel Schepler <email address hidden>  Sun, 10 Jul 2005 02:24:07 -0700
Obsolete in breezy-release on 2008-03-25
ddd (1:3.3.9-3build1) breezy; urgency=low


  * Rebuild for libxp6 dep.

 -- Barry deFreese <email address hidden>  Tue,  4 Oct 2005 22:45:20 -0400
Obsolete in hoary-release on 2008-03-19
ddd (1:3.3.9-3) unstable; urgency=low


  * USERINFO has been renamed to USERINFO.txt; adjust debian/rules code
    to match, to get correct information on the About DDD dialog.

 -- Daniel Schepler <email address hidden>  Thu, 22 Jul 2004 03:49:37 -0700
Obsolete in warty-release on 2008-01-09
ddd (1:3.3.8-2) unstable; urgency=low


  * Fix NEWS symlink.  Closes: #241601.
    Post-sarge, I'm planning to sanify the package to use /usr/share/ddd
    instead of e.g. /usr/share/ddd-3.3.8, which should eliminate the
    necessity to keep updating the ddd.links file.
  * Add debian/ddd.info, to make sure that dh_installinfo creates
    postinst snippets for the info pages.  Closes: #245712.
  * Adjust versioning of debhelper build dependency to ensure we get
    the fix for bug #246301.
  * Remove xlibs-dev build dependency in accordance with the xfree86
    lib package split.  The dependencies of libxaw7-dev and lesstif2-dev
    suffice.

 -- Daniel Schepler <email address hidden>  Wed, 28 Apr 2004 16:55:43 -0700
116 of 16 results