Ubuntu

Change log for “debomatic” package in Ubuntu

112 of 12 results
Published in trusty-release on 2013-12-20
Deleted in trusty-proposed (Reason: moved to release)
debomatic (0.11-2) unstable; urgency=medium


  * debian/patches/setpgrp.patch:
    - Remove setpgrp call to fix endless loop in threads (Closes: #690311).
  * debian/control:
    - Suggest apt-utils and devscripts.
    - Bump Standards-Version to 3.9.5.

 -- Luca Falavigna <email address hidden>  Thu, 19 Dec 2013 21:33:35 +0100

Available diffs

Superseded in trusty-release on 2013-12-20
Published in saucy-release on 2013-06-05
Deleted in saucy-proposed (Reason: moved to release)
debomatic (0.11-1) unstable; urgency=low


  * New upstream final release.
  * Upload to unstable.
  * debian/control:
    - Bump X-Python-Version to 2.7.
    - Suggests piuparts package.

 -- Luca Falavigna <email address hidden>  Wed, 05 Jun 2013 15:02:52 +0200

Available diffs

Superseded in saucy-release on 2013-06-05
Published in raring-release on 2012-10-18
Published in quantal-release on 2012-05-27
debomatic (0.10-2) unstable; urgency=low


  * debian/rules:
    - Delete docs/_build directory during clean phase (Closes: #671163).

 -- Luca Falavigna <email address hidden>  Sat, 26 May 2012 18:37:51 +0200

Available diffs

Superseded in quantal-release on 2012-05-27
debomatic (0.10-1) unstable; urgency=low


  * New upstream release.
    - New documentation, which also explains module plugin needs GPG
      support enabled to work (Closes: #653455).
    - Fix init script to allow stop and restart methods (Closes: #653468).
    - Lintian options are now customizable (Closes: #655454).
  * debian/compat:
    - Bump compatibility level to 9.
  * debian/control:
    - Drop python-docutils from Build-Depends field.
    - Add python-sphinx, texlive-latex-base, texlive-latex-recommended,
      texlive-fonts-recommended, texlive-latex-extra and gettext to
      Build-Depends field.
    - Add python-daemon and python-lockfile to Depends field.
    - Replace gnupg with gpgv in Recommends field.
    - Bump X-Python-Version field to >= 2.6.
    - Bump Standards-Version to 3.9.3.
  * debian/copyright:
    - Convert to DEP5 format.
  * debian/doc-base:
    - Update for new documentation format.
  * debian/docs:
    - README is no longer shipped in release tarball.
  * debian/watch:
    - Update watch file.

 -- Luca Falavigna <email address hidden>  Sun, 01 Apr 2012 00:43:28 +0200

Available diffs

Superseded in quantal-release on 2012-04-30
Published in precise-release on 2011-10-13
Published in oneiric-release on 2011-04-28
Obsolete in natty-release on 2013-06-04
debomatic (0.9-1) unstable; urgency=low

  * New upstream release.
    - Package rebuild support (Closes: #591937).
    - Pass --configfile as last parameter, so some default options can
      be overwritten by configuration file (Closes: #531175).
  * Switch to format 3.0 (quilt).
  * Switch to dh_python2.
  * debian/control:
    - Recommend debian-archive-keyring and ubuntu-keyring due to recent
      debootstrap changes which require archive keys to generate chroots.
    - Bump Standards-Version to 3.9.1, no changes needed.
  * debian/copyright:
    - Adjust copyright information.
  * debian/rules:
    - Delete unused .egg-info file.
 -- Luca Falavigna <email address hidden>   Sun, 06 Feb 2011 10:51:18 +0100

Available diffs

Superseded in natty-release on 2011-02-06
Obsolete in maverick-release on 2013-03-05
debomatic (0.8-1) unstable; urgency=low

  * New upstream release.
    - cowbuilder support (Closes: #531173).
  * debian/control:
    - Add python-docutils to Build-Depends-Indep.
    - Add cowbuilder as alternate dependency for pbuilder.
    - Bump Standards-Version to 3.8.4, no changes needed.
  * debian/copyright:
    - Adjust copyright years.
 -- Ubuntu Archive Auto-Sync <email address hidden>   Sun,  09 May 2010 13:46:36 +0100

Available diffs

Superseded in maverick-release on 2010-05-09
Published in lucid-release on 2009-11-05
debomatic (0.7-1) unstable; urgency=low

  * New upstream version.
    - Provide init script and default file (Closes: #530029).
  * debian/control:
    - Update my e-mail address.
    - Remove DM-Upload-Allowed field.
    - Refresh build-dependencies.
    - Do not build-depend on docbook2x and docbook-xml, man pages are
      no longer generated by scripts.
    - Bump python-pyinotify minimum version to 0.8.6-1.
    - Bump Standards-Version to 3.8.3, no changes required.
  * debian/copyright:
    - Update copyright informations.
  * debian/examples, debian/manpages:
    - Removed, no longer needed with new upstream version.
  * debian/doc-base:
    - Register doc-base informations.

 -- Ubuntu Archive Auto-Sync <email address hidden>   Thu,  05 Nov 2009 05:55:44 +0000

Available diffs

Superseded in lucid-release on 2009-11-05
Obsolete in karmic-release on 2013-03-04
debomatic (0.6-3) unstable; urgency=low

  * Switch to debhelper 7.
  * Switch to python-support.
  * Install Debomatic module in a private directory.
  * Changes for upcoming Python 2.6:
    + debian/control:
      - Add python (>= 2.5.4-1~) to Build-Depends-Indep to enable use of
        /usr/share/python/python.mk macros.
      - Remove python-all-dev from Build-Depends-Indep.
    + debian/rules:
      - Include /usr/share/python/python.mk.
      - Pass $(py_setup_install_args) to setup.py to let distutils install
        modules in the correct directory.
  * Add ${misc:Depends} to debomatic dependencies.
  * Bump Standards-Version to 3.8.1, no changes required.

 -- Ubuntu Archive Auto-Sync <email address hidden>   Sat,  02 May 2009 11:47:08 +0100

Available diffs

Superseded in karmic-release on 2009-05-02
debomatic (0.6-2) unstable; urgency=low

  * Add Python Applications Packaging Team to Uploaders.
  * Add Vcs-* fields in source stanza.

 -- Ubuntu Archive Auto-Sync <email address hidden>   Tue,  28 Apr 2009 23:01:36 +0100

Available diffs

Superseded in karmic-release on 2009-04-28
Obsolete in jaunty-release on 2013-02-28
debomatic (0.6-1) experimental; urgency=low

  * New upstream release.
  * Adjust copyright holders.
  * Remove all patches (implemented upstream), as well as quilt support.
  * Add DM-Upload-Allowed field.

 -- Luca Falavigna <email address hidden>   Mon,  09 Feb 2009 08:48:45 +0000

Available diffs

Superseded in jaunty-release on 2009-02-09
Obsolete in intrepid-release on 2013-02-20
debomatic (0.5-2) unstable; urgency=low

  * debian/patches/packagequeue_files:
    - Add files to packagequeue even if they are already available, so
      they can be removed when packages have been successfully built.
  * debian/patches/acceptedqueue:
    - Add acceptedqueue to allow packages waiting for a lock to be built
      if previously accepted.

 -- Luca Falavigna <email address hidden>   Wed,  24 Sep 2008 09:30:10 +0100

Available diffs

Superseded in intrepid-release on 2008-09-24
debomatic (0.5-1) unstable; urgency=low

  * Initial release (Closes: #426231)

 -- Ubuntu Archive Auto-Sync <email address hidden>   Fri,  11 Jul 2008 09:41:21 +0100
112 of 12 results