scilab installer bad path and fonts

Bug #3496 reported by J C Nash on 2005-10-23
22
Affects Status Importance Assigned to Milestone
defoma (Ubuntu)
Medium
MOTU

Bug Description

1) After install of scilab, scilab-bin and scilab-doc on Breezy, open terminal and type "scilab". Get msg

/usr/bin/scilab: line 31: /usr/lib/pvm3//lib/pvmgetarch: No such file or directory

2) Scilab launches with incomprehensible fonts. Very hard to kill.

JN

Jason Ribeiro (jrib) wrote :

I can verify that this happens to me as well on Breezy. I am currently running 3.1.1 downloaded from scilab's website as a result.

The font appears to be either TAMu_Kadambri, TAMu_Kalyani,or TAMu_Maduram on my system. I searched for config files where I might change this but could not find anything.

Changed in scilab:
assignee: nobody → motu
Rob Frohne (frohro) wrote :

Me too!

Donato Di Paola (donuts) wrote :

1) [Fixed] Install libpvm3 and pvm (recommended) packages. [These are libraries to run a parallel job]

2) I think that scilab don't find some font libraries (may be X font lib.), but I could not find a solution.

Lars Ljung (larslj) wrote :

The problem with the fonts can be fixed by removing some of the "-unknown-tamu*" entries from /var/lib/defoma/pango.d/pangox.aliases (you can leave the *-iso10646-1 entries). This is probable not the right solution.

"xlsfonts|grep tamu" shows these fonts both with the encoding iso8859-1 and with iso10646-1. This is clearly wrong, isn't it? The only latin characters in there is the digits 0-9.

Maybe we should file this bug under some other package instead?

Manu Cornet (lmanul) wrote :

Same problem with an up-to-date dapper (exact same error and font problem). Marking as confirmed.

Changed in scilab:
status: Unconfirmed → Confirmed

Attaching a screenshot.

LaserJock (laserjock) wrote :

Just a FYI, not a real fix:

There is a new Debian maintainer for Scilab. I contacted him and asked about Scilab 4.0 . He said that he is working on it and it should be packaged soon. Hopefully these bugs will go away with the new version.

weatherman (thaw) wrote :

same thing here, kubuntu dapper

Aanjhan Ranganathan (aanjhan) wrote :

I know that language. Its my mother-tongue. Its picking up tamil fonts [A language of India]

Alexandre Otto Strube (surak) wrote :

Jordan, can you please keep us informed on this new Debian maintainer and the continuity of this bug? Thanks a lot!

Barry deFreese (bddebian) wrote :

This is really a defoma/pango issue not a scilab problem.

AT (olivier-torres) wrote :

For those not using tamil fonts (sorry Aanjhan!) :

1) Remove (force nodeps) packages
ttf-indic-fonts and ttf-tamil-fonts.
2) Start Scilab.

Works on Kubuntu (Breezy 5.10)
See http://scilabsoft.inria.fr/lycee/forum/viewtopic.php?p=13&sid=5e9b895dbcc43ad5abd8c4893c8fe928
(for those understanding french).

Better: download the 4.0 version sources from Scilab site. Compile and enjoy !

AT

x (xk2c-deactivatedaccount) wrote :

> from Jordan Mantha at 2006-03-17

> Just a FYI, not a real fix:

> There is a new Debian maintainer for Scilab. I contacted
> him and asked about Scilab 4.0 . He said that he is
> working on it and it should be packaged soon.

As of today:
http://packages.debian.org/unstable/math/scilab
scilab (3.0-14.1)

hmmm

Maybe we need to make it our own?

Looks as though there is progress towards version 4 being released, see https://launchpad.net/distros/ubuntu/+source/scilab/+bug/58088

While we're still using the buggy version 3, I discovered that it's possible to run scilab in command line (as opposed to windowed) mode, using the command 'scilab -nw'. This appears to get round the font problem. Obviously it's not an ideal solution, but does allow scilab to be used without messing around with packages or compiling from source.

couannette (couannette) wrote :

The idea "wait for version N+1 to remove this bug" is not the good way to think !

Version N+1 will come with new features, with new bugs and *maybe* with fix for your bug discussed here.
This is a common behaviour in Open Source communities : escape ahead...

The good way to think is then : how do we fix this with the lowest effort and the most flexibility (will upstream guys get our fix in time to be included in the next release ?).

The very good value added of a distro community is to point at things that could be fixed : it is clearly stated above that this bug is related to defoma/pango.

Can we do better ?

I'll investigate on this defoma/pango track and try to find a solution that should be included in current release of scilab.

couannette (couannette) wrote :

First result:

when you launch scilab, it is a shell script that launch the gui.
This gui is composed of one "console" = zterm and of one "menu" = scilex.

If you launch scilab by hand, i.e. :

      $ /usr/lib/scilab/bin/zterm -f arial -e /usr/lib/scilab/bin/scilex

then scilab works.

There is a pango problem, but scilab works.
Additional reference: http://www.usenetlinux.com/archive/topic.php/t-503378.html

Indeed it seems to work fine with the launcher suggested, but the help
browser breaks fairly quickly on my system with a PANGO error. I'm
running Ubuntu Dapper.

JN

couannette wrote:
> First result:
>
> when you launch scilab, it is a shell script that launch the gui.
> This gui is composed of one "console" = zterm and of one "menu" = scilex.
>
> If you launch scilab by hand, i.e. :
>
> $ /usr/lib/scilab/bin/zterm -f arial -e /usr/lib/scilab/bin/scilex
>
> then scilab works.
>
> There is a pango problem, but scilab works.
> Additional reference: http://www.usenetlinux.com/archive/topic.php/t-503378.html
>

Sylvestre Ledru (sylvestre) wrote :

Hello guys,

I am one of the developer of scilab and in charge of the Linux/Unix versions.

Sorry for this issue and the delay on this. A good way of fixing this issue is to use the official gui and not the GTK one.

I will contact the creator of the ubuntu package, Gauvain Pocentek, to see what we can do about this issue.

Cheers,
Sylvestre

Barry deFreese (bddebian) wrote :

4.x has been in a couple of releases now. Does this bug still exist? Thanks.

Changed in defoma:
status: Confirmed → Incomplete

I've not seen the bug since Scilab 4.0 made its way into the repositories, it doesn't occur on any of the Feisty boxes I use.

Barry deFreese (bddebian) wrote :

Thanks for the reply. I am marking this as fixed.

Changed in defoma:
status: Incomplete → Fix Released
Xijun Wang (xijunw) wrote :

Hey, I still find this problem on year 2010. Google brought me to here, and I attached a snapshot of this problem on my ubuntu 10.04 LTS - the Lucid Lynx - released in April 2010. I installed the Scilab 5.2.1 from the default repository. (ubuntu software center).

I have tried to change some configure files of Scilab to overcome the problem, some files I searched related to GUI or startup in /usr/share/scilab/ folder, but it does not work.

Please anybody give me some idea how to solve it?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers