Change log for dh-ocaml package in Ubuntu

119 of 19 results
Published in eoan-release on 2019-04-18
Published in disco-release on 2018-10-30
Published in cosmic-release on 2018-05-01
Published in bionic-release on 2017-10-24
Published in artful-release on 2017-07-21
Deleted in artful-proposed (Reason: moved to release)
dh-ocaml (1.1.0) unstable; urgency=medium

  [ Mehdi Dogguy ]
  * Minor simplifications in dom-new-git-repo
  * Use gbp pq now that it exists (also, in stable)
  * Use gbp-clone to clone git repos and track relevant branches
  * Use new dispatch address for git commit notifications

  [ Ralf Treinen ]
  * dh_ocamlinit manpage: document prefixes OPT, BYTE, DYN
  * dom-new-git-repo: replace git-import-orig by gbp import-orig
    (Closes: #862777)

  [ Johannes Schauer ]
  * dh_ocamlinit: also check for ocamlopt when filtering DYN lines

  [ Stéphane Glondu ]
  * Fix incorrect usage of doit (Closes: #868470)
  * Fix reproducible build (Closes: #830282)
  * Bump debhelper compat to 10
  * Bump Standards-Version to 4.0.0
  * Update Vcs-*

 -- Stéphane Glondu <email address hidden>  Sun, 16 Jul 2017 09:47:04 +0200
Superseded in artful-release on 2017-07-21
Deleted in artful-proposed on 2017-07-22 (Reason: moved to release)
dh-ocaml (1.0.10ubuntu1) artful; urgency=medium

  * Add ocamlbuild dependency, due to split, this should minimise
    ubuntu-delta due to many ftbs from the package split.

 -- Dimitri John Ledkov <email address hidden>  Thu, 29 Jun 2017 12:41:43 +0100

Available diffs

Superseded in artful-release on 2017-07-18
Obsolete in zesty-release on 2018-06-22
Obsolete in yakkety-release on 2018-01-23
Published in xenial-release on 2016-04-08
Superseded in xenial-release on 2016-04-08
Obsolete in wily-release on 2018-01-22
Deleted in wily-proposed (Reason: moved to release)
dh-ocaml (1.0.10) unstable; urgency=medium

  [ Riley Baird ]
  * Added option to set alioth username in dom-git-new-repo

  [ Stéphane Glondu ]
  * Use a deterministic order in generated .info files. Patch by Chris
    Lamb (Closes: #779037)
  * Policy: allow installation of *.{cmxs,cma,cmo} and META in runtime
    packages (and other minor changes) (Closes: #500036)
  * Bump debhelper compat level to 9
  * Bump Standards-Version to 3.9.6

 -- Stéphane Glondu <email address hidden>  Wed, 12 Aug 2015 16:44:39 +0200

Available diffs

Superseded in wily-release on 2015-08-13
Obsolete in vivid-release on 2018-01-18
Obsolete in utopic-release on 2016-11-03
Deleted in utopic-proposed on 2018-01-19 (Reason: moved to release)
dh-ocaml (1.0.9) unstable; urgency=medium


  * Add OCAMLBUILD_BEST variable in ocamlvars.mk: 'native' on native
    architectures and 'byte' otherwise.

 -- Mehdi Dogguy <email address hidden>  Thu, 08 May 2014 13:27:01 +0200

Available diffs

Superseded in utopic-release on 2014-07-15
Published in trusty-release on 2014-02-01
Deleted in trusty-proposed (Reason: moved to release)
dh-ocaml (1.0.8) unstable; urgency=medium


  [ Ralf Treinen ]
  * Packaging policy, chapter libpack: libxxx-ocaml-dev packages go into
    section ocaml, not libdevel.

  [ Stéphane Glondu ]
  * Sort generated md5sums files to ease build reproducibility
  * Update Vcs-*
  * Bump Standards-Version to 3.9.5

 -- Stéphane Glondu <email address hidden>  Sat, 01 Feb 2014 15:12:38 +0100

Available diffs

Superseded in trusty-release on 2014-02-01
Obsolete in saucy-release on 2015-04-24
Obsolete in raring-release on 2015-04-24
Deleted in raring-proposed on 2015-04-27 (Reason: moved to release)
dh-ocaml (1.0.7) unstable; urgency=low


  * Follow-up fix for dom-new-git-repo /o\

 -- Mehdi Dogguy <email address hidden>  Sun, 06 Jan 2013 11:26:02 +0100

Available diffs

Superseded in raring-release on 2013-01-06
Deleted in raring-proposed on 2013-01-07 (Reason: moved to release)
dh-ocaml (1.0.6) unstable; urgency=low


  [ Sylvain Le Gall ]
  * Remove Sylvain Le Gall from uploaders

  [ Mehdi Dogguy ]
  * dom-new-git-repo: Use KGB instead of CIA for new Git repositories.

 -- Mehdi Dogguy <email address hidden>  Sat, 06 Oct 2012 20:13:39 +0200

Available diffs

Superseded in raring-release on 2012-10-29
Obsolete in quantal-release on 2015-04-24
dh-ocaml (1.0.5) unstable; urgency=low


  [ Ralf Treinen ]
  * Fixed typo in message string of dom-safe-pull.

  [ Stéphane Glondu ]
  * Fix computation of ABI with recent OCaml snapshots
  * Put debian/copyright in 1.0 format
  * Bump Standards-Version to 3.9.3 (no changes)

 -- Stéphane Glondu <email address hidden>  Wed, 18 Apr 2012 07:51:55 +0200

Available diffs

Superseded in quantal-release on 2012-04-30
Published in precise-release on 2011-12-26
dh-ocaml (1.0.3) unstable; urgency=low

  [ Євгеній Мещеряков ]
  * Add new program, dh_ocamlclean, for cleaning files generated by
    dh_ocamlinit, and use it instead of dh_ocamlinit -d (closes: #651131)
 -- Ubuntu Archive Auto-Sync <email address hidden>   Mon,  26 Dec 2011 17:47:54 +0000

Available diffs

Superseded in precise-release on 2011-12-26
dh-ocaml (1.0.2) unstable; urgency=low

  * dom-new-git-repo: use git.debian.org for ssh host (Closes: #632246)
  * dh_ocaml: set umask to 0022 (Closes: #636906)
 -- Ubuntu Archive Auto-Sync <email address hidden>   Mon,  17 Oct 2011 09:13:56 +0000

Available diffs

Superseded in precise-release on 2011-10-17
Obsolete in oneiric-release on 2015-04-24
dh-ocaml (1.0.1) unstable; urgency=low

  * Added patch to dh_ocaml:
    + Fix parsing of .onodefine files.
    + Pass --nodefined option during the computation 
      of binary package dependencies.
  * Added myself (Romain Beauxis) as uploader.
 -- Ubuntu Archive Auto-Sync <email address hidden>   Thu,  23 Jun 2011 10:33:47 +0000

Available diffs

Superseded in oneiric-release on 2011-06-23
dh-ocaml (1.0.0) unstable; urgency=low

  [ Stéphane Glondu ]
  * Adaptation to OCaml 3.12:
    - bump major version to 1.0, since this version won't work with
      previous versions of OCaml
    - there is a single ocamlobjinfo tool now; remove references to old
      ocaml{dumpapprox,plugininfo,byteinfo} tools from dh_ocaml and
      ocaml-md5sums
  * Bump debhelper compat level to 8
  * Bump Standards-Version to 3.9.2 (no changes)

  [ Ralf Treinen ]
  * Changed suggestion of git-core to git.

  [ Sylvain Le Gall ]
  * Fix --notifications option for dom-new-git-repo
 -- Ubuntu Archive Auto-Sync <email address hidden>   Sat,  30 Apr 2011 12:42:45 +0000

Available diffs

Superseded in oneiric-release on 2011-04-30
Obsolete in natty-release on 2013-06-04
dh-ocaml (0.9.6) unstable; urgency=low

  [ Stéphane Glondu ]
  * debian/control:
    - add git-core to Suggests
    - bump Standards-Version to 3.9.1 (no changes)
  * tools/:
    - dom-new-git-repo: explicitly use sh when executing remote commands
      via ssh (Closes: #588371)
    - dom-git-checkout: check for existence of upstream/pristine-tar
      remote branches before creating local ones (Closes: #591555)

  [ Ralf Treinen ]
  * policy/: continue work started by Sylvain Le Gall on splitting the 
    document into policy and reference (thanks, Sylvain!):
    - current value of ocaml version no longer mentionend in policy
    - fix location of library directory (closes: #591556)
    - refactor sections, many small changes all over the document
    - streamline discussion on bytecode vs native code
    - compiling with -custom is deprecated (closes: #500286)
    - reference: add section on dh
    - findlib integration: META files always go in the directory of the
      library, debian-specific ones should have a comment.
  * Makefile: generate the reference document
  * update authors in doc-base registration for the policy
  * add doc-base registration for the reference.
  * Added myself to uploaders.

Available diffs

Superseded in natty-release on 2010-10-15
Obsolete in maverick-release on 2013-03-05
Obsolete in lucid-release on 2016-10-26
dh-ocaml (0.9.3) unstable; urgency=low

  * Revert fix to #500869; -u is deprecated (Closes: #554510)

Available diffs

Superseded in lucid-release on 2009-11-17
dh-ocaml (0.9.1) unstable; urgency=low

  [ Stéphane Glondu ]
  * dh_ocamldoc: fix typo in regexp (Closes: #549939)
  * dh_ocaml: better error when /usr/lib doesn't exist in a relevant
    binary package
  * dom-new-git-repo:
    - cope with new scheme of example hooks with recent versions of git
    - issue a warning when nothing is pushed

  [ Mehdi Dogguy ]
  * Don't pass --nodefined-map to ocaml-lintian
  * Add a variable to be able to desactivate dh_ocaml in a cdbs
    package when needed. The variable WITH_DH_OCAML has to be set
    to 0 to desactivate dh_ocaml.
  * ocaml-md5sums: Print object file's name when failing
  * Replace class/ocaml.mk with rules/ocaml.mk in policy/appendix-cdbs.xml
    (Closes: #550378)

  [ Stefano Zacchiroli ]
  * dh_ocamldoc manpage improvements: mention how ocamlfind is detected
    and that order is relevant when shipping doc elsewhere

Available diffs

Superseded in lucid-release on 2009-11-05
Obsolete in karmic-release on 2013-03-04
dh-ocaml (0.5.0) unstable; urgency=low

  [ Stephane Glondu ]
  * Use "<<" for Replaces, not "<=" (Closes: #528241)
  * Add ocaml-pkg-update-uploaders (Closes: #516764)
  * Add dom-safe-pull

  [ Mehdi Dogguy ]
  * Add variables OCAML_RUNTIME and OCAML_RUNTIME_NOX in ocamlvars.mk: which
    are, respectively, ocaml-base-nox-$(OCAML_ABI) and ocaml-base-$(OCAML_ABI)
    on non-native archs.
  * Install script tools dom-{new-git-repo,git-checkout,mrconfig} in
    /usr/bin (Closes: #516777)
  * Install dom-{apply,save}-patches in /usr/bin/ and update policy to
    explain briefly how to use them.
  * Add manpages for new tools
  * Add docbook-xsl, libxml2-utils and xsltproc to generate manpages

  [ Ralf Treinen ]
  * Add a section on setting the archive section of ocaml programs.
  * Set Section to ocaml

  [ Sylvain Le Gall ]
  * Add dom-switch-opt to test byte compilation on native arch

 -- Bhavani Shankar <email address hidden>   Mon,  20 Jul 2009 19:24:26 +0100

Available diffs

Superseded in karmic-release on 2009-07-20
dh-ocaml (0.4.1ubuntu2) karmic; urgency=low

  * Fix version in Replaces.

 -- Colin Watson <email address hidden>   Tue, 12 May 2009 10:39:12 +0100

Available diffs

Superseded in karmic-release on 2009-05-12
dh-ocaml (0.4.1ubuntu1) karmic; urgency=low

  * Use << for Replaces rather than <=, to cope with previous Ubuntu
    variants of ocaml.

 -- Colin Watson <email address hidden>   Mon, 11 May 2009 17:45:27 +0100

Available diffs

Superseded in karmic-release on 2009-05-11
Superseded in karmic-release on 2009-05-11
dh-ocaml (0.4.1) unstable; urgency=low

  [ Samuel Mimram ]
  * Correct typo in dh_ocaml (Closes: #514996)

  [ Stefano Zacchiroli ]
  * switch versioning scheme to major.minor.micro: we will bump minor
    only for significant changes, and micro for bugfixes (as usual)
  * package description: clarify that debian/rules helpers are both for
    CDBS and for generic debian/rules
  * ocamlinit.mk: avoid stripping leading white spaces while filling .in
    files. Rationale: that could break files for which spaces are relevant
    (e.g. debian/patches/*.in)

119 of 19 results