Change log for disruptor package in Ubuntu

112 of 12 results
Published in disco-release on 2018-10-30
Published in cosmic-release on 2018-09-19
Deleted in cosmic-proposed (Reason: moved to release)
disruptor (3.4.2-2) unstable; urgency=medium

  * Team upload.
  * Declare compliance with Debian Policy 4.2.1.
  * Use source/target 1.7 explicitly. (Closes: #906347)

 -- Markus Koschany <email address hidden>  Tue, 28 Aug 2018 15:55:41 +0200

Available diffs

Superseded in cosmic-release on 2018-09-19
Deleted in cosmic-proposed on 2018-09-20 (Reason: moved to release)
disruptor (3.4.2-1) unstable; urgency=medium

  * Team upload.
  * New upstream version 3.4.2
    - Fix race condition in BatchEventProcessor with 3 or more
      starting/halting concurrently.
    - Fix race between run() and halt() on BatchEventProcessor.
    - Drop support for JDK6, support JDK7 and above only.
    - Add ThreadHints.onSpinWait to all busy spins within Disruptor.
    - Increase default sleep time for LockSupport.parkNanos to prevent
      busy spinning.
    - Removes the Histogram class

  * Set target=1.9 and specify "-XDignore.symbol.file" in debian/pom.xml
    to address FTBFS with openjdk-10. (Closes: #902317)
  * Enable tests; add build-dep on junit4

 -- tony mancill <email address hidden>  Sun, 24 Jun 2018 22:13:04 -0700

Available diffs

Superseded in cosmic-release on 2018-06-25
Deleted in cosmic-proposed on 2018-06-26 (Reason: moved to release)
disruptor (3.3.11-1) unstable; urgency=medium

  * Team upload.
  * New upstream release
  * Standards-Version updated to 4.1.4
  * Use salsa.debian.org Vcs-* URLs

 -- Emmanuel Bourg <email address hidden>  Mon, 04 Jun 2018 22:40:39 +0200

Available diffs

Superseded in cosmic-release on 2018-06-05
Published in bionic-release on 2018-02-13
Deleted in bionic-proposed (Reason: moved to release)
disruptor (3.3.8-1) unstable; urgency=medium

  [ tony mancill ]
  * Bump Standards-Version to 4.1.3
  * Mark libdisruptor-java as Multi-Arch: foreign
  * Update Homepage link to use https
  * Cleanup unused files in debian/patches

  [ Emmanuel Bourg ]
  * New upstream release
  * Suggest the optional dependencies instead of recommending them
  * Switch to debhelper level 11

 -- Emmanuel Bourg <email address hidden>  Tue, 13 Feb 2018 10:31:02 +0100

Available diffs

Superseded in bionic-release on 2018-02-13
Deleted in bionic-proposed on 2018-02-15 (Reason: moved to release)
disruptor (3.3.7-1) unstable; urgency=medium

  * New upstream version 3.3.7
  * Update debian/watch and debian/copyright to use Files-Excluded for
    repack of upstream tarball.  Remove debian/orig-tar.sh.
  * Bump Standards-Version to 4.1.1
  * Use DH 10.

 -- tony mancill <email address hidden>  Sun, 15 Oct 2017 12:34:01 -0700

Available diffs

Superseded in bionic-release on 2017-11-02
Published in artful-release on 2017-04-20
Obsolete in zesty-release on 2018-06-22
Deleted in zesty-proposed (Reason: moved to release)
disruptor (3.3.6-1) unstable; urgency=medium

  * Team upload.
  * New upstream version.
  * Update debian/watch to sort -rc versions before releases.

 -- tony mancill <email address hidden>  Sun, 09 Oct 2016 19:46:29 -0700

Available diffs

Superseded in zesty-release on 2016-11-02
Obsolete in yakkety-release on 2018-01-23
Deleted in yakkety-proposed on 2018-01-23 (Reason: moved to release)
disruptor (3.3.5-1) unstable; urgency=medium

  * Team upload.
  * New upstream release.
  * Update Vcs- URLs to use https.
  * Bump Standards-Version to 3.9.8 (no changes).
  * Add <email address hidden> to Uploaders.

 -- tony mancill <email address hidden>  Wed, 27 Jul 2016 23:06:41 -0700

Available diffs

Superseded in yakkety-release on 2016-07-28
Published in xenial-release on 2016-01-23
Deleted in xenial-proposed (Reason: moved to release)
disruptor (3.3.4-1) unstable; urgency=medium

  * New upstream release
  * Updated debian/pom.xml
  * Build with the DH sequencer instead of CDBS

 -- Emmanuel Bourg <email address hidden>  Fri, 22 Jan 2016 16:19:12 +0100

Available diffs

Superseded in xenial-release on 2016-01-23
Obsolete in wily-release on 2018-01-22
Deleted in wily-proposed on 2018-01-22 (Reason: moved to release)
disruptor (3.3.2-1) unstable; urgency=medium

  * New upstream release
  * Updated debian/pom.xml
  * Standards-Version updated to 3.9.6 (no changes)

 -- Emmanuel Bourg <email address hidden>  Wed, 29 Apr 2015 22:25:42 +0200

Available diffs

Superseded in wily-release on 2015-05-06
Obsolete in vivid-release on 2018-01-18
Obsolete in utopic-release on 2016-11-03
Deleted in utopic-proposed on 2018-01-19 (Reason: moved to release)
disruptor (3.3.0-2) unstable; urgency=medium


  * New upstream release
  * Updated debian/pom.xml

 -- Emmanuel Bourg <email address hidden>  Mon, 28 Jul 2014 13:03:11 +0200

Available diffs

Superseded in utopic-release on 2014-07-28
Deleted in utopic-proposed on 2014-07-30 (Reason: moved to release)
disruptor (3.2.1-1) unstable; urgency=medium


  * New upstream release
  * Updated debian/pom.xml

 -- Emmanuel Bourg <email address hidden>  Wed, 19 Mar 2014 12:57:14 +0100

Available diffs

Superseded in utopic-release on 2014-05-03
Published in trusty-release on 2014-01-30
Deleted in trusty-proposed (Reason: moved to release)
disruptor (3.2.0-1) unstable; urgency=medium


  * Initial release (Closes: #736354)

 -- Emmanuel Bourg <email address hidden>  Wed, 22 Jan 2014 23:19:52 +0100
112 of 12 results