Change log for dkms package in Ubuntu

175 of 113 results
Published in bionic-updates on 2018-07-23
Deleted in bionic-proposed (Reason: moved to -updates)
dkms (2.3-3ubuntu9.2) bionic; urgency=medium

  * 0009-Add-support-for-UEFI-Secure-Boot-validation-toggling.patch: source
    /usr/share/debconf/confmodule from dkms_common.postinst to ensure we have
    all the environment ready to successfully show debconf prompts when dkms
    modules are being built. (LP: #1781001)

 -- Mathieu Trudel-Lapierre <email address hidden>  Wed, 18 Jul 2018 09:33:31 -0400

Available diffs

Published in disco-release on 2018-10-30
Published in cosmic-release on 2018-07-20
Deleted in cosmic-proposed (Reason: moved to release)
dkms (2.3-3ubuntu11) cosmic; urgency=medium

  * 0009-Add-support-for-UEFI-Secure-Boot-validation-toggling.patch: source
    /usr/share/debconf/confmodule from dkms_common.postinst to ensure we have
    all the environment ready to successfully show debconf prompts when dkms
    modules are being built. (LP: #1781001)

 -- Mathieu Trudel-Lapierre <email address hidden>  Mon, 16 Jul 2018 16:14:29 -0400

Available diffs

Superseded in bionic-updates on 2018-07-23
Deleted in bionic-proposed on 2018-07-24 (Reason: moved to -updates)
dkms (2.3-3ubuntu9.1) bionic; urgency=medium

  * 0009-Add-support-for-UEFI-Secure-Boot-validation-toggling.patch: move sign
    code to dkms script itself, so it also applies on kernel upgrades.
    (LP: #1772950)

 -- Mathieu Trudel-Lapierre <email address hidden>  Wed, 23 May 2018 13:15:53 -0400

Available diffs

Superseded in cosmic-release on 2018-07-20
Deleted in cosmic-proposed on 2018-07-22 (Reason: moved to release)
dkms (2.3-3ubuntu10) cosmic; urgency=medium

  * 0009-Add-support-for-UEFI-Secure-Boot-validation-toggling.patch: move sign
    code to dkms script itself, so it also applies on kernel upgrades.
    (LP: #1772950)

 -- Mathieu Trudel-Lapierre <email address hidden>  Wed, 23 May 2018 13:15:53 -0400

Available diffs

Superseded in cosmic-release on 2018-05-23
Published in bionic-release on 2018-04-23
Deleted in bionic-proposed (Reason: moved to release)
dkms (2.3-3ubuntu9) bionic; urgency=medium

  * 0009-Add-support-for-UEFI-Secure-Boot-validation-toggling.patch: use find
    to get all .ko modules from a dkms build to ensure we also catch any .kos
    that might have been built in subdirectories.
  * 0009-Add-support-for-UEFI-Secure-Boot-validation-toggling.patch: make sure
    we only try to enroll a MOK if we've signed modules.

 -- Mathieu Trudel-Lapierre <email address hidden>  Mon, 23 Apr 2018 16:42:51 -0400

Available diffs

Superseded in bionic-release on 2018-04-23
Deleted in bionic-proposed on 2018-04-25 (Reason: moved to release)
dkms (2.3-3ubuntu8) bionic; urgency=medium

  * 0009-Add-support-for-UEFI-Secure-Boot-validation-toggling.patch: handle
    signing of all .ko modules from a dkms build regardless of whether their
    name matches the dkms package name.  LP: #1766215.

 -- Steve Langasek <email address hidden>  Mon, 23 Apr 2018 09:10:30 -0700

Available diffs

Superseded in bionic-release on 2018-04-23
Deleted in bionic-proposed on 2018-04-25 (Reason: moved to release)
dkms (2.3-3ubuntu7) bionic; urgency=medium

  * 0009-Add-support-for-UEFI-Secure-Boot-validation-toggling.patch: update
    for the new update-secureboot-policy code: have it generate a new MOK if
    there isn't one yet, and use that so sign newly-built kernel modules.
    (LP: #1748983)

 -- Mathieu Trudel-Lapierre <email address hidden>  Wed, 18 Apr 2018 17:23:41 -0400

Available diffs

Superseded in bionic-release on 2018-04-23
Deleted in bionic-proposed on 2018-04-24 (Reason: moved to release)
dkms (2.3-3ubuntu6) bionic; urgency=medium

  * Move dpkg-dev to a real depends, needed for dpkg-architecture
    calls (LP: #1753430)

 -- Gianfranco Costamagna <email address hidden>  Mon, 19 Mar 2018 10:31:39 +0100

Available diffs

Superseded in bionic-release on 2018-03-19
Deleted in bionic-proposed on 2018-03-20 (Reason: moved to release)
dkms (2.3-3ubuntu5) bionic; urgency=medium

  * 0016-make-sure-info-are-reset.patch: make sure the variable is reset
    before each module parsing, avoiding issues when a module has no
    "version:" field, and not taking as good any previous value.

 -- Gianfranco Costamagna <email address hidden>  Fri, 02 Mar 2018 13:13:53 +0100

Available diffs

Superseded in bionic-release on 2018-03-02
Deleted in bionic-proposed on 2018-03-03 (Reason: moved to release)
dkms (2.3-3ubuntu4) bionic; urgency=medium

  * 0015-change-arch-in-mkdeb-template.patch: Utilize DEBIAN_BUILD_ARCH in the
    control file for mkdeb. Thanks to Launchpad user martin for the patch.
    (LP: #1729051)

 -- Brian Murray <email address hidden>  Tue, 12 Dec 2017 15:32:01 -0800

Available diffs

Published in xenial-updates on 2017-10-16
Deleted in xenial-proposed (Reason: moved to -updates)
dkms (2.2.0.3-2ubuntu11.5) xenial; urgency=medium

  * 0014-remove-initrd-backup.patch: When removing a kernel also remove
    related .old-dkms file from /boot after its been created not before.
    (LP: #1515513)

 -- Brian Murray <email address hidden>  Thu, 05 Oct 2017 13:14:20 -0700
Superseded in bionic-release on 2017-12-14
Published in artful-release on 2017-10-12
Deleted in artful-proposed (Reason: moved to release)
dkms (2.3-3ubuntu3) artful; urgency=medium

  * 0014-remove-initrd-backup.patch: When removing a kernel also remove
    related .old-dkms file from /boot after its been created not before.
    (LP: #1515513)

 -- Brian Murray <email address hidden>  Thu, 05 Oct 2017 13:10:42 -0700

Available diffs

Obsolete in zesty-updates on 2018-06-22
Deleted in zesty-proposed on 2018-06-22 (Reason: moved to -updates)
dkms (2.3-3ubuntu1.2) zesty; urgency=medium

  * 0014-remove-initrd-backup.patch: When removing a kernel also remove
    related .old-dkms file from /boot after its been created not before.
    (LP: #1515513)

 -- Brian Murray <email address hidden>  Thu, 05 Oct 2017 11:45:16 -0700
Superseded in xenial-proposed on 2017-10-09
dkms (2.2.0.3-2ubuntu11.4) xenial; urgency=medium

  * 0014-remove-initrd-backup.patch: When removing a kernel also remove
    related .old-dkms file from /boot. (LP: #1515513)

 -- Brian Murray <email address hidden>  Mon, 02 Oct 2017 14:55:53 -0700
Superseded in zesty-proposed on 2017-10-09
dkms (2.3-3ubuntu1.1) zesty; urgency=medium

  * 0014-remove-initrd-backup.patch: When removing a kernel also remove
    related .old-dkms file from /boot. (LP: #1515513)

 -- Brian Murray <email address hidden>  Fri, 15 Sep 2017 15:33:17 -0700

Available diffs

Superseded in artful-release on 2017-10-12
Deleted in artful-proposed on 2017-10-13 (Reason: moved to release)
dkms (2.3-3ubuntu2) artful; urgency=medium

  * 0014-remove-initrd-backup.patch: When removing a kernel also remove
    related .old-dkms file from /boot. (LP: #1515513)

 -- Brian Murray <email address hidden>  Fri, 15 Sep 2017 15:33:17 -0700

Available diffs

Superseded in artful-release on 2017-09-16
Deleted in artful-proposed on 2018-06-22 (Reason: moved to release)
Obsolete in zesty-security on 2018-06-22
Superseded in zesty-updates on 2017-10-16
Deleted in zesty-proposed on 2018-06-22 (Reason: moved to -updates)
dkms (2.3-3ubuntu1) zesty; urgency=medium

  * 0013-postinst-Fix-newest-kernel-detection.patch: dkms_common.postinst:  We
    were passing a list of kernels to get_newest_kernel(), when it expected a
    single kernel as its first argument - the currently running kernel. This
    in turn meant that the sometimes (if the first thing in the list was
    itself the newest kernel), the wrong kernel was passed into
    _get_newest_kernel_debian(). As a result this falsely reported that there
    was no 'newest' kernel available and then didn't build modules for it.
    Drop the parameter to get_newest_kernel(), and instead rely on
    CURRENT_KERNEL being set to $(uname -r). (LP: #1681566)

 -- Iain Lane <email address hidden>  Thu, 13 Apr 2017 15:50:18 +0100
Superseded in artful-release on 2017-04-22
Obsolete in zesty-release on 2018-06-22
Deleted in zesty-proposed on 2018-06-22 (Reason: moved to release)
dkms (2.3-3) unstable; urgency=medium

  * Upstream post-2.3 cherry-picks for apport (LP: #1661843)

 -- Aron Xu <email address hidden>  Tue, 07 Feb 2017 23:27:25 +0800

Available diffs

Superseded in zesty-release on 2017-02-08
Deleted in zesty-proposed on 2017-02-09 (Reason: moved to release)
dkms (2.3-2) unstable; urgency=medium

  [ Adam Cornad ]
  * Don't assume /boot/config-* exists, test first.

  [ Aron Xu ]
  * d/control: update VCS-*, std-ver: 3.9.8
  * d/rules: add shim support for Ubuntu derivatives

 -- Aron Xu <email address hidden>  Wed, 28 Dec 2016 19:57:32 +0800
Superseded in zesty-release on 2017-01-09
Deleted in zesty-proposed on 2017-01-10 (Reason: moved to release)
dkms (2.2.0.3-2ubuntu15) zesty; urgency=medium

  * dpkg-compare-noise.patch: Don't assume /boot/config-* exists, test first.

 -- Adam Conrad <email address hidden>  Fri, 16 Dec 2016 12:45:10 -0700
Published in trusty-updates on 2016-10-27
Deleted in trusty-proposed (Reason: moved to -updates)
dkms (2.2.0.3-1.1ubuntu5.14.04.9) trusty; urgency=medium

  * apport_name_in_valueerror.diff: (LP: #1588479)
    - Check the ValueError from apport for the package name too, this prevents
      reporting of dkms crashes about unsupported kernels.

 -- Brian Murray <email address hidden>  Thu, 15 Sep 2016 14:25:09 -0700
Superseded in xenial-updates on 2017-10-16
Deleted in xenial-proposed on 2017-10-17 (Reason: moved to -updates)
dkms (2.2.0.3-2ubuntu11.3) xenial; urgency=medium

  * apport_name_in_valueerror.diff: (LP: #1588479)
    - Check the ValueError from apport for the package name too, this prevents
      reporting of dkms crashes about unsupported kernels.

 -- Brian Murray <email address hidden>  Thu, 15 Sep 2016 14:22:14 -0700
Superseded in zesty-release on 2016-12-17
Obsolete in yakkety-release on 2018-01-23
Deleted in yakkety-proposed on 2018-01-23 (Reason: moved to release)
dkms (2.2.0.3-2ubuntu14) yakkety; urgency=medium

  * apport_name_in_valueerror.diff: (LP: #1588479)
    - Check the ValueError from apport for the package name too, this prevents
      reporting of dkms crashes about unsupported kernels.

 -- Brian Murray <email address hidden>  Thu, 15 Sep 2016 13:46:49 -0700
Superseded in trusty-updates on 2016-10-27
Deleted in trusty-proposed on 2016-11-01 (Reason: moved to -updates)
dkms (2.2.0.3-1.1ubuntu5.14.04.8) trusty; urgency=medium

  * debian/patches/Parallel-depmod-failure.patch: (LP: #1608499)
    - Backport fix from 2.3 to fix a race condition in dkms autoinstall

 -- Robert Hooker <email address hidden>  Thu, 08 Sep 2016 16:47:45 -0400
Superseded in xenial-updates on 2016-10-27
Deleted in xenial-proposed on 2016-11-01 (Reason: moved to -updates)
dkms (2.2.0.3-2ubuntu11.2) xenial; urgency=medium

  * debian/patches/Parallel-depmod-failure.patch: (LP: #1608499)
     - Backport fix from 2.3 to fix a race condition in dkms autoinstall

 -- Robert Hooker <email address hidden>  Thu, 08 Sep 2016 15:38:21 -0400
Superseded in yakkety-release on 2016-09-16
Deleted in yakkety-proposed on 2016-09-18 (Reason: moved to release)
dkms (2.2.0.3-2ubuntu13) yakkety; urgency=medium

  * debian/patches/Parallel-depmod-failure.patch: (LP: #1608499)
    - Backport fix from 2.3 to fix a race condition in dkms autoinstall

 -- Robert Hooker <email address hidden>  Thu, 08 Sep 2016 16:43:56 -0400
Superseded in trusty-updates on 2016-09-22
Deleted in trusty-proposed on 2016-09-23 (Reason: moved to -updates)
dkms (2.2.0.3-1.1ubuntu5.14.04.7) trusty; urgency=medium

  * Build Linux modules in a specific order (LP: #1491729)
    - Add POST_BUILD directive, and implement a BUILD_DEPENDS directive that
      instructs `dkms autoinstall` to build Linux modules in a specific order to
      ensure ZFS to build after SPL.
    - Force the installation of a module if it is listed in
      /usr/share/dkms/modules_to_force_install

 -- Colin Ian King <email address hidden>  Fri, 24 Jun 2016 16:43:12 +0100
Superseded in trusty-updates on 2016-07-28
Deleted in trusty-proposed on 2016-07-29 (Reason: moved to -updates)
dkms (2.2.0.3-1.1ubuntu5.14.04.6) trusty; urgency=medium

  * debian/patches/shim_secureboot_support.patch: use update-secureboot-policy,
    which has the benefit of being handled via triggers, to allow users to
    toggle validation in shim. (LP: #1574727)

 -- Mathieu Trudel-Lapierre <email address hidden>  Fri, 20 May 2016 14:46:26 -0400
Obsolete in wily-updates on 2018-01-22
Deleted in wily-proposed on 2018-01-22 (Reason: moved to -updates)
dkms (2.2.0.3-2ubuntu6.2) wily; urgency=medium

  * debian/patches/shim_secureboot_support.patch: use update-secureboot-policy,
    which has the benefit of being handled via triggers, to allow users to
    toggle validation in shim. (LP: #1574727)

 -- Mathieu Trudel-Lapierre <email address hidden>  Fri, 20 May 2016 14:46:26 -0400
Superseded in xenial-updates on 2016-09-22
Deleted in xenial-proposed on 2016-09-23 (Reason: moved to -updates)
dkms (2.2.0.3-2ubuntu11.1) xenial; urgency=medium

  * debian/patches/shim_secureboot_support.patch: move to using the script
    update-secureboot-policy, which also has the benefit of being handled via
    triggers, to avoid prompting users multiple times to disable Secure Boot
    validation in shim. (LP: #1574727)
  * debian/templates: remove secureboot templates; no templates left.
  * debian/postinst: handle cleanup of the previous templates.

 -- Mathieu Trudel-Lapierre <email address hidden>  Wed, 18 May 2016 16:43:40 -0400
Superseded in yakkety-release on 2016-09-09
Deleted in yakkety-proposed on 2016-09-10 (Reason: moved to release)
dkms (2.2.0.3-2ubuntu12) yakkety; urgency=medium

  * debian/patches/shim_secureboot_support.patch: move to using the script
    update-secureboot-policy, which also has the benefit of being handled via
    triggers, to avoid prompting users multiple times to disable Secure Boot
    validation in shim.
  * debian/templates: remove secureboot templates; no templates left.
  * debian/postinst: handle cleanup of the previous templates.

 -- Mathieu Trudel-Lapierre <email address hidden>  Wed, 18 May 2016 16:43:40 -0400
Superseded in yakkety-release on 2016-05-23
Published in xenial-release on 2016-03-19
Deleted in xenial-proposed (Reason: moved to release)
dkms (2.2.0.3-2ubuntu11) xenial; urgency=medium

  * debian/patches/shim_secureboot_support.patch: (LP: #1558438)
    - fix quoting variables for setup_mok_validation() to account for passwords
      that might have special characters.
    - use printf rather than straight echo to pass values to mokutil.
    - ask the user to confirm password; not just write it once, this will avoid
      issues with typos in the Secure Boot keys.
  * debian/templates:
    - rename dkms/text/bad_secureboot_key to dkms/error/bad_secureboot_key.
    - add dkms/text/secureboot_key_mismatch.
    - add dkms/secureboot_key_again.

 -- Mathieu Trudel-Lapierre <email address hidden>  Fri, 18 Mar 2016 20:54:11 -0400
Superseded in xenial-release on 2016-03-19
Deleted in xenial-proposed on 2016-03-20 (Reason: moved to release)
dkms (2.2.0.3-2ubuntu10) xenial; urgency=medium

  * debian/patches/shim_secureboot_support.path: mokutil is annoying in that
    it's not quite handling non-interactiveness correctly; better make the
    package postinst succeed even if mokutil reports an error, since we
    already check for the password length, etc.; and mokutil failing should
    not constitute in itself a good reason to make apt unhappy.

 -- Mathieu Trudel-Lapierre <email address hidden>  Mon, 14 Mar 2016 13:05:38 -0400
Superseded in xenial-release on 2016-03-14
Deleted in xenial-proposed on 2016-03-16 (Reason: moved to release)
dkms (2.2.0.3-2ubuntu9) xenial; urgency=medium

  * debian/patches/shim_secureboot_support.patch: add support for disabling
    shim's validation for Secure Boot, so as to allow third-party drivers use
    in the context of Secure Boot.

 -- Mathieu Trudel-Lapierre <email address hidden>  Tue, 12 Jan 2016 14:37:34 -0500
Superseded in xenial-release on 2016-01-13
Deleted in xenial-proposed on 2016-01-14 (Reason: moved to release)
dkms (2.2.0.3-2ubuntu8) xenial; urgency=medium

  * apport_python3.patch: Force unicode conversion for attaching DKMSBuildLog.
    This is in principle a human readable file, and the subsequent code wants
    to treat it as a string, not bytes. (LP: #1303275)

 -- Martin Pitt <email address hidden>  Mon, 30 Nov 2015 08:06:45 +0100
Superseded in wily-updates on 2016-07-14
Deleted in wily-proposed on 2016-07-15 (Reason: moved to -updates)
dkms (2.2.0.3-2ubuntu6.1) wily; urgency=medium

  * Build Linux modules in a specific order (LP: #1491729)
    - Add POST_BUILD directive, and implement a BUILD_DEPENDS directive that
      instructs `dkms autoinstall` to build Linux modules in a specific order to
      ensure ZFS to build after SPL.
    - Force the installation of a module if it is listed in
      /usr/share/dkms/modules_to_force_install

 -- Colin Ian King <email address hidden>  Tue, 10 Nov 2015 11:02:00 +0000
Superseded in xenial-release on 2015-11-30
Deleted in xenial-proposed on 2015-12-01 (Reason: moved to release)
dkms (2.2.0.3-2ubuntu7) xenial; urgency=medium

  * Build Linux modules in a specific orfer (LP: #1491729)
    - Add POST_BUILD directive, and implement a BUILD_DEPENDS directive that
      instructs `dkms autoinstall` to build Linux modules in a specific order to
      ensure ZFS to build after SPL.
    - Force the installation of a module if it is listed in
      /usr/share/dkms/modules_to_force_install

 -- Colin Ian King <email address hidden>  Tue, 10 Nov 2015 11:02:00 +0000
Superseded in trusty-updates on 2016-07-14
Published in trusty-security on 2015-09-30
dkms (2.2.0.3-1.1ubuntu5.14.04.5) trusty-security; urgency=medium

  * dkms_apport.py: update to the recent apport.utils api changes
    (lp: #1499842)

 -- Marc Deslauriers <email address hidden>  Wed, 30 Sep 2015 07:33:54 -0400
Published in precise-updates on 2015-09-30
Published in precise-security on 2015-09-30
dkms (2.2.0.3-1ubuntu3.6) precise-security; urgency=medium

  * dkms_apport.py: update to the recent apport.utils api changes
    (lp: #1499842)

 -- Marc Deslauriers <email address hidden>  Wed, 30 Sep 2015 07:35:45 -0400
Superseded in xenial-release on 2015-11-11
Obsolete in wily-release on 2018-01-22
Deleted in wily-proposed on 2018-01-22 (Reason: moved to release)
dkms (2.2.0.3-2ubuntu6) wily; urgency=medium

  * Improve previous fix to also handle existing files (LP: #1500450)

 -- Marc Deslauriers <email address hidden>  Wed, 30 Sep 2015 10:37:18 -0400
Obsolete in vivid-updates on 2018-01-18
Obsolete in vivid-security on 2018-01-18
dkms (2.2.0.3-2ubuntu3.3) vivid-security; urgency=medium

  * dkms_apport.py: update to the recent apport.utils api changes
    (lp: #1499842)

 -- Marc Deslauriers <email address hidden>  Wed, 30 Sep 2015 07:28:50 -0400
Superseded in wily-proposed on 2015-09-30
dkms (2.2.0.3-2ubuntu5) wily; urgency=medium

  * dkms_apport.py: update to the recent apport.utils api changes
    (lp: #1499842)

 -- Sebastien Bacher <email address hidden>  Wed, 30 Sep 2015 11:27:45 +0200
Superseded in precise-updates on 2015-09-30
Deleted in precise-proposed on 2015-10-02 (Reason: moved to -updates)
dkms (2.2.0.3-1ubuntu3.4) precise-proposed; urgency=low

  * d/s/autopkgtest: only collect logs if there are any.  (LP: #1498896)

 -- Andy Whitcroft <email address hidden>  Wed, 23 Sep 2015 15:39:40 +0100
Superseded in trusty-updates on 2015-09-30
Deleted in trusty-proposed on 2015-10-02 (Reason: moved to -updates)
dkms (2.2.0.3-1.1ubuntu5.14.04.3) trusty; urgency=low

  * d/s/autopkgtest: only collect logs if there are any.  (LP: #1498896)

 -- Andy Whitcroft <email address hidden>  Wed, 23 Sep 2015 15:21:08 +0100
Superseded in vivid-updates on 2015-09-30
Deleted in vivid-proposed on 2015-10-02 (Reason: moved to -updates)
dkms (2.2.0.3-2ubuntu3.1) vivid; urgency=low

  * d/s/autopkgtest: only collect logs if there are any.  (LP: #1498896)

 -- Andy Whitcroft <email address hidden>  Wed, 23 Sep 2015 13:15:19 +0100
Superseded in wily-release on 2015-09-30
Deleted in wily-proposed on 2015-10-02 (Reason: moved to release)
dkms (2.2.0.3-2ubuntu4) wily; urgency=low

  * d/s/autopkgtest: only collect logs if there are any.  (LP: #1498896)

 -- Andy Whitcroft <email address hidden>  Wed, 23 Sep 2015 13:15:19 +0100
Superseded in precise-updates on 2015-09-30
Deleted in precise-proposed on 2015-10-01 (Reason: moved to -updates)
dkms (2.2.0.3-1ubuntu3.3) precise-proposed; urgency=medium

  * Backport dkms-autopkgtest helper script, so that we can run DKMS tests for
    new kernel uploads triggered by britney via autodep8. (LP: #1489045)

 -- Martin Pitt <email address hidden>  Thu, 27 Aug 2015 12:44:25 +0200
Superseded in trusty-updates on 2015-09-30
Deleted in trusty-proposed on 2015-10-01 (Reason: moved to -updates)
dkms (2.2.0.3-1.1ubuntu5.14.04.2) trusty; urgency=medium

  * Backport dkms-autopkgtest helper script, so that we can run DKMS tests for
    new kernel uploads triggered by britney via autodep8. (LP: #1489045)

 -- Martin Pitt <email address hidden>  Thu, 27 Aug 2015 12:32:04 +0200
Superseded in wily-release on 2015-09-23
Obsolete in vivid-release on 2018-01-18
Deleted in vivid-proposed on 2018-01-19 (Reason: moved to release)
dkms (2.2.0.3-2ubuntu3) vivid; urgency=medium

  * Re-fix LP: #960770, the change for which was dropped in the latest merge
    from Debian.
 -- Steve Langasek <email address hidden>   Wed, 11 Mar 2015 11:15:36 -0700
Superseded in trusty-updates on 2015-09-09
Deleted in trusty-proposed on 2015-09-10 (Reason: moved to -updates)
dkms (2.2.0.3-1.1ubuntu5.14.04.1) trusty; urgency=medium

  * Add apport_package_key_with_version.patch: Include the package version in
    the Package data as apport does this with any report it creates and the
    Error Tracker expects to find the version there. (LP: #1429967)
 -- Brian Murray <email address hidden>   Mon, 09 Mar 2015 11:45:07 -0700
Obsolete in utopic-updates on 2016-11-03
Deleted in utopic-proposed on 2016-11-03 (Reason: moved to -updates)
dkms (2.2.0.3-1.1ubuntu5.14.10.1) utopic; urgency=medium

  * Add apport_package_key_with_version.patch: Include the package version in
    the Package data as apport does this with any report it creates and the
    Error Tracker expects to find the version there. (LP: #1429967)
 -- Brian Murray <email address hidden>   Mon, 09 Mar 2015 11:16:12 -0700
Superseded in trusty-updates on 2015-07-15
Deleted in trusty-proposed on 2015-07-17 (Reason: moved to -updates)
dkms (2.2.0.3-1.1ubuntu5.14.04) trusty; urgency=medium

  * fixed_sed_without_options_issue.patch: Backport of patch to fix sed issues.
    (LP: #1358373)
 -- Chris J Arges <email address hidden>   Mon, 01 Dec 2014 16:53:16 -0600
Superseded in utopic-updates on 2015-07-15
Deleted in utopic-proposed on 2015-07-17 (Reason: moved to -updates)
dkms (2.2.0.3-1.1ubuntu5.14.10) utopic; urgency=medium

  * fixed_sed_without_options_issue.patch: Backport of patch to fix sed issues.
    (LP: #1358373)
 -- Chris J Arges <email address hidden>   Mon, 01 Dec 2014 16:53:16 -0600
Superseded in vivid-release on 2015-03-11
Deleted in vivid-proposed on 2015-03-13 (Reason: moved to release)
dkms (2.2.0.3-2ubuntu2) vivid; urgency=medium

  * Add apport_package_key_with_version.patch: Include the package version in
    the Package data as apport does this with any crash file it creates and
    the Error Tracker expects to find the version there.
 -- Brian Murray <email address hidden>   Fri, 14 Nov 2014 10:37:49 -0800
Superseded in vivid-release on 2014-11-14
Deleted in vivid-proposed on 2014-11-16 (Reason: moved to release)
dkms (2.2.0.3-2ubuntu1) vivid; urgency=medium

  * Merge with Debian unstable. Remaining Ubuntu changes:
    - Some patches, see their patch header for details:
      Add-support-for-forcing-modules-installation.patch,
      apport_dup_signature.patch,
      apport_python3.patch,
      apport_supported_kernel_packages.diff
  * Add debian/scripts/dkms-autopkgtest script: Common autopkgtest script for
    testing a dkms source package.

Superseded in precise-updates on 2015-09-09
Deleted in precise-proposed on 2015-09-10 (Reason: moved to -updates)
dkms (2.2.0.3-1ubuntu3.2) precise-proposed; urgency=low

  * Backport from trunk: Add patch that fixes have_one_kernel for non-
    zero return code. (LP: #1261116)
 -- Antonius Riha <email address hidden>   Sat, 21 Dec 2013 10:15:29 +0100
Superseded in vivid-release on 2014-11-11
Obsolete in utopic-release on 2016-11-03
Published in trusty-release on 2014-01-15
Deleted in trusty-proposed (Reason: moved to release)
dkms (2.2.0.3-1.1ubuntu5) trusty; urgency=low

  [ Mario Limonciello ]
  * Backport from trunk: Add patch that fixes have_one_kernel for non-
    zero return code. (LP: #1261116)
 -- Antonius Riha <email address hidden>   Fri, 10 Jan 2014 16:50:11 +0100
Superseded in trusty-release on 2014-01-15
Obsolete in saucy-release on 2015-04-24
Deleted in saucy-proposed on 2015-04-28 (Reason: moved to release)
dkms (2.2.0.3-1.1ubuntu4) saucy; urgency=low

  * apport_python3.patch: Fix bug links in header.
  * apport_python3.patch: Call package hook through python3, not python.
    (LP: #1171344)
 -- Martin Pitt <email address hidden>   Wed, 29 May 2013 08:31:34 +0200
Superseded in saucy-release on 2013-05-29
Deleted in saucy-proposed on 2013-05-30 (Reason: moved to release)
dkms (2.2.0.3-1.1ubuntu3) saucy; urgency=low

  * Add apport_dup_signature.patch: Don't use the whole DKMS build log as
    duplicate signature, this is way too long. Just use the first actual
    compiler error, together with the package name and version. (LP: #1175785)
 -- Martin Pitt <email address hidden>   Thu, 02 May 2013 15:39:26 -0700
Obsolete in quantal-updates on 2015-04-24
Deleted in quantal-proposed on 2015-05-01 (Reason: moved to -updates)
dkms (2.2.0.3-1.1ubuntu1.1) quantal; urgency=low

  * Don't Recommend any linux-headers packages, our installers
    all install headers matching your kernel anyway, and this
    dependency causes more problems than it solves (LP: #960770)
 -- Adam Conrad <email address hidden>   Thu, 17 Jan 2013 16:27:13 -0700
Superseded in precise-updates on 2014-02-03
Deleted in precise-proposed on 2014-02-04 (Reason: moved to -updates)
dkms (2.2.0.3-1ubuntu3.1) precise-proposed; urgency=low

  * Don't Recommend any linux-headers packages, our installers
    all install headers matching your kernel anyway, and this
    dependency causes more problems than it solves (LP: #960770)
 -- Timo Aaltonen <email address hidden>   Thu, 10 Jan 2013 13:11:20 +0200
Superseded in saucy-release on 2013-05-02
Obsolete in raring-release on 2015-04-24
Deleted in raring-proposed on 2015-04-27 (Reason: moved to release)
dkms (2.2.0.3-1.1ubuntu2) raring; urgency=low

  * Don't Recommend any linux-headers packages, our installers
    all install headers matching your kernel anyway, and this
    dependency causes more problems than it solves (LP: #960770)
 -- Adam Conrad <email address hidden>   Wed, 31 Oct 2012 11:28:52 +0000
Superseded in raring-release on 2012-10-31
Obsolete in quantal-release on 2015-04-24
Deleted in quantal-proposed on 2015-05-01 (Reason: moved to release)
dkms (2.2.0.3-1.1ubuntu1) quantal-proposed; urgency=low

  * Merge from Debian unstable, remaining changes:
    - Add apport_supported_kernel_packages.diff:
      Only report bugs about supported kernel versions.
    - Add Add-support-for-forcing-modules-installation.patch, backported
      from trunk:
      Add support to force module installation by adding files to
      /usr/share/dkms/modules_to_force_install
    - Add apport_python3.patch: Port apport hook to Python 3 and
      take care of opening the output file in binary mode
    - debian/control: added 'dpkg-dev' and 'debhelper' to Suggests.

Superseded in quantal-release on 2012-07-27
dkms (2.2.0.3-1ubuntu5) quantal; urgency=low

  * debian/control: added 'dpkg-dev' and 'debhelper' to Suggests (LP:
    #989998)
 -- Aditya Vaidya <email address hidden>   Wed, 11 Jul 2012 08:28:02 -0400
Superseded in quantal-release on 2012-07-11
dkms (2.2.0.3-1ubuntu4) quantal; urgency=low

  * Add apport_python3.patch: Port apport hook to Python 3 (LP: #1013171) and
    take care of opening the output file in binary mode (LP: #1008092)
 -- Martin Pitt <email address hidden>   Thu, 21 Jun 2012 08:52:35 +0200
Superseded in quantal-release on 2012-06-21
Published in precise-release on 2012-04-23
Deleted in precise-proposed (Reason: moved to release)
dkms (2.2.0.3-1ubuntu3) precise-proposed; urgency=low

  * Add linux-headers-generic-pae to recommended headers packages so that i386
    installs get the right headers (LP: #986475)
 -- Scott Kitterman <email address hidden>   Sat, 21 Apr 2012 15:01:27 -0400
Superseded in precise-release on 2012-04-23
dkms (2.2.0.3-1ubuntu2) precise; urgency=low

  [ Alberto Milone ]
  * Backport from trunk: Add support to force module installation by
    adding files to /usr/share/dkms/modules_to_force_install
 -- Mario Limonciello <email address hidden>   Tue, 03 Apr 2012 18:03:02 -0500
Superseded in precise-release on 2012-04-03
dkms (2.2.0.3-1ubuntu1) precise; urgency=low

  * Only report bugs about supported kernel versions. This fixes a regression
    introduced in 2.2.0.2-1ubuntu2. (LP: #940285)
    - Add apport_supported_kernel_packages.diff:
      Check the result of is_distro_package() and fix the check if the kernel
      header package is installed at all.
 -- Felix Geyer <email address hidden>   Fri, 24 Feb 2012 14:08:47 +0100
Superseded in precise-release on 2012-03-01
dkms (2.2.0.3-1) unstable; urgency=low


  * [e24a52f] Imported Upstream version 2.2.0.3
  * [09da5c7] bump standards version
  * [713ebfd] add missing debhelper token to preinst
  * [8970435] add versioned build depends for debhelper
  * [db4238c] switch to dh7
  * [13a34c7] update lintian override for DKMS apport rule

 -- Mario Limonciello <email address hidden>  Wed, 07 Dec 2011 13:21:33 -0600
Superseded in precise-release on 2011-12-08
Obsolete in oneiric-release on 2015-04-24
dkms (2.2.0.2-1ubuntu4) oneiric; urgency=low

  * Autoinstall modules that have just been added too. (LP: #867922)
 -- Mario Limonciello <email address hidden>   Wed, 05 Oct 2011 18:17:21 -0500
Superseded in oneiric-release on 2011-10-06
dkms (2.2.0.2-1ubuntu3) oneiric; urgency=low

  * Disable the reserved tree name check. Thanks to Mario
    Lemonciello for the patch. (LP: #855635)
 -- David Henningsson <email address hidden>   Tue, 27 Sep 2011 07:59:21 +0200
Superseded in oneiric-release on 2011-09-27
dkms (2.2.0.2-1ubuntu2) oneiric; urgency=low

  * Prevent crash in apport hook if the package is not an Ubuntu one
    (LP: #816199)
 -- Brian Murray <email address hidden>   Mon, 12 Sep 2011 13:55:21 -0700
Superseded in oneiric-release on 2011-09-13
dkms (2.2.0.2-1ubuntu1) oneiric; urgency=low

  [ Brian Murray]
  * Add a duplicate signature to the apport hook, so that reports caused by
    a common failure can more easily be identified as duplicates.
    LP: #766160.
 -- Steve Langasek <email address hidden>   Thu, 01 Sep 2011 10:37:41 -0700

Available diffs

Superseded in oneiric-release on 2011-09-01
dkms (2.2.0.2-1) unstable; urgency=low

  [ Mario Limonciello ]
  * [c5846b6] Imported Upstream version 2.2.0.2
    - Doesn't leave files in /tmp (Closes: #633802)
    - Autoinstall works on multiple kernels (Closes: #634979) (LP: #812979)
    - PRE_BUILD command working directory fix. (LP: #812088)
  * [83b5f6e] Drop kfreebsd.patch.  Merged upstream

  [ Giuseppe Iuculano ]
  * [a80ecc5] Updated VCS control field

Available diffs

Superseded in oneiric-release on 2011-08-03
dkms (2.2.0.1-0ubuntu1) oneiric; urgency=low

  * New upstream version.  Bugs fixed in Ubuntu:
  * Apport hook:
    - Only generate reports about supported kernel version (LP: #766150)
    - Include fglrx make file (LP: #792444)
    - Crashes in get_source() (LP: #532496)
    - Apport script fails (LP: #798498)
  * Openafs modules leaving empty make.log (LP: #593509)
  * '_' in module name causes mkdeb to fail (LP: #511619)
  * PRE_BUILD command invoked from wrong directory. (LP: #702638)
  * Speed up for large amounts of modules (LP: #786672)
  * Leaves temp files in /tmp (LP: #810134)
  * Generate .changes file for LP: upload (LP: #582668)
  * Don't change access rights of upstream source (LP: #582670)
  * common.postinst fails on failed build (LP: #595968)
  * Using a hyphen as part of PACKAGE_VERSION causes failures (LP: #599983)
  * dkms shouldn't source all the variables in dkms.conf (LP: #599985)
 -- Mario Limonciello <email address hidden>   Thu, 14 Jul 2011 13:18:56 -0500
175 of 113 results