dosemu-freedos (dapper and most probably edgy)

Bug #73056 reported by StefanPotyra
8
Affects Status Importance Assigned to Milestone
Dapper Backports
Fix Released
Undecided
Unassigned
Edgy Backports
Fix Released
Undecided
Unassigned
dosemu-freedos (Ubuntu)
Fix Released
Undecided
Ubuntu Backporters

Bug Description

dosemu-freedos in dapper and edgy cause a segfault in dosemu.

Revision history for this message
StefanPotyra (sistpoty) wrote :

Hi,

dapper,edgy-version: b8p-4
feisty-version (that works): 1:0.0.b9r5a-3
(both unchanged from debian/unstable)

at the moment, this is just for discussion as I'd like to hear your comments on this:

dosemu-freedos doesn't work both with the proposed SRU and the original version present in dapper. Since edgy didn't have any (source) changes to dosemu and dosemu-freedos, it most probably won't work there as well. (I can test, but I'll need to set up a i386 edgy first).

Identifying the exact thing to fix seems very hard, because:
* dosemu-freedos contains quite some asm code
* the changes are *huge* (filtered diff of sources is 11,529,418 Byte)
* dosemu-freedos doesn't build from source, but rather ships prebuilt binaries (along with their sources)

That said, I don't think I will be able to supply a reasonable small diff for an SRU. I also don't have the slightest clue yet, where I might look for the error.

Currently I see two possibilities:
* bring dosemu-freedos in via -backports
  + no big changes to a stable version
  - would mean a version of dosemu in updates, that still wouldn't be working in combination with dosemu-freedos from the corresponding release pocket.

* bring dosemu-freedos in via -updates
  + install stuff from updates and be happy
  + can't break stuff that's already broken
  - the diff is... well... *huge*

What do you suggest?

P.S.: Bart, subscribing you as well, maybe you can also give some hints. I hope you don't mind ;).

Cheers,
    Stefan.

Changed in dosemu-freedos:
assignee: nobody → motu-sru
Revision history for this message
Daniel T Chen (crimsun) wrote :

-updates is supposedly for non-invasive, eyeballable changes. I agree that having a broken version in -updates is suboptimal, but I think it's safer to use -backports in this context due to sheer invasiveness.

Revision history for this message
StefanPotyra (sistpoty) wrote :

Ok, reassigning to backports.

Changed in dosemu-freedos:
assignee: motu-sru → ubuntu-backporters
Revision history for this message
John Dong (jdong) wrote :

Transferring over to backports....

Changed in dosemu-freedos:
status: Unconfirmed → Fix Released
Revision history for this message
John Dong (jdong) wrote :

Builds in Dapper, but I have not tested it

Changed in dapper-backports:
status: Unconfirmed → Confirmed
Revision history for this message
John Dong (jdong) wrote :

Builds in Edgy, tested and confirmed working.

Changed in edgy-backports:
status: Unconfirmed → Confirmed
Revision history for this message
John Dong (jdong) wrote :

Approved for edgy-backports.

Changed in edgy-backports:
status: Confirmed → In Progress
Revision history for this message
Colin Watson (cjwatson) wrote :

 * Trying to backport dosemu-freedos...
  - <dosemu-freedos_0.0.b9r5a.orig.tar.gz: downloading from librarian>
  - <dosemu-freedos_0.0.b9r5a-3.diff.gz: downloading from librarian>
  - <dosemu-freedos_0.0.b9r5a-3.dsc: downloading from librarian>
I: Extracting dosemu-freedos_0.0.b9r5a-3.dsc ... done.
I: Building backport of dosemu-freedos-0.0.b9r5a as 1:0.0.b9r5a-3~edgy1 ... done.

Changed in edgy-backports:
status: In Progress → Fix Released
Revision history for this message
John Dong (jdong) wrote :

Tested and approved for dapepr-backports

Changed in dapper-backports:
status: Confirmed → In Progress
Revision history for this message
Martin Pitt (pitti) wrote :

 * Trying to backport dosemu-freedos...
  - <dosemu-freedos_0.0.b9r5a.orig.tar.gz: downloading from librarian>
  - <dosemu-freedos_0.0.b9r5a-3.diff.gz: downloading from librarian>
  - <dosemu-freedos_0.0.b9r5a-3.dsc: downloading from librarian>
I: Extracting dosemu-freedos_0.0.b9r5a-3.dsc ... done.
I: Building backport of dosemu-freedos-0.0.b9r5a as 1:0.0.b9r5a-3~dapper1 ... done.

Changed in dapper-backports:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers