Eclipse fails to boot

Bug #3074 reported by Nathan Meryash on 2005-10-11
18
Affects Status Importance Assigned to Milestone
eclipse (Ubuntu)
Medium
Unassigned

Bug Description

I reported a bug against eclipse on the eclipse bugzilla regarding an Eclipse
boot issue in Breezy. They report this is an Ubuntu distro issue and not Eclipse. I am not sure which it is. Please review the following for details:

https://bugs.eclipse.org/bugs/show_bug.cgi?id=112165

Changed in eclipse:
assignee: nobody → motu
Sebastian Dröge (slomo) on 2005-10-12
Changed in eclipse:
assignee: motu → doko
Christian Dröge (christian-d) wrote :

I can confirm this bug on my amd64 box. Strangely I can't reproduce this bug on the computer of my brother (i386).

Nathan Meryash (ngmlinux) wrote :

My machine is AMD64, HOWEVER I'm running i386 Ubuntu (Breezy) on it (due to the fact the AMD64 platform is not fully supported by all packages, eclipse plugins included).

Matthias Klose (doko) wrote :

> My machine is AMD64, HOWEVER I'm running i386 Ubuntu (Breezy) on it (due to the fact > the AMD64 platform is not fully supported by all packages, eclipse plugins included).

that's an unsupported installation. try to install the linux32 package and run linux32 eclipse

Nathan Meryash (ngmlinux) wrote :

Just to clarify I said I am runnning 32bit linux and 32bit eclipse (although my hardware is AMD64).

Has anyone been able to investigate this bug any further? Anyone working on a fix?

AMcHugh (ahmchugh) wrote :

I'm getting what looks to be the same problem on AMD64 hardware running the 64 bit version.

Ka-Hing Cheung (kahing) wrote :

I have the same problem on PPC as well.

Kareema (markmueller86) wrote :

Just for clarification: This bug does not show on i386 (tested).

I reproduced this bug with the following VMs on Ubuntu AMD64 Breezy and Dapper:

java version "1.5.0_05"
Java(TM) 2 Runtime Environment, Standard Edition (build 1.5.0_05-b05)
Java HotSpot(TM) 64-Bit Server VM (build 1.5.0_05-b05, mixed mode)

java version "1.4.2"
gij (GNU libgcj) version 4.0.3 20051023 (prerelease) (Ubuntu 4.0.2-3ubuntu1)

Using the package from the Eclipse website, Eclipse works with both virtual machines!

More info about this problem can be fount at the ubuntu forums: http://www.ubuntuforums.org/showthread.php?t=82127

Jan Pfeifer (pfjan) wrote :

Same problem on Ubuntu Dapper AMD64, Java 1.5.0-06.

Package list:
$ dpkg --list | grep eclipse
ii eclipse 3.1.1-8ubuntu2 Extensible Tool Platform and Java IDE
ii eclipse-base 3.1.1-1ubuntu3 Eclipse distribution base
ii eclipse-cdt 3.0.1-2 C/C++ Development Tools for Eclipse
ii eclipse-jdt 3.1.1-8ubuntu2 Java Development Tools plug-ins for Eclipse
ii eclipse-jdt-common 3.1.1-8ubuntu2 Java Development Tools plug-ins for Eclipse
ii eclipse-pde 3.1.1-8ubuntu2 Plug-in Development Environment to develop E
ii eclipse-pde-common 3.1.1-8ubuntu2 Plug-in Development Environment to develop E
ii eclipse-platform 3.1.1-8ubuntu2 Eclipse platform without plug-ins to develop
ii eclipse-platform-common 3.1.1-8ubuntu2 Eclipse platform without plug-ins to develop
ii eclipse-rcp 3.1.1-8ubuntu2 Eclipse rich client platform
ii eclipse-rcp-common 3.1.1-8ubuntu2 Eclipse rich client platform (common files)
ii eclipse-sdk 3.1.1-8ubuntu2 Extensible Tool Platform and Java IDE
ii eclipse-source 3.1.1-8ubuntu2 Eclipse source code plug-ins

hope this helps :-)

Aldous Peñaranda (dous) wrote :

This might have been due to a wrong build for libswt-gtk-3.1-java. Can you please try to run it again now that an update has been released?

Works for me now

Jan Pfeifer (pfjan) wrote :

Works for me as well, great job.

Matthias Klose (doko) wrote :

eclipse doesn't use libswt-gtk-3.1-java at all, this is unrelated.

did you (buggs, Jan Pfeifer) really check on amd64?

Aldous Peñaranda (dous) wrote :

I just thought maybe this is related to malone bug #28832 or debian bug #336338?

hi Mathias,

yes, I'm running on amd64 dapper:

$ /usr/bin/eclipse
using specified vm: /usr/lib/j2sdk1.5-sun/
(it is running now, no problems)

$ dpkg --list | grep eclipse
ii eclipse 3.1.1-8ubuntu2 Extensible Tool Platform and Java IDE
ii eclipse-cdt 3.0.1-2 C/C++ Development Tools for Eclipse
ii eclipse-jdt 3.1.1-8ubuntu2 Java Development Tools plug-ins for Eclipse
ii eclipse-jdt-common 3.1.1-8ubuntu2 Java Development Tools plug-ins for Eclipse
ii eclipse-pde 3.1.1-8ubuntu2 Plug-in Development Environment to develop E
ii eclipse-pde-common 3.1.1-8ubuntu2 Plug-in Development Environment to develop E
ii eclipse-platform 3.1.1-8ubuntu2 Eclipse platform without plug-ins to develop
ii eclipse-platform-common 3.1.1-8ubuntu2 Eclipse platform without plug-ins to develop
ii eclipse-rcp 3.1.1-8ubuntu2 Eclipse rich client platform
ii eclipse-rcp-common 3.1.1-8ubuntu2 Eclipse rich client platform (common files)
ii eclipse-sdk 3.1.1-8ubuntu2 Extensible Tool Platform and Java IDE
ii eclipse-source 3.1.1-8ubuntu2 Eclipse source code plug-ins

$ dpkg --list | grep swt
ii libswt3.1-gtk-java 3.1.1-8ubuntu2 Fast and rich GUI toolkit for Java, gtk2 ver
ii libswt3.1-gtk-jni 3.1.1-8ubuntu2 Platform dependent files for libswt3.1-gtk-j

$ uname -a
Linux galactica 2.6.15.1-ubuntu1.20060206 #1 SMP Mon Feb 6 09:04:51 BRST 2006 x86_64 GNU/Linux

I built my kernel because I needed the latest Alsa libraries. Also, I had to select a sensors (i2c) module that Ubuntu's pre-packaged kernel is not including.

----- Original Message ----
From: Matthias Klose <email address hidden>
To: <email address hidden>
Sent: Tue 07 Feb 2006 10:46:22 AM BRST
Subject: [Bug 3074] Eclipse fails to boot

Public bug report changed:
https://launchpad.net/malone/bugs/3074

Comment:
eclipse doesn't use libswt-gtk-3.1-java at all, this is unrelated.

did you (buggs, Jan Pfeifer) really check on amd64?

Yes, amd64, with jdk 1.4.
All i can say it did not work until some weeks, say 3, ago and now it works.

deman (deman2k) wrote :

Are you sure that libswt-gtk-3.1-java not related to eclipse at all? I've problem starting eclipse 3.1.1-8ubuntu2 in just freshly dist-upgrade to dapper. I've tried so many thing, but the last one in which I completely remove libswt-gtk-3.1-java (this cause all the eclipse package to be uninstalled) makes my eclipse working again.

This might help.

Xavier De Poorter (depx) wrote :

in fact eclipse works only with root user : is it a permission problem ? if yes, i dont know where ...

Matthias Klose (doko) wrote :

Xavier De Poorter wrote:
> in fact eclipse works only with root user : is it a permission problem ?
> if yes, i dont know where ...

sorry, this has nothing to do with the original report. If you think,
you have found a bug, then please describe why the behaviour should be
considered a bug, and open a new bug report. eclipse as found in the
current dapper testing version works fine for me on i386, powerpc and amd64.

Matthias Klose (doko) wrote :

eclipse works for me in the current dapper development release (3.1.2-1ubuntu5). Please can you recheck?

Changed in eclipse:
status: Unconfirmed → Needs Info

Yes, it works, as reported a lot. How about closing this one :-)

Matthias Klose (doko) on 2006-03-28
Changed in eclipse:
status: Needs Info → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.