Change log for eclipse package in Ubuntu

175 of 84 results
Deleted in disco-release (Reason: (From Debian) ROM; Old and unmaintained, replaced by fine...)
Published in cosmic-release on 2018-05-01
Published in bionic-release on 2018-02-22
Deleted in bionic-proposed (Reason: moved to release)
eclipse (3.8.1-11) unstable; urgency=medium

  * Team upload.
  * Declare compliance with Debian Policy 4.1.3.
  * Drop binary package libequinox-osgi-java which is now provided by
    src:libequinox-osgi-java.
  * Remove obsolete libequinox-osgi-java install filesi and debian/rules code.
  * Drop obsolete eclipse-platform.menu file.

 -- Markus Koschany <email address hidden>  Wed, 21 Feb 2018 18:00:21 +0100

Available diffs

Superseded in bionic-release on 2018-02-22
Published in artful-release on 2017-04-20
Obsolete in zesty-release on 2018-06-22
Deleted in zesty-proposed (Reason: moved to release)
eclipse (3.8.1-10) unstable; urgency=medium

  * Team upload.
  * Transition to Jetty 9

 -- Emmanuel Bourg <email address hidden>  Wed, 26 Oct 2016 01:16:44 +0200

Available diffs

Superseded in zesty-release on 2016-11-03
Obsolete in yakkety-release on 2018-01-23
Published in xenial-release on 2015-10-22
Obsolete in wily-release on 2018-01-22
Deleted in wily-proposed (Reason: moved to release)
eclipse (3.8.1-8) unstable; urgency=medium

  * Update icu4j dependency to libicu4j-49-java
    - required by eclipse-cdt 8.6.0.
  * Bump Standards-Version to 3.9.6.
  * Convert Vcs-* fields in d/control into canonical format.

 -- Jakub Adam <email address hidden>  Sat, 28 Feb 2015 19:13:20 +0100

Available diffs

Superseded in wily-release on 2015-06-14
Obsolete in vivid-release on 2018-01-18
Deleted in vivid-proposed on 2018-01-19 (Reason: moved to release)
eclipse (3.8.1-7) unstable; urgency=medium


  * Team upload.
  * Install all arch-dependent files into eclipse-rcp correctly by renaming
    override_dh_install to override_dh_install-arch.
    Fix wrong override for dh_install-indep and move jh_classpath commands
    to the appropriate override target. (Closes: #770457, #763994)

 -- Markus Koschany <email address hidden>  Mon, 24 Nov 2014 02:31:41 +0100

Available diffs

Superseded in vivid-release on 2015-03-13
Deleted in vivid-proposed on 2015-03-15 (Reason: moved to release)
eclipse (3.8.1-6) unstable; urgency=medium


  [ Emmanuel Bourg ]
  * Team upload.
  * Replaced the jsr14 compilation target with 1.5 to compile with Java 8

  [ Jakub Adam ]
  * Refreshed d/eclipse-build-generatedScripts.tar.bz2 (Closes: #759847).
  * Override needless-suggest-recommend-libservlet-java lintian warning
    - follows from an optional OSGi dependency on javax.servlet.

 -- Jakub Adam <email address hidden>  Sun, 14 Sep 2014 13:52:58 +0200

Available diffs

Superseded in vivid-release on 2014-11-12
Obsolete in utopic-release on 2016-11-03
Published in trusty-release on 2014-01-17
Deleted in trusty-proposed (Reason: moved to release)
eclipse (3.8.1-5.1) unstable; urgency=low


  [ Jakub Adam ]
  * Compile org.eclipse.osgi bundle for java 1.5.
    - Required for Tycho build with Java 7.
  * Fix FTBFS on s390x architecture.
  * Provide convenient symlinks for jdi.jar and jdimodel.jar (Closes: #734797).
  * Add README.ports.
  * Move Orbit jar symlinks mentioned in bundles.info from eclipse-platform-data
    into eclipse-platform (Closes: #735096, #732244).
    - Ensures bundles.info is always consistent with bundle names.

  [ Matthias Klose ]
  * Build for arm64 and ppc64el.

  [ tony mancill ]
  * Bump Standards-Version to 3.9.5.

 -- tony mancill <email address hidden>  Thu, 16 Jan 2014 20:52:11 -0800
Superseded in trusty-release on 2014-01-17
Deleted in trusty-proposed on 2014-01-19 (Reason: moved to release)
eclipse (3.8.1-4ubuntu1) trusty; urgency=low

  * Build for arm64 and ppc64el.
 -- Matthias Klose <email address hidden>   Sat, 11 Jan 2014 18:37:37 +0100
Superseded in trusty-release on 2014-01-12
Obsolete in saucy-release on 2015-04-24
Deleted in saucy-proposed on 2015-04-28 (Reason: moved to release)
eclipse (3.8.1-4) unstable; urgency=low


  * Fix help webapp with tomcat-jasper.jar from libtomcat7-java 7.0.40.
  * Improved eclipse-jdt extended description (Closes: #700256).

 -- Jakub Adam <email address hidden>  Wed, 12 Jun 2013 19:36:31 +0200
Superseded in saucy-release on 2013-08-11
Obsolete in raring-release on 2015-04-24
Deleted in raring-proposed on 2015-04-27 (Reason: moved to release)
eclipse (3.8.1-1ubuntu1) raring; urgency=low

  * Do not define G_DISABLE_DEPRECATED to fix build failure.
 -- Matthias Klose <email address hidden>   Wed, 10 Apr 2013 11:53:55 +0200
Superseded in raring-release on 2013-04-10
Deleted in raring-proposed on 2013-04-11 (Reason: moved to release)
eclipse (3.8.1-1) experimental; urgency=low


  * New upstream release.
  * Update extended description of eclipse-platform-data (Closes: #679423).
  * Fix libgnomeproxy compilation with glib >= 2.32 (Closes: #679328).
  * Expose org.eclipse.jface and its dependencies in /usr/share/java.
  * Don't let patches delete files.
    - Works around dpkg bug #683547.
    - Affected patches are use-deb-build-compiler-flags.patch and
      find-tomcat-libs.patch.
  * Refreshed d/patches/eclipse-help-fix-jsp-precompilation.patch.

 -- Jakub Adam <email address hidden>  Sun, 14 Oct 2012 14:59:33 +0200
Superseded in raring-release on 2013-04-02
Obsolete in quantal-release on 2015-04-24
eclipse (3.8.0~rc4-1ubuntu1) quantal; urgency=low

  * Merge from Debian unstable.  Remaining changes:
    - d/p/glib-single-include.patch: Fix FTBFS with glib 2.31+.

Superseded in quantal-release on 2012-08-08
eclipse (3.8.0~rc3-4ubuntu1) quantal; urgency=low

  * debian/patches/glib-single-include.patch:
    - Fix FTBFS with glib 2.31+ (LP: #1016350)
 -- Jeremy Bicha <email address hidden>   Tue, 26 Jun 2012 15:00:17 -0400
Superseded in quantal-release on 2012-06-26
eclipse (3.8.0~rc3-4) unstable; urgency=low


  * Upload to unstable.
  * Add upper bound on swt-gtk dependency.

 -- Niels Thykier <email address hidden>  Wed, 20 Jun 2012 12:55:00 +0200

Available diffs

Superseded in quantal-release on 2012-06-21
Published in precise-release on 2012-04-04
eclipse (3.7.2-1) unstable; urgency=low


  * New upstream release.
  * Use SWT from swt-gtk package instead of the bundled version
    (Closes: #538808).
  * Add org.eclipse.equinox.log to eclipse-rcp.
  * Update package synopsis and extended descriptions
    (Closes: #655945, #655946).
  * Bump Standards-Version to 3.9.3 (no changes required).
  * Fix broken installaton after some package Eclipse core platform
    depends on is upgraded (Closes: #662153, #663335).

 -- Jakub Adam <email address hidden>  Sun, 11 Mar 2012 20:10:20 +0100

Available diffs

Superseded in precise-release on 2012-04-04
eclipse (3.7.1-1) unstable; urgency=low


  * New upstream release (Closes: #652839).
  * Fix FTBFS with libjasper-java 5.5.33-2
  * Add Jakub Adam to Uploaders
  * Depend on libjasper-java >= 5.5.33-2 (Closes: #648641)
  * Removed GDK_NATIVE_WINDOWS=true workaround
  * Fixed update site injection on first Eclipse startup and changed
    URL to Indigo update site

 -- Jakub Adam <email address hidden>  Sat, 31 Dec 2011 15:49:15 +0100

Available diffs

Superseded in precise-release on 2012-01-01
eclipse (3.7.0-1) unstable; urgency=low


  [ Benjamin Drung ]
  * Upload to unstable (Closes: #631382, #642085).
  * Use pkg-config to determine CFLAGS and LIBS for gnomeproxy.
  * Eclipse 3.7 requires at least version 3.3 of asm3.
  * Update debian/copyright.
  * Drop xulrunner from Apport hook.
  * Update debian/watch file.
  * Add patch to find libjasper-java 5.5.33-1 on Debian.
  * Update lintian overrides.

  [ Damien Raude-Morvan ]
  * d/patches/find-newer-servlet-api.patch: Patch to support libservlet2.5.

 -- Benjamin Drung <email address hidden>  Sat, 22 Oct 2011 16:01:50 +0200
Superseded in precise-release on 2011-10-24
Obsolete in oneiric-release on 2015-04-24
eclipse (3.7.0-0ubuntu1) oneiric; urgency=low

  * Upload to Ubuntu (LP: #860723).
  * Use pkg-config to determine CFLAGS and LIBS for gnomeproxy.
  * Eclipse 3.7 requires at least version 3.3 of asm3.
  * Update debian/copyright.
  * Drop xulrunner from Apport hook.
  * Update debian/watch file.
  * Add patch to find libjasper-java 5.5.33-1 on Debian.
  * Update lintian overrides.

Available diffs

Superseded in oneiric-release on 2011-09-27
eclipse (3.5.2-11ubuntu3) oneiric; urgency=low

  * Don't build the internal browser in order to drop the Gecko dependency
    (see https://blueprints.launchpad.net/ubuntu/+spec/ \
          desktop-o-mozilla-rapid-release-maintenance)
    - add debian/patches/default-external-browser.patch to set the default
      browser executable to xdg-open. This ensures that eclipse does the
      right thing and opens the help in the users preferred browser (rather
      than hardoding /usr/bin/mozilla)
    - drop xulrunner-1.9.2-dev build-depend from debian/rules
    - comment out the bits in debian/rules for finding the xulrunner install
      path and replacing /usr/bin/eclipse with our own wrapper
    - Don't pass "--with xulrunner" to dh
    - Don't pass libswt-xpcominit-gtk-*.so and libswt-xulrunner-gtk-*.so to
      dh_shlibdeps
 -- Chris Coulson <email address hidden>   Tue, 26 Jul 2011 10:12:03 +0100
Superseded in oneiric-release on 2011-07-26
eclipse (3.5.2-11ubuntu2) oneiric; urgency=low

  * Correct the ordering of linker options when building the native SWT libs.
    Fixes a failure to resolve symbols at runtime
    - add debian/patches/link-flag-ordering.patch
    - update debian/patches/series
 -- Chris Coulson <email address hidden>   Tue, 26 Jul 2011 00:03:52 +0100
Superseded in oneiric-release on 2011-07-26
eclipse (3.5.2-11ubuntu1) oneiric; urgency=low

  * Merge from Debian unstable (LP: #812161).  Remaining changes:
    - debian/patches/gnomeproxy-makefile.patch: Set Java include path for
      libgnomeproxy.
    - debian/patches/gnomeproxy-pkg-config.patch: Use pkg-config to find
      include files and libraries for libgnomeproxy.  (LP: #749218)
    - Use xulrunner-1.9.2-dev, not xulrunner-dev, as eclipse isn't 2.0
      compatible yet.
 -- James Page <email address hidden>   Mon, 18 Jul 2011 11:02:29 +0100
Superseded in oneiric-release on 2011-07-18
eclipse (3.5.2-10ubuntu2) oneiric; urgency=low

  * debian/patches/gnomeproxy-makefile.patch: Set Java include path for
    libgnomeproxy.
  * debian/patches/gnomeproxy-pkg-config.patch: Use pkg-config to find
    include files and libraries for libgnomeproxy.  (LP: #749218)
 -- Anders Kaseorg <email address hidden>   Thu, 26 May 2011 22:19:59 +0200
Superseded in oneiric-release on 2011-05-26
eclipse (3.5.2-10ubuntu1) oneiric; urgency=low

  * Merge from Debian unstable (LP: #780267). Remaining changes:
    - Use xulrunner-1.9.2-dev, not xulrunner-dev, as eclipse isn't 2.0
      compatible yet.

Available diffs

Superseded in oneiric-release on 2011-05-11
Obsolete in natty-release on 2013-06-04
eclipse (3.5.2-8ubuntu3) natty; urgency=low

  * debian/control:
    - Use xulrunner-1.9.2-dev, not xulrunner-dev, as eclipse isn't 2.0
      compatible yet.  That and a rebuild fixes LP: #728825
 -- Michael Terry <email address hidden>   Tue, 15 Mar 2011 11:14:51 -0400

Available diffs

Superseded in natty-release on 2011-03-15
eclipse (3.5.2-8ubuntu2) natty; urgency=low

  * debian/extra/eclipse:
    - Actually, don't export UBUNTU_MENUPROXY=0 here because that affects
      launched applications too.  Instead, it is blacklisted by appmenu-gtk.
 -- Michael Terry <email address hidden>   Tue, 01 Mar 2011 12:52:55 -0500

Available diffs

Obsolete in maverick-updates on 2013-03-05
Deleted in maverick-proposed on 2013-03-05 (Reason: moved to -updates)
eclipse (3.5.2-6ubuntu1.1) maverick-proposed; urgency=low

  [ Thomas Watson ]
  * Backported fix for finding root CA in keystore rather than from JAR.
    (LP: #655833)

  [ Benjamin Drung ]
  * Added NEWS entry about how to workaround #587657.
 -- Benjamin Drung <email address hidden>   Wed, 20 Oct 2010 01:15:47 +0200
Obsolete in lucid-updates on 2016-10-26
Deleted in lucid-proposed on 2016-11-01 (Reason: moved to -updates)
eclipse (3.5.2-2ubuntu4.3) lucid-proposed; urgency=low

  * Backported fix for finding root CA in keystore rather than from JAR.
    (LP: #655833)
 -- Thomas Watson <email address hidden>   Wed, 20 Oct 2010 00:58:03 +0200
Superseded in natty-release on 2011-03-01
eclipse (3.5.2-8ubuntu1) natty; urgency=low

  * Do not symlink ant-trax.jar, because ant 1.8.1-1 does not ship it any more.
 -- Benjamin Drung <email address hidden>   Tue, 19 Oct 2010 11:57:41 +0200

Available diffs

Superseded in natty-release on 2010-10-19
Obsolete in maverick-release on 2013-03-05
eclipse (3.5.2-6ubuntu1) maverick; urgency=low

  * debian/extra/eclipse:
    - no appmenu for eclipse (thanks bratsche) (LP: #613119)
 -- Didier Roche <email address hidden>   Thu, 30 Sep 2010 17:52:31 +0200

Available diffs

Superseded in maverick-release on 2010-09-30
eclipse (3.5.2-6) unstable; urgency=low

  [ Adnan Hodzic ]
  * Fixed libjetty-java and sat4j build/regular dependency versioning
    (see #591140)

  [ Niels Thykier ]
  * Added patch for pde-build to make it stop writing to ~/workspace,
    which is not acceptable during autobuilds. (Closes: #592526)
  * Use mh_clean for cleaning up after the maven repo helper, instead
    of using a homemade clean rule.
  * Bumped Standards-Versions to 3.9.1 - no changes required.
 -- Benjamin Drung <email address hidden>   Fri, 20 Aug 2010 12:56:39 +0200

Available diffs

Superseded in maverick-release on 2010-08-21
eclipse (3.5.2-5) unstable; urgency=medium

  [ Benjamin Drung ]
  * Fix pattern matching to detect correct architecture.

  [ Niels Thykier ]
  * Move operations on arch:all packages to its own make target. Fixes FTBFS on
    all buildds.
 -- Benjamin Drung <email address hidden>   Tue, 29 Jun 2010 22:00:44 +0200

Available diffs

Superseded in maverick-release on 2010-06-29
eclipse (3.5.2-4) unstable; urgency=low

  [ Niels Thykier ]
  * Added menu entry for the Debian menu.
  * Moved a lot of arch-indep plugins into eclipse-platform-data.
  * Backported fix for poor tooltip colors with certain themes.
    (Closes: #582302, LP: #540332)
  * Backported fix for hover text visability problem.
  * Corrected a format issue in debian/copyright.
  * Removed depends on cvs for eclipse-plugin-cvs, it is not needed.
    (LP: #592508)
  * Removed Depends on JRE for libequinox-osgi-java.
  * Added patch to use sat4j 2.2 instead of 2.1 (Closes: #586978)
  * Added recommends on eclipse-pde for eclipse-platform.
    (LP: #593260)
  * Added patch to install the o.e.equinox.concurrent plugin in
    eclipse-platform (Closes: #585178)
  * Bumped (Build-)Depends on libhamcrest-java to 1.1-8 to avoid
    being affected by a regression in libhamcrest-java 1.1-7.

  [ Adnan Hodzic ]
  * Added debian/patches/fix-bashism.patch (Closes: #581099)

  [ Yulia Novozhilova ]
  * Added the Maven POMs for libequinox-osgi.java (LP: #598039)
  * Added a Build-Depends dependency on maven-repo-helper and maven-ant-helper
  * Added missing recommends on libservlet2.5-java for libequinox-osgi-java.

  [ Benjamin Drung ]
  * Bump Standards-Version to 3.9.0 (no changes required).
 -- Benjamin Drung <email address hidden>   Mon, 28 Jun 2010 22:25:42 +0200

Available diffs

Superseded in lucid-updates on 2011-05-06
Deleted in lucid-proposed on 2011-05-07 (Reason: moved to -updates)
eclipse (3.5.2-2ubuntu4.2) lucid-proposed; urgency=low

  * Backported fix for poor tooltip colors with certain themes. (LP: #540332)
  * Backported fix for hover text visability problem.
 -- Niels Thykier <email address hidden>   Fri, 25 Jun 2010 00:43:37 +0200
Superseded in maverick-release on 2010-06-28
eclipse (3.5.2-3) unstable; urgency=low

  [ Benjamin Drung ]
  * Set org.eclipse.swt.browser.XULRunnerPath explicitly. (LP: #546518)
  * Set MOZILLA_FIVE_HOME instead of LD_LIBRARY_PATH and
    org.eclipse.swt.browser.XULRunnerPath (LP: #559229, #553779).
  * Add apport hook to collect more useful data for bug reports.
  * Improve xulrunner path detection to work on Debian and Ubuntu.

  [ Niels Thykier ]
  * Added missing copyright statement about ownership over the Debian
    packaging.
  * Made eclipse use version depends on -jdt and -pde to ensure smoother
    upgrades from older versions.
  * Added reportbug helpers to eclipse-platform and eclipse.
  * Added Recommends on default-jdk | sun-java6-jdk for eclipse-jdt.
    (LP: #576952)
  * Added patch to deal with broken help-menu. (Closes: #576106, LP: #549904)
 -- Benjamin Drung <email address hidden>   Sat, 08 May 2010 23:17:14 +0200

Available diffs

Superseded in lucid-updates on 2010-07-28
Deleted in lucid-proposed on 2010-07-29 (Reason: moved to -updates)
eclipse (3.5.2-2ubuntu4.1) lucid-proposed; urgency=low

  [ Niels Thykier ]
  * Added Recommends on default-jdk | sun-java6-jdk for eclipse-jdt.
    (LP: #576952)
  * Added patch to deal with broken help-menu. (Closes: #576106, LP: #549904)
 -- Benjamin Drung <email address hidden>   Sun, 09 May 2010 00:39:43 +0200
Superseded in maverick-release on 2010-05-09
Obsolete in lucid-release on 2016-10-26
eclipse (3.5.2-2ubuntu4) lucid; urgency=low

  * No source change rebuild to pick up new location of sat4j (LP: #566131).
 -- Benjamin Drung <email address hidden>   Thu, 22 Apr 2010 14:38:12 +0200

Available diffs

Obsolete in karmic-updates on 2013-03-04
Deleted in karmic-proposed on 2013-03-04 (Reason: moved to -updates)
eclipse (3.5.1+repack~1-0ubuntu4) karmic-proposed; urgency=low

  * Backported patch from upstream to fix libpango crashes. (LP: #531376)
  * Backported update site injection. (LP: #460944)
 -- Niels Thykier <email address hidden>   Sat, 27 Mar 2010 23:21:55 +0100
Superseded in lucid-release on 2010-04-22
eclipse (3.5.2-2ubuntu3) lucid; urgency=low

  * Add apport hook to collect more useful data for bug reports.
 -- Benjamin Drung <email address hidden>   Thu, 15 Apr 2010 21:44:52 +0200

Available diffs

Superseded in lucid-release on 2010-04-15
eclipse (3.5.2-2ubuntu2) lucid; urgency=low

  [ Niels Thykier ]
  * Added missing copyright statement about ownership over the Debian packaging.

  [ Benjamin Drung ]
  * Set MOZILLA_FIVE_HOME instead of LD_LIBRARY_PATH and
    org.eclipse.swt.browser.XULRunnerPath (LP: #559229, #553779).
 -- Benjamin Drung <email address hidden>   Tue, 13 Apr 2010 02:12:21 +0200

Available diffs

Superseded in lucid-release on 2010-04-13
eclipse (3.5.2-2ubuntu1) lucid; urgency=low

  * Set org.eclipse.swt.browser.XULRunnerPath explicitly. (LP: #546518)
 -- Benjamin Drung <email address hidden>   Thu, 25 Mar 2010 20:22:03 +0100

Available diffs

Superseded in lucid-release on 2010-03-25
eclipse (3.5.2-2) unstable; urgency=low

  [ Niels Thykier ]
  * Changed section of eclipse packages to devel.
  * Install IJG_README from source dir rather than install dir.
    (Closes: #574619)
  * Added missing replace on eclipse to eclipse-platform-data. (Closes: #574607)
  * Fix broken symlinks in libequinox-osgi-java.
  * Imported ecj-gccmain-java.patch from ecj to add better support for gcj.

  [ Benjamin Drung ]
  * Integrate upstream-eclipse-build-repack.patch from final 0.5.0
    eclipse-build release.

Superseded in lucid-release on 2010-03-24
eclipse (3.5.1+repack~3-0ubuntu2) lucid; urgency=low

  * Rebase to packaging from pkg-java/eclipse (thanks to Niels Thykier):
    + Set a sane file limit for osgi-bundles. (Closes: #558693, LP: #293573)
    + Inject update sites on first run. (LP: #460944)
    + Prevent conflict with swt-gtk's swt packages.
      - Rename our swt packages.
      - Do not install conflicting symlinks/files.
      (Closes: #541638, LP: #491880)
    + Imported patch from Fedora that fixes seg. faults in libpango.
      (LP: #445009)
    + Update manpage. (LP: #494065)
    + Bump Standards-Version to 3.8.4.
  * Re-add versioned dependency on libcommons-el-java, libjetty-java,
    libservlet2.4-java; the packages are now available in Ubuntu.
  * Drop versioned dependency on liblucene2-java and libmx4j-java; they are not
    yet available in Ubuntu.
 -- Benjamin Drung <email address hidden>   Sat, 30 Jan 2010 18:55:04 +0100
Superseded in lucid-release on 2010-01-30
eclipse (3.5.1+repack~3-0ubuntu1) lucid; urgency=low

  * Rebase to packaging from pkg-java/eclipse:
    + Stopped using special hacks and work arounds to find JVMs.
      (Closes: #353360)
      - This removes the need for ~/.eclipse/eclipserc (Closes: #402077)
      - This makes eclipse read eclipse.ini (Closes: #491334)
    + Moved the executable to eclipse-platform from eclipse.
      (Closes: #358594)
    + Put the osgi jar-files into its own separate package. (LP: #102717)
    + Added workaround for gtk problems. (Closes: #552480)
    + Added missing API references. (Closes: #376850)
    + Moved org.eclipse.ant.ui to eclipse-platform. (LP: #477944)
    + Added information about how to create the orig.tar.gz.
      (Closes: #505553)
    + Rewrote symlink script to handle folders that are renamed on different
      archs/builds. (LP: #471859)
    + Move eclipse.ini into /etc (LP: #43162)
  * Drop versioned dependency on libcommons-el-java, libjetty-java,
    libservlet2.4-java; they are not yet available in Ubuntu.
 -- Benjamin Drung <email address hidden>   Tue, 29 Dec 2009 18:48:17 +0100
Superseded in lucid-release on 2009-12-29
eclipse (3.5.1+repack~2-0ubuntu1) lucid; urgency=low

  * Add support for additional architectures, fix the jni bindings
    for 64bit ports.

 -- Matthias Klose <email address hidden>   Sun, 01 Nov 2009 11:13:18 +0100
Superseded in karmic-updates on 2010-05-26
Deleted in karmic-proposed on 2010-05-27 (Reason: moved to -updates)
eclipse (3.5.1+repack~1-0ubuntu3) karmic-proposed; urgency=low

  * Add build-dependency on libxt-dev (now exposed by correct
    swt-gtk build). LP: #463732.

 -- Matthias Klose <email address hidden>   Fri, 30 Oct 2009 10:57:31 +0100
Superseded in karmic-proposed on 2009-10-30
eclipse (3.5.1+repack~1-0ubuntu2) karmic-proposed; urgency=low

  * Build swt-gtk with -DJNI64 on 64bit archs (bad assumption about
    uname -i output). LP: #463732.

 -- Matthias Klose <email address hidden>   Thu, 29 Oct 2009 21:37:11 +0100
Superseded in lucid-release on 2009-11-02
Obsolete in karmic-release on 2013-03-04
eclipse (3.5.1+repack~1-0ubuntu1) karmic; urgency=low

  * Update packaging from pkg-java/eclipse (including patches to build
    on sparc).
  * Add patches to build on armel and ia64. LP: #449766.
  * Build used linux-gtk configurations only.
  * Set GDK_NATIVE_WINDOWS on startup. LP: #458703.

 -- Matthias Klose <email address hidden>   Sun, 25 Oct 2009 15:41:22 +0100
Superseded in karmic-release on 2009-10-25
eclipse (3.5.1-0ubuntu7) karmic; urgency=low

  * Install org.eclipse.update.core.linux on x86 (LP: #454819).
  * Add missing conflict between libequinox-osgi-java and older
    eclipse-rcp (LP: #455023).
  * eclipse-jdt depends on eclipse-plugin-cvs.

 -- Benjamin Drung <email address hidden>   Mon, 19 Oct 2009 18:18:42 +0200

Available diffs

Superseded in karmic-release on 2009-10-19
eclipse (3.5.1-0ubuntu6) karmic; urgency=low

  * Correct misspelt package in debian/rules, too (LP: #454616).

 -- Benjamin Drung <email address hidden>   Sun, 18 Oct 2009 14:43:05 +0200

Available diffs

Superseded in karmic-release on 2009-10-18
eclipse (3.5.1-0ubuntu5) karmic; urgency=low

  * Correct misspelt package name to libequinox-osgi-java (LP: #454251).

 -- Benjamin Drung <email address hidden>   Sun, 18 Oct 2009 00:27:26 +0200

Available diffs

Superseded in karmic-release on 2009-10-18
eclipse (3.5.1-0ubuntu4) karmic; urgency=low

  * Move arch independent rules into arch dependent rules (LP: #452272).

 -- Benjamin Drung <email address hidden>   Sat, 17 Oct 2009 19:33:09 +0200

Available diffs

Superseded in karmic-release on 2009-10-17
eclipse (3.5.1-0ubuntu3) karmic; urgency=low

  * Configure eclipse properly for Software Updates (LP: #438414).
  * Split osgi jars in its own package (LP: #102717).
  * Add source jar files to packages.

 -- Benjamin Drung <email address hidden>   Thu, 15 Oct 2009 02:24:07 +0200

Available diffs

Superseded in karmic-release on 2009-10-15
eclipse (3.5.1-0ubuntu2) karmic; urgency=low

  * New snapshot from eclipse-build.
    - Apply GTK 2.18 z-order patch (LP: #443004).
  * Remove unversioned swt.jar link (LP: #446155).
  * Add wrapper script for setting LD_LIBRARY_PATH (LP: #445842).
  * Call remove with -f to fix FTBFS on powerpc.

 -- Benjamin Drung <email address hidden>   Fri, 09 Oct 2009 21:41:39 +0200

Available diffs

Superseded in karmic-release on 2009-10-09
eclipse (3.5.1-0~ubuntu1) karmic; urgency=low

  * Fix build failure on lpia.
  * For anything else kudos to the eclipse-team.

Available diffs

Superseded in karmic-release on 2009-10-06
eclipse (3.4.1-1) unstable; urgency=low

  * Build for unstable.

Available diffs

Superseded in karmic-release on 2009-09-10
eclipse (3.4.1-0ubuntu2) karmic; urgency=low

  * debian/rules
    - Replace occurances of default-java with java-6-openjdk. Fixes FTBFS.

 -- Onkar Shinde <email address hidden>   Tue, 14 Jul 2009 07:48:05 +0530

Available diffs

Superseded in karmic-release on 2009-07-14
eclipse (3.4.1-0ubuntu1) karmic; urgency=low

  * Fix build dependencies.
  * Disable building the -gcj packages (not updated for 3.4.x).
  * TODO's before releasing with a distribution:
    - Clean tarball (no binaries included, no third party libs included).
    - Add OSGi information to required build dependencies.
    - Build using dependencies from the distribution repository.
    - Depend on the third party libraries shipped with the distribution,
      don't include the copies included in eclipse.
    - Disable the eclipse updater for components shipped with the distribution.

 -- Matthias Klose <email address hidden>   Sun, 28 Jun 2009 12:18:44 +0200

Available diffs

Superseded in karmic-release on 2009-06-28
Obsolete in jaunty-release on 2013-02-28
eclipse (3.2.2-5ubuntu3) jaunty; urgency=low

  * no changes upload for nss/nspr SONAME mini-transition

 -- Alexander Sack <email address hidden>   Mon, 12 Jan 2009 16:21:46 +0100

Available diffs

Superseded in jaunty-release on 2009-01-12
Obsolete in intrepid-release on 2013-02-20
Obsolete in hardy-release on 2015-04-24
eclipse (3.2.2-5ubuntu2) hardy; urgency=low

  * Add libxul0d to eclipse dependencies. LP: #199271.

 -- Emilio Pozuelo Monfort <email address hidden>   Sun, 09 Mar 2008 18:14:15 +0100
Superseded in hardy-release on 2008-03-09
eclipse (3.2.2-5ubuntu1) hardy; urgency=low

  [ Flávio Martins ]
  * Merge from Debian unstable. Remaining Ubuntu changes:
    - Change maintainer to MOTU in debian/control.in and debian/control
    - Regenerated debian/control for Ubuntu.
  * Build-depend on libxul-dev instead of firefox-dev. Closes LP: #191586
  * Closes LP: #183137 LP: #67858

  [ Emilio Pozuelo Monfort ]
  * debian/control{.in}:
    - Move eclipse-source from eclipse's Depends to Suggests. LP: #67862
  * Commented out icedtea in debian/extra/java_home, since it doesn't work
    and makes eclipse not start if the user has icedtea installed.

 -- Emilio Pozuelo Monfort <email address hidden>   Mon, 03 Mar 2008 16:40:56 +0100
Superseded in hardy-release on 2008-03-03
eclipse (3.2.2-4ubuntu1) hardy; urgency=low

  * Merge from debian unstable, remaining changes:
    - Change maintainer to MOTU in debian/control.in and debian/control
    - Regenerated debian/control for Ubuntu.

Superseded in hardy-release on 2007-11-28
Obsolete in gutsy-release on 2011-09-16
eclipse (3.2.2-3ubuntu3) gutsy; urgency=low

  * Replace ecj-bootstrap-gcj with ecj-gcj in eclipse-gcj's Depends.

 -- Steve Kowalik <email address hidden>   Fri, 14 Sep 2007 17:34:23 +1000
Superseded in gutsy-release on 2007-09-14
eclipse (3.2.2-3ubuntu2) gutsy; urgency=low

  * In eclipse-awt-libpath.dpatch added paths to fix ppc build.
    (LP: #138498)
  * Fix build on lpia. (LP: #138497)
  * Move to gcj-4.2.

 -- Flavio Martins <email address hidden>   Sun, 09 Sep 2007 21:20:21 +0100
Superseded in gutsy-release on 2007-09-12
eclipse (3.2.2-3ubuntu1) gutsy; urgency=low

  * In debian/control and debian/rules change from xulrunner to firefox
  * Set distribution name to Ubuntu in debian/rules
  * Change maintainer to MOTU in debian/control.in and debian/control

Superseded in gutsy-release on 2007-09-09
eclipse (3.2.2-1) unstable; urgency=low

  [ Michael Koch ]
  * Sparc build fixes.
  * debian/extra/java_home: Added paths for SUN JDK 6.
    Closes: #415712, #418877.
  * debian/rules: Don't force empty bootclasspath.
  * lintian/*: fixed lintian warnings for eclipse 3.2.2.

 -- Emmet Hikory <email address hidden>   Tue,  12 Jun 2007 15:13:32 +0100
Superseded in gutsy-release on 2007-06-12
Obsolete in feisty-release on 2009-08-20
eclipse (3.2.2-0ubuntu3) feisty; urgency=low

  [ Michael Koch ]
  * Sparc build fixes.

 -- Matthias Klose <email address hidden>   Fri,  6 Apr 2007 16:46:23 +0200
Obsolete in edgy-updates on 2008-06-19
eclipse (3.2.1-0ubuntu3) edgy-updates; urgency=low

  [ SRU #68380 ]
  * Upload to edgy-updates.

 -- Matthias Klose <email address hidden>   Mon,  2 Apr 2007 11:07:37 +0200
Superseded in feisty-release on 2007-04-10
eclipse (3.2.2-0ubuntu2) feisty; urgency=low

  [ Michael Koch ]
  * Added debian/patches/eclipse-add-ppc64-sparc64-s390-s390x.dpatch, which
    adds support for ppc64, sparc, sparc64, s390 and hppa.
  * debian/rules: Added support for unofficial ports.
  * debian/control.in: Added build-dependency on zip.

  [ Matthias Klose ]
  * Update the platform patch for 3.2.2.
  * On ia64, skip some jar files for native compilation to avoid ICEs.

  [ Vladimír Lapáček ]
  * Fixed disable-junit4-apt patch for ppc.

 -- Vladimír Lapáček <email address hidden>   Sun,  1 Apr 2007 14:17:45 +0200
Superseded in feisty-release on 2007-04-01
eclipse (3.2.2-0ubuntu1) feisty; urgency=low

  * New upstream release
  * Updated debian/rules for the new upstream
  * Added com.ibm.icu.source plugin to satisfy dependencies
  * Update junit4 patch for the new upstream
  * Updated the eclipse-ecj-gcj patch from Fedora

 -- Vladimír Lapáček <email address hidden>   Thu,  8 Mar 2007 08:28:48 -0500
Deleted in edgy-proposed on 2008-01-28 (Reason: moved to -updates)
eclipse (3.2.1-0ubuntu2) edgy-proposed; urgency=low

  [ SRU #68380 ]
  * debian/control.in: eclipse-gcj: Depend on eclipse.
  * debian/rules: Reenable 64bit build patches. Ubuntu #68053.

 -- Matthias Klose <email address hidden>   Fri,  8 Dec 2006 14:06:07 +0100
Superseded in feisty-release on 2007-03-23
eclipse (3.2.1-2ubuntu1) feisty; urgency=low

  * Merge with Debian unstable; remaining changes:
    - Regenerated control file.

Superseded in feisty-release on 2006-12-13
eclipse (3.2.1-1ubuntu1) feisty; urgency=low

  * Merge with Debian unstable.

Superseded in feisty-release on 2006-12-06
Obsolete in edgy-release on 2008-06-19
eclipse (3.2.1-0ubuntu1) edgy; urgency=low

  [ Michael Koch ]
  * New upstream version.
    - Added debian/patches/eclipse-disable-junit4-apt.dpatch to disable
      JUnit4 support.
    - Added debian/patches/eclipse-tomcat55.dpatch,
      debian/patches/eclipse-tomcat55-build.dpatch,
      debian/patches/eclipse-webapp-tomcat55.dpatch and
      debian/patches/eclipse-webapp-tomcat55-newarches.dpatch to add support
      for tomcat 5.5.
    - Added debian/patches/eclipse-jsch.dpatch to use the JSch version
      from Debian.
    - Removed debian/patches/eclipse-tomcat5.dpatch. Obsoleted by tomcat5.5
      patches.
    - Updated debian/patches/eclipse-libswt-xulrunner.dpatch to apply cleanly.
    - Removed debian/patches/eclipse-java-model-cache.dpatch.
      Implemented upstream.
    - Removed debian/patches/eclipse-heapstatus.dpatch. Implemented upstream.
    - Updated debian/patches/eclipse-fileinitializer.dpatch,
      debian/patches/eclipse-updatehomedir.dpatch,
      debian/patches/eclipse-javadoc-bootclasspath.dpatch,
      debian/patches/eclipse-gnuformatterjdtui.dpatch,
      debian/patches/eclipse-disable-motif.dpatch and
      debian/patches/eclipse-libswt-enableall.dpatch to apply to new upstream.
    - libswt3.2-gtk-gcj.install, libswt3.2-gtk-gcj.postinst,
      libswt3.2-gtk-gcj.postrm, libswt3.2-gtk-java.install,
      libswt3.2-gtk-jni.dirs, libswt3.2-gtk-jni.install:
      Moved over from the respective files from 3.1.x.
    - libswt3.1-gtk-gcj.install, libswt3.1-gtk-gcj.postrm,
      libswt3.1-gtk-gcj.postinst, libswt3.1-gtk-java.install,
      libswt3.1-gtk-jni.dirs, libswt3.1-gtk-jni.install: Removed.
    - debian/rules: Adjusted list of license files to delete.
      (Thanks to Vladimir Lapacek for patches for Tomcat 5.5 integration)
  * extra/package-links.txt, extra/links.txt: Link tomcat 5.5 jars.
  * debian/rules: Changed list of patches to apply. Updated to version numbers.
  * debian/extra/ecj-gcj.1, debian/extra/ecj-java.1: Fixed manpage name.
  * debian/control.in: Added new meta package eclipse-gcj for native eclipse
    users.
  * Moved all files to /usr/lib/eclipse to make all plugins work.
  * debian/control.in: eclipse-jdt-common, eclipse-pde-common,
    eclipse-platform-common, eclipse-rcp-common: Removed.
  * Build icu4j as a eclipse plugin.

  [ Matthias Klose ]
  * Build-depend on java-gcj-compat-dev (>> 1.0.65-4), remove explicit build
    dependency on ecj-bootstrap-gcj.
  * Don't build ecj again, just use the system one.
  * Don't build the eclipse-ecj and eclipse-ecj-gcj packages anymore.
  * Use java-gcj-compat-dev to compile the jar files to native code
    and register them.
  * debian/patches/eclipse-libswt-mozilla.dpatch: Update.
  * debian/rules: Apply eclipse-libswt-mozilla-profiles when building
    with mozilla.
  * debian/rules: Fix libswt-gtk.jar symlink.
  * Build swt bindings with -O2.
  * debian/patches/eclipse-libswt-xpcomgcc4.dpatch: New, taken from FC.
  * debian/patches/eclipse-libswt-firefox.dpatch: Updated from FC.
  * debian/patches/eclipse-libswt-firefox2.dpatch: New, taken from FC.
  * debian/rules: Uses bashisms, set SHELL.
  * Speed up native build on multiprocessor machines.
  * debian/extras/eclipse.sh: Remove mozilla error dialog.
  * debian/control.in: Let eclipse recommend eclipse-gcj.
  * debian/copyright: Update.

  [ Vladimir Lapacek ]
  * Build jsch as a eclipse plugin.

  [ Stephan Michels ]
  * Added "lib" prefix to the links of the tomcat plugin in package-links.txt
  * Ensured that the directories exist before links were created
  * Converted native presentation patch to 3.2
  * Show error dialog only if the mozilla/firefox wasn't found.
  * Updated updatehomedir patch from Fedora's repository

 -- Matthias Klose <email address hidden>   Sun, 22 Oct 2006 18:29:02 +0200
Superseded in edgy-release on 2006-10-23
eclipse (3.1.2-3ubuntu1) edgy; urgency=low

  * Synchronize with Debian experimental.

Superseded in edgy-release on 2006-08-15
eclipse (3.1.2-2ubuntu1) edgy; urgency=low

  * Synchronize with Debian.
  * Build from current SVN repository.

  [ Michael Koch ]
  * debian/rules: Added support to build with xulrunner. Made it the default.
    Closes: #352184.
  * debian/patches/eclipse-libswt-xulrunner.dpatch: New file.
  * debian/control.in: libswt3.1-gtk-java: Make @MOZILLA_DEP@ a Recommends.
    libswt3.1-gtk-jni: Make dependencies on GNOME and Mozilla a Recommends.
    Closes: #361696, #368705.
  * debian/control.in: eclipse-platform-common: Added Depends on
    java2-runtime. Closes: #369415.
  * debian/control.in: eclipse-jdt-common: Don't Depends on eclipse-jdt.
    Closes: #375908.
  * debian/control.in: libswt3.1-gtk-jni: Don't Depends on libswt3.1-gtk-java.
    Closes: #375870.
  * debian/extra/java_home: Added path for SUN JDK from non-free. Thanks to
    Tom Marble. Closes: #368583, #369194, #369950.

  [ Stephan Michels ]
  * debian/extra/ecj-gcj.1, debian/extra/ecj-java.1: Revised.
  * debian/extra/efj.1, debian/eclipse-efj.manpages: New manpage for efj.

Superseded in edgy-release on 2006-07-14
Obsolete in dapper-release on 2011-09-06
eclipse (3.1.2-1ubuntu6) dapper; urgency=low

  * Move swt.jar into the libswt3.1-gtk-java package.
  * Add a new package libswt3.1-gtk-gcj.
  * Merge from Debian unstable:
    - debian/extra/efj.sh: Rewritten to match the code from eclipse.sh
      Closes:  #353555

 -- Matthias Klose <email address hidden>   Mon, 17 Apr 2006 16:04:41 +0200
175 of 84 results