eglibc 2.12.1-0ubuntu8 source package in Ubuntu

Changelog

eglibc (2.12.1-0ubuntu8) maverick-security; urgency=low

  * SECURITY UPDATE: root escalation via LD_AUDIT DST expansion.
    - debian/patches/any/dst-expansion-fix.diff: upstream fixes.
    - CVE-2010-3847
    - debian/patches/any/disable-ld_audit.diff: turn off LD_AUDIT
      for setuid binaries.
 -- Kees Cook <email address hidden>   Thu, 21 Oct 2010 12:45:24 -0700

Upload details

Uploaded by:
Kees Cook on 2010-10-22
Uploaded to:
Maverick
Original maintainer:
Ubuntu Developers
Component:
main
Architectures:
any
Section:
libs
Urgency:
Low Urgency

See full publishing history Publishing

Series Pocket Published Component Section

Downloads

File Size MD5 Checksum
eglibc_2.12.1.orig.tar.gz 22.5 MiB 99637e034aed7ddfb6056715e69d8e19
eglibc_2.12.1-0ubuntu8.diff.gz 833.8 KiB c6042da17e1f12b45ffae2f9b12abdc3
eglibc_2.12.1-0ubuntu8.dsc 2.9 KiB cdc98ab274986ec3ecc5cb89f1cecba8

View changes file

Binary packages built by this source

eglibc-source: Embedded GNU C Library: sources

 This package contains the sources and patches which are needed to
 build eglibc.

glibc-doc: Embedded GNU C Library: Documentation

 Contains The GNU C Library Reference manual in info and html format
 as well as the man pages for libpthread functions and the complete
 GNU C Library ChangeLog.

libc-bin: Embedded GNU C Library: Binaries

 This package contains utility programs related to the GNU C Library.
 .
  * catchsegv: catch segmentation faults in programs
  * getconf: query system configuration variables
  * getent: get entries from administrative databases
  * iconv, iconvconfig: convert between character encodings
  * ldd, ldconfig: print/configure shared library dependencies
  * locale, localedef: show/generate locale definitions
  * rpcinfo: report RPC information
  * tzselect, zdump, zic: select/dump/compile time zones

libc-dev-bin: No summary available for libc-dev-bin in ubuntu natty.

No description available for libc-dev-bin in ubuntu natty.

libc6: Embedded GNU C Library: Shared libraries

 Contains the standard libraries that are used by nearly all programs on
 the system. This package includes shared versions of the standard C library
 and the standard math library, as well as many others.

libc6-amd64: GNU C Library: 64bit Shared libraries for AMD64

 This package includes shared versions of the standard C library and the
 standard math library, as well as many others. This is the 64bit version
 of the library, meant for AMD64 systems.

libc6-dbg: No summary available for libc6-dbg in ubuntu natty.

No description available for libc6-dbg in ubuntu natty.

libc6-dev: Embedded GNU C Library: Development Libraries and Header Files

 Contains the symlinks, headers, and object files needed to compile
 and link programs which use the standard C library.

libc6-dev-amd64: GNU C Library: 64bit Development Libraries for AMD64

 Contains the symlinks and object files needed to compile and link programs
 which use the standard C library. This is the 64bit version of the
 library, meant for AMD64 systems.

libc6-dev-i386: GNU C Library: 32-bit development libraries for AMD64

 Contains the symlinks and object files needed to compile and link programs
 which use the standard C library. This is the 32bit version of the
 library, meant for AMD64 systems.

libc6-dev-ppc64: GNU C Library: 64bit Development Libraries for PowerPC64

 Contains the symlinks and object files needed to compile and link programs
 which use the standard C library. This is the 64bit version of the
 library, meant for PowerPC64 systems.

libc6-i386: No summary available for libc6-i386 in ubuntu natty.

No description available for libc6-i386 in ubuntu natty.

libc6-pic: Embedded GNU C Library: PIC archive library

 Contains an archive library (ar file) composed of individual shared objects.
 This is used for creating a library which is a smaller subset of the
 standard libc shared library. The reduced library is used on the Debian
 boot floppies. If you are not making your own set of Debian boot floppies
 using the `boot-floppies' package, you probably don't need this package.

libc6-ppc64: No summary available for libc6-ppc64 in ubuntu natty.

No description available for libc6-ppc64 in ubuntu natty.

libc6-prof: No summary available for libc6-prof in ubuntu natty.

No description available for libc6-prof in ubuntu natty.

libc6-udeb: Embedded GNU C Library: Shared libraries - udeb

 Contains the standard libraries that are used by nearly all programs on
 the system. This package includes shared versions of the standard C library
 and the standard math library, as well as many others.
 .
 This package contains a minimal set of libraries needed for the Debian
 installer. Do not install it on a normal system.

libc6-xen: GNU C Library: Shared libraries [Xen version]

 Contains the standard libraries that are used by nearly all programs on
 the system. This package includes shared versions of the standard C
 library and the standard math library, as well as many others.
 .
 This set of libraries is optimized for the Xen hypervisor, and will be
 selected instead when running under Xen.

libnss-dns-udeb: GNU C Library: NSS helper for DNS - udeb

 Contains the standard libraries that are used by nearly all programs on
 the system. This package includes shared versions of the standard C library
 and the standard math library, as well as many others.
 .
 This package contains the DNS NSS helper needed for the Debian installer.
 Do not install it on a normal system.

libnss-files-udeb: GNU C Library: NSS helper for files - udeb

 Contains the standard libraries that are used by nearly all programs on
 the system. This package includes shared versions of the standard C library
 and the standard math library, as well as many others.
 .
 This package contains the files NSS helper needed for the Debian installer.
 Do not install it on a normal system.

nscd: Embedded GNU C Library: Name Service Cache Daemon

 A daemon which handles passwd, group and host lookups
 for running programs and caches the results for the next
 query. You should install this package only if you use
 slow Services like LDAP, NIS or NIS+