wrong usage of find(1) in update-mozilla-thunderbird-chrome

Bug #27167 reported by Christian Kujau on 2005-12-15
10
Affects Status Importance Assigned to Milestone
enigmail (Ubuntu)
Medium
Unassigned

Bug Description

as happened before with other packages update-mozilla-thunderbird-chrome (which
is called by the postinst routine of mozilla-thunderbird-enigmail) does also use
"-name" before "-maxdepth":

--- /usr/sbin/update-mozilla-thunderbird-chrome.orig 2005-12-15
23:10:45.777811536 +0100
+++ /usr/sbin/update-mozilla-thunderbird-chrome 2005-12-15 23:11:47.052496368 +0100
@@ -72,7 +72,7 @@
 # previously packaged extensions):
 # remove those that are symlinks pointing to nowhere
 # and remove those that are directory and are in defaults/profile/extensions
-for f in `find ${LIBDIR}/extensions/ -name '{*}' -maxdepth 1`; do
+for f in `find ${LIBDIR}/extensions/ -maxdepth 1 -name '{*}'`; do
     if [ -L $f ] && [ ! -e $f ]; then
         rm ${RM_FLAGS} -f $f
     elif [ ! -L $f ] && [ -d $f ] && [ -d
${LIBDIR}/defaults/profile/extensions/`basename $f` ]; then
@@ -89,7 +89,7 @@
     fi
 done
 # create symlinks that are not already there
-for f in `find ${LIBDIR}/defaults/profile/extensions/ -name '{*}' -maxdepth 1`; do
+for f in `find ${LIBDIR}/defaults/profile/extensions/ -maxdepth 1 -name '{*}'`; do
     [ "${VERBOSE}" ] && echo "W: ${f} should be in ${LIBDIR}/extensions/" >&2
     if [ ! -e ${LIBDIR}/extensions/`basename $f` ]; then
         ln -s $f ${LIBDIR}/extensions
@@ -123,7 +123,7 @@
 chmod 0644 ${VARDIR}/extensions/installed-extensions.txt

 if [ "$VERBOSE" ]; then
- for f in `find ${LIBDIR}/extensions/ -name '{*}' -maxdepth 1`; do
+ for f in `find ${LIBDIR}/extensions/ -maxdepth 1 -name '{*}'`; do
         if ! grep `basename $f` ${VARDIR}/extensions/installed-extensions.txt
2>&1 > /dev/null; then
            echo "W: `basename $f` not in
${VARDIR}/extensions/installed-extensions.txt" >&2

thanks,
Christian.

Dennis Kaarsemaker (dennis) wrote :

*** Bug 27168 has been marked as a duplicate of this bug. ***

Adam Conrad (adconrad) wrote :

update-mozilla-thunderbird-chrome is obsolete as of tbird 1.5, and is no longer used by enigmail.

Changed in enigmail:
status: Unconfirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.