Segfault when Startings Wings3d

Bug #62145 reported by Simon Wittber on 2006-09-24
66
Affects Status Importance Assigned to Milestone
erlang (Ubuntu)
Medium
Unassigned

Bug Description

I'm running Edgy Eft.

When starting Wings3d (version 0.98.32b-1) erlang (version 1:11.b.1-1) segfaults.

This is the first time I've tried to run Wings3d on a SMP system.

Simon Wittber (simonwittber) wrote :

I can confirm this problem, allthough i do not use an SMP system.

Philip Belemezov (phible) wrote :

I can confirm this on amd64 with Edgy (final).

I can confirm this too. On AMD64 non-SMP. The problems lies in libsdl-erlang and not in Wings3D.

If you run any samples in libsdl-erlang, you get a segfault:

neumann@Silvester:/usr/share/doc/libsdl-erlang/examples$ erl
Erlang (BEAM) emulator version 5.5.1 [source] [64-bit] [async-threads:0] [kernel-poll:false]

Eshell V5.5.1 (abort with ^G)
1> l(testglutless).
{error,nofile}
2> l(testglutess).
{module,testglutess}
3> testglutess:go().
Command:68:SDL_GL_SetAttributeFunc: ok
Command:36:SDL_SetVideoModeFunc: ok
Command:105:SDL_EventStateFunc: ok
Command:105:SDL_EventStateFunc: ok
Command:105:SDL_EventStateFunc: ok
Command:470:glViewport: ok
Command:354:glMatrixMode: ok
Command:337:glLoadIdentity: ok
Command:364:glOrtho: ok
Command:354:glMatrixMode: ok
Command:337:glLoadIdentity: ok
Command:256:glEnable: ok
Command:244:glDepthFunc: ok
Command:212:glClearColor: ok
Command:210:glClear: ok
Command:219:glColor3fv: ok
Command:624:gluNewTess: ok
Command:643:gluTessCallback: Segmentation fault

Partial backtrace in the driver:

#0 0x00002aaaab2121ac in eglu_tessCallback ()
   from /usr/lib/erlang/lib/esdl-0.94.1025/priv/sdl_driver.so
#1 0x00002aaaab209a18 in sdl_get_temp_buff ()
   from /usr/lib/erlang/lib/esdl-0.94.1025/priv/sdl_driver.so
#2 0x000000000044f3a0 in erts_port_control ()
....

I can confirm the problem lies in libsdl-erlang. If you try to compile libsdl-erlang after getting the source with apt-get source, you'll notice that it doesn't seem to be compatible with the installed erlang version.
I solved the problem by installing a debian package with a new version of libsdl-erlang from here:
http://packages.debian.org/unstable/libs/libsdl-erlang

I think the current version could be integrated unmodified in Ubuntu to fix the problem.

That's exactly what Sergei Golovan from Erlang Packagers has told me. libsdl-erlang should be updated.

Changed in erlang:
status: Unconfirmed → Confirmed
Gabriel Bauman (gabrielbauman) wrote :

Confirmed on Edgy.

Wings3D on AMD64 edgy

Rafe Magnuson (rafe) wrote :

Confirmed again.

Edgy on an IBM T40 laptop

Incidentally I ran this same build of Wings3D on windows and it crashed with similar conditions, though I unfortunately dont have the bug report any longer.

-R

Kaptain Chaos (kaptain-chaos) wrote :

erlang-base crash when starting Wings 3D

Hans L (thehans) wrote :

confirmed yet again.

Has anyone found a workaround? Some other way of installing it to get it running?

Josh X (jw478) wrote :

In order to get Wings3D running, just do what Jonathan and Francois-Denis said: update libsdl-erlang.

Go to
http://packages.debian.org/unstable/libs/libsdl-erlang

and scroll down to find the appropriate download for your architecture. Download the .deb file, and install. Easy as that.

(You will get a warning that an older, better-supported version is available.)

mundi (j-mwill) wrote :

/var/crash/_usr_lib_erlang_erts-5.5.1_bin_beam.1000.crash

Slogger (slogger) wrote :

I get this error also. :(

Slogger (slogger) wrote :

stated fix works perfectly and takes 2 seconds, tho :)

>
> Go to
> http://packages.debian.org/unstable/libs/libsdl-erlang
>
> and scroll down to find the appropriate download for your architecture.
> Download the .deb file, and install. Easy as that.
>
> (You will get a warning that an older, better-supported version is
> available.)
>
>

I tried it too, it works !!!!

Thanks !!!

Ralph Janke (txwikinger) wrote :

I believed this is fixed in hardy BETA.

I started wings3d without any trouble. Could please someone who had the trouble confirm that this does not occur in Hardy?

Thanks

Changed in erlang:
assignee: nobody → txwikinger
status: Confirmed → Incomplete
Ralph Janke (txwikinger) wrote :

We are closing this bug report because it lacks the information we need to investigate that the problem has not been fixed already, as described in the previous comments. Please reopen it if you can give us the missing information, and don't hesitate to submit bug reports in the future. To reopen the bug report you can click on the current status, under the Status column, and change the Status back to "New". Thanks again!

Changed in erlang:
assignee: txwikinger → nobody
status: Incomplete → Fix Released
Vik (vik-catalyst) wrote :

I can confirm that running wings3d 0.98.36-5 with libsdl-erlang 0.96.0626-7 under the current Ubuntu 8.04.1 Hardy release results in the following crash:

$ wings3d
Erlang (BEAM) emulator version 5.6.1 [source] [smp:2] [async-threads:0] [kernel-poll:false]

Eshell V5.6.1 (abort with ^G)
1> Trying OpenGL modes
  [{buffer_size,32},
   {depth_size,32},
   {stencil_size,8},
   {accum_size,16}]
  [{buffer_size,24},
   {depth_size,32},
   {stencil_size,8},
   {accum_size,16}]
  [{buffer_size,24},
   {depth_size,24},
   {stencil_size,8},
   {accum_size,16}]
Actual: RGBA: 8 8 8 0 Depth: 24 Stencil: 8 Accum: 16 16 16 16
Segmentation fault

I am happy to post additional info, just clue me in. I'll add myself to the watch list.

Vik :v)

Changed in erlang:
status: Fix Released → New
RJ Clay (rjclay) wrote :

For the issue found again in the current version (Hardy), please try to obtain a backtrace following the instructions at http://wiki.ubuntu.com/DebuggingProgramCrash and upload the backtrace (as an attachment) to the bug report. This will greatly help us in tracking down the problem.

Changed in erlang:
status: New → Incomplete
Vik (vik-catalyst) wrote :

Slight problem: Following the instructions results in the following:

vik@kereru:~/tmp$ gdb wings3d 2>&1 | tee gdb-wings3d.txt
GNU gdb 6.8-debian
Copyright (C) 2008 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law. Type "show copying"
and "show warranty" for details.
This GDB was configured as "i486-linux-gnu"...
"/usr/bin/wings3d": not in executable format: File format not recognized
(gdb)

Yes, I did look at the script file. It uses /usr/bin/erl to launch the application. This too is a script. Not sure what to do from here.

Vik :v)

Daniel T Chen (crimsun) on 2008-09-11
Changed in erlang:
importance: Undecided → Medium
status: Incomplete → Confirmed
Gabriel Bauman (gabrielbauman) wrote :

I can't duplicate this in Intrepid; wings3d no longer crashes on startup and works fine on three machines here. Marking fix released.

If you're reporting a Wings3D crash, don't reopen this one unless the crash prevents you from opening WIngs3D at all. Anything else is a separate issue.

Changed in erlang:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers