Change log for etherboot package in Ubuntu

122 of 22 results
Deleted in precise-release on 2012-02-06 (Reason: (From Debian) RoM; replaced by ipxe; Debian bug #626966)
etherboot (5.4.5) precise; urgency=low

  * etherboot is no longer supported, and has been dropped from Debian.
    Turn this package into a meta package:
    - etherboot depends on ipxe
    - kvm-pxe depends on kvm-ipxe
 -- Serge Hallyn <email address hidden>   Fri, 25 Nov 2011 16:10:18 -0600

Available diffs

Superseded in precise-release on 2011-12-13
Obsolete in oneiric-release on 2015-04-24
etherboot (5.4.4-7ubuntu3) oneiric; urgency=low

  * Remove bnx2 - src/drivers/net/bnx2_fw.h contains binary firmware.
    (LP: #823381) (Closes: #618564)
 -- Serge Hallyn <email address hidden>   Sun, 07 Aug 2011 14:45:14 -0500

Available diffs

Superseded in oneiric-release on 2011-08-09
Obsolete in natty-release on 2013-06-04
Obsolete in maverick-release on 2013-03-05
etherboot (5.4.4-7ubuntu2) maverick; urgency=low

  * Revert back the change "Add kvm-pxe package containing the PXE ROM's
    kvm needs to pxeboot." and drop the etherboot-qemu package to have
    the problem described in LP: #570870 fixed.
  * debian/rules: Prefer "chmod 0644 debian/kvm-pxe/usr/share/qemu/*" to
    "chmod -x $(CURDIR)/debian/kvm-pxe/usr/share/qemu/*" as the first one
    does one of the things that the second one does.

Available diffs

Superseded in maverick-release on 2010-09-09
etherboot (5.4.4-7ubuntu1) maverick; urgency=low

  * Merge from debian unstable, remaining changes:
    - debian/rules: unexport LDFLAGS and CFLAGS to avoid a FTBFS
    - nossp.patch: compile using -fno-stack-protector.
    - debian/control:
      + Added build dependency on grub (grub-legacy is not yet in Ubuntu)
      + Build-Depend on syslinux instead of syslinux-common | syslinux. We need
        /usr/bin/syslinux during build.
  * Dropped changes:
    - Add kvm-pxe package containing the PXE ROM's kvm needs to pxeboot:
      fixed in debian
    - debian/rules: fix the installation directory of the kvm-pxe roms
      to /usr/share/qemu, rather than /usr/share/kvm, LP: #570870: change
      no longer needed as we dropped the change "Add kvm-pxe package containing
      the PXE ROM's kvm needs to pxeboot." as it's fixed in debian
    - Add patch etherboot-5.4.4-e1000-tx-volatile.patch from Fedora
      Taken from https://bugzilla.redhat.com/show_bug.cgi?id=507391
      (LP: #617316): fixed in debian
    - debian/control: Added build dependency on syslinux (syslinux-common
      is not yet in Ubuntu): replaced by the change "Build-Depend
      on syslinux instead of syslinux-common | syslinux. We need
      /usr/bin/syslinux during build."

Available diffs

Obsolete in lucid-updates on 2016-10-26
Deleted in lucid-proposed on 2016-11-01 (Reason: moved to -updates)
etherboot (5.4.4-1ubuntu1.2) lucid-proposed; urgency=low

  * debian/rules: fix the installation directory of the kvm-pxe roms
    to /usr/share/qemu, rather than /usr/share/kvm, LP: #570870
 -- Dustin Kirkland <email address hidden>   Tue, 27 Apr 2010 15:57:56 -0500
Superseded in maverick-release on 2010-09-09
etherboot (5.4.4-1ubuntu3) maverick; urgency=low

  [ Serge Hallyn ]
  * Add patch etherboot-5.4.4-e1000-tx-volatile.patch from Fedora
    Taken from https://bugzilla.redhat.com/show_bug.cgi?id=507391
    (LP: #617316)

  [ Stefano Rivera ]
  * Build-Depend on syslinux instead of syslinux-common | syslinux. We need
    /usr/bin/syslinux during build.
 -- Serge Hallyn <email address hidden>   Fri, 20 Aug 2010 17:40:16 -0500

Available diffs

Superseded in maverick-release on 2010-08-21
etherboot (5.4.4-1ubuntu2) maverick; urgency=low

  * debian/rules: fix the installation directory of the kvm-pxe roms
    to /usr/share/qemu, rather than /usr/share/kvm, LP: #570870
 -- Dustin Kirkland <email address hidden>   Fri, 20 Aug 2010 15:53:46 -0500

Available diffs

Deleted in lucid-proposed on 2010-07-28 (Reason: unverified SRU)
etherboot (5.4.4-1ubuntu1.1) lucid-proposed; urgency=low

  * debian/rules: symlink the kvm-pxe roms to /usr/share/qemu, LP: #570870
 -- Dustin Kirkland <email address hidden>   Mon, 03 May 2010 11:40:08 +0000

Available diffs

Superseded in maverick-release on 2010-08-20
Obsolete in lucid-release on 2016-10-26
etherboot (5.4.4-1ubuntu1) lucid; urgency=low

  * Merge from debian unstable, remaining changes:
    - Add kvm-pxe package containing the PXE ROM's kvm needs to pxeboot.
    - debian/rules: unexport LDFLAGS and CFLAGS to avoid a FTBFS
    - nossp.patch: compile using -fno-stack-protector.
  * Discarded changes:
    - Add quilt to build system. (integrated in Debian)
    - genisoimage.patch: Replace all references to mkisofs to geniosimage.
      (integrated in Debian)
    - virtio.patch: Add virtio-net driver. (integrated upstream)
  * debian/control:
    - Added build dependency on grub (grub-legacy is not yet in Ubuntu)
    - Added build dependency on syslinux (syslinux-common is not yet in Ubuntu)
 -- Fabrice Coutadeur <email address hidden>   Sat, 02 Jan 2010 07:25:53 +0100
Superseded in lucid-release on 2010-01-02
Obsolete in karmic-release on 2013-03-04
etherboot (5.4.3+dfsg-0.2ubuntu2) karmic; urgency=low

  * detect_mtools_4.0.patch: add correct detection of Mtools > 0.4. Patch taken
    from Debian (thanks Stefano Zacchiroli)

 -- Fabrice Coutadeur <email address hidden>   Sat, 10 Oct 2009 07:19:12 +0000
Superseded in karmic-release on 2009-10-10
Obsolete in jaunty-release on 2013-02-28
etherboot (5.4.3+dfsg-0.2ubuntu1) jaunty; urgency=low

  * Merge from debian unstable, remaining changes:
    - Add quilt to build system.
    - Add kvm-pxe package containing the PXE ROM's kvm needs to pxeboot.
    - virtio.patch: Add virtio-net driver.
    - genisoimage.patch: Replace all references to mkisofs to geniosimage.
    - nossp.patch: compile using -fno-stack-protector.

Superseded in jaunty-release on 2008-11-05
Obsolete in intrepid-release on 2013-02-20
etherboot (5.4.3+dfsg-0.1ubuntu2) intrepid; urgency=low

  * Add quilt to build system.
  * Add kvm-pxe package containing the PXE ROM's kvm needs to pxeboot.
  * virtio.patch: Add virtio-net driver.
  * undi-asm.patch: Fix FTBFS caused by toolchain changes.

 -- Soren Hansen <email address hidden>   Fri, 04 Jul 2008 15:22:12 +0200
Superseded in intrepid-release on 2008-07-04
etherboot (5.4.3+dfsg-0.1ubuntu1) intrepid; urgency=low

  * Merge from debian unstable, remaining changes:
    - Replace all references to mkisofs to geniosimage.
    - src/Config: compile using -fno-stack-protector. Fixes FTBFS.
    - Modify maintainer value to match maintainer spec.

Superseded in intrepid-release on 2008-06-20
Obsolete in hardy-release on 2015-04-24
etherboot (5.4.2-1.2ubuntu1) hardy; urgency=low

  * Merge from Debian unstable. Remaining Ubuntu changes:
    - replace all references to mkisofs to genisoimage.
    - src/Config: compile using -fno-stack-protector. Fixes FTBFS
    - Modify Maintainer value to match the DebianMaintainerField specification.

Superseded in hardy-release on 2007-12-11
Obsolete in gutsy-release on 2011-09-16
etherboot (5.4.2-1.1ubuntu2) gutsy; urgency=low

  * replace all references to mkisofs to genisoimage.

 -- Reinhard Tartler <email address hidden>   Thu, 20 Sep 2007 15:19:28 +0200
Superseded in gutsy-release on 2007-09-20
etherboot (5.4.2-1.1ubuntu1) gutsy; urgency=low

  * src/Config: compile using -fno-stack-protector. Fixes FTBFS
  * Modify Maintainer value to match the DebianMaintainerField specification.

 -- Albin Tonnerre <email address hidden>   Fri, 10 Aug 2007 09:16:07 +0200
Superseded in gutsy-release on 2007-08-10
Obsolete in feisty-release on 2009-08-20
etherboot (5.4.2-1.1) unstable; urgency=low

  * NMU
  * Grub's files have moved to /usr/lib, update build process.
    Closes: #393044

 -- Ubuntu Archive Auto-Sync <email address hidden>   Tue,  07 Nov 2006 01:30:47 +0000
Superseded in feisty-release on 2006-11-08
Obsolete in edgy-release on 2008-06-19
etherboot (5.4.2-1) unstable; urgency=low

  * new upstream version
  * mtools version & amd64 dependency fix (closes: #358124, #361230)
  * added contrib/ dir to usr/share/doc (closes: #344856)
  * added grub hack from Robert Millan, thanks (closes: #290521)

 -- Ubuntu Archive Auto-Sync <email address hidden>   Thu,  15 Jun 2006 13:48:08 +0100
Superseded in edgy-release on 2006-06-15
Obsolete in dapper-release on 2011-09-06
Superseded in dapper-release on 2006-02-03
etherboot (5.4.1-1) unstable; urgency=low


  * New upstream release (closes: #325196)
  * amd64 support & gcc-4.0 fixes, 2nd try ;) (closes: #326869, #265919, #319561)

 -- RISKO Gergely <email address hidden>  Thu, 17 Nov 2005 20:06:07 +0100
Obsolete in breezy-release on 2008-03-25
etherboot (5.3.14-1) unstable; urgency=high


  * New upstream release (closes: #290525)
  * amd64 support added (closes: #265919)

 -- RISKO Gergely <email address hidden>  Sat, 19 Mar 2005 21:15:17 +0100
Obsolete in hoary-release on 2008-03-19
etherboot (5.2.5-2) unstable; urgency=low


  * really fix 260744, I'm a moron, sorry.

 -- RISKO Gergely <email address hidden>  Mon,  9 Aug 2004 15:12:29 +0200
Obsolete in warty-release on 2008-01-09
etherboot (5.2.4-2) unstable; urgency=low


  * add dependency on syslinux (closes: #253623)
  * Section: doc added to the doc package

 -- RISKO Gergely <email address hidden>  Thu, 10 Jun 2004 21:48:49 +0200
122 of 22 results