Not all characters sit on the baseline

Bug #3217 reported by Sitsofe Wheeler on 2005-10-16
4
Affects Status Importance Assigned to Milestone
evince (Ubuntu)
Low
Ubuntu Desktop Bugs

Bug Description

(Oh how I long for a bug template)

Description:
Sometimes characters in PDFs do not all sit on the base line. There is a slight pixel vertical misalignment making the lines look messy.

Steps to reproduce the problem:
1. Download http://www.changethis.com/13.SmartPeople/download/?screen=0&action=download_manifesto .
2. Open the saved PDF in evince .
3. Press F5 to leave presentation mode.
4. Set the zoom to 150% and make the window wider.
5. Go to page 2.

Expected results:
The baseline of all characters in the same font to be level.

Actual results:
If you look at the e of the first "The" on the page you will notice that it appears to be lower than "Th". The same goes for the c of "cubicle" on the third line.

Additional information:
This isn't actually an evince bug because xpdf and even acroread have the same problem. However acroread has the option not to use Local Fonts and not using local fonts makes the problem go away. The same problem has been observed in other distros (e.g. OpenSUSE 10) too. GNOME font settings are 96dpi, Smoothing of grayscale and hinting of Medium (the defaults originally picked).

I have only filed it evince because that is where I first saw it and I hope that this will let the bug be moved to its proper home.

Cropped screenshot of evince showing the misaligned baseline problem

Changed in evince:
assignee: nobody → gnome
Sebastien Bacher (seb128) wrote :

Thanks for your bug. Feel free to open a bug on malone if you want a template, but are they useful to describe a bug?

How do I open a bug on malone? See https://launchpad.net/people/sitsofe for further confusion.

Sebastien Bacher (seb128) wrote :

opne http://launchpad.net, click on the "Bugs" tab, put "malonee for the " Jump to bugs in product: " and you have the page for that

Sitsofe Wheeler (sitsofe) wrote :

Thank you.

The template request has been filed as bug #3383

Sitsofe Wheeler (sitsofe) wrote :

I'm using Xgl on an upgraded dapper flight 3 and the rendering in evince 0.5.0-0ubuntu1 is no longer as bad as the previously attached screenshot. I'll have to check to make sure it's not very slightly misaligned now.

Sitsofe Wheeler (sitsofe) wrote :

The baseline is pretty even in Xorg too. There does appear to be a one pixel problem at the bottom of letters which don't normally have decenders though (on the 4th line starting "Am I an idiot?" letters like d,o,O,s,e seem to sit lower than the rest of the line).

Sebastien Bacher (seb128) wrote :

The rendering looks fine on my dapper installation. Does anybody else has an issue with it?

I decided to compare PDF rendering to that of other platforms based on these results I'd say that my recent comment was wrong as other platforms exhibit similar behaviour, thus this bug has been fixed.

Sebastien Bacher (seb128) wrote :

Thank you for the comment, closing as fixed so

Changed in evince:
assignee: gnome → desktop-bugs
status: Unconfirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.