subfolders don't show in 2.8.1

Bug #63797 reported by Nikhil Fernandes on 2006-10-03
28
Affects Status Importance Assigned to Milestone
evolution-exchange
Fix Released
Critical
evolution-data-server (Ubuntu)
High
Ubuntu Desktop Bugs
evolution-exchange (Ubuntu)
Undecided
Unassigned

Bug Description

I don't see subfolders in my inbox, even though I can verify that they exist using web access. All the messages are still there, but they are all in the parent folder.

Michael Smith (enginerd) wrote :

I can confirm that the subfolders are missing in my exchange account. However my messages in the subfolders are not in the main inbox folder. I can only access them through OWA.

Ditto, I had to downgrade evolution, and all dependencies to the 2.8.0 versions.

The attached patch is the change that broke (at least that is my best guess, I haven't double checked it). It might be worth reverting this patch locally in ubuntu packages until things are fixed properly upstream.

John Anderson (john-e-anderson) wrote :

Same problem. My new message sound plays every time it checks now, because I have new messages in a subfolder. So the plugin must be finding these messages on some level anyhow.

Changed in evolution-exchange:
status: Unconfirmed → Confirmed
Nikhil Fernandes (njfernandes) wrote :

My mistake: The messages do not show. However, new messages that should be moved by a rule to the subfolder are not moved at all.

Michael Smith (enginerd) wrote :

Yes i see that same action of messages not being moved.
I also get the sound as received mail but the message is in the subfolder for filters set at the exchange server level.

Changed in evolution-exchange:
status: Unknown → Unconfirmed
Sebastien Bacher (seb128) wrote :

I've forwarded the issue upstream: http://bugzilla.gnome.org/show_bug.cgi?id=360593

Changed in evolution-exchange:
assignee: nobody → desktop-bugs
importance: Undecided → High
Changed in evolution-exchange:
status: Unconfirmed → Confirmed
Sebastien Bacher (seb128) wrote :

This upload fixes the issue:

 evolution-data-server (1.8.1-0ubuntu3) edgy; urgency=low
 .
   * debian/patches/90_from_cvs_fix_exchange_subfolders_listing.patch:
     - patch from CVS, fix subfolders not being listed with exchange
       (Ubuntu: #63797)

Changed in evolution-exchange:
status: Confirmed → Fix Released
Rob Hughes (rob-robhughes) wrote :

I can confirm that the fix works for me. I now have folders again. Thanks.

Changed in evolution-exchange:
status: Unconfirmed → Fix Released
Changed in evolution-exchange:
status: Confirmed → Fix Released
Changed in evolution-exchange:
importance: Unknown → Critical
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.