Change log for evolution-data-server package in Ubuntu

175 of 342 results
Published in disco-release on 2019-01-08
Deleted in disco-proposed (Reason: moved to release)
evolution-data-server (3.30.4-1) unstable; urgency=medium

  * New upstream release
  * Drop obsolete Build-Depends on gnome-common
  * Restore -Wl,-O1 to our LDFLAGS
  * Bump Standards-Version to 4.3.0

 -- Jeremy Bicha <email address hidden>  Mon, 07 Jan 2019 08:21:11 -0500

Available diffs

Superseded in disco-release on 2019-01-08
Deleted in disco-proposed on 2019-01-09 (Reason: moved to release)
evolution-data-server (3.30.3-1) unstable; urgency=medium

  * New upstream release
  * debian/libebackend-1.2-10.symbols: Add new symbols
  * debian/libebook-contacts-1.2-2.symbols: Drop no-longer needed protobuf
    leaked symbols

 -- Jeremy Bicha <email address hidden>  Mon, 10 Dec 2018 10:43:18 -0500
Superseded in disco-release on 2018-12-15
Deleted in disco-proposed on 2018-12-16 (Reason: moved to release)
evolution-data-server (3.30.2-2build1) disco; urgency=medium

  * No-change rebuild for icu soname changes.

 -- Matthias Klose <email address hidden>  Tue, 13 Nov 2018 08:11:43 +0000
Superseded in disco-release on 2018-11-23
Deleted in disco-proposed on 2018-11-24 (Reason: moved to release)
evolution-data-server (3.30.2-2) unstable; urgency=medium

  * Fix postinst script if update-notifier is not installed
    - Thanks Felix Zielcke for the suggested fix (Closes: #911603)

 -- Jeremy Bicha <email address hidden>  Mon, 22 Oct 2018 17:31:43 -0400
Superseded in disco-release on 2018-11-09
Published in cosmic-release on 2018-10-08
Deleted in cosmic-proposed (Reason: moved to release)
evolution-data-server (3.30.1-1build1) cosmic; urgency=medium

  * No change rebuild to import translations in launchpad

 -- Sebastien Bacher <email address hidden>  Mon, 08 Oct 2018 13:00:18 +0200
Superseded in cosmic-release on 2018-10-08
Deleted in cosmic-proposed on 2018-10-10 (Reason: moved to release)
evolution-data-server (3.30.1-1) unstable; urgency=medium

  * New upstream release
  * Update dh_auto_test override for cmake but continue ignoring test
    failures

 -- Jeremy Bicha <email address hidden>  Mon, 24 Sep 2018 10:42:24 -0400

Available diffs

Superseded in cosmic-release on 2018-09-28
Deleted in cosmic-proposed on 2018-09-29 (Reason: moved to release)
evolution-data-server (3.30.0-1) unstable; urgency=medium

  * New upstream release

 -- Jeremy Bicha <email address hidden>  Mon, 03 Sep 2018 17:48:54 -0400

Available diffs

Superseded in cosmic-proposed on 2018-09-04
evolution-data-server (3.29.92-2) unstable; urgency=medium

  * Have libedataserverui1.2-dev depend on libecal1.2-dev (Closes: #907757)

 -- Jeremy Bicha <email address hidden>  Sat, 01 Sep 2018 15:04:46 -0400

Available diffs

Superseded in cosmic-proposed on 2018-09-03
evolution-data-server (3.29.92-1) unstable; urgency=medium

  * New upstream release
  * debian/evolution.install: Install org.gnome.Evolution-alarm-notify.desktop
  * Release to unstable

 -- Jeremy Bicha <email address hidden>  Mon, 27 Aug 2018 05:52:56 -0400

Available diffs

Superseded in cosmic-release on 2018-09-05
Deleted in cosmic-proposed on 2018-09-06 (Reason: moved to release)
evolution-data-server (3.29.90-1) experimental; urgency=medium

  * New upstream development release
  * Update library names for soname bumps
  * Add Breaks/Replaces for evolution-alarm-notify's move from libevolution
  * debian/control.in: Build-Depend on libcanberra-gtk3-dev (>= 0.25)
  * Update symbols files
  * debian/libebook-contacts-1.2-2.symbols: Mark a symbol as optional

 -- Jeremy Bicha <email address hidden>  Fri, 10 Aug 2018 09:34:12 -0400
Published in bionic-updates on 2018-09-24
Deleted in bionic-proposed (Reason: moved to -updates)
evolution-data-server (3.28.5-0ubuntu0.18.04.1) bionic; urgency=medium

  * New upstream release (LP: #1784514)

 -- Jeremy Bicha <email address hidden>  Tue, 31 Jul 2018 10:14:54 -0400
Superseded in cosmic-release on 2018-08-12
Deleted in cosmic-proposed on 2018-08-15 (Reason: moved to release)
evolution-data-server (3.28.5-3ubuntu1) cosmic; urgency=medium

  * debian/libebook-contacts-1.2-2.symbols: Mark a symbol as optional
    since it isn't present in Ubuntu's ppc64el build

Superseded in cosmic-proposed on 2018-07-31
evolution-data-server (3.28.5-2) unstable; urgency=medium

  * Update symbols files for new release

 -- Jeremy Bicha <email address hidden>  Mon, 30 Jul 2018 22:09:40 -0400
Published in trusty-updates on 2018-07-26
Published in trusty-security on 2018-07-26
evolution-data-server (3.10.4-0ubuntu1.6) trusty-security; urgency=medium

  * SECURITY UPDATE: Unexpected STARTTLS downgrade
    - debian/patches/CVE-2016-10727.patch: When a user has setup the STARTTLS
      encryption method, but the server doesn't support it, then an error should
      be shown to the user, instead of using unsecure connection. In
      camel/providers/imapx/camel-imax-server.c
    - CVE-2016-10727

 -- Mike Salvatore <email address hidden>  Wed, 25 Jul 2018 09:55:41 -0400
Published in xenial-updates on 2018-07-26
Published in xenial-security on 2018-07-26
evolution-data-server (3.18.5-1ubuntu1.1) xenial-security; urgency=medium

  * SECURITY UPDATE: Unexpected STARTTLS downgrade
    - debian/patches/CVE-2016-10727.patch: When a user has setup the STARTTLS
      encryption method, but the server doesn't support it, then an error should
      be shown to the user, instead of using unsecure connection. In
      camel/providers/imapx/camel-imax-server.c
    - CVE-2016-10727

 -- Mike Salvatore <email address hidden>  Wed, 25 Jul 2018 09:13:51 -0400
Superseded in bionic-updates on 2018-09-24
Deleted in bionic-proposed on 2018-09-25 (Reason: moved to -updates)
evolution-data-server (3.28.3-0ubuntu0.18.04.1) bionic; urgency=medium

  * New upstream version (lp: #1769637)

 -- Sebastien Bacher <email address hidden>  Thu, 05 Jul 2018 17:34:36 +0200
Superseded in cosmic-release on 2018-07-31
Deleted in cosmic-proposed on 2018-08-01 (Reason: moved to release)
evolution-data-server (3.28.3-0ubuntu1) cosmic; urgency=medium

  * New upstream version (lp: #1769637)

 -- Sebastien Bacher <email address hidden>  Thu, 05 Jul 2018 17:34:36 +0200
Superseded in cosmic-release on 2018-07-05
Deleted in cosmic-proposed on 2018-07-07 (Reason: moved to release)
evolution-data-server (3.28.2-1) unstable; urgency=medium

  * New upstream release (LP: #1769637)

 -- Jeremy Bicha <email address hidden>  Mon, 07 May 2018 08:21:46 -0400
Superseded in cosmic-release on 2018-05-07
Published in bionic-release on 2018-04-11
Deleted in bionic-proposed (Reason: moved to release)
evolution-data-server (3.28.1-1ubuntu1) bionic; urgency=medium

  * Sync with Debian (LP: #1758956). Remaining change:
    - Add transitional evolution-data-server-online-accounts package.
      This can be dropped after Ubuntu 18.04 LTS.

Superseded in bionic-release on 2018-04-11
Deleted in bionic-proposed on 2018-04-13 (Reason: moved to release)
evolution-data-server (3.28.0-2ubuntu2) bionic; urgency=medium

  * No change rebuild for launchpad import

 -- Sebastien Bacher <email address hidden>  Wed, 28 Mar 2018 12:00:53 +0200

Available diffs

Superseded in bionic-release on 2018-03-28
Deleted in bionic-proposed on 2018-03-29 (Reason: moved to release)
evolution-data-server (3.28.0-2ubuntu1) bionic; urgency=medium

  * Sync with Debian (LP: #1758956). Remaining change:
    - Add transitional evolution-data-server-online-accounts package.
      This can be dropped after Ubuntu 18.04 LTS.

Superseded in bionic-release on 2018-03-28
Deleted in bionic-proposed on 2018-03-29 (Reason: moved to release)
evolution-data-server (3.28.0-1ubuntu1) bionic; urgency=medium

  * Sync with Debian (LP: #1752578). Remaining change:
    - Add transitional evolution-data-server-online-accounts package.
      This can be dropped after Ubuntu 18.04 LTS.

Available diffs

Superseded in bionic-release on 2018-03-12
Deleted in bionic-proposed on 2018-03-14 (Reason: moved to release)
evolution-data-server (3.27.90-1ubuntu1) bionic; urgency=medium

  * Sync with Debian (LP: #1752578). Remaining change:
    - Add transitional evolution-data-server-online-accounts package.
      This can be dropped after Ubuntu 18.04 LTS.

Available diffs

Superseded in bionic-release on 2018-03-04
Deleted in bionic-proposed on 2018-03-06 (Reason: moved to release)
evolution-data-server (3.26.5-1ubuntu3) bionic; urgency=medium

  * Lower gnome-shell Conflicts to version in Ubuntu, thanks ricotz!

 -- Jeremy Bicha <email address hidden>  Thu, 15 Feb 2018 15:48:48 -0500
Superseded in bionic-proposed on 2018-02-15
evolution-data-server (3.26.5-1ubuntu2) bionic; urgency=medium

  * Backport patch to build against latest libgweather

Superseded in bionic-proposed on 2018-02-15
evolution-data-server (3.26.5-1ubuntu1) bionic; urgency=medium

  * Sync with Debian. Remaining change:
    - Add transitional evolution-data-server-online-accounts package.
      This can be dropped after Ubuntu 18.04 LTS.

Superseded in bionic-release on 2018-02-16
Deleted in bionic-proposed on 2018-02-17 (Reason: moved to release)
evolution-data-server (3.26.3-1ubuntu1) bionic; urgency=medium

  * Sync with Debian. Remaining change:
    - Add transitional evolution-data-server-online-accounts package.
      This can be dropped after Ubuntu 18.04 LTS.

Superseded in bionic-release on 2017-12-11
Deleted in bionic-proposed on 2017-12-13 (Reason: moved to release)
evolution-data-server (3.26.2.1-1ubuntu3) bionic; urgency=medium

  * Build-depend on libical3-dev | libical-dev (>= 2.0).

 -- Matthias Klose <email address hidden>  Sat, 09 Dec 2017 12:56:46 +0100
Superseded in bionic-proposed on 2017-12-09
evolution-data-server (3.26.2.1-1ubuntu2) bionic; urgency=medium

  * No-change rebuild for libical soname change.

 -- Matthias Klose <email address hidden>  Sat, 09 Dec 2017 11:51:58 +0000
Superseded in bionic-release on 2017-12-10
Deleted in bionic-proposed on 2017-12-11 (Reason: moved to release)
evolution-data-server (3.26.2.1-1ubuntu1) bionic; urgency=medium

  * Sync with Debian (LP: #1731910). Remaining change:
    - Add transitional evolution-data-server-online-accounts package.
      This can be dropped after Ubuntu 18.04 LTS.

Superseded in bionic-proposed on 2017-11-14
evolution-data-server (3.26.2-1ubuntu2) bionic; urgency=medium

  * No-change rebuild for icu soname change.

 -- Matthias Klose <email address hidden>  Tue, 07 Nov 2017 08:52:30 +0000

Available diffs

Superseded in bionic-release on 2017-11-22
Deleted in bionic-proposed on 2017-11-23 (Reason: moved to release)
evolution-data-server (3.26.2-1ubuntu1) bionic; urgency=medium

  * Sync with Debian. Remaining change:
    - Add transitional evolution-data-server-online-accounts package.
      This can be dropped after Ubuntu 18.04 LTS.

Superseded in bionic-proposed on 2017-10-30
evolution-data-server (3.26.1-1ubuntu2) bionic; urgency=medium

  * No-change rebuild for libicu soname change.

 -- Matthias Klose <email address hidden>  Wed, 25 Oct 2017 15:39:50 +0000

Available diffs

Superseded in bionic-release on 2017-10-31
Published in artful-release on 2017-10-03
Deleted in artful-proposed (Reason: moved to release)
evolution-data-server (3.26.1-1ubuntu1) artful; urgency=medium

  * Sync with Debian. Remaining change:
    - Add transitional evolution-data-server-online-accounts package.
      This can be dropped after Ubuntu 18.04 LTS.

Superseded in artful-release on 2017-10-03
Deleted in artful-proposed on 2017-10-04 (Reason: moved to release)
evolution-data-server (3.26.0-1ubuntu1) artful; urgency=medium

  * Sync with Debian. Remaining change:
    - Add transitional evolution-data-server-online-accounts package.
      This can be dropped after Ubuntu 18.04 LTS.

Superseded in artful-proposed on 2017-09-11
evolution-data-server (3.25.92-1ubuntu2) artful; urgency=medium

  * debian/control:
    - Have evolution-data-server-tests depend on evolution-common and
      evolution-data-server since they're needed by the tests.

 -- Jeremy Bicha <email address hidden>  Mon, 04 Sep 2017 11:34:26 -0400
Superseded in artful-proposed on 2017-09-04
evolution-data-server (3.25.92-1ubuntu1) artful; urgency=medium

  * Sync with Debian. Remaining change:
    - Add transitional evolution-data-server-online-accounts package.
      This can be dropped after Ubuntu 18.04 LTS.

Superseded in artful-release on 2017-09-14
Deleted in artful-proposed on 2017-09-15 (Reason: moved to release)
evolution-data-server (3.25.91-0ubuntu1) artful; urgency=medium

  * New upstream release

 -- Jeremy Bicha <email address hidden>  Mon, 21 Aug 2017 08:55:29 -0400
Superseded in artful-release on 2017-08-21
Deleted in artful-proposed on 2017-08-22 (Reason: moved to release)
evolution-data-server (3.25.90-0ubuntu1) artful; urgency=medium

  * New upstream release
  * Add new symbols
  * debian/control:
    - Have libebook-contacts1.2-dev depend on its gir package
  * debian/evolution-data-server.install:
    - Install new list-sources tool
    - owncloud backend has been renamed to webdav
  * Drop git_remove-version-number-from-pot.patch:
    - Applied in new release

 -- Jeremy Bicha <email address hidden>  Tue, 08 Aug 2017 12:11:49 -0400

Available diffs

Superseded in artful-release on 2017-08-08
Deleted in artful-proposed on 2017-08-10 (Reason: moved to release)
evolution-data-server (3.24.4-0ubuntu2) artful; urgency=medium

  * No change rebuild for launchpad translations import

 -- Sebastien Bacher <email address hidden>  Wed, 19 Jul 2017 16:17:16 +0200
Superseded in artful-proposed on 2017-07-19
evolution-data-server (3.24.4-0ubuntu1) artful; urgency=medium

  * New upstream release
  * debian/rules: Explicitly set SENDMAIL_PATH to avoid a build warning

 -- Jeremy Bicha <email address hidden>  Tue, 18 Jul 2017 13:24:43 -0400
Superseded in artful-release on 2017-07-20
Deleted in artful-proposed on 2017-07-21 (Reason: moved to release)
evolution-data-server (3.24.3-0ubuntu3) artful; urgency=medium

  * debian/patches/ubuntu_gettext_domain.patch:
    - set GETTEXT_DOMAIN to be "evolution-data-server" instead of
      ${PROJECT_NAME} since dh_translations is not smart enough to follow
      variables to get the domain

 -- Sebastien Bacher <email address hidden>  Wed, 12 Jul 2017 12:30:17 +0200

Available diffs

Superseded in artful-release on 2017-07-13
Deleted in artful-proposed on 2017-07-14 (Reason: moved to release)
evolution-data-server (3.24.3-0ubuntu2) artful; urgency=medium

  * Add git_remove-version-number-from-pot.file:
    - Don't add version number to .pot filename (LP: #1702759)

 -- Jeremy Bicha <email address hidden>  Tue, 11 Jul 2017 10:27:34 -0400

Available diffs

Superseded in artful-release on 2017-07-11
Deleted in artful-proposed on 2017-07-12 (Reason: moved to release)
evolution-data-server (3.24.3-0ubuntu1) artful; urgency=medium

  * New upstream release
  * Drop avoid-rpath.patch and set -DCMAKE_SKIP_RPATH=on in debian/rules
  * debian/libcamel-1.2-60.symbols: Add new symbol

 -- Jeremy Bicha <email address hidden>  Mon, 19 Jun 2017 10:43:54 -0400
Superseded in artful-release on 2017-06-19
Deleted in artful-proposed on 2017-06-20 (Reason: moved to release)
evolution-data-server (3.24.2-0ubuntu2) artful; urgency=medium

  * Disable Ubuntu Online Accounts integration
  * Convert evolution-data-server-online-accounts into a transitional
    package depending on evolution-data-server which now provides
    the remaining GNOME Online Accounts support.

 -- Jeremy Bicha <email address hidden>  Mon, 05 Jun 2017 08:34:44 -0400
Superseded in artful-proposed on 2017-06-05
evolution-data-server (3.24.2-0ubuntu1) artful; urgency=medium

  * New upstream release (LP: #1685683)
    - Switch from autotools to cmake
  * Add new packages:
    - evolution-data-server-tests
    - gir1.2-camel-1.2
    - gir1.2-edataserverui-1.2
  * Rename libcamel-1.2-59 -> libcamel-1.2-60
  * Rename libebook-1.2-16 -> libebook-1.2-19
  * debian/control:
    - Build-depend on db-util to silence test warning
  * Update 01-noinst-libedbus-private.patch
  * Add avoid-rpath.patch:
    - Set -DCMAKE_SKIP_RPATH=ON

 -- Jeremy Bicha <email address hidden>  Sun, 04 Jun 2017 22:01:01 -0400
Obsolete in yakkety-updates on 2018-01-23
Deleted in yakkety-proposed on 2018-01-23 (Reason: moved to -updates)
evolution-data-server (3.22.7-0ubuntu0.1) yakkety; urgency=medium

  * New upstream bugfix release (LP: #1664222)

 -- Jeremy Bicha <email address hidden>  Fri, 31 Mar 2017 14:16:02 -0400
Superseded in artful-release on 2017-06-14
Obsolete in zesty-release on 2018-06-22
Deleted in zesty-proposed on 2018-06-22 (Reason: moved to release)
evolution-data-server (3.22.7-0ubuntu1) zesty; urgency=medium

  * New upstream release.

 -- Jeremy Bicha <email address hidden>  Tue, 21 Mar 2017 15:05:06 -0400
Superseded in zesty-release on 2017-03-23
Deleted in zesty-proposed on 2017-04-07 (Reason: moved to release)
evolution-data-server (3.22.6-1ubuntu1) zesty; urgency=medium

  * Merge with Debian (LP: #1628792). Remaining Ubuntu changes:
    - debian/control:
      + Build-depend on libaccounts-glib-dev and libsignon-glib-dev
    - debian/rules:
      + Enable Ubuntu online accounts
    - debian/control,
      debian/evolution-data-server.install:
      debian/evolution-data-server-online-accounts.install:
      + Split online accounts support into a separate package
  * Add evolution-data-server.postinst to recommend restarting
    after updating. Logging out then logging back in is not sufficient.

Superseded in zesty-release on 2017-03-14
Deleted in zesty-proposed on 2017-03-15 (Reason: moved to release)
evolution-data-server (3.22.5-1ubuntu1) zesty; urgency=medium

  * Merge with Debian (LP: #1664222). Remaining Ubuntu changes:
    - debian/control:
      + Build-depend on libaccounts-glib-dev and libsignon-glib-dev
    - debian/rules:
      + Enable Ubuntu online accounts
    - debian/control,
      debian/evolution-data-server.install:
      debian/evolution-data-server-online-accounts.install:
      + Split online accounts support into a separate package
  * Add evolution-data-server.postinst to recommend restarting
    after updating. Logging out then logging back in is not sufficient.

Superseded in zesty-release on 2017-02-15
Deleted in zesty-proposed on 2017-02-16 (Reason: moved to release)
evolution-data-server (3.22.4-1ubuntu1) zesty; urgency=medium

  * Merge with Debian. Remaining Ubuntu changes:
    - debian/control:
      + Build-depend on libaccounts-glib-dev and libsignon-glib-dev
    - debian/rules:
      + Enable Ubuntu online accounts
    - debian/control,
      debian/evolution-data-server.install:
      debian/evolution-data-server-online-accounts.install:
      + Split online accounts support into a separate package

Superseded in yakkety-updates on 2017-04-13
Deleted in yakkety-proposed on 2017-04-15 (Reason: moved to -updates)
evolution-data-server (3.22.3-0ubuntu0.1) yakkety; urgency=medium

  * New upstream bugfix release (LP: #1639926)

 -- Jeremy Bicha <email address hidden>  Wed, 14 Dec 2016 01:22:11 -0500
Superseded in zesty-release on 2017-01-18
Deleted in zesty-proposed on 2017-01-19 (Reason: moved to release)
evolution-data-server (3.22.3-1ubuntu1) zesty; urgency=medium

  * Merge with Debian. Remaining Ubuntu changes:
    - debian/control:
      + Build-depend on libaccounts-glib-dev and libsignon-glib-dev
    - debian/rules:
      + Enable Ubuntu online accounts
    - debian/control,
      debian/evolution-data-server.install:
      debian/evolution-data-server-online-accounts.install:
      + Split online accounts support into a separate package

Superseded in zesty-release on 2016-12-13
Deleted in zesty-proposed on 2016-12-14 (Reason: moved to release)
evolution-data-server (3.22.2-1ubuntu1) zesty; urgency=medium

  * Merge with Debian (LP: #1639926). Remaining Ubuntu changes:
    - debian/control:
      + Build-depend on libaccounts-glib-dev and libsignon-glib-dev
    - debian/rules:
      + Enable Ubuntu online accounts
    - debian/control,
      debian/evolution-data-server.install:
      debian/evolution-data-server-online-accounts.install:
      + Split online accounts support into a separate package

Available diffs

Superseded in zesty-release on 2016-11-08
Obsolete in yakkety-release on 2018-01-23
Deleted in yakkety-proposed on 2018-01-23 (Reason: moved to release)
evolution-data-server (3.22.1-0ubuntu2) yakkety; urgency=medium

  * debian/libedataserver-1.2-22.symbols:
    - Add new symbol

Superseded in yakkety-proposed on 2016-10-10
evolution-data-server (3.22.1-0ubuntu1) yakkety; urgency=medium

  * New upstream bugfix release (LP: #1631955)
    - Fix Google authentication failure with expired tokens.
      The fix may still be incomplete.

 -- Jeremy Bicha <email address hidden>  Mon, 10 Oct 2016 09:42:08 -0400

Available diffs

Superseded in yakkety-release on 2016-10-11
Deleted in yakkety-proposed on 2016-10-12 (Reason: moved to release)
evolution-data-server (3.22.0-1ubuntu1) yakkety; urgency=medium

  * Merge with Debian (LP: #1584978). Remaining Ubuntu changes:
    - debian/control:
      + Build-depend on libaccounts-glib-dev and libsignon-glib-dev
      + Don't build-depend on libphonenumber-dev (it's in universe)
      + Have e-d-s break/replace e-d-s-common (<< 3.20.3~) since
        Debian had e-d-s install the .service file instead
    - debian/rules:
      + Enable Ubuntu online accounts
    - debian/control,
      debian/evolution-data-server.install:
      debian/evolution-data-server-online-accounts.install:
      + Split online accounts support into a separate package
  * Dropped changes:
    - Don't enable libphonenumber. Since libphonenumber has been promoted to
      main, let's enable this (LP: #1626627)

Available diffs

Superseded in yakkety-release on 2016-10-02
Deleted in yakkety-proposed on 2016-10-03 (Reason: moved to release)
evolution-data-server (3.21.91-0ubuntu1) yakkety; urgency=medium

  * New upstream release
  * Bump dh compat to 10

 -- Jeremy Bicha <email address hidden>  Mon, 29 Aug 2016 11:45:54 -0400
Superseded in yakkety-release on 2016-08-29
Deleted in yakkety-proposed on 2016-08-31 (Reason: moved to release)
evolution-data-server (3.21.90-0ubuntu3) yakkety; urgency=medium

  * Don't have evolution-data-server-online-accounts recommend
    signon-plugin-password (LP: #1571942)

 -- Jeremy Bicha <email address hidden>  Sat, 27 Aug 2016 15:14:30 -0400
Superseded in yakkety-release on 2016-08-28
Deleted in yakkety-proposed on 2016-08-29 (Reason: moved to release)
evolution-data-server (3.21.90-0ubuntu2) yakkety; urgency=medium

  * Revert accidentally pushed changes to autopkgtests

Superseded in yakkety-proposed on 2016-08-19
evolution-data-server (3.21.90-0ubuntu1) yakkety; urgency=medium

  * New upstream release (LP: #1613291)
  * Rename libcamel-1.2-57 -> libcamel-1.2-59
  * Rename libedataserver-1.2-21 -> libedataserver-1.2-22
  * Update symbols
  * Build-depend on libwebkit2gtk-4.0-dev instead of libwebkitgtk-3.0-dev
  * debian/rules:
    - Drop --disable-google-auth

 -- Jeremy Bicha <email address hidden>  Fri, 19 Aug 2016 12:47:28 -0400
Superseded in yakkety-release on 2016-08-27
Deleted in yakkety-proposed on 2016-08-29 (Reason: moved to release)
evolution-data-server (3.20.5-0ubuntu1) yakkety; urgency=medium

  * Merge with Debian (LP: #1584978). Remaining Ubuntu changes:
    - debian/control:
      + Build-depend on libaccounts-glib-dev and libsignon-glib-dev
      + Don't build-depend on libphonenumber-dev (it's in universe)
      + Have e-d-s break/replace e-d-s-common (<< 3.20.3~) since
        Debian had e-d-s install the .service file instead
    - debian/rules:
      + Enable Ubuntu online accounts
      + Don't enable libphonenumber
    - debian/libedataserverui-1.2-1.symbols:
      + Add missing symbols file
    - debian/control,
      debian/evolution-data-server.install:
      debian/evolution-data-server-online-accounts.install:
      + Split online accounts support into a separate package
  * New upstream release
  * debian/control, debian/rules:
    - Don't add new build-depends on libwebkitgtk-3.0-dev, it's in universe
    - Use --disable-google-auth

Superseded in yakkety-release on 2016-08-13
Deleted in yakkety-proposed on 2016-08-16 (Reason: moved to release)
evolution-data-server (3.18.5-1ubuntu3) yakkety; urgency=medium

  * No-change rebuild for libical soname change.

 -- Matthias Klose <email address hidden>  Wed, 25 May 2016 12:59:00 +0000

Available diffs

Superseded in yakkety-release on 2016-06-01
Deleted in yakkety-proposed on 2016-06-02 (Reason: moved to release)
evolution-data-server (3.18.5-1ubuntu2) yakkety; urgency=medium

  * No-change rebuild for libicu soname change.

 -- Matthias Klose <email address hidden>  Fri, 22 Apr 2016 22:54:13 +0000

Available diffs

Superseded in yakkety-release on 2016-04-26
Published in xenial-release on 2016-02-23
Deleted in xenial-proposed (Reason: moved to release)
evolution-data-server (3.18.5-1ubuntu1) xenial; urgency=medium

  * Merge with Debian, remaining Ubuntu changes:
  * debian/control:
    - Add build depends on libaccounts-glib-dev, libsignon-glib-dev
    - Bump build depends on libgdata-dev (so we get gtasks support)
  * debian/rules:
    - Enable Ubuntu online accounts
  * debian/libedataserverui-1.2-1.symbols:
    - Add missing symbols file
  * debian/control,
    debian/evolution-data-server.install:
    debian/evolution-data-server-online-accounts.install:
    - Split online accounts support into a separate package

Superseded in xenial-release on 2016-02-23
Deleted in xenial-proposed on 2016-02-24 (Reason: moved to release)
evolution-data-server (3.18.4-0ubuntu1) xenial; urgency=medium

  * New upstream version

 -- Sebastien Bacher <email address hidden>  Fri, 12 Feb 2016 13:47:09 +0100
Superseded in xenial-release on 2016-02-12
Deleted in xenial-proposed on 2016-02-13 (Reason: moved to release)
evolution-data-server (3.18.3-1ubuntu2) xenial; urgency=medium

  * Multiarchify the library packages.

 -- Matthias Klose <email address hidden>  Wed, 27 Jan 2016 23:49:38 +0100
Superseded in xenial-release on 2016-01-28
Deleted in xenial-proposed on 2016-01-29 (Reason: moved to release)
evolution-data-server (3.18.3-1ubuntu1) xenial; urgency=medium

  * Merge with Debian, remaining Ubuntu changes:
  * debian/control:
    - Add build depends on libaccounts-glib-dev, libsignon-glib-dev
    - Bump build depends on libgdata-dev (so we get gtasks support)
  * debian/rules:
    - Build with dh_install --fail-missing
    - Filter out -Bsymbolic-functions from LDFLAGS (for future people
      wondering about this change, see e.g. BGO #594473 and duplicates).
    - Enable Ubuntu online accounts
  * debian/libedataserverui-1.2-1.symbols:
    - Add missing symbols file
  * debian/control,
    debian/evolution-data-server.install:
    debian/evolution-data-server-online-accounts.install:
    - Split online accounts support into a separate package

Superseded in xenial-proposed on 2015-12-16
evolution-data-server (3.18.3-0ubuntu1) xenial; urgency=medium

  * New upstream version
  * debian/control:
    - clear out some old conflicts, not needed since trusty

 -- Sebastien Bacher <email address hidden>  Wed, 16 Dec 2015 09:17:57 +0100
Superseded in xenial-release on 2015-12-16
Deleted in xenial-proposed on 2015-12-18 (Reason: moved to release)
evolution-data-server (3.18.2-0ubuntu2) xenial; urgency=medium

  * debian/control:
    - let evolution-data-server-online-accounts recommends
      signon-plugin-password, it's required for authentication with
      several services

 -- Sebastien Bacher <email address hidden>  Thu, 03 Dec 2015 16:49:58 +0100

Available diffs

Superseded in xenial-release on 2015-12-03
Deleted in xenial-proposed on 2015-12-05 (Reason: moved to release)
evolution-data-server (3.18.2-0ubuntu1) xenial; urgency=medium

  * New upstream version

 -- Sebastien Bacher <email address hidden>  Thu, 12 Nov 2015 19:16:52 +0100

Available diffs

Superseded in xenial-release on 2015-11-13
Deleted in xenial-proposed on 2015-11-14 (Reason: moved to release)
evolution-data-server (3.18.1-1ubuntu1) xenial; urgency=medium

  * Merge with Debian, remaining Ubuntu changes:
  * debian/control:
    - Add build depends on libaccounts-glib-dev, libsignon-glib-dev
    - Bump build depends on libgdata-dev (so we get gtasks support)
    - Add evolution-data-server-online-accounts package
  * debian/rules:
    - Build with dh_install --fail-missing
    - Filter out -Bsymbolic-functions from LDFLAGS (for future people
      wondering about this change, see e.g. BGO #594473 and duplicates).
    - Enable Ubuntu online accounts
  * debian/libedataserverui-1.2-1.symbols:
    - Add missing symbols file
  * debian/evolution-data-server.install:
  * debian/evolution-data-server-online-accounts.install:
    - Split online accounts support into a separate package

 -- Robert Ancell <email address hidden>  Tue, 27 Oct 2015 17:39:58 +1300
Superseded in xenial-release on 2015-11-07
Obsolete in wily-release on 2018-01-22
Deleted in wily-proposed on 2018-01-22 (Reason: moved to release)
evolution-data-server (3.16.5-1ubuntu3) wily; urgency=medium

  [ Sebastien Bacher ]
  * debian/patches/git_invalid_unref_source.patch:
    - "[UOA] Incorrect ESource unref in e_signon_session_password_get()"

  [ Iain Lane ]
  * debian/patches/git_Bug-755075-Recent-glib-2.45.8-change-breaks-account-.patch
    - Fix settings incorrectly returning their default values, which breaks
      some setups (LP: #1498945)
  * Include some changes which were committed to the VCS for 1ubuntu1 (delta
    reduction vs. Debian) but accidentally not uploaded.
    - Debian disabled libphonenumber too; take their commented out rules
      snippet
    - debian/libebackend-1.2-10.install: Use a regex and mark leaked icu
      symbols as optional.

 -- Iain Lane <email address hidden>  Wed, 30 Sep 2015 12:36:50 +0100
Superseded in wily-release on 2015-09-30
Deleted in wily-proposed on 2015-10-01 (Reason: moved to release)
evolution-data-server (3.16.5-1ubuntu2) wily; urgency=medium

  * debian/patches/git_uoa_warnings.patch:
    - backport patch to fix uoa warnings
  * debian/patches/git_uoa_refresh_token.patch:
    - backport patch to fix google oauth token refresh (lp: #1498473)
  * debian/patches/git_runtime_warning.patch:
    - backport another warning fix change

 -- Sebastien Bacher <email address hidden>  Wed, 23 Sep 2015 16:01:26 +0200
Obsolete in vivid-updates on 2018-01-18
Deleted in vivid-proposed on 2018-01-19 (Reason: moved to -updates)
evolution-data-server (3.12.11-0ubuntu1.15.04.1) vivid; urgency=medium

  * Add patch for GNOME bug #749292 (SMTP connection lost while reading
    message data) (LP: #1442756)

 -- Iain Lane <email address hidden>  Thu, 17 Sep 2015 11:06:16 +0100
175 of 342 results