Error while Refreshing folder: Summary and folder mismatch, even after a sync

Bug #28403 reported by Debian Bug Importer on 2006-01-12
22
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Evolution
Fix Released
Unknown
evolution (Debian)
Fix Released
Unknown
evolution (Ubuntu)
High
Sebastien Bacher

Bug Description

Automatically imported from Debian bug report #347703 http://bugs.debian.org/347703

Debian Bug Importer (debzilla) wrote :
Download full text (6.2 KiB)

Message-Id: <email address hidden>
Date: Thu, 12 Jan 2006 09:02:02 +0100
From: Csillag Kristof <email address hidden>
To: Debian Bug Tracking System <email address hidden>
Subject: Error while Refreshing folder: Summary and folder mismatch, even after a sync

Package: evolution
Version: 2.4.2.1-1
Severity: grave

Yesterday when I did my daily upgrade, I got the new evolution 2.4 package.
When I started to start it, it froze.
(See #347672: evolution: Evolution 2.4.2.1 freezes on startup)

I did not have the time to debug it, so I just downgraded to the testing version
(2.2.something), and then the problem was over.

Today I decided to give it another try. I upgraded again.
This time it did not freeze, but gave this error:

"Error while Refreshing folder:
Summary and folder mismatch, even after a sync."

In the list of mail, each one seems to be duplicated.
If I click on one, it says

"Unable to retrieve message
Summary and folder mismatch, even after a sync."

... so it's still unusable.

I guess I will have do downgrade again...

-- System Information:
Debian Release: 3.1
  APT prefers unstable
  APT policy: (500, 'unstable'), (500, 'testing')
Architecture: i386 (i686)
Kernel: Linux 2.6.14
Locale: LANG=hu_HU, LC_CTYPE=hu_HU (charmap=ISO-8859-2)

Versions of packages evolution depends on:
ii evolution-data-server 1.4.2.1-1 evolution database backend server
ii gconf2 2.12.1-8 GNOME configuration database syste
ii gnome-icon-theme 2.12.1-2 GNOME Desktop icon theme
ii gtkhtml3.8 3.8.1-1 HTML rendering/editing library - b
ii libart-2.0-2 2.3.17-1 Library of functions for 2D graphi
ii libatk1.0-0 1.10.3-1 The ATK accessibility toolkit
ii libaudiofile0 0.2.6-6 Open-source version of SGI's audio
ii libbonobo2-0 2.10.1-1 Bonobo CORBA interfaces library
ii libbonoboui2-0 2.10.1-1 The Bonobo UI library
ii libc6 2.3.5-11 GNU C Library: Shared libraries an
ii libcairo2 1.0.2-3 The Cairo 2D vector graphics libra
ii libcamel1.2-6 1.4.2.1-1 The Evolution MIME message handlin
ii libcomerr2 1.37-2sarge1 common error description library
ii libcompfaceg1 1989.11.11-24 Compress/decompress images for mai
ii libdb4.2 4.2.52-18 Berkeley v4.2 Database Libraries [
ii libebook1.2-5 1.4.2.1-1 Client library for evolution addre
ii libecal1.2-3 1.4.2.1-1 Client library for evolution calen
ii libedataserver1.2-4 1.4.2.1-1 Utility library for evolution data
ii libedataserverui1.2-6 1.4.2.1-1 GUI utility library for evolution
ii libesd0 0.2.36-2 Enlightened Sound Daemon - Shared
ii libfontconfig1 2.3.1-2 generic font configuration library
ii libfreetype6 2.1.7-2.4 FreeType 2 font engine, shared lib
ii libgail-common 1.8.4-1 GNOME Accessibility Implementation
ii libgail17 1.8.4-1 GNOME Accessibi...

Read more...

Sebastien Bacher (seb128) wrote :

probably debian specific, waiting for them to sort it out

Paul van Genderen (paulvg) wrote :

This is still in 2.6.0. Although it doesn't freeze, I now have 1008 unread mails, and counting. It seems that each time the message appears, emails have been duplicated. Moving Inbox.ev-summary out of the way doesn't help.

I use fetchmail and postfix, and have pointed Evolution to the local mail spool. Maybe that has something to do with it.

Paul van Genderen (paulvg) wrote :

Procmail is also installed.

Changed in evolution:
status: Needs Info → Confirmed
Paul van Genderen (paulvg) wrote :

evolution --offline stops evolution from trying to sync and is very useful to remove the duplicates.

Paul van Genderen (paulvg) wrote :

http://bugzilla.gnome.org/show_bug.cgi?id=322727

And there's still 3GB disk space left.

Paul van Genderen (paulvg) wrote :

Close evolution, remove .evolution/mail/local/*summary and restart evo. That fixes it.

Paul van Genderen (paulvg) wrote :

A solution has been found so medium priority again now

Sebastien Bacher (seb128) wrote :

Paul, they don't have a patch but a theory and a workaround, how does that change the priority?

I just changed it back to what it was after I found out about the
workaround. Feel free to change it again if you like.

Op vr, 07-04-2006 te 08:41 +0000, schreef Sebastien Bacher:
> Paul, they don't have a patch but a theory and a workaround, how does that change the priority?

Changed in evolution:
status: Unconfirmed → Confirmed
Jamie Strandboge (jdstrand) wrote :

This appears to be:
http://bugzilla.gnome.org/show_bug.cgi?id=213072

Also, the procedure to reliably workaround this bug is:
1. put evolution in offline mode (File/Work Offline)
2. close evolution
3. open a terminal and run:
      evolution --force-shutdown
      find ~/.evolution/mail/local -name "*ev-summary" -exec rm -f {} \;
4. start evolution
5. wait several seconds (until the status bar at the bottom is empty)
6. close evolution (it may take a long time to close)
7. Start evolution
8. Enable online mode (File/Work Online)

If you start evolution in Online mode after removing the summary files, then you may end up with duplicates and/or more folder mismatch errors. If you don't do 'evolution --force-shutdown', then you may also end up with more folder mismatch errors.

There seems to be some discussion of this getting fixed here:
http://www.go-evolution.org/Camel.Local#Mbox_bugs

Lee Revell (rlrevell) wrote :

I am afflicted by this bug several times a week, and the workaround is no help for me.

"Several seconds" - ha! I have very large folders - after removing the summary and restarting it takes 30-60 minutes to regenerate the indexes and summaries. During this time I cannot receive any mail - it just sits and spins "Storing folder...", and eventually the progress bar stops or Evolution crashes.

The only solution is to move the mbox files out of the way, restart Evo, and manually re-import them.

Is anyone working on the root cause of this bug - aka preventing the summary from getting corrupted in the first place?

Sebastien Bacher (seb128) wrote :

marking as duplicate of bug #27014

Changed in evolution:
status: Confirmed → In Progress
Changed in evolution:
status: In Progress → Fix Released
Changed in evolution:
status: Confirmed → Fix Released
Changed in evolution:
status: Fix Released → Confirmed
Changed in evolution:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.