Change log for f-el package in Ubuntu

16 of 6 results
Published in disco-release on 2018-10-30
Published in cosmic-release on 2018-05-01
Published in bionic-release on 2018-01-25
Deleted in bionic-proposed (Reason: moved to release)
f-el (0.20.0-1) unstable; urgency=medium

  * New upstream release.
  * Drop extract-changelog-from-README.patch.
    Obsoleted by upstream changes.

 -- Sean Whitton <email address hidden>  Fri, 12 Jan 2018 16:59:15 -0700

Available diffs

Superseded in bionic-release on 2018-01-25
Deleted in bionic-proposed on 2018-01-26 (Reason: moved to release)
f-el (0.19.0-3) unstable; urgency=medium

  * Team upload.
  * Update package to current pkg-emacsen standards.
  * debian/control:
    - Remove trailing commas.
    - Bump standards version to 4.1.1 (no changes needed).
    - Drop depends emacs.
    - Drop enhances emacs24
    - Drop Build-Using: ${misc:Built-Using}
    
 -- Nicholas D Steeves <email address hidden>  Tue, 03 Oct 2017 22:18:26 -0400

Available diffs

Superseded in bionic-release on 2017-11-02
Published in artful-release on 2017-06-21
Deleted in artful-proposed (Reason: moved to release)
f-el (0.19.0-2) unstable; urgency=high

  * Update dh_auto_build override to use s.el and dash.el as installed by
    elpa-s and elpa-dash (Closes: #865295).
    Thank you to Adrian Bunk for noticing that this needed to be done.
  * Update build dependencies:
    - dash-el => elpa-dash
    - s-el => elpa-s.
  * Update binary package dependencies:
    - Replace s-el and dash-el entries with ${elpa:Depends}.
    - Drop 0003-remove-Package-Requires.patch
      Obsoleted by switching to depend on elpa-s and elpa-dash.
    - Tighten build-dep on dh-elpa to (>= 1.7).
      Ensures that elpa-s and elpa-dash dependencies are included in
      ${elpa:Depends}.
  * Drop d/source/options for dgit.
    Although dgit does not require dropping this file, it serves no
    purpose and gets in the way of uploading.
  * Drop stray '--parallel' from d/rules.
    Implicit at compat 10.
  * Bump standards version to 4.0.0 (no changes required).

 -- Sean Whitton <email address hidden>  Tue, 20 Jun 2017 13:00:51 +0100

Available diffs

Superseded in artful-release on 2017-06-21
Obsolete in zesty-release on 2018-06-22
Deleted in zesty-proposed on 2018-06-22 (Reason: moved to release)
f-el (0.19.0-1) unstable; urgency=medium

  * New upstream release.
    - New build-dependency on elpa-ert-async.
  * Bump to debhelper compat & build-dep to 10.
  * Use dh_elpa_test to run the test suite.
    - Add Testsuite: field.
  * Quilt patch changes:
    - Extract & install upstream changelog from README.md.
    - Apply 0001-Debian-README.patch to README.md.tpl, not README.md.
    - Rename 0003-disable-undercover.patch -> patch-test-runner-for-Debian.patch
    - Fix loading f.el in patch-test-runner-for-Debian.patch
    - Add Forwarded: headers to all patches.
    - Refresh patches.
  * Rebuild README.md from README.md.tpl during package build.
  * Improve extended description.
  * Run `wrap-and-sort -abst`.

 -- Sean Whitton <email address hidden>  Tue, 11 Oct 2016 17:14:45 -0700

Available diffs

Superseded in zesty-release on 2016-11-03
Obsolete in yakkety-release on 2018-01-23
Deleted in yakkety-proposed on 2018-01-23 (Reason: moved to release)
f-el (0.18.2-1) unstable; urgency=medium

  * Package new upstream release.
  * Refresh Package-Requires patch.
  * Bump standards version to 3.9.8; no changes required.

 -- Sean Whitton <email address hidden>  Tue, 26 Apr 2016 18:37:34 -0700

Available diffs

Superseded in yakkety-release on 2016-04-27
Published in xenial-release on 2015-12-20
Deleted in xenial-proposed (Reason: moved to release)
f-el (0.17.3-1) unstable; urgency=medium

  * Initial release. (Closes: #807882)

 -- Sean Whitton <email address hidden>  Mon, 14 Dec 2015 21:49:16 -0700
16 of 6 results