f-el 0.19.0-2 source package in Ubuntu

Changelog

f-el (0.19.0-2) unstable; urgency=high

  * Update dh_auto_build override to use s.el and dash.el as installed by
    elpa-s and elpa-dash (Closes: #865295).
    Thank you to Adrian Bunk for noticing that this needed to be done.
  * Update build dependencies:
    - dash-el => elpa-dash
    - s-el => elpa-s.
  * Update binary package dependencies:
    - Replace s-el and dash-el entries with ${elpa:Depends}.
    - Drop 0003-remove-Package-Requires.patch
      Obsoleted by switching to depend on elpa-s and elpa-dash.
    - Tighten build-dep on dh-elpa to (>= 1.7).
      Ensures that elpa-s and elpa-dash dependencies are included in
      ${elpa:Depends}.
  * Drop d/source/options for dgit.
    Although dgit does not require dropping this file, it serves no
    purpose and gets in the way of uploading.
  * Drop stray '--parallel' from d/rules.
    Implicit at compat 10.
  * Bump standards version to 4.0.0 (no changes required).

 -- Sean Whitton <email address hidden>  Tue, 20 Jun 2017 13:00:51 +0100

Upload details

Uploaded by:
Debian Emacs addons team on 2017-06-20
Uploaded to:
Sid
Original maintainer:
Debian Emacs addons team
Architectures:
all
Section:
misc
Urgency:
Very Urgent

See full publishing history Publishing

Series Pocket Published Component Section
Artful release on 2017-06-21 universe misc

Builds

Artful: [FULLYBUILT] amd64

Downloads

File Size SHA-256 Checksum
f-el_0.19.0-2.dsc 2.1 KiB 812fe06b155bd8531d911545b5ece0e393aba85c7cc08526158e77cfc5b1fa68
f-el_0.19.0.orig.tar.xz 15.8 KiB 3c6662d9a67ef889ef1b50e0673dffaf3148c1fa7d8551910e3cbbcccb234290
f-el_0.19.0-2.debian.tar.xz 5.2 KiB c0071fa6b73993ddba1169c7aa51018bbd3b9a61b610070903d4e8c435047de4

Available diffs

No changes file available.

Binary packages built by this source

elpa-f: modern API for working with files and directories in Emacs Lisp

 f.el provides numerous useful functions for working with files and
 directories in Emacs Lisp.
 .
 After installation, see /usr/share/doc/elpa-f/README.md.gz for full
 API documentation.