Ubuntu

-w option for stdout output doesn't work

Reported by Thomas Butter on 2005-05-27
26
Affects Status Importance Assigned to Milestone
faad2 (Ubuntu)
Medium
MOTU

Bug Description

the -w option for stdout output doesn't work

the -w option for stdout output doesn't work. the output is corrupted and not playable. it is fixed in the current cvs version afaik.

Changed in faad2:
assignee: nobody → motu
Sebastian Dröge (slomo) wrote :

I can confirm that... but as current cvs is under a gpl-incompatible license i don't want to pull any changes from there, sorry

Changed in faad2:
status: Unconfirmed → Confirmed
John Steele Scott (toojays) wrote :

Are there different forks of this library? I found a version 2.5 which seems very much GPL'd: <http://www.audiocoding.com/modules/mydownloads/singlefile.php?cid=1&lid=23>

John Steele Scott (toojays) wrote :

Btw, the -w option seems to work for me.

I use it with slimserver to convert m4a to flac for streaming to a sqeezebox like so. I have the following line in my slimserver config to get flac on stdout.

[faad] -w -d -s 44100 -f2 $FILE$ | [flac] -cs --fast --endian=little --channels=2 --bps=16 --sample-rate=44100 --sign=signed -

This mostly works for me on my PPC box. The problem I am having with this is that faad does not correctly shutdown when the pipe closes. That sounds like a different issue to corrupted output.

Rocco Stanzione (trappist) wrote :

If this is still a problem, could you please post instructions to reproduce? ie, what are you piping the output to, that's complaining of corrupted input?

Changed in faad2:
status: Confirmed → Needs Info
Sebastian Dröge (slomo) wrote :
Changed in faad2:
status: Needs Info → Confirmed
Daniel T Chen (crimsun) wrote :

8.04's version does not exhibit this symptom.

Changed in faad2:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers