Change log for faad2 package in Ubuntu

131 of 31 results
Published in cosmic-release on 2018-05-01
Published in bionic-release on 2017-12-19
Deleted in bionic-proposed (Reason: moved to release)
faad2 (2.8.8-1) unstable; urgency=medium

  * New upstream version 2.8.8

 -- Fabian Greffrath <email address hidden>  Mon, 18 Dec 2017 21:28:02 +0100

Available diffs

Superseded in bionic-release on 2017-12-19
Deleted in bionic-proposed on 2017-12-20 (Reason: moved to release)
faad2 (2.8.6-1) unstable; urgency=medium

  * New upstream version 2.8.6

 -- Fabian Greffrath <email address hidden>  Mon, 06 Nov 2017 17:05:46 +0100

Available diffs

Superseded in bionic-release on 2017-11-11
Deleted in bionic-proposed on 2017-11-12 (Reason: moved to release)
faad2 (2.8.5-1) unstable; urgency=medium

  * New upstream version 2.8.5
  * Remove faad2_version.patch, upstream has changed the
    FAAD2_VERSION macro to read 'unknown'.
  * Refresh reproducible-build.patch.
  * Add the NeAACDecGetVersion@Base symbol to the libfaad2.symbols file,
    this function is supposed to be used to get the FAAD2 library
    version at runtime.
  * Update debian/copyright for recently added or removed source files.
  * Bump Standards-Version to 4.1.0.

 -- Fabian Greffrath <email address hidden>  Sat, 30 Sep 2017 14:29:31 +0200

Available diffs

Published in trusty-updates on 2017-08-31
Published in trusty-security on 2017-08-31
faad2 (2.7-8+deb7u1build0.14.04.1) trusty-security; urgency=medium

  * fake sync from Debian

Superseded in bionic-release on 2017-11-06
Published in artful-release on 2017-08-05
Deleted in artful-proposed (Reason: moved to release)
faad2 (2.8.1-2) unstable; urgency=medium

  * Set the FAAD2_VERSION macro back to the version string,
    thanks Adrian Bunk (Closes: #868854).
    + In the next upstream release this macro will read "unknown version"
      and an API will be provided to retrieve the actual library version
      at run-time.

 -- Fabian Greffrath <email address hidden>  Wed, 02 Aug 2017 20:46:57 +0200

Available diffs

Superseded in artful-release on 2017-08-05
Deleted in artful-proposed on 2017-08-06 (Reason: moved to release)
faad2 (2.8.1-1) unstable; urgency=medium

  * New upstream version 2.8.1.
    + Fixes multiple vulnerabilities: CVE-2017-9218,
      CVE-2017-9219, CVE-2017-9220, CVE-2017-9221,
      CVE-2017-9222, CVE-2017-9223, CVE-2017-9253,
      CVE-2017-9254, CVE-2017-9255, CVE-2017-9256,
      CVE-2017-9257 (Closes: #867724).
  * Update debian/watch file.
  * Refresh reproducible-build.patch.
  * Remove debian/README.source and debian/gbp.conf files, 
    they do not apply anymore.
  * Bump Standards-Version to 4.0.0.
  * Bump debhelper compat to 10.
  * Fix vcs-field-uses-insecure-uri lintian warnings.
  * Enable all hardening flags.
  * Update debian/copyright,
    refer to MPL-1.1 in common-licenses.
  * Drop obsolete faad2-dbg package.

 -- Fabian Greffrath <email address hidden>  Mon, 17 Jul 2017 22:25:26 +0200

Available diffs

Superseded in artful-release on 2017-07-19
Obsolete in zesty-release on 2018-06-22
Deleted in zesty-proposed on 2018-06-22 (Reason: moved to release)
faad2 (2.8.0~cvs20161113-1) unstable; urgency=medium

  * New upstream CVS snapshot.
    + Fixes implicit SBR detection via AudioSpecificConfig
      on systems with unsigned char (Closes: #843173).
  * Change Uploaders field to use my Debian account.

 -- Fabian Greffrath <email address hidden>  Sun, 13 Nov 2016 17:45:15 +0100
Superseded in zesty-release on 2016-11-14
Obsolete in yakkety-release on 2018-01-23
Published in xenial-release on 2015-10-22
Obsolete in wily-release on 2018-01-22
Deleted in wily-proposed (Reason: moved to release)
faad2 (2.8.0~cvs20150510-1) unstable; urgency=medium

  * New upstream CVS snapshot.
    + Does not crash when given ADTS AAC file with large ID3v2 tag anymore,
      thanks Mike Crowe for the bug report and patch (Closes: #689712).
    + Does not crash with the Mayhem testcase anymore, thanks Alexandre Rebert
      for the bug report (Closes: #715882).
  * Add debian/README.source to document how the Debian source tarball was
    created and force xz compression in debian/gbp.conf.
  * Remove all patches that were either applied, solved differently or
    disapproved upstream:
    + autotools-compat.patch: Disapproved upstream.
    + noinst-mp4ff.patch: Applied upstream.
    + manpage.patch: Applied upstream.
    + incorrect_pointer_size.patch: Does not apply anymore.
    + bpa-stdin.patch: Applied upstream.
    + path_max.patch: Applied upstream.
    + fix_ftbfs_with_gcc4.5.patch: Disapproved upstream.
    + symbol-visibility.patch: Does not apply anymore.
    + libfaad-drm.patch: Applied upstream.
  * Ship upstream's own frontend and API documentation manpages.
  * Update Debian packaging copyright years.
  * Remove '__DATE__' CPP macro for reproducible builds.

 -- Fabian Greffrath <email address hidden>  Mon, 11 May 2015 13:59:49 +0200

Available diffs

Superseded in wily-release on 2015-05-11
Deleted in wily-proposed on 2015-05-13 (Reason: moved to release)
faad2 (2.7-9) unstable; urgency=medium

  * Build the DRM version of the library as well as the normal version,
    thanks Julian Cable for the idea and the patch!
  * Remove Andres Mejia from Uploaders (Closes: #743545).
  * Remove "DM-Upload-Allowed" field from debian/control.
  * Mark the faad2-dbg package as "Multi-Arch: same" and
    remove faad ("Multi-Arch: no") from its Dependencies.
  * Remove debian/source/local-options, they are default now.
  * Add faad.lintian-overrides for a spelling error that is used
    in the id3 specification.
  * Fix "vcs-field-not-canonical" lintian warning.
  * Fix "'visibility' attribute ignored on non-class types" compiler warnings
    introduced by our symbol versioning patch.
  * Fix most autotools warnings.
  * Bump "Standards-Version" to 3.9.6.
  * Run "wrap-and-sort -asb".
  * Add extensive API documentation in libfaad.3, courtesy of Julian Cable.

 -- Fabian Greffrath <email address hidden>  Thu, 30 Apr 2015 18:04:42 +0200

Available diffs

Superseded in wily-release on 2015-05-07
Obsolete in vivid-release on 2018-01-18
Obsolete in utopic-release on 2016-11-03
Published in trusty-release on 2013-10-18
Obsolete in saucy-release on 2015-04-24
Obsolete in raring-release on 2015-04-24
Obsolete in quantal-release on 2015-04-24
faad2 (2.7-8) unstable; urgency=low


  [ Fabian Greffrath ]
  * debian/patches/path_max.patch:
    + Dynamically allocate file name buffers,
      instead of relying on PATH_MAX.
  * Set appropriate symbol visibility attributes.
  * Rebuild autofoo with dh-autoreconf.
  * Add debian/libfaad2.symbols file.
  * Multi-Archify.
  * Remove redundant license blurb from debian/copyright.
  * libmp4ff ist not packaged, so do not install it either.
  * Simplify debian/*.install accordingly.

  [ Andres Mejia ]
  * Make dev package multiarch installable.
  * Bump to Standards-Version 3.9.3.

 -- Andres Mejia <email address hidden>  Sun, 18 Mar 2012 09:07:55 -0400

Available diffs

Superseded in quantal-release on 2012-04-30
Published in precise-release on 2011-10-15
faad2 (2.7-7) unstable; urgency=low


  [ Andres Mejia ]
  * Update to my @debian.org email.
  * Update gbp.conf.
  
  [ Reinhard Tartler ]
  * Update Vcs-Browser field
  * bump standards version (no changes needed)

  [ Fabian Greffrath ]
  * Convert to 3.0 (quilt) source format.
  * Re-enable two patches that got lost in the 2.7-6 upload:
    - debian/patches/bpa-stdin.patch
      + Apply SqueezeCenter patches from FreeBSD that enable streaming with
        BBCiPlayer and ezstream (LP: #470562).
    - debian/patches/path_max.patch
      + Extend file name buffers for longer path names (LP: #475050).
  * Merge patch from 2.7-6ubuntu1:
    - debian/patches/fix_ftbfs_with_gcc4.5.patch
      + Correctly declare lrintf in libfaad/common.h to avoid a conflict of
        declaration in mathcalls.h to fix FTBFS on i386
  * Improve debian/copyright.

 -- Fabian Greffrath <email address hidden>  Wed, 03 Aug 2011 14:19:49 +0200
Superseded in precise-release on 2011-10-15
Obsolete in oneiric-release on 2015-04-24
Obsolete in natty-release on 2013-06-04
faad2 (2.7-6ubuntu1) natty; urgency=low

  [ Angel Abad <email address hidden> ]
  * Merge from debian unstable (LP: #680474). Remaining changes:
    - debian/patches/fix_ftbfs_with_gcc4.5.patch
      + Correctly declare lrintf in libfaad/common.h to avoid a conflict of
        declaration in mathcalls.h to fix FTBFS on i386

  [ Bhavani Shankar <email address hidden> ]
  * Remove useless chunk from the patch I created above to fix FTBFS
    which happened due to my mistake. Sigh!

Available diffs

Superseded in natty-release on 2010-11-23
faad2 (2.7-5ubuntu1) natty; urgency=low

  * debian/patches/fix_ftbfs_with_gcc4.5.patch
    - Correctly declare lrintf in libfaad/common.h to avoid a conflict of
      declaration in mathcalls.h to fix FTBFS on i386
 -- Bhavani Shankar <email address hidden>   Tue, 23 Nov 2010 12:35:27 +0530

Available diffs

Superseded in natty-release on 2010-11-23
faad2 (2.7-5) unstable; urgency=low

  * Update my e-mail address.
  * Apply SqueezeCenter patches from FreeBSD that enable streaming with
    BBCiPlayer and ezstream (LP: #470562).
  * Extend file name buffers for longer path names (LP: #475050).
 -- Ubuntu Archive Auto-Sync <email address hidden>   Mon,  22 Nov 2010 10:15:21 +0000

Available diffs

Superseded in natty-release on 2010-11-22
Obsolete in maverick-release on 2013-03-05
Obsolete in lucid-release on 2016-10-26
faad2 (2.7-4) unstable; urgency=low

  * debian/control: Do not build the shared libmp4ff library packages
    anymore (Closes: #550679).
  * Removed debian/patches/force-include-stdint_h.patch.
  * Removed debian/patches/libmp4ff-shared-lib.patch.
  * Removed debian/patches/70_automake-1.9.patch.
  * Added debian/README.source.
  * Bumped Standards-Version to 3.8.3.
  * Raised Build-Depends to debhelper (>= 7.0.50~), thanks lintian.
  * Removed debian/libmp4ff-dev.install and debian/libmp4ff0.install.
  * Removed libmp4ff0 from Depends for faad2-dbg.

Available diffs

Superseded in lucid-release on 2009-11-10
faad2 (2.7-2) unstable; urgency=low

  * upload to unstable.

Available diffs

Superseded in lucid-release on 2009-11-05
Obsolete in karmic-release on 2013-03-04
Obsolete in jaunty-release on 2013-02-28
Obsolete in intrepid-release on 2013-02-20
faad2 (2.6.1-3.1) unstable; urgency=high

  * Non-maintainer upload by the security team
  * Include upstream patch to fix heap overflow in the frontend code
    (Closes: #499899)

 -- William Grant <email address hidden>   Wed,  08 Oct 2008 14:17:39 +0100

Available diffs

Obsolete in hardy-updates on 2015-04-24
Obsolete in hardy-security on 2015-04-24
faad2 (2.6.1-2ubuntu0.1) hardy-security; urgency=low

  * SECURITY UPDATE: Heap-based buffer overflow in the decodeMP4file function
    (frontend/main.c) in FAAD2 before 2.6.1 allows remote attackers to cause
    a denial of service (crash) and possibly execute arbitrary code via a
    crafted MPEG-4 (MP4) file. (Closes LP: #277110)
  * 12_heap_overflow.dpatch
    - Patch supplied by upstream to address vulnerability.
  * References
    http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2008-4201
    http://www.audiocoding.com/patch/main_overflow.diff
    CVE-2008-4201

 -- Stefan Lesicnik <email address hidden>   Thu, 02 Oct 2008 16:26:26 +0200

Available diffs

Obsolete in dapper-updates on 2011-09-06
Obsolete in dapper-security on 2011-09-06
faad2 (2.0.0+cvs20040908+mp4v2+bmp-0ubuntu3.6.06.1) dapper-security; urgency=low

  * SECURITY UPDATE: Heap-based buffer overflow in the decodeMP4file function
    (frontend/main.c) in FAAD2 before 2.6.1 allows remote attackers to cause
    a denial of service (crash) and possibly execute arbitrary code via a
    crafted MPEG-4 (MP4) file. (Closes LP: #277110)
  * 11_CVE-2008-4201.diff
    - Patch supplied by upstream modified slightly to patch cleanly
      and address vulnerability.
  * References
    http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2008-4201
    http://www.audiocoding.com/patch/main_overflow.diff
    CVE-2008-4201

 -- Stefan Lesicnik <email address hidden>   Fri, 03 Oct 2008 10:55:41 +0200
Obsolete in gutsy-updates on 2011-09-16
Obsolete in gutsy-security on 2011-09-16
faad2 (2.0.0+cvs20040908+mp4v2+bmp-0ubuntu5.1) gutsy-security; urgency=low

  * SECURITY UPDATE: Heap-based buffer overflow in the decodeMP4file function
    (frontend/main.c) in FAAD2 before 2.6.1 allows remote attackers to cause
    a denial of service (crash) and possibly execute arbitrary code via a
    crafted MPEG-4 (MP4) file. (Closes LP: #277110)
  * 11_CVE-2008-4201.diff
    - Patch supplied by upstream modified slightly to patch cleanly
      and address vulnerability.
  * References
    http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2008-4201
    http://www.audiocoding.com/patch/main_overflow.diff
    CVE-2008-4201

 -- Stefan Lesicnik <email address hidden>   Fri, 03 Oct 2008 10:46:07 +0200
Obsolete in feisty-updates on 2009-08-20
Obsolete in feisty-security on 2009-08-20
faad2 (2.0.0+cvs20040908+mp4v2+bmp-0ubuntu3.7.04.1) feisty-security; urgency=low

  * SECURITY UPDATE: Heap-based buffer overflow in the decodeMP4file function
    (frontend/main.c) in FAAD2 before 2.6.1 allows remote attackers to cause
    a denial of service (crash) and possibly execute arbitrary code via a
    crafted MPEG-4 (MP4) file. (Closes LP: #277110)
  * 11_CVE-2008-4201.diff
    - Patch supplied by upstream modified slightly to patch cleanly
      and address vulnerability.
  * References
    http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2008-4201
    http://www.audiocoding.com/patch/main_overflow.diff
    CVE-2008-4201

 -- Stefan Lesicnik <email address hidden>   Fri, 03 Oct 2008 10:55:41 +0200
Superseded in intrepid-release on 2008-10-08
faad2 (2.6.1-3) unstable; urgency=low

  * Closes: #479802: Update man page to reflect on raw PCM is supported on
    standard out. Also, have faad fail on trying to send non-raw PCM to
    standard out.
  * Apply new knowledge about the differences between hyphens, en-dashes, and
    em-dashes to man pages.
  * Move faad man page to patch system.
  * Update standards version.
  * Add license declarations and copyright declarations to copyright file.
    Tidy up authors.

 -- Ubuntu Archive Auto-Sync <email address hidden>   Mon,  23 Jun 2008 13:54:55 +0100

Available diffs

Superseded in intrepid-release on 2008-06-23
Obsolete in hardy-release on 2015-04-24
faad2 (2.6.1-2) unstable; urgency=low

  * Remove XMMS plugin as XMMS is being removed (Closes: #456724)

Superseded in hardy-release on 2008-02-13
Superseded in hardy-release on 2007-11-16
faad2 (2.6-1) unstable; urgency=low

  * Import new 2.6 release. Includes several small off-by-one scale
    fixes.
  * Update the copyright as new code includes a clarification of the license 
    text, which indicates that the entire work is under the GPLv2 (closes:
    #419339).

Superseded in hardy-release on 2007-11-05
Obsolete in gutsy-release on 2011-09-16
faad2 (2.0.0+cvs20040908+mp4v2+bmp-0ubuntu5) gutsy; urgency=low

  * 10_libmp4_sample_check.diff: fixed SIGSEGV while listening to m4a
    files (LP: 40043)
  * Update Maintainer field in debian/control

 -- Luca Falavigna <email address hidden>   Tue, 12 Jun 2007 13:17:39 +0200
Superseded in gutsy-release on 2007-06-14
faad2 (2.0.0+cvs20040908+mp4v2+bmp-0ubuntu4) gutsy; urgency=low

  * rebuild for libgcc2

 -- LaMont Jones <email address hidden>   Tue, 12 Jun 2007 06:53:25 -0600
Superseded in gutsy-release on 2007-06-12
Obsolete in feisty-release on 2009-08-20
Obsolete in edgy-release on 2008-06-19
Obsolete in dapper-release on 2011-09-06
Superseded in dapper-release on 2006-02-03
faad2 (2.0.0+cvs20040908+mp4v2+bmp-0ubuntu3) dapper; urgency=low


  * 01_systems.h.diff:
    + Fix the config.h include to mp4_config.h and copy config.h to
      /usr/include/mp4_config.h. Bad bad upstream

 -- Sebastian Dröge <email address hidden>  Wed,  9 Nov 2005 18:42:24 +0100
Obsolete in breezy-release on 2008-03-25
faad2 (2.0.0+cvs20040908+mp4v2+bmp-0ubuntu1) breezy; urgency=low


  * The "Go Open videos are playable now" release
  * Sync from CVS (newest version we can ship because of license changes)
  * Added bmp plugin and libmp4v2 to tarball
  * Added autotools stuff to tarball
  * Removed 01_bmp-plugin.diff, 02_Make.am.diff, 03_autoreconf.diff,
    05_option_w.diff, 08_amd64.diff
  * Updated 09_amd64.diff
  * Fixed the API to be compatible again with 2.0.0
  * libmp4ff isn't shipped by default anymore: for compatibility reasons we
    ship it

 -- Sebastian Dröge <email address hidden>  Wed,  7 Sep 2005 12:25:29 +0200
Obsolete in breezy-release on 2008-03-25
faad2 (2.0.0+cvs20040908+mp4v2+bmp-0ubuntu2) breezy; urgency=low


  * Added libmp4-0 to Conflicts/Replaces for libmp4v2-0

 -- Sebastian Dröge <email address hidden>  Sun,  9 Oct 2005 15:47:08 +0200
Obsolete in hoary-release on 2008-03-19
faad2 (2.0.0-0.3) unstable; urgency=low


  * Add libfaac-dev in Build-Depends.
  * Little hack to not build the mpeg4ip plugin.

 -- Christian Marillat <email address hidden>  Wed, 26 Jan 2005 07:36:25 +0100
Obsolete in warty-release on 2008-01-09
faad2 (2.0.0-0.1) unstable; urgency=low


  * Really apply my patch to link against -lm

 -- Christian Marillat <email address hidden>  Thu, 29 Jul 2004 15:48:22 +0200
131 of 31 results