Change log for facter package in Ubuntu

146 of 46 results
Published in cosmic-release on 2018-09-07
Deleted in cosmic-proposed (Reason: moved to release)
facter (3.11.0-1build2) cosmic; urgency=medium

  * No-change rebuild for cpp-hocon soname change.

 -- Matthias Klose <email address hidden>  Fri, 07 Sep 2018 17:06:41 +0200
Superseded in cosmic-proposed on 2018-09-07
facter (3.11.0-1build1) cosmic; urgency=medium

  * No-change rebuild for boost soname change.

 -- Matthias Klose <email address hidden>  Tue, 17 Jul 2018 12:55:33 +0000
Superseded in cosmic-release on 2018-09-07
Deleted in cosmic-proposed on 2018-09-08 (Reason: moved to release)
facter (3.11.0-1) unstable; urgency=medium

  * New upstream release
    + Refresh patches
    + Rename libfacter3.10.0 to libfacter3.11.0

 -- Apollon Oikonomopoulos <email address hidden>  Thu, 29 Mar 2018 13:13:41 +0300

Available diffs

Superseded in cosmic-release on 2018-05-06
Published in bionic-release on 2018-03-29
Deleted in bionic-proposed (Reason: moved to release)
facter (3.10.0-4) unstable; urgency=medium

  * Make facter compatible with RapidJSON 1.1 (Closes: #893351)

 -- Apollon Oikonomopoulos <email address hidden>  Mon, 19 Mar 2018 14:26:24 +0200

Available diffs

Superseded in bionic-release on 2018-03-29
Published in artful-release on 2017-04-20
Obsolete in zesty-release on 2018-06-22
Obsolete in yakkety-release on 2018-01-23
Published in xenial-release on 2016-02-01
Deleted in xenial-proposed (Reason: moved to release)
facter (2.4.6-1) unstable; urgency=medium

  * Imported upstream release 2.4.6

 -- Stig Sandbeck Mathisen <email address hidden>  Wed, 27 Jan 2016 22:09:18 +0100
Superseded in xenial-release on 2016-02-01
Superseded in xenial-release on 2015-10-24
Obsolete in wily-release on 2018-01-22
Obsolete in vivid-release on 2018-01-18
Deleted in vivid-proposed on 2018-01-22 (Reason: moved to release)
facter (2.3.0-0ubuntu1) vivid; urgency=medium

  * New upstream release
  * d/p/kvm-cpuinfo: updated
 -- Ryan Harper <email address hidden>   Wed, 21 Jan 2015 13:32:15 -0600

Available diffs

Superseded in vivid-release on 2015-01-22
Obsolete in utopic-release on 2016-11-03
Deleted in utopic-proposed on 2016-11-03 (Reason: moved to release)
facter (2.1.0-1ubuntu1) utopic; urgency=medium

  * Merge from Debian testing. Remaining changes:
    - d/control: virt-what is not in main, so move Depends to Suggests.
    - d/control, d/tests: add dep8 smoke test.
    - d/p/kvm-cpuinfo: detect "Common KVM processor" in /proc/cpuinfo as
      virtual (LP: #1170325).

Available diffs

Superseded in utopic-release on 2014-07-25
Deleted in utopic-proposed on 2014-07-26 (Reason: moved to release)
facter (2.0.1-1ubuntu1) utopic; urgency=medium

  * Merge from Debian testing. Remaining changes:
    - d/control: virt-what is not in main, so move Depends to Suggests.
    - d/control, d/tests: add dep8 smoke test.
    - d/p/kvm-cpuinfo: detect "Common KVM processor" in /proc/cpuinfo as
      virtual.
 -- Robie Basak <email address hidden>   Fri, 09 May 2014 18:10:31 +0000

Available diffs

Superseded in utopic-release on 2014-05-09
Published in trusty-release on 2014-02-18
Deleted in trusty-proposed (Reason: moved to release)
facter (1.7.5-1ubuntu1) trusty; urgency=medium

  * Merge from Debian unstable. Remaining changes:
    - d/control: virt-what is not in main, so move Depends to Suggests.
    - d/control, d/tests: add dep8 smoke test.
    - d/p/kvm-cpuinfo: detect "Common KVM processor" in /proc/cpuinfo as
      virtual (LP: #1170325).

Available diffs

Superseded in trusty-release on 2014-02-18
Deleted in trusty-proposed on 2014-02-20 (Reason: moved to release)
facter (1.7.3-1ubuntu1) trusty; urgency=medium

  * Merge from Debian unstable. Remaining changes:
    - d/control: virt-what is not in main, so move Depends to Suggests.
    - d/control, d/tests: add dep8 smoke test.
    - d/p/kvm-cpuinfo: detect "Common KVM processor" in /proc/cpuinfo as
      virtual (LP: #1170325).
 -- Robie Basak <email address hidden>   Tue, 21 Jan 2014 14:36:17 +0000

Available diffs

Superseded in trusty-release on 2014-01-21
Deleted in trusty-proposed on 2014-01-23 (Reason: moved to release)
facter (1.7.2-1ubuntu1) trusty; urgency=low

  * Merge from Debian unstable (LP: #1246416).  Remaining changes:
    - d/control: virt-what is not in main, so move Depends to Suggests.
    - d/control, d/tests: add dep8 smoke test.
    - d/p/kvm-cpuinfo: detect "Common KVM processor" in /proc/cpuinfo as
      virtual (LP: #1170325).
  * Move ruby-json back to Depends (dropping the delta with debian) as it
    is now in main.

Available diffs

Published in precise-updates on 2013-09-19
Deleted in precise-proposed (Reason: moved to -updates)
facter (1.6.5-1ubuntu1.2) precise; urgency=low

  * d/p/thread-critical-freeze: fix "puppet apply" hang by avoiding
    unnecessary thread critical sections (LP: #986973).
 -- Robie Basak <email address hidden>   Tue, 02 Jul 2013 03:21:36 +0000
Superseded in precise-proposed on 2013-07-18
facter (1.6.5-1ubuntu1.1) precise; urgency=low

  * d/p/kvm-cpuinfo: detect "Common KVM processor" in /proc/cpuinfo as virtual
    (LP: #1170325).
  * Add dep8 smoke test.
 -- Robie Basak <email address hidden>   Mon, 20 May 2013 10:59:11 +0000
Obsolete in quantal-updates on 2015-04-24
Deleted in quantal-proposed on 2015-05-01 (Reason: moved to -updates)
facter (1.6.9-2ubuntu1.12.10.1) quantal; urgency=low

  * d/p/kvm-cpuinfo: detect "Common KVM processor" in /proc/cpuinfo as virtual
    (LP: #1170325).
  * d/control: force build against ruby 1.8 to match the existing archive
    binary (LP: #1173265).
  * Add dep8 smoke test.
 -- Robie Basak <email address hidden>   Fri, 17 May 2013 12:35:40 +0000
Obsolete in raring-updates on 2015-04-24
Deleted in raring-proposed on 2015-04-27 (Reason: moved to -updates)
facter (1.6.9-2ubuntu1.13.04.1) raring; urgency=low

  * d/p/kvm-cpuinfo: detect "Common KVM processor" in /proc/cpuinfo as virtual
    (LP: #1170325).
  * d/control: force build against ruby 1.8 to match the existing archive
    binary (LP: #1173265).
  * Add dep8 smoke test.
 -- Robie Basak <email address hidden>   Mon, 20 May 2013 13:48:59 +0000
Superseded in trusty-release on 2013-10-30
Obsolete in saucy-release on 2015-04-24
Deleted in saucy-proposed on 2015-04-28 (Reason: moved to release)
facter (1.7.0-1ubuntu1) saucy; urgency=low

  * Merge from Debian unstable (LP: #1173265).  Remaining changes:
    - debian/control: ruby-json is not in main, so move Depends to Suggests.
  * Dropped changes:
    - gem2deb and ruby-pkg-tools are now in main:
      + use what we had in natty; we don't want ruby-pkg-tools
         in main. (LP: #408402)
      + Continue using ruby + libopenssl-ruby as Build-Depends even tho Debian
        has moved to gem2deb (not in main).
    - No longer necessary:
      + Use dh_prep instead of dh_clean, add build-arch + build-indep targets
    - Debian packaging now supports multiple Ruby versions:
      + Make binary package depend on ruby1.8 explicitly
    - Applied in Debian:
      + debian/patches/ubuntu_xen_print_virtual.patch: correctly detect
        xen0,xenu. (LP: #980291)
  * d/control: virt-what is not in main, so move Depends to Suggests.
  * d/control, d/tests: add dep8 smoke test.
  * d/p/kvm-cpuinfo: detect "Common KVM processor" in /proc/cpuinfo as virtual
    (LP: #1170325).

Available diffs

Superseded in saucy-release on 2013-05-24
Obsolete in raring-release on 2015-04-24
Obsolete in quantal-release on 2015-04-24
facter (1.6.9-2ubuntu1) quantal; urgency=low

  * Merge from Debian unstable (LP: #1007560).  Remaining changes:
    - debian/rules:
      + use what we had in natty; we don't want ruby-pkg-tools
         in main. (LP: #408402)
      + Use dh_prep instead of dh_clean, add build-arch + build-indep targets
    - debian/control:
      + Continue using ruby + libopenssl-ruby as Build-Depends even tho Debian
        has moved to gem2deb (not in main). Move ruby-json to Suggests.
      + Make binary package depend on ruby1.8 explicitly
  * debian/patches/ubuntu_xen_print_virtual.patch: correctly detect
    xen0,xenu. (LP: #980291)

Available diffs

Superseded in quantal-release on 2012-06-01
Published in precise-release on 2012-02-13
facter (1.6.5-1ubuntu1) precise; urgency=low

  * Merge from Debian testing.  Remaining changes:
    - debian/rules: use what we had in natty; we don't want ruby-pkg-tools
      in main. (LP: #408402)
    - debian/control: Continue using ruby + libopenssl-ruby as Build-Depends
      even tho Debian has moved to gem2deb (not in main). Move ruby-json to
      Suggests.
    - debian/rules: Use dh_prep instead of dh_clean, add build-arch +
      build-indep targets
    - debian/control: Make binary package depend on ruby1.8 explicitly

Available diffs

Superseded in precise-release on 2012-02-13
facter (1.6.4-2ubuntu1) precise; urgency=low

  * Merge from Debian testing (LP: #922788). Remaining changes:
    - debian/rules: use what we had in natty; we don't want ruby-pkg-tools
      in main. (LP: #408402)
    - debian/control: Continue using ruby + libopenssl-ruby as Build-Depends
      even tho Debian has moved to gem2deb (not in main). Move ruby-json to
      Suggests.
    - debian/rules: Use dh_prep instead of dh_clean, add build-arch +
      build-indep targets
    - debian/control: Make binary package depend on ruby1.8 explicitly.
  * Dropped changes:
    - debian/control: Update debhelper Build-Depends to 8 (Updated in Debian)

Available diffs

Superseded in precise-release on 2012-01-30
facter (1.6.2-1ubuntu1) precise; urgency=low

  * Merge from Debian testing (LP: #888671).  Remaining changes:
    - debian/rules: use what we had in natty; we don't want ruby-pkg-tools
      in main. (LP: #408402)
    - debian/control: Continue using ruby + libopenssl-ruby as Build-Depends
      even tho Debian has moved to gem2deb (not in main). Move ruby-json to
      Suggests.
  * debian/rules: Use dh_prep instead of dh_clean, add build-arch + build-indep
    targets
  * debian/control: Update debhelper Build-Depends to 8, make binary package
    depend on ruby1.8 explicitly.

Available diffs

Obsolete in lucid-updates on 2016-10-26
Deleted in lucid-proposed on 2016-11-01 (Reason: moved to -updates)
facter (1.5.6-2ubuntu2.3) lucid-proposed; urgency=low

  * lib/facter/ec2.rb: Rescue condition in can_connect() when timeout()
    actually has a chance to timeout. (LP: #885998)
 -- Adam Gandelman <email address hidden>   Mon, 07 Nov 2011 10:18:18 -0800
Obsolete in maverick-updates on 2013-03-05
Deleted in maverick-proposed on 2013-03-05 (Reason: moved to -updates)
facter (1.5.7-1ubuntu1.3) maverick-proposed; urgency=low

  * lib/facter/ec2.rb: Rescue condition in can_connect() when timeout()
    actually has a chance to timeout. (LP: #885998)
 -- Adam Gandelman <email address hidden>   Mon, 07 Nov 2011 10:27:58 -0800
Obsolete in natty-updates on 2013-06-04
Deleted in natty-proposed on 2013-06-04 (Reason: moved to -updates)
facter (1.5.8-2ubuntu2.2) natty-proposed; urgency=low

  * debian/patches/fix_ec2_metadata_facts.patch: Refreshed to rescue condition
    in can_connect() when timeout() actually has a chance to timeout.
    (LP: #885998)
 -- Adam Gandelman <email address hidden>   Mon, 07 Nov 2011 10:47:01 -0800
Superseded in maverick-updates on 2011-11-08
Superseded in maverick-proposed on 2011-11-08
facter (1.5.7-1ubuntu1.2) maverick-proposed; urgency=low

  * lib/facter/ec2.rb: Properly handle ip+port when testing connectivity
    of ec2 metadata service.(LP: #732953)
  * lib/facter/util/collection.rb: Backported fix from upstream commit
    2255abee7bdb9b6478ca228546e3d275dbac0ec3. Reload all facts if the
    requested fact is not found.  Ensures consistency after facts
    have been cleared. (LP: #876130)
 -- Adam Gandelman <email address hidden>   Tue, 25 Oct 2011 10:43:54 -0700
Superseded in lucid-updates on 2011-11-08
Superseded in lucid-proposed on 2011-11-08
facter (1.5.6-2ubuntu2.2) lucid-proposed; urgency=low

  * lib/facter/ec2.rb: Properly handle ip+port when testing connectivity
    of ec2 metadata service.(LP: #732953)
  * lib/facter/util/collection.rb: Backported fix from upstream commit
    2255abee7bdb9b6478ca228546e3d275dbac0ec3. Reload all facts if the
    requested fact is not found.  Ensures consistency after facts
    have been cleared. (LP: #876130)
 -- Adam Gandelman <email address hidden>   Tue, 25 Oct 2011 10:28:17 -0700
Obsolete in oneiric-updates on 2015-04-24
Deleted in oneiric-proposed on 2015-04-26 (Reason: moved to -updates)
facter (1.5.9-1ubuntu1.1) oneiric-proposed; urgency=low

  * debian/patches/reload_all_facts.patch: Reload all facts if the
    requested fact is not found.  Ensures consistency after facts
    have been cleared. (LP: #876130)
 -- Adam Gandelman <email address hidden>   Tue, 18 Oct 2011 16:23:06 -0700
Superseded in natty-updates on 2011-11-08
Superseded in natty-proposed on 2011-11-08
facter (1.5.8-2ubuntu2.1) natty-proposed; urgency=low

  * debian/patches/reload_all_facts.patch: Reload all facts if the
    requested fact is not found.  Ensures consistency after facts
    have been cleared. (LP: #876130)
  * debian/patches/fix_ec2_metadata_facts.patch: Properly handle ip+port
    when testing connectivity of ec2 metadata service.(LP: #732953)
 -- Adam Gandelman <email address hidden>   Thu, 20 Oct 2011 10:40:35 -0700
Superseded in precise-release on 2011-11-27
facter (1.6.1-1ubuntu1) precise; urgency=low

  * Merge from Debian unstable (LP: #877621). Remaining changes:
    - debian/rules: use what we had in natty; we dont want ruby-pkg-tools
      in main. (LP: #408402)
  * debian/control: Continue using ruby + libopenssl-ruby as Build-Depends
    even tho Debian has moved to gem2deb (not in main). Move ruby-json to
    Suggests.

Available diffs

Superseded in precise-release on 2011-10-18
Obsolete in oneiric-release on 2015-04-24
facter (1.5.9-1ubuntu1) oneiric; urgency=low

  * Merge from debian unstable (LP: #788284).  Remaining changes:
    - Dropped ruby-pkg-tools and libsetup-ruby1.8; debian/rules: use what we
      had in natty; we dont want ruby-pkg-tools in main. (LP: #408402)
  * Dropped changes to lib/facter/ec2.rb. (Use the latest-meta api so it
    always does not retunr false). This was fixed upstream.

Available diffs

Superseded in oneiric-release on 2011-05-27
Obsolete in natty-release on 2013-06-04
facter (1.5.8-2ubuntu2) natty; urgency=low

  * lib/facter/ec2.rb: Use the latest-meta api so it always
    does not return false. (LP: #732953)
 -- Chuck Short <email address hidden>   Mon, 04 Apr 2011 11:34:30 -0400

Available diffs

Superseded in maverick-updates on 2011-11-07
Deleted in maverick-proposed on 2011-11-08 (Reason: moved to -updates)
facter (1.5.7-1ubuntu1.1) maverick-proposed; urgency=low

  * Cherry-picked KVM detection for 'virtual' fact from upstream commit
    62b6773a63bb96273fbc. (LP: #708080).
 -- Oliver Brakmann <email address hidden>   Thu, 27 Jan 2011 19:03:10 +0100
Superseded in lucid-updates on 2011-11-07
Deleted in lucid-proposed on 2011-11-08 (Reason: moved to -updates)
facter (1.5.6-2ubuntu2.1) lucid-proposed; urgency=low

  * Cherry-picked KVM detection for 'virtual' fact from upstream commit
    62b6773a63bb96273fbc. (LP: #708080).
 -- Oliver Brakmann <email address hidden>   Wed, 26 Jan 2011 21:36:23 +0100

Available diffs

Superseded in natty-release on 2011-04-04
facter (1.5.8-2ubuntu1) natty; urgency=low

  * Merge from debian unstable.  Remaining changes:
    - Dropped ruby-pkg-tools and libsetup-ruby1.8, we dont want ruby-pkg-tools
      in main. (LP: #408402)

Available diffs

Superseded in natty-release on 2011-02-08
facter (1.5.7-3ubuntu1) natty; urgency=low

  * Merge from debian unstable, remaining changes are:
    - Dropped ruby-pkg-tools and libsetup-ruby1.8, we dont want ruby-pkg-tools
      in main. (LP: #408402)
 -- Chuck Short <email address hidden>   Mon, 10 Jan 2011 11:25:00 -0500

Available diffs

Superseded in natty-release on 2011-01-10
Obsolete in maverick-release on 2013-03-05
facter (1.5.7-1ubuntu1) maverick; urgency=low

  * Merge from debian testing.  Remaining changes:
    - Dropped ruby-pkg-tools, and libsetup-ruby1.8, and cdbs, use what
      we had in lucid. Since we dont want ruby-pkg-tools in main
      (LP: #408402)

Available diffs

Superseded in maverick-release on 2010-05-18
Obsolete in lucid-release on 2016-10-26
facter (1.5.6-2ubuntu2) lucid; urgency=low

  * Dropped ruby-pkg-tools, and libsetup-ruby1.8, and cdbs, use what
    we had in karmic. Since we dont want ruby-pkg-tools in main.
    (LP: #408402)
 -- Chuck Short <email address hidden>   Fri, 26 Mar 2010 08:34:25 -0400

Available diffs

Superseded in lucid-release on 2010-03-26
facter (1.5.6-2ubuntu1) lucid; urgency=low

  * Merge from debian testing, remaining changes:
    - Use bind9-host9 only.

Available diffs

Superseded in lucid-release on 2010-01-29
Obsolete in karmic-release on 2013-03-04
Superseded in karmic-release on 2009-09-23
facter (1.5.4-1ubuntu1) karmic; urgency=low

  * Use bind9-host9 only.

 -- Chuck Short <email address hidden>   Mon, 03 Aug 2009 09:51:59 -0400

Available diffs

Superseded in karmic-release on 2009-08-03
facter (1.5.4-1) unstable; urgency=low

  [ Nigel Kersten ]
  * New upstream release
  * Switch maintainer to pkg-puppet-devel list
  * Modify uploaders
  * Update watch file regexp to exclude release canditate tarballs
  * Use upstream install.rb script to build rather than copying manually

  [ Andrew Pollock ]
  * debian/control: add libopenssl-ruby to build dependencies
  * debian/control: bump Standards-Version (no changes)
  * debian/compat: increase to 5
  * debian/control: add pciutils and ${misc:Depends} to dependencies

 -- Ubuntu Archive Auto-Sync <email address hidden>   Tue,  28 Apr 2009 23:03:14 +0100

Available diffs

Superseded in karmic-release on 2009-04-28
Obsolete in jaunty-release on 2013-02-28
facter (1.5.1-0.1) unstable; urgency=low

  * Non-maintainer upload
  * New upstream release to fix zombie problem (Closes: #497363)

Available diffs

Obsolete in gutsy-backports on 2011-09-16
facter (1.3.8-1~gutsy1) gutsy-backports; urgency=low

  * Automated backport upload; no source changes.

Obsolete in feisty-backports on 2009-08-20
facter (1.3.8-1~feisty1) feisty-backports; urgency=low

  * Automated backport upload; no source changes.

Superseded in jaunty-release on 2008-11-05
Obsolete in intrepid-release on 2013-02-20
Obsolete in hardy-release on 2015-04-24
facter (1.3.8-1) unstable; urgency=low

  * New upstream release.
  * Add 4.0/etch as a new entry in the debianversion fact.
  * Unfutz the debianversion fact so it doesn't annoy us with it's
    "constant already defined" whining.

 -- Ubuntu Archive Auto-Sync <email address hidden>   Tue,  23 Oct 2007 16:05:27 +0100
Superseded in hardy-release on 2007-10-23
Obsolete in gutsy-release on 2011-09-16
facter (1.3.7-1) unstable; urgency=low

  * New upstream release.  Closes: #418967.
  * Add dependency on net-tools (for ifconfig).  Closes: #415899.
  * Add a new 'debianversion' fact.  Closes: #378895.  Thanks to David
    Schmitt for the patch.
  * Add a dependency on host | bind9-host (for host).  Closes: #403109.

 -- Ubuntu Archive Auto-Sync <email address hidden>   Thu,  26 Apr 2007 23:49:43 +0100
Superseded in gutsy-release on 2007-04-27
Obsolete in feisty-release on 2009-08-20
facter (1.3.5-1) unstable; urgency=low

  * New upstream release.

 -- Ubuntu Archive Auto-Sync <email address hidden>   Mon,  13 Nov 2006 16:34:34 +0000
Superseded in feisty-release on 2006-11-13
Obsolete in edgy-release on 2008-06-19
facter (1.3.3-1) unstable; urgency=low

  * New upstream release.

146 of 46 results