fai-setup fails because of a file conflict

Bug #34366 reported by Xavier Claessens on 2006-03-10
8
Affects Status Importance Assigned to Milestone
fai (Ubuntu)
High
Reinhard Tartler

Bug Description

Here is the error message when running fai-setup:

Configuration file `/etc/dhcp3/dhclient-script'
 ==> Deleted (by you or by a script) since installation.
 ==> Package distributor has shipped an updated version.
   What would you like to do about it ? Your options are:
    Y or I : install the package maintainer's version
    N or O : keep your currently-installed version
      D : show the differences between the versions
      Z : background this process to examine the situation
 The default action is to keep your current version.
*** dhclient-script (Y/I/N/O/D/Z) [default=N] ? dpkg: error processing fai-nfsroot (--configure):
 EOF on stdin at conffile prompt
Errors were encountered while processing:
 fai-nfsroot
E: Sub-process /usr/bin/dpkg returned an error code (1)

The problem seems that deboostrap provide this config file and fai-nfsroot want to install another version of this file. Since fai-setup is runned in non-interactive mode we can't answer the question and then it fails.

Revision history for this message
Xavier Claessens (zdra) wrote :

I read /usr/sbin/make-fai-nfsroot script to see what's going on. I see that packages are installed by the following command:

$ROOTCMD apt-get -y --fix-missing install $packages </dev/null

So there is the -y option that should avoid that kind of problem... Tried with --force-yes and it doesn't works neither. I removed the </dev/null and know fai-setup stops and ask me if I want to overwrite the config file, I simply say "Y" and it works.

I don't understand what's the problem...

Revision history for this message
Henning Sprang (henning) wrote :

Yes, fai-nfsroot, a package that is NEVER to be installed in a normal system, does contain files which conflict witrh other files in the dhcp3-client package.

However, FAI normally tries to exclude the dhcp3-client package in the debootstrap call, but it seems that Ubuntu debootstrap ignores this request, which in turn leads to conflicts when after debootstrapping the fai-nfsroot package is installed in the nfsroot

These problems don't exist in Debian stable.

Possible solutions:
- make debootstrapo behave correctly and exclude dhcp3-client if specified to do so.

- remove the conflicting files from fai-nfsroot (but they have to be put at that location somehow, then, because they are required to let installatrions work)

other things to check:
- check Debian testing and Debian sid behaviour - does their debootstrap behave different?
- why, in the first place, does debootstrap define dhcp3-client as an essential package?

Revision history for this message
Henning Sprang (henning) wrote :

I can confirm this problem, and I think it's a major bugm, because it renders the package unusable

Changed in fai:
status: Unconfirmed → Confirmed
Revision history for this message
Xavier Claessens (zdra) wrote :

the problem is that debootstrap wants ubuntu-minimal which depends on dhcp3-client. So if you exclude dhcp3-client it will be added back to resolv depedencies.

I don't know how to solve that problem, but it seems to be ubuntu specific.

Revision history for this message
Reinhard Tartler (siretart) wrote :

Changes:
 fai (2.9.1ubuntu1) dapper; urgency=low
 .
   * do a really nasty hack to work around Malone #34366
   * adjusted config files to point to ubuntu locations
   * fix make-fai-nfsroot to detect kernel revision properly
     (Closes: Malone #43989)

Changed in fai:
assignee: nobody → siretart
status: Confirmed → Fix Committed
Revision history for this message
Reinhard Tartler (siretart) wrote :

reopen if my workaround causes other problems

Changed in fai:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers