Ubuntu

“ffmpeg-debian” 3:0.svn20080206-12ubuntu3.2 source package in Ubuntu

Changelog

ffmpeg-debian (3:0.svn20080206-12ubuntu3.2) intrepid-security; urgency=low

  * SECURITY UPDATE: Fix a multitude of security issues
    - debian/patches/CVE-2009-46XX/security-issue03.patch: check stream
      existence before assignment
    - debian/patches/CVE-2009-46XX/security-issue04.patch: check submap
      indexes
    - debian/patches/CVE-2009-46XX/security-issue05.patch: check classbook
      value
    - debian/patches/CVE-2009-46XX/security-issue06.patch: add checks for
      per-packet mode indexes and per-header mode mapping indexes
    - debian/patches/CVE-2009-46XX/security-issue07.patch: check masterbook
      index and subclass book index.
    - debian/patches/CVE-2009-46XX/security-issue08.patch: check
      res_setup->books
    - debian/patches/CVE-2009-46XX/security-issue09.patch: check
      begin/end/partition_size
    - debian/patches/CVE-2009-46XX/security-issue10.patch: check validity
      of channels & samplerate
    - debian/patches/CVE-2009-46XX/security-issue11.patch: fix book_idx
      check
    - debian/patches/CVE-2009-46XX/security-issue12.patch: sanity checks
      for magnitude and angle
    - debian/patches/CVE-2009-46XX/security-issue13.patch: fix = -> == typo
    - debian/patches/CVE-2009-46XX/security-issue14.patch: check dimensions
      against 0 too
    - debian/patches/CVE-2009-46XX/security-issue15.patch: fix
      init_get_bits() buffer size
    - debian/patches/CVE-2009-46XX/security-issue17.patch: make sure that
      all memory allocations succeed
    - debian/patches/CVE-2009-46XX/security-issue18.patch: fix possible
      buffer over-read in vorbis_comment
    - debian/patches/CVE-2009-46XX/security-issue19.patch: set data_size to
      0 to avoid having it uninitialized
    - debian/patches/CVE-2009-46XX/security-issue20.patch: disable parsing
      for ogg streams where no ogg header was found
    - debian/patches/CVE-2009-46XX/security-issue22.patch: check codec_id
      and codec_type, make sure priv_data is freed and codec is set to NULL
    - CVE-2009-4632
    - CVE-2009-4633
    - CVE-2009-4634
    - CVE-2009-4635
    - CVE-2009-4637
    - CVE-2009-4639
    - CVE-2009-4640
 -- Marc Deslauriers <email address hidden>   Thu, 08 Apr 2010 09:13:16 -0400

Upload details

Uploaded by:
Marc Deslauriers on 2010-04-08
Uploaded to:
Intrepid
Original maintainer:
Reinhard Tartler
Component:
main
Architectures:
any
Section:
libs
Urgency:
Low Urgency

See full publishing history Publishing

Series Pocket Published Component Section

Downloads

File Size MD5 Checksum
ffmpeg-debian_0.svn20080206.orig.tar.gz 2.8 MiB 3c21869969f2490ec73bb2dbea37f205
ffmpeg-debian_0.svn20080206-12ubuntu3.2.diff.gz 40.9 KiB 5247e89dd7791662fb1b7206fa47a768
ffmpeg-debian_0.svn20080206-12ubuntu3.2.dsc 1.9 KiB 752021eeead9a8f85985372e8c288c26

Binary packages built by this source

ffmpeg: multimedia player, server and encoder

 This package contains the ffplay multimedia player, the ffserver streaming
 server and the ffmpeg audio and video encoder. They support most existing
 file formats (AVI, MPEG, OGG, Matroska, ASF...) and encoding formats (MPEG,
 DivX, MPEG4, AC3, DV...).

ffmpeg-dbg: No summary available for ffmpeg-dbg in ubuntu intrepid.

No description available for ffmpeg-dbg in ubuntu intrepid.

ffmpeg-doc: No summary available for ffmpeg-doc in ubuntu intrepid.

No description available for ffmpeg-doc in ubuntu intrepid.

libavcodec-dev: development files for libavcodec

 This is the codec library from the ffmpeg project. It supports most existing
 encoding formats (MPEG, DivX, MPEG4, AC3, DV...).
 .
 This package contains the header files and static libraries needed to
 compile applications or shared objects that use libavcodec.

libavcodec51: No summary available for libavcodec51 in ubuntu intrepid.

No description available for libavcodec51 in ubuntu intrepid.

libavdevice-dev: No summary available for libavdevice-dev in ubuntu intrepid.

No description available for libavdevice-dev in ubuntu intrepid.

libavdevice52: No summary available for libavdevice52 in ubuntu intrepid.

No description available for libavdevice52 in ubuntu intrepid.

libavformat-dev: development files for libavformat

 This is the demuxer library from the ffmpeg project. It supports most
 existing file formats (AVI, MPEG, OGG, Matroska, ASF...).
 .
 This package contains the header files and static libraries needed to
 compile applications or shared objects that use libavformat.

libavformat52: No summary available for libavformat52 in ubuntu intrepid.

No description available for libavformat52 in ubuntu intrepid.

libavutil-dev: development files for libavutil

 This is the common utility library from the ffmpeg project. It is required
 by all other ffmpeg libraries.
 .
 This package contains the header files and static libraries needed to
 compile applications or shared objects that use libavutil.

libavutil49: No summary available for libavutil49 in ubuntu intrepid.

No description available for libavutil49 in ubuntu intrepid.

libpostproc-dev: development files for libpostproc

 This is the video postprocessing library from the ffmpeg project.
 .
 This package contains the header files and static libraries needed to
 compile applications or shared objects that use libpostproc.

libpostproc51: No summary available for libpostproc51 in ubuntu intrepid.

No description available for libpostproc51 in ubuntu intrepid.

libswscale-dev: development files for libswscale

 This is the video scaling library from the ffmpeg project.
 .
 This package contains the header files and static libraries needed to
 compile applications or shared objects that use libswscale.

libswscale0: No summary available for libswscale0 in ubuntu intrepid.

No description available for libswscale0 in ubuntu intrepid.