filelight crashes on exit

Bug #30754 reported by Michael Blakeley on 2006-02-07
30
Affects Status Importance Assigned to Milestone
filelight (Debian)
Fix Released
Unknown
filelight (Ubuntu)
Medium
MOTU

Bug Description

Filelight is an extremely useful and cool tool, but it crashes every time on exit (breezy + updates, kubuntu-desktop, x86).

I believe that the package probably needs an update to fix this:

$ apt-show-versions -a filelight
filelight 0.99beta6-0ubuntu3 install ok installed
No unstable version
filelight 0.99beta6-0ubuntu3 unknown
filelight/unknown uptodate 0.99beta6-0ubuntu3

$ filelight --version
Qt: 3.3.4
KDE: 3.5.1
Filelight: 1.0-beta4

The latest (http://www.methylblue.com/filelight/#packages) is 1.0-beta6, and is supposed to fix many crashing bugs. This could be one of them.

Here's the crash info, though I don't think it'll be very helpful:

(no debugging symbols found)
Using host libthread_db library "/lib/tls/i686/cmov/libthread_db.so.1".
(no debugging symbols found)
`system-supplied DSO at 0xffffe000' has disappeared; keeping its symbols.
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[Thread debugging using libthread_db enabled]
[New Thread -1231939360 (LWP 7247)]
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[KCrash handler]
#6 0xffffe410 in __kernel_vsyscall ()
#7 0xb6d1c9b1 in raise () from /lib/tls/i686/cmov/libc.so.6
#8 0xb6d1e2c9 in abort () from /lib/tls/i686/cmov/libc.so.6
#9 0xb6d506ea in __fsetlocking () from /lib/tls/i686/cmov/libc.so.6
#10 0xb6d56f54 in malloc_trim () from /lib/tls/i686/cmov/libc.so.6
#11 0xb6d572ca in free () from /lib/tls/i686/cmov/libc.so.6
#12 0xb6ed8c71 in operator delete () from /usr/lib/libstdc++.so.6
#13 0xb66ae3d6 in KParts::GenericFactory<Filelight::Part>::~GenericFactory ()
   from /usr/lib/kde3/libfilelight.so
#14 0xb77b2b7b in KLibrary::~KLibrary () from /usr/lib/libkdecore.so.4
#15 0xb77b32dc in KLibLoader::close_pending () from /usr/lib/libkdecore.so.4
#16 0xb77b36fb in KLibLoader::~KLibLoader () from /usr/lib/libkdecore.so.4
#17 0xb775c386 in KLibLoader::cleanUp () from /usr/lib/libkdecore.so.4
#18 0xb77fd024 in KApplication::~KApplication () from /usr/lib/libkdecore.so.4
#19 0x08054234 in KCompletionBase::setAutoDeleteCompletionObject ()
#20 0xb6d08ea2 in __libc_start_main () from /lib/tls/i686/cmov/libc.so.6
#21 0x08050901 in ?? ()

Michael Blakeley (mike+ubuntu) wrote :
Download full text (3.6 KiB)

Filelight is an extremely useful and cool tool, but it crashes every time on exit (breezy + updates, kubuntu-desktop, x86).

I believe that the package probably needs an update to fix this:

$ apt-show-versions -a filelight
filelight 0.99beta6-0ubuntu3 install ok installed
No unstable version
filelight 0.99beta6-0ubuntu3 unknown
filelight/unknown uptodate 0.99beta6-0ubuntu3

$ filelight --version
Qt: 3.3.4
KDE: 3.5.1
Filelight: 1.0-beta4

The latest (http://www.methylblue.com/filelight/#packages) is 1.0-beta6, and is supposed to fix many crashing bugs. This could be one of them.

Here's the crash info, though I don't think it'll be very helpful:

(no debugging symbols found)
Using host libthread_db library "/lib/tls/i686/cmov/libthread_db.so.1".
(no debugging symbols found)
`system-supplied DSO at 0xffffe000' has disappeared; keeping its symbols.
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[Thread debugging using libthread_db enabled]
[New Thread -1231939360 (LWP 7247)]
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[KCrash handler]
#6 0xffffe410 in __kernel_vsyscall ()
#7 0xb6d1c9b1 in raise () from /lib/tls/i686/cmov/libc.so.6
#8 0xb6d1e2c9 in abort () from /lib/tls/i686/cmov/libc.so.6
#9 0xb6d506ea in __fsetlocking () from /lib/tls/i686/cmov/libc.so.6
#10 0xb6d56f54 in malloc_trim () from /lib/tls/i686/cmov/libc.so.6
#11 0xb6d572ca in free () from /lib/tls/i686/cmov/libc.so.6
#12 0xb6ed8c71 in operator delete () from /usr/lib/libstdc++.so.6
#13 0xb66ae3d6 in KParts::GenericFactory<Filelight::Part>::~GenericFactory ()
   from /usr/lib/kde3/libfilelight.so
#14 0xb77b2b7b in KLibrary::~KLibrary () from /usr/lib/libkdecore.so.4
#15 0xb77b32dc...

Read more...

Changed in filelight:
assignee: nobody → motu

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Hi,

filelight also crashes for me on exit. Attached is a backtrace from the
kcrash handler.

Regards,
  Bastian
- --
  ,''`. Bastian Kleineidam
 : :' : GnuPG Schlüssel
 `. `' gpg --keyserver wwwkeys.pgp.net --recv-keys 32EC6F3E
   `-

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.2 (GNU/Linux)
Comment: Using GnuPG with Thunderbird - http://enigmail.mozdev.org

iD8DBQFEA3H5eBwlBDLsbz4RAnbYAJ4+BDwlBYJz3SCEBARTUfGxyJ81iQCfcnVK
N0Br4W9GaIMV1t8Gx2EQcBk=
=BO1Q
-----END PGP SIGNATURE-----

Download full text (4.6 KiB)

Package: filelight
Version: 0.99beta6-1+b1
Followup-For: Bug #343903

i can also duplicate this bug:

[dkg@squeak ~]$ mkdir empty
[dkg@squeak ~]$ filelight empty/
kbuildsycoca running...
filelight: FSTAB: proc
filelight: FSTAB: ext3
filelight: FSTAB: swap
filelight: FSTAB: tmpfs
filelight: FSTAB: ext3
filelight: FSTAB: ext3
filelight: FSTAB: ext3
filelight: FSTAB: auto
filelight: Scan requested for: file:///home/dkg/empty/
filelight: >> bool RadialMap::Map::resize(const QRect&)
filelight: >> bool RadialMap::Map::resize(const QRect&)
filelight: >> void RadialMap::Map::make(const Directory*, bool)
filelight: >> void RadialMap::Map::setRingBreadth()
filelight: >> void RadialMap::Map::colorise()
filelight: >> void RadialMap::Map::paint(unsigned int)
filelight: >> void RadialMap::Map::make(const Directory*, bool)
filelight: >> void RadialMap::Map::setRingBreadth()
filelight: >> void RadialMap::Map::colorise()
filelight: >> void RadialMap::Map::paint(unsigned int)
*** glibc detected *** free(): invalid pointer: 0xb66b5ac0 ***
KCrash: Application 'filelight' crashing...
[dkg@squeak ~]$

and the backtrace offered by KCrash shows the following:

(no debugging symbols found)
Using host libthread_db library "/lib/tls/libthread_db.so.1".
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[Thread debugging using libthread_db enabled]
[New Thread -1232255296 (LWP 14687)]
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[KCrash handler]
#5 0xb6ceb7c7 in raise () from /lib/tls/libc.so.6
#6 0xb6ced06b in abort () from /lib/tls/libc.so.6
#7 0xb6d22545 in __fsetlocking () from /lib/tls/libc.so.6
#8 0xb6d28b97 in malloc_usable_size () from /lib/tls/libc.so.6
#9 0xb6d29032 in free () from /...

Read more...

Vassilis Pandis (pandisv) wrote :

I can confirm this. It has not been fixed in the latest beta ( I compiled from source). This also affects Debian. There are two bugs similar to yours there but none of them (including yours) have debugging symbols so I can't be too sure. If somebody knows better, please correct me.

Changed in filelight:
status: Unconfirmed → Confirmed
arild (info-abergh) wrote :

Still there in Kubuntu 6.06 LTS Release Candidate...

dan (silkworm0) wrote :

Also can confirm. Identical backtrace. Kubuntu 6.06 with all updates.

Vassilis Pandis (pandisv) wrote :

I forwarded the problem to the developer via e-mail.

Max Howell (max-howell) wrote :

Hi, I'm the developer.

This is fixed in SVN, I'll try to release his weekend as I already promised someone else. But if I don't (I hae a busy weekend), you may like to checkout SVN and release that. Thanks,

Max

Changed in filelight:
status: Unconfirmed → Confirmed

#
# bts-link upstream status pull for source package filelight
# see http://lists.debian.org/debian-devel-announce/2006/05/msg00001.html
#

user <email address hidden>

# remote status report for #343903
# * http://bugs.kde.org/show_bug.cgi?id=132679
# * remote status changed: (?) -> RESOLVED
# * remote resolution changed: (?) -> FIXED
# * closed upstream
tags 343903 + fixed-upstream
usertags 343903 + status-RESOLVED resolution-FIXED

# remote status report for #356626
# * http://bugs.kde.org/show_bug.cgi?id=132679
# * remote status changed: (?) -> RESOLVED
# * remote resolution changed: (?) -> FIXED
# * closed upstream
tags 356626 + fixed-upstream
usertags 356626 + status-RESOLVED resolution-FIXED

thanks

Fixed for 1.0, thanks,

Max Howell

Vassilis Pandis (pandisv) wrote :

Filelight 1.0 has been released but is not in Debian yet.

Pascal (pascaldekloe) wrote :

Filelight 1.0 was released at 19/08/2006.

Please? :)

Michael Blakeley (mike+ubuntu) wrote :

Still crashes on exit in edgy, but the trace is different:

0x00002ac2865aec71 in nanosleep () from /lib/libc.so.6
#0 0x00002ac2865aec71 in nanosleep () from /lib/libc.so.6
#1 0x00002ac2865aea94 in sleep () from /lib/libc.so.6
#2 0x00002ac285587375 in KCrash::startDrKonqi ()
   from /usr/lib/libkdecore.so.4
#3 0x00002ac28559b6d7 in KCrash::defaultCrashHandler ()
   from /usr/lib/libkdecore.so.4
#4 0x00002ac28654a510 in killpg () from /lib/libc.so.6
#5 0x0000000000000000 in ?? ()

$ apt-show-versions filelight
filelight/edgy uptodate 0.99beta6-1ubuntu1

Jeremy Kerr (jk-ozlabs) wrote :

My crash on edgy (filelight version 0.99beta6-1ubuntu1) looks like this:

(C++ function names have been demangled)

*** glibc detected *** filelight: free(): invalid pointer: 0x0ddefac0 ***
======= Backtrace: =========
/lib/libc.so.6[0xe9ca2e4]
/lib/libc.so.6(__libc_free+0xc8)[0xe9cbe48]
/usr/lib/libstdc++.so.6(operator delete(void*)+0x18)[0xeb83988]
/usr/lib/kde3/libfilelight.so(KParts::GenericFactory<Filelight::Part>::~GenericFactory()+0x58)[0xddc95ec]
/usr/lib/libkdecore.so.4(KLibrary::~KLibrary()+0x84)[0xf6f4b38]
/usr/lib/libkdecore.so.4(KLibLoader::close_pending(KLibWrapPrivate*)+0xe0)[0xf6f3f94]
/usr/lib/libkdecore.so.4(KLibLoader::~KLibLoader()+0xb0)[0xf70d264]
/usr/lib/libkdecore.so.4(KLibLoader::cleanUp()+0x48)[0xf6818ac]
/usr/lib/libkdecore.so.4(KApplication::~KApplication()+0xb8)[0xf727b1c]
filelight[0x1000cfa8]
/lib/libc.so.6[0xe96e728]
/lib/libc.so.6[0xe96e978]

Max Howell (max-howell) wrote :

Who do I need to sleep with to get you guys to ship the latest version of Filelight? I released it over a year ago now! :)

pietjepuk (pietjepuk72) wrote :
Download full text (3.2 KiB)

Same happens on Mint KDE 2.2 (filelight 0.99beta6-1ubuntu1). Probably not a surprise.
For completeness (maybe useless):
(no debugging symbols found)
Using host libthread_db library "/lib/tls/i686/cmov/libthread_db.so.1".
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[Thread debugging using libthread_db enabled]
[New Thread -1232234832 (LWP 11685)]
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[KCrash handler]
#6 0xffffe410 in __kernel_vsyscall ()
#7 0xb6ce5770 in raise () from /lib/tls/i686/cmov/libc.so.6
#8 0xb6ce6ef3 in abort () from /lib/tls/i686/cmov/libc.so.6
#9 0xb6d1ad0b in __fsetlocking () from /lib/tls/i686/cmov/libc.so.6
#10 0xb6d228bd in mallopt () from /lib/tls/i686/cmov/libc.so.6
#11 0xb6d22a44 in free () from /lib/tls/i686/cmov/libc.so.6
#12 0xb6ea0fc1 in operator delete () from /usr/lib/libstdc++.so.6
#13 0xb65e1339 in KParts::GenericFactory<Filelight::Part>::~GenericFactory ()
   from /usr/lib/kde3/libfilelight.so
#14 0xb77c1d51 in KLibrary::~KLibrary () from /usr/lib/libkdecore.so.4
#15 0xb77c147f in KLibLoader::close_pending () from /usr/lib/libkdecore.so.4
#16 0xb77d6d35 in KLibLoader::~KLibLoader () from /usr/lib/libkdecore.so.4
#17 0xb776231b in KLibLoader::cleanUp () from /usr/lib/libkdecore.so.4
#18 0xb77eba17 in KApplication::~KApplication () from /usr/lib/libkdecore.so.4
#19 0x08054184 in KCompletionBase::setAutoDeleteCompletionObject ()
#20 0xb6cd18cc in __libc_start_main () from /l...

Read more...

Adric Riedel (adric-riedel) wrote :

Filelight *still* crashes in Ubuntu 7.04.

Harald Sitter (apachelogger) wrote :

filelight 1.0, which is fixing this issue, just got uploaded into the queue for gutsy ... just waiting for successful build

Changed in filelight:
status: Confirmed → In Progress
Harald Sitter (apachelogger) wrote :

filelight 1.0 arrived in gutsy

Changed in filelight:
status: In Progress → Fix Released
Cedric (cedric-dewijs) wrote :

You can compile and install filelight yourself. You first need to install KDE-dev, and then you can compile filelight without problem:

cedric@athlon:~/download/filelight-1.0$ ./configure && make && sudo make install

Download full text (4.0 KiB)

Source: filelight
Source-Version: 1.0-1

We believe that the bug you reported is fixed in the latest version of
filelight, which is due to be installed in the Debian FTP archive:

filelight_1.0-1.diff.gz
  to pool/main/f/filelight/filelight_1.0-1.diff.gz
filelight_1.0-1.dsc
  to pool/main/f/filelight/filelight_1.0-1.dsc
filelight_1.0-1_amd64.deb
  to pool/main/f/filelight/filelight_1.0-1_amd64.deb
filelight_1.0.orig.tar.gz
  to pool/main/f/filelight/filelight_1.0.orig.tar.gz

A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed. If you
have further comments please address them to <email address hidden>,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
Raúl Sánchez Siles <email address hidden> (supplier of updated filelight package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing <email address hidden>)

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Format: 1.7
Date: Fri, 16 Nov 2007 19:20:42 +0100
Source: filelight
Binary: filelight
Architecture: source amd64
Version: 1.0-1
Distribution: unstable
Urgency: low
Maintainer: Debian KDE Extras Team <email address hidden>
Changed-By: Raúl Sánchez Siles <email address hidden>
Description:
 filelight - show where your diskspace is being used
Closes: 231399 255896 256423 304605 307717 341680 343903 343905 343905 354706 356626 363410 393827 404460 408554 414934 424741 436852 445935
Changes:
 filelight (1.0-1) unstable; urgency=low
 .
   * New upstream release: Crashes fix, displaying non-latin1 correctly and
     several new features. (Closes: #445935, #424741)
   * Splitted l10n to a new package.
   * Bugs closed:
     + filelight always places hover information on first monitor (Closes:
     #255896)
     + filelight doesn't handle utf-8 files (Closes: #256423)
     + always crashing on exit (Closes: #404460)
     + bug in filelight - crash on exit (Closes: #356626)
     + glibc detects free() of invalid pointer on exit (Closes: #343903)
     + memory usage is obscene (Closes: #231399)
     + lots of noise on stderr from RadialMap methods (Closes: #343905)
     + very large files and directories lead to confusion (Closes: #393827)
     + Filelight ignores large files (Closes: #341680)
     + Piles of WARNING messages on startup, but it works. (Closes:
       #307717)
     + filelight lacks a manpage [patch] (Closes: #414934). Thanks to
       James R. Van Zandt.
     + Spelling mistake in package description (Closes: #363410). Thanks to
       James Westby.
     + please build with --disable-debug to prevent spurious stdout-output
       (Closes: #408554)
     + filelight(GNU/k*BSD): FTBFS: out of date config.sub/config.guess
       (Closes: #304605)
     + lots of noise on stderr from RadialMap methods (Closes: #343905)
   * Packaging issues:
     + Changed packaging to CDBS.
     + Provide upstream AUTHORS file.
     + Honour the nostrip in the DEB_BUILD_OPTIONS. (Closes: #436852)
     + Changed menu section to Applicati...

Read more...

Changed in filelight:
status: Confirmed → Fix Released

# A New Hope
# A log time ago, in a galaxy far, far away
# something happened.
#
# Magically this resulted in the following
# action being taken, but this fake control
# message doesn't tell you why it happened
#
# The action:
# Bug archived.
thanks
# This fakemail brought to you by your local debbugs
# administrator

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.