Ubuntu

Change log for “firefox-3.0” package in Ubuntu

175 of 113 results
Published in hardy-updates on 2011-04-29
Published in hardy-security on 2011-04-29
firefox-3.0 (3.6.17+build3+nobinonly-0ubuntu0.8.04.1) hardy-security; urgency=low

  * New upstream release v3.6.17 build3 (FIREFOX_3_6_17_BUILD3)
    - see USN-1112-1

  * Refresh patch after upstream landing of (bmo: 477724) aka
    avoid pointless shell interpreter hanging around
    - update debian/patches/abrowser_run_mozilla.patch
 -- Micah Gersten <email address hidden>   Fri, 22 Apr 2011 02:18:05 -0500
Superseded in hardy-updates on 2011-04-29
Superseded in hardy-security on 2011-04-29
firefox-3.0 (3.6.16+build1+nobinonly-0ubuntu0.8.04.1) hardy-security; urgency=low

  * New upstream release v3.6.16 (FIREFOX_3_6_16_BUILD1)
    - see USN-1091-1
 -- Micah Gersten <email address hidden>   Wed, 23 Mar 2011 10:45:17 -0500
Superseded in hardy-updates on 2011-03-24
Superseded in hardy-security on 2011-03-24
firefox-3.0 (3.6.15+build1+nobinonly-0ubuntu0.8.04.1) hardy-security; urgency=low

  * New upstream release v3.6.15 (FIREFOX_3_6_15_BUILD1)
    - see USN-1049-2
 -- Micah Gersten <email address hidden>   Thu, 03 Mar 2011 10:39:48 -0600
Superseded in hardy-updates on 2011-03-07
Superseded in hardy-security on 2011-03-07
firefox-3.0 (3.6.14+build3+nobinonly-0ubuntu0.8.04.1) hardy-security; urgency=low

  * New upstream release v3.6.14 (FIREFOX_3_6_14_BUILD3)
    - see USN-1049-1
 -- Micah Gersten <email address hidden>   Mon, 21 Feb 2011 05:21:18 -0600
Superseded in hardy-updates on 2011-03-02
Superseded in hardy-security on 2011-03-02
firefox-3.0 (3.6.13+build3+nobinonly-0ubuntu0.8.04.1) hardy-security; urgency=low

  * New upstream release v3.6.13 (FIREFOX_3_6_13_BUILD3)
    - see USN-1019-1

  * Fix LP: #602002 - abrowser will only launch with command firefox instead
    of abrowser. Add the necessary symlink
    - update debian/firefox.links
  * Drop patch after upstream landing of bmo: 551152 aka Symlinked components
    break everything
    - remove debian/patches/lp518422.patch
    - update debian/patches/series
 -- Chris Coulson <email address hidden>   Mon, 06 Dec 2010 11:55:24 +0000
Superseded in hardy-updates on 2010-12-09
Superseded in hardy-security on 2010-12-09
firefox-3.0 (3.6.12+build1+nobinonly-0ubuntu0.8.04.1) hardy-security; urgency=low

  * New upstream release v3.6.12 (FIREFOX_3_6_12_BUILD1)
    - see USN-1011-1
 -- Chris Coulson <email address hidden>   Wed, 27 Oct 2010 08:42:08 -0400
Superseded in hardy-updates on 2010-10-28
Superseded in hardy-security on 2010-10-28
firefox-3.0 (3.6.11+build3+nobinonly-0ubuntu0.8.04.1) hardy-security; urgency=low

  * New upstream release v3.6.11 (FIREFOX_3_6_11_BUILD3)
    - see USN-997-1
    - Fixes LP: #589236 and LP: #239952

  * Bump minimum system NSS to 3.12.8 after landing of (bmo: 600104) aka
    Bump minimum required version for system NSS to 3.12.8
    - update debian/rules
  * Bump minimum system NSPR to 4.8.6 after landing of (bmo: 567620) aka
    Bump minimum required version for system NSPR to 4.8.6
    - update debian/rules
  * Bump minimum version of sqlite to 3.7.1 after landing of (bmo: 583611) aka
    Upgrade to SQLite 3.7.1
    - update debian/rules
 -- Chris Coulson <email address hidden>   Wed, 13 Oct 2010 13:13:11 +0100
Obsolete in jaunty-updates on 2013-02-28
Obsolete in jaunty-security on 2013-02-28
firefox-3.0 (3.6.11+build3+nobinonly-0ubuntu0.9.04.1) jaunty-security; urgency=low

  * New upstream release v3.6.11 (FIREFOX_3_6_11_BUILD3)
    - see USN-997-1
    - Fixes LP: #589236 and LP: #239952

  * Bump minimum system NSS to 3.12.8 after landing of (bmo: 600104) aka
    Bump minimum required version for system NSS to 3.12.8
    - update debian/rules
  * Bump minimum system NSPR to 4.8.6 after landing of (bmo: 567620) aka
    Bump minimum required version for system NSPR to 4.8.6
    - update debian/rules
  * Bump minimum version of sqlite to 3.7.1 after landing of (bmo: 583611) aka
    Upgrade to SQLite 3.7.1
    - update debian/rules
 -- Chris Coulson <email address hidden>   Wed, 13 Oct 2010 12:27:52 +0100
Superseded in hardy-updates on 2010-10-20
Superseded in hardy-security on 2010-10-20
firefox-3.0 (3.6.10+build1+nobinonly-0ubuntu0.8.04.1) hardy-security; urgency=low

  * New upstream release v3.6.10 (FIREFOX_3_6_10_BUILD1)

  * Fix LP: #637434 - components.list is not installed
    - update debian/firefox.install
 -- Chris Coulson <email address hidden>   Wed, 15 Sep 2010 19:25:32 +0100
Superseded in jaunty-updates on 2010-10-20
Superseded in jaunty-security on 2010-10-20
firefox-3.0 (3.6.10+build1+nobinonly-0ubuntu0.9.04.1) jaunty-security; urgency=low

  * New upstream release v3.6.10 (FIREFOX_3_6_10_BUILD1)

  * Fix LP: #637434 - components.list is not installed
    - update debian/firefox.install
 -- Chris Coulson <email address hidden>   Wed, 15 Sep 2010 18:53:27 +0100
Superseded in jaunty-updates on 2010-09-16
Superseded in jaunty-security on 2010-09-16
firefox-3.0 (3.6.9+build1+nobinonly-0ubuntu0.9.04.1) jaunty-security; urgency=low

  * New upstream release v3.6.9 (FIREFOX_3_6_9_BUILD1)
    - see USN-975-1

  * Fix LP: #609941 - Provide a transition path from residual Firefox 2
    packages left over from Hardy
    - update debian/control
    - add debian/firefox-2.preinst
 -- Chris Coulson <email address hidden>   Wed, 25 Aug 2010 23:11:38 +0100
Superseded in hardy-updates on 2010-09-16
Superseded in hardy-security on 2010-09-16
firefox-3.0 (3.6.9+build1+nobinonly-0ubuntu0.8.04.1) hardy-security; urgency=low

  * New upstream release v3.6.9 (FIREFOX_3_6_9_BUILD1)
    - see USN-975-1
 -- Chris Coulson <email address hidden>   Wed, 25 Aug 2010 15:26:08 +0100
Superseded in hardy-updates on 2010-09-08
Superseded in hardy-security on 2010-09-08
firefox-3.0 (3.6.8+build1+nobinonly-0ubuntu0.8.04.1) hardy-security; urgency=low

  * New upstream release v3.6.8 (FIREFOX_3_6_8_BUILD1)
    - see USN-957-2
 -- Chris Coulson <email address hidden>   Fri, 23 Jul 2010 10:47:30 +0200
Superseded in jaunty-updates on 2010-09-08
Superseded in jaunty-security on 2010-09-08
firefox-3.0 (3.6.8+build1+nobinonly-0ubuntu0.9.04.1) jaunty-security; urgency=low

  * New upstream release v3.6.8 (FIREFOX_3_6_8_BUILD1)
    - see USN-930-6
 -- Chris Coulson <email address hidden>   Fri, 23 Jul 2010 10:44:54 +0200
Superseded in jaunty-updates on 2010-07-26
Superseded in jaunty-security on 2010-07-26
firefox-3.0 (3.6.7+build2+nobinonly-0ubuntu0.9.04.1) jaunty-security; urgency=low

  * New major upstream release v3.6.7 (FIREFOX_3_6_7_BUILD2)
    - see USN-930-1

  * Switch to using unversioned binaries. This means that firefox and
    firefox-gnome-support are no longer meta-packages depending on the latest
    versioned binary packages, but they ship the binary components. Convert
    firefox-3.0* packages to meta packages which pull in the unversioned binaries
    to ensure a smooth upgrade path
    - update debian/control
    - rename debian/firefox-3.0-dev.install => debian/firefox-dev.install
    - rename debian/firefox-3.0-dev.links => debian/firefox-dev.links
    - rename debian/firefox-3.0-final.desktop => debian/firefox-final.desktop
    - rename debian/firefox-3.0-gnome-support.install => debian/firefox-gnome-support.install
    - rename debian/firefox-3.0-gnome-support.postinst.in => debian/firefox-gnome-support.postinst
    - rename debian/firefox-3.0-minefield.desktop => debian/firefox-minefield.desktop
    - rename debian/firefox-3.0-granparadiso.desktop => debian/firefox-namoroka.desktop
    - rename debian/firefox-3.0-restart-required.update-notifier => debian/firefox-restart-required.update-notifier
    - rename debian/firefox-3.0.dirs => debian/firefox.dirs
    - rename debian/firefox-3.0.install => debian/firefox.install
    - rename debian/firefox-3.0.links => debian/firefox.links
    - rename debian/firefox-3.0.menu => debian/firefox.menu
    - rename debian/firefox-3.0.postinst.in => debian/firefox.postinst.in
    - rename debian/firefox-3.0.prerm => debian/firefox.prerm.in
    - rename debian/abrowser-3.0.desktop => debian/abrowser.desktop
    - update Icon name in debian/firefox-final.desktop
    - update Icon, Exec and StartupWMClass fields in debian/firefox-minefield.desktop
    - update Name and Description in debian/firefox-restart-required.update-notifier
    - update debian/firefox.links to not create versioned link in /usr/bin
    - update fields in debian/firefox.menu
    - update debian/firefox.postinst.in
    - update debian/firefox.prerm.in
    - update debian/abrowser.desktop
  * Implement MIN_SYS_DEPS approach that does not use system xulrunner
    and only a minimal set of system dependencies.
    + drop patches not required anymore:
      - delete debian/patches/dont_depend_on_nspr_sources.patch
      - update debian/patches/series
    + move .install lines that depend on whether MIN_SYS_DEPS is used or not
      to debian/rules in ifneq (,$(MIN_SYS_DEPS)) blocks
      - update debian/rules
      - update debian/firefox.install
    + ship gnome support .so's inside of the main package, but keep dependencies in
      the (now empty) gnome-support package; to achieve this, we first install
      the gnome support files in the -gnome-support package and move them to the
      main package _after_ shlib depends where generated
      - update debian/rules
    + do not build-depend on xulrunner dev package anymore; local xulrunner builds
      with MIN_SYS_DEPS=0 should still work though
      - update debian/control
    + fix firefox.sh to handle all-static build
      - update debian/firefox.sh.in
  * Fix LP: #398121 - firefox-3.5-gnome-support failed to install/upgrade; we
    make the postinst script more failsafe
    - update debian/firefox-gnome-support.postinst
  * Add libstartup-notification0-dev to build-deps as it now seems to be
    mandatory on lpia
    - update debian/control
  * Add libasound2-dev to Build-Depends for the new HTML5 <video> tag
    - update debian/control
  * Add libiw-dev to build-depends to fix build failure
    - update debian/control
  * Add libnotify-dev to build-depends
    - update debian/control
  * adjust packaging to support localized searchplugins
    + ship default searchplugins in /usr/lib/firefox-addons/searchplugins/en-US/
      and link that directory to $(DEBIAN_FF3_DIR)/distribution/searchplugins instead
      of the main firefox APP_DIR
      - update debian/rules
    + set default searchplugin locale pref to en-US - which is used as a
      fallback if no matching searchplugins/LOCALE directory exists for the
      current locale directory
      - update debian/firefox.js
    + do not install upstream searchplugins through debhelper file and
      install "debsearch" to the new distribution/.../en-US location
      - update debian/firefox.install
    + ship "common" searchplugins link that points to the old default
      searchplugins location '/usr/lib/firefox-addons/searchplugins/
      - update debian/rules
      - update debian/firefox.links
    + rework localized search engine patch to use ChromeRegistry locale
      information rather than a char pref; also change plugin dir order to allow
      locale specific searchplugins to overlay the ones shipped in
      "searchplugins/common"
      - add debian/patches/bz515232_att399338_distro_locale_searchplugins.patch
      - update debian/patches/series
  * Add patch for armv7 support
    - add debian/patches/bz532198_lp488354_ns_invokebyindex_not_thumb2_safe.patch
    - update debian/patches/series
  * Fix LP: #428306 - default search engines are removed and readded (keywords
    wiped) with upgrade
    - add debian/patches/bz534663_attXXX_normalize_distribution_searchplugins.patch
    - update debian/patches/series
  * Fix LP: #423610 - daily build failures after landing of mozilla-nss.pc droppage
    (bug 422829); we drop our previously used nspr pkgconfig patch and fix
    configure.in to not require in-source nspr if libxul-sdk is used
    - delete debian/patches/nspr_flags_by_pkg_config_hack.patch
    - add debian/patches/bzXXX_libxul_sdk_nspr.patch
    - update debian/patches/series
  * Add ability to set a preferred plugin for a given mime-type
    - add debian/patches/bzXXX_plugin_for_mimetype_pref.patch
    - update debian/patches/series
  * Enable NetworkManager integration for proper offline detection
    - update debian/firefox.js
  * Update profile migration tool for new version
    - update debian/migrator/main.c
  * Move mozclient project files from mozilla-descripts to this package
    - add debian/mozclient/firefox-3.0.conf
    - add debian/mozclient/firefox-3.0.mk
    - add debian/moz-rev.sh
    - update debian/rules
  * Fix LP: #520963 - sysprefs not honoured since firefox is built without
    system xulrunner; resurrect the patch we ship in xulrunner
    - add debian/patches/add_syspref_dir.patch
    - update debian/patches/series
  * Drop patches applied upstream
    - remove debian/patches/bz421977_att334578.patch
    - remove debian/patches/bz436133_att322801.patch
    - remove debian/patches/installer_shouldnt_copy_xulrunner.patch
    - remove debian/patches/installer_use_stdout_for_missing_files.patch
  * Update / rebase patches
    - rename debian/patches/bzXXX_reload_new_plugins.patch =>
      debian/patches/bz460917_att350845_reload_new_plugins.patch
    - update debian/patches/awesome_browser_branding_install.patch
    - update debian/patches/browser_branding.patch
    - update debian/patches/lp185622_system_path_default_browser.patch
    - update debian/patches/ubuntu_no_app_updates.patch
  * Add a cairo LCD filter to use Freetype LCD colour filtering features,
    based on the same patch applied to our system cairo package. Thanks to
    Marc Deslauriers for helping to make this work
    - add debian/patches/lp512615_cairo_lcd_filter.patch
    - update debian/patches/series
  * Fix LP: #518422 - Firefox does not start with certain addons installed;
    don't normalize paths for xpti.dat
    - add debian/patches/lp518422.patch
    - update debian/series
  * Fix LP: #548866 - forgets middlemouse.contentLoadURL on upgrade; add patch
    from xulrunner-1.9
    - update debian/patches/series
    - add debian/patches/lp548866_bz467766_att351173-dont-reset-user-prefs-on-upgrade.patch
  * Add support for using lockPref in preferences files
    - add debian/patches/bz467738_att351145_lockPref_everywhere.patch
    - update debian/patches/series
  * Drop useless patch:
    - drop debian/patches/ftbfs-with-branding-dir
    - update debian/patches/series
  * Build with --enable-ipc on amd64, i386 and armel. These are the only
    architectures where OOPP is supported. Build with --disable-ipc on all
    other architectures
    - update debian/rules
  * Install the plugin-container binary for OOPP support when building
    with --enable-ipc
    - update debian/rules
  * Fix LP: #443147 - Firefox on ARM inappropriately adds scroll bars to many
    frames and images; this is a workaround that forces -O2 for the whole
    mozilla tree build on armel; the scroll bar only manifests on lucid toolchain
    when using the upstream optimization flag mix
    - update debian/rules
  * Fix FTBFS on sparc; disable jit on sparc until bmo 502369 is fixable
    - update debian/rules
  * Update rosetta template name to firefox-3.6
    - update debian/translation-support/install.rdf.in
  * add CMDNAME_USER feature to overwrite cmdname for abrowser in run-mozilla.sh
    - add debian/patches/abrowser_run_mozilla.patch
    - update debian/patches/series
  * Provide extra translations in desktop files
    - update debian/firefox-final.desktop
  * Don't provide firefox-*-dom-inspector and firefox-*-venkman transitional
    packages. We use an internal copy of xulrunner now, which no longer provides
    these extensions
    - update debian/control
  * Create checksums for NSS libraries to make FIPS mode work
    - update debian/rules
  * Handle the system preferences moving location and beween packages during
    the upgrade - migrate the old settings to the new location if they have
    customisations already (and keep a backup of the new settings). Delete the
    old settings if they haven't been customised by the system administrator
    - add debian/firefox-3.0.preinst
    - update debian/firefox.postinst.in
  * If the previous customised system configuration from 3.0 is retained
    during the upgrade, ensure that new preferenes defined in the stock 3.6
    configuration are added to the existing migrated configuration
    - update debian/firefox.postinst.in
 -- Chris Coulson <email address hidden>   Thu, 15 Jul 2010 22:45:42 +0100
Superseded in hardy-updates on 2010-07-26
Superseded in hardy-security on 2010-07-26
firefox-3.0 (3.6.7+build2+nobinonly-0ubuntu0.8.04.1) hardy-security; urgency=low

  * New upstream release v3.6.7 (FIREFOX_3_6_7_BUILD2)
    - see USN-957-1
 -- Chris Coulson <email address hidden>   Thu, 15 Jul 2010 22:38:49 +0100
Superseded in hardy-updates on 2010-07-22
Superseded in hardy-security on 2010-07-22
firefox-3.0 (3.6.6+nobinonly-0ubuntu0.8.04.2) hardy-security; urgency=low

  * Fix LP: #600022 - don't ship files which conflict with the Firefox 2
    package. Revert the change to install the preferences in /etc/firefox
    and add some logic to move them back again. Install the icon as
    firefox-3.0.png.
    - update debian/firefox-3.0.preinst
    - update debian/firefox-final.desktop
    - update debian/firefox-minefield.desktop
    - update debian/firefox-namoroka.desktop
    - update debian/firefox.install
    - update debian/firefox.postinst.in
    - add debian/firefox.preinst
    - update debian/rules
  * Bump the firefox-3.0 conflict on firefox - this avoids an unnecessary
    conffile prompt for users upgrading from 3.6.6+nobinonly-0ubuntu0.8.04.1
    - update debian/control
  * Clean up files left in /etc/firefox/profile by version
    3.6.6+nobinonly-0ubuntu0.8.04.1
    - update debian/firefox.preinst
 -- Chris Coulson <email address hidden>   Wed, 30 Jun 2010 13:52:46 +0100
Superseded in hardy-updates on 2010-06-30
Superseded in hardy-security on 2010-06-30
firefox-3.0 (3.6.6+nobinonly-0ubuntu0.8.04.1) hardy-security; urgency=low

  * New major upstream release v3.6.6 (FIREFOX_3_6_6_RELEASE)
    - see USN-930-1
  * Note that sun-java5-plugin has no support for Firefox 3.6. Users of
    sun-java5-plugin are advised to upgrade to sun-java6-plugin

  * Switch to using unversioned binaries. This means that firefox and
    firefox-gnome-support are no longer meta-packages depending on the latest
    versioned binary packages, but they ship the binary components. Convert
    firefox-3.0* packages to meta packages which pull in the unversioned binaries
    to ensure a smooth upgrade path
    - update debian/control
    - rename debian/firefox-3.0-dev.install => debian/firefox-dev.install
    - rename debian/firefox-3.0-dev.links => debian/firefox-dev.links
    - rename debian/firefox-3.0-final.desktop => debian/firefox-final.desktop
    - rename debian/firefox-3.0-gnome-support.install => debian/firefox-gnome-support.install
    - rename debian/firefox-3.0-gnome-support.postinst.in => debian/firefox-gnome-support.postinst
    - rename debian/firefox-3.0-minefield.desktop => debian/firefox-minefield.desktop
    - rename debian/firefox-3.0-granparadiso.desktop => debian/firefox-namoroka.desktop
    - rename debian/firefox-3.0-restart-required.update-notifier => debian/firefox-restart-required.update-notifier
    - rename debian/firefox-3.0.dirs => debian/firefox.dirs
    - rename debian/firefox-3.0.install => debian/firefox.install
    - rename debian/firefox-3.0.links => debian/firefox.links
    - rename debian/firefox-3.0.menu => debian/firefox.menu
    - rename debian/firefox-3.0.postinst.in => debian/firefox.postinst.in
    - rename debian/firefox-3.0.prerm => debian/firefox.prerm.in
    - update Icon name in debian/firefox-final.desktop
    - update Icon, Exec and StartupWMClass fields in debian/firefox-minefield.desktop
    - update Name and Description in debian/firefox-restart-required.update-notifier
    - update debian/firefox.links to not create versioned link in /usr/bin
    - update fields in debian/firefox.menu
    - update debian/firefox.postinst.in
    - update debian/firefox.prerm.in
  * Implement MIN_SYS_DEPS approach that does not use system xulrunner
    and only a minimal set of system dependencies.
    + drop patches not required anymore:
      - delete debian/patches/dont_depend_on_nspr_sources.patch
      - update debian/patches/series
    + move .install lines that depend on whether MIN_SYS_DEPS is used or not
      to debian/rules in ifneq (,$(MIN_SYS_DEPS)) blocks
      - update debian/rules
      - update debian/firefox.install
    + ship gnome support .so's inside of the main package, but keep dependencies in
      the (now empty) gnome-support package; to achieve this, we first install
      the gnome support files in the -gnome-support package and move them to the
      main package _after_ shlib depends where generated
      - update debian/rules
    + do not build-depend on xulrunner dev package anymore; local xulrunner builds
      with MIN_SYS_DEPS=0 should still work though
      - update debian/control
    + fix firefox.sh to handle all-static build
      - update debian/firefox.sh.in
  * Fix LP: #398121 - firefox-3.5-gnome-support failed to install/upgrade; we
    make the postinst script more failsafe
    - update debian/firefox-gnome-support.postinst
  * Add libstartup-notification0-dev to build-deps as it now seems to be
    mandatory on lpia
    - update debian/control
  * Add libasound2-dev to Build-Depends for the new HTML5 <video> tag
    - update debian/control
  * Add libiw-dev to build-depends to fix build failure
    - update debian/control
  * Add libnotify-dev to build-depends
    - update debian/control
  * adjust packaging to support localized searchplugins
    + ship default searchplugins in /usr/lib/firefox-addons/searchplugins/en-US/
      and link that directory to $(DEBIAN_FF3_DIR)/distribution/searchplugins instead
      of the main firefox APP_DIR
      - update debian/rules
    + set default searchplugin locale pref to en-US - which is used as a
      fallback if no matching searchplugins/LOCALE directory exists for the
      current locale directory
      - update debian/firefox.js
    + do not install upstream searchplugins through debhelper file and
      install "debsearch" to the new distribution/.../en-US location
      - update debian/firefox.install
    + ship "common" searchplugins link that points to the old default
      searchplugins location '/usr/lib/firefox-addons/searchplugins/
      - update debian/rules
      - update debian/firefox.links
    + rework localized search engine patch to use ChromeRegistry locale
      information rather than a char pref; also change plugin dir order to allow
      locale specific searchplugins to overlay the ones shipped in
      "searchplugins/common"
      - add debian/patches/bz515232_att399338_distro_locale_searchplugins.patch
      - update debian/patches/series
  * Add patch for armv7 support
    - add debian/patches/bz532198_lp488354_ns_invokebyindex_not_thumb2_safe.patch
    - update debian/patches/series
  * Fix LP: #428306 - default search engines are removed and readded (keywords
    wiped) with upgrade
    - add debian/patches/bz534663_attXXX_normalize_distribution_searchplugins.patch
    - update debian/patches/series
  * Fix LP: #423610 - daily build failures after landing of mozilla-nss.pc droppage
    (bug 422829); we drop our previously used nspr pkgconfig patch and fix
    configure.in to not require in-source nspr if libxul-sdk is used
    - delete debian/patches/nspr_flags_by_pkg_config_hack.patch
    - add debian/patches/bzXXX_libxul_sdk_nspr.patch
    - update debian/patches/series
  * Add ability to set a preferred plugin for a given mime-type
    - add debian/patches/bzXXX_plugin_for_mimetype_pref.patch
    - update debian/patches/series
  * Enable NetworkManager integration for proper offline detection
    - update debian/firefox.js
  * Update profile migration tool for new version
    - update debian/migrator/main.c
  * Move mozclient project files from mozilla-descripts to this package
    - add debian/mozclient/firefox-3.0.conf
    - add debian/mozclient/firefox-3.0.mk
    - add debian/moz-rev.sh
    - update debian/rules
  * Fix LP: #520963 - sysprefs not honoured since firefox is built without
    system xulrunner; resurrect the patch we ship in xulrunner
    - add debian/patches/add_syspref_dir.patch
    - update debian/patches/series
  * Drop patches applied upstream
    - remove debian/patches/bz436133_att322801.patch
    - debian/patches/installer_shouldnt_copy_xulrunner.patch
    - debian/patches/installer_use_stdout_for_missing_files.patch
    - update debian/patches/series
  * Update / rebase patches
    - rename debian/patches/bzXXX_reload_new_plugins.patch =>
      debian/patches/bz460917_att350845_reload_new_plugins.patch
    - update debian/patches/lp185622_system_path_default_browser.patch
    - update debian/patches/ubuntu_no_app_updates.patch
  * Add a cairo LCD filter to use Freetype LCD colour filtering features,
    based on the same patch applied to our system cairo package. Thanks to
    Marc Deslauriers for helping to make this work
    - add debian/patches/lp512615_cairo_lcd_filter.patch
    - update debian/patches/series
  * Fix LP: #518422 - Firefox does not start with certain addons installed;
    don't normalize paths for xpti.dat
    - add debian/patches/lp518422.patch
    - update debian/series
  * Fix LP: #548866 - forgets middlemouse.contentLoadURL on upgrade; add patch
    from xulrunner-1.9
    - update debian/patches/series
    - add debian/patches/lp548866_bz467766_att351173-dont-reset-user-prefs-on-upgrade.patch
  * Add support for using lockPref in preferences files
    - add debian/patches/bz467738_att351145_lockPref_everywhere.patch
    - update debian/patches/series
  * Drop useless patch:
    - drop debian/patches/ftbfs-with-branding-dir
    - update debian/patches/series
  * Build with --enable-ipc on amd64, i386 and armel. These are the only
    architectures where OOPP is supported. Build with --disable-ipc on all
    other architectures
    - update debian/rules
  * Install the plugin-container binary for OOPP support when building
    with --enable-ipc
    - update debian/rules
  * Fix LP: #443147 - Firefox on ARM inappropriately adds scroll bars to many
    frames and images; this is a workaround that forces -O2 for the whole
    mozilla tree build on armel; the scroll bar only manifests on lucid toolchain
    when using the upstream optimization flag mix
    - update debian/rules
  * Fix FTBFS on sparc; disable jit on sparc until bmo 502369 is fixable
    - update debian/rules
  * Update rosetta template name to firefox-3.6
    - update debian/translation-support/install.rdf.in
  * Provide extra translations in desktop files
    - update debian/firefox-final.desktop
  * Introduce alternative branding by splitting the official branding in to
    a firefox-branding package and providing abrowser and abrowser-branding.
    firefox depends on either of the branding packages, which conflict with each
    other
    - add debian/abrowser.desktop
    - update debian/control
    - update debian/rules
    - add debian/patches/abrowser_run_mozilla.patch
    - add debian/patches/awesome_browser_branding_install.patch
    - add debian/patches/browser_branding.patch
    - update debian/patches/series
  * Add a ubuntu-abrowser.js file dedicated to abrowser and set useragent
    to Firefox/version
    - add debian/ubuntu-abrowser.js.tmpl
    - update debian/rules
  * Don't provide firefox-*-dom-inspector and firefox-*-venkman transitional
    packages. We use an internal copy of xulrunner now, which no longer provides
    these extensions
    - update debian/control
  * Create checksums for NSS libraries to make FIPS mode work
    - update debian/rules
  * Ensure that startup notification works with the bundled xulrunner - build
    with --enable-startup-notification
    - update debian/rules
  * Handle the system preferences moving location and beween packages during
    the upgrade - migrate the old settings to the new location if they have
    customisations already (and keep a backup of the new settings). Delete the
    old settings if they haven't been customised by the system administrator
    - add debian/firefox-3.0.preinst
    - update debian/firefox.postinst.in
  * If the previous customised system configuration from 3.0 is retained
    during the upgrade, ensure that new preferenes defined in the stock 3.6
    configuration are added to the existing migrated configuration
    - update debian/firefox.postinst.in
 -- Chris Coulson <email address hidden>   Mon, 28 Jun 2010 13:00:32 +0100
Superseded in hardy-updates on 2010-06-29
Superseded in hardy-security on 2010-06-29
firefox-3.0 (3.0.19+nobinonly-0ubuntu0.8.04.1) hardy-security; urgency=low

  * New upstream release v3.0.19 (FIREFOX_3_0_19_RELEASE)
    - see USN-920-1
 -- Chris Coulson <email address hidden>   Wed, 31 Mar 2010 19:36:06 +0100
Obsolete in intrepid-updates on 2013-02-20
Obsolete in intrepid-security on 2013-02-20
firefox-3.0 (3.0.19+nobinonly-0ubuntu0.8.10.1) intrepid-security; urgency=low

  * New upstream release v3.0.19 (FIREFOX_3_0_19_RELEASE)
    - see USN-920-1
 -- Chris Coulson <email address hidden>   Wed, 31 Mar 2010 16:39:30 +0100
Superseded in jaunty-updates on 2010-07-22
Superseded in jaunty-security on 2010-07-22
firefox-3.0 (3.0.19+nobinonly-0ubuntu0.9.04.1) jaunty-security; urgency=low

  * New upstream release v3.0.19 (FIREFOX_3_0_19_RELEASE)
    - see USN-920-1
 -- Chris Coulson <email address hidden>   Wed, 31 Mar 2010 16:26:22 +0100
Superseded in intrepid-updates on 2010-04-10
Superseded in intrepid-security on 2010-04-09
firefox-3.0 (3.0.18+build1+nobinonly-0ubuntu0.8.10.1) intrepid-security; urgency=low

  * New upstream release v3.0.18 (FIREFOX_3_0_18_BUILD1)
    - see USN-895-1
 -- Micah Gersten <email address hidden>   Sun, 14 Feb 2010 16:57:10 -0600
Superseded in hardy-updates on 2010-04-10
Superseded in hardy-security on 2010-04-09
firefox-3.0 (3.0.18+build1+nobinonly-0ubuntu0.8.04.1) hardy-security; urgency=low

  * New upstream release v3.0.18 (FIREFOX_3_0_18_BUILD1)
    - see USN-895-1
 -- Micah Gersten <email address hidden>   Sun, 14 Feb 2010 16:51:09 -0600
Superseded in jaunty-updates on 2010-04-10
Superseded in jaunty-security on 2010-04-09
firefox-3.0 (3.0.18+build1+nobinonly-0ubuntu0.9.04.1) jaunty-security; urgency=low

  * New upstream release v3.0.18 (FIREFOX_3_0_18_BUILD1)
    - see USN-895-1
 -- Micah Gersten <email address hidden>   Sun, 14 Feb 2010 16:32:36 -0600
Superseded in hardy-updates on 2010-02-17
Superseded in hardy-security on 2010-02-17
firefox-3.0 (3.0.17+nobinonly-0ubuntu0.8.04.1) hardy-security; urgency=low

  * New upstream release v3.0.17 (FIREFOX_3_0_17_RELEASE)
    - see USN-877-1
 -- Alexander Sack <email address hidden>   Wed, 06 Jan 2010 05:30:15 +0100
Superseded in intrepid-updates on 2010-02-17
Superseded in intrepid-security on 2010-02-17
firefox-3.0 (3.0.17+nobinonly-0ubuntu0.8.10.1) intrepid-security; urgency=low

  * New upstream release v3.0.17 (FIREFOX_3_0_17_RELEASE)
    - see USN-877-1
 -- Alexander Sack <email address hidden>   Wed, 06 Jan 2010 05:17:02 +0100
Superseded in jaunty-updates on 2010-02-17
Superseded in jaunty-security on 2010-02-17
firefox-3.0 (3.0.17+nobinonly-0ubuntu0.9.04.1) jaunty-security; urgency=low

  * New upstream release v3.0.17 (FIREFOX_3_0_17_RELEASE)
    - see USN-877-1
 -- Alexander Sack <email address hidden>   Wed, 06 Jan 2010 05:13:55 +0100
Superseded in hardy-updates on 2010-01-08
Superseded in hardy-security on 2010-01-08
firefox-3.0 (3.0.16+nobinonly-0ubuntu0.8.04.1) hardy-security; urgency=low

  * New upstream release v1.9.0.16 (FIREFOX_3_0_16_RELEASE)
    - see USN-873-1
 -- Alexander Sack <email address hidden>   Wed, 16 Dec 2009 02:30:45 +0100
Superseded in intrepid-updates on 2010-01-08
Superseded in intrepid-security on 2010-01-08
firefox-3.0 (3.0.16+nobinonly-0ubuntu0.8.10.1) intrepid-security; urgency=low

  * New upstream release v1.9.0.16 (FIREFOX_3_0_16_RELEASE)
    - see USN-873-1
 -- Alexander Sack <email address hidden>   Wed, 16 Dec 2009 02:26:33 +0100
Superseded in jaunty-updates on 2010-01-08
Superseded in jaunty-security on 2010-01-08
firefox-3.0 (3.0.16+nobinonly-0ubuntu0.9.04.1) jaunty-security; urgency=low

  * New upstream release v1.9.0.16 (FIREFOX_3_0_16_RELEASE)
    - see USN-873-1
 -- Alexander Sack <email address hidden>   Wed, 16 Dec 2009 02:22:16 +0100
Superseded in jaunty-updates on 2009-12-18
Superseded in jaunty-security on 2009-12-18
firefox-3.0 (3.0.15+nobinonly-0ubuntu0.9.04.1) jaunty-security; urgency=low

  * security/stability v3.0.15 (FIREFOX_3_0_15_RELEASE)
    - see USN-853-1

 -- Alexander Sack <email address hidden>   Wed, 28 Oct 2009 16:25:38 +0100
Superseded in intrepid-updates on 2009-12-18
Superseded in intrepid-security on 2009-12-18
firefox-3.0 (3.0.15+nobinonly-0ubuntu0.8.10.1) intrepid-security; urgency=low

  * security/stability v3.0.15 (FIREFOX_3_0_15_RELEASE)
    - see USN-853-1

 -- Alexander Sack <email address hidden>   Wed, 28 Oct 2009 16:17:29 +0100
Superseded in hardy-updates on 2009-12-18
Superseded in hardy-security on 2009-12-18
firefox-3.0 (3.0.15+nobinonly-0ubuntu0.8.04.1) hardy-security; urgency=low

  * security/stability v3.0.15 (FIREFOX_3_0_15_RELEASE)
    - see USN-853-1

 -- Alexander Sack <email address hidden>   Wed, 28 Oct 2009 16:10:32 +0100
Superseded in hardy-updates on 2009-10-30
Superseded in hardy-security on 2009-10-30
firefox-3.0 (3.0.14+build2+nobinonly-0ubuntu0.8.04.1) hardy-security; urgency=low

  * security/stability v3.0.14 build2 (FIREFOX_3_0_14_RELEASE)
    - see USN-821-1
    - fix LP: #236853 - firefox crashed with SIGSEGV in NSSRWLock_LockRead_Util()

 -- Alexander Sack <email address hidden>   Mon, 07 Sep 2009 14:27:50 +0200
Superseded in intrepid-updates on 2009-10-30
Superseded in intrepid-security on 2009-10-30
firefox-3.0 (3.0.14+build2+nobinonly-0ubuntu0.8.10.1) intrepid-security; urgency=low

  * security/stability v3.0.14 build2 (FIREFOX_3_0_14_RELEASE)
    - see USN-821-1
    - fix LP: #236853 - firefox crashed with SIGSEGV in NSSRWLock_LockRead_Util()

 -- Alexander Sack <email address hidden>   Mon, 07 Sep 2009 14:26:32 +0200
Superseded in jaunty-updates on 2009-10-30
Superseded in jaunty-security on 2009-10-30
firefox-3.0 (3.0.14+build2+nobinonly-0ubuntu0.9.04.1) jaunty-security; urgency=low

  * security/stability v3.0.14 build2 (FIREFOX_3_0_14_RELEASE)
    - see USN-821-1
    - fix LP: #236853 - firefox crashed with SIGSEGV in NSSRWLock_LockRead_Util()

 -- Alexander Sack <email address hidden>   Mon, 07 Sep 2009 14:24:57 +0200
Deleted in karmic-release on 2009-10-27 (Reason: superseded by firefox-3.5, LP#461782)
Superseded in karmic-release on 2009-09-10
firefox-3.0 (3.0.14+build2+nobinonly-0ubuntu1) karmic; urgency=low

  * security/stability v3.0.14 build2 (FIREFOX_3_0_14_RELEASE)
    - see USN-821-1
    - fix LP: #236853 - firefox crashed with SIGSEGV in NSSRWLock_LockRead_Util()

  [ Alexander Sack <email address hidden> ]
  * hook firefox-addons/searchplugins as the distribution/searchplugins
    directory to support localized distro search engines.
    - update debian/rules
  * in case localized search engines are available the main searchplugins
    directory is not scanned anymore; to fix this we provide a compatibility
    link /usr/lib/firefox-addons/searchplugins/common => /usr/lib/firefox-addons/searchplugins
    - update debian/firefox-3.0.links
  * fix localized search engine upstream code to properly deal with general.useragent.locale
    being a complex pref; also change plugin dir order to allow locale specific searchplugins
    to overlay the ones shipped in "searchplugins/common"
    - add debian/patches/fix_complex_locale_distro_searchplugins.patch
    - update debian/patches/series

 -- Alexander Sack <email address hidden>   Wed, 02 Sep 2009 17:36:45 +0200
Superseded in karmic-release on 2009-09-10
Superseded in karmic-release on 2009-09-07
firefox-3.0 (3.0.13+nobinonly-0ubuntu3) karmic; urgency=low

  * good-bye "Multisearch"; we remove our karmic alpha3 experiment called
    "Multisearch" as we are approaching alpha4 (LP: #402767, #402804, #406893,
     #410997, #408484, #403246)
    - remove <email address hidden>/...
    - update debian/firefox-3.0.install
    - update debian/rules

 -- Alexander Sack <email address hidden>   Tue, 11 Aug 2009 11:14:32 +0200
Superseded in karmic-release on 2009-08-11
firefox-3.0 (3.0.13+nobinonly-0ubuntu2) karmic; urgency=low

  * Firefox 3.5 by default transition
    + see: https://blueprints.launchpad.net/ubuntu/+spec/desktop-karmic-firefox-3.5
    + drop meta packages moved to 3.5: firefox, abrowser and firefox-gnome-support
      - update debian/control
    + fix restart issues by installing proper versioned binary (without a
      firefox-fsh patch; in turn drop unversioned firefox link from .install
      - update debian/rules
      - update debian/firefox-3.0.install
    * fix .desktop file starting firefox 3.5, by invoking the right versioned
      firefox binary; in same turn add 3.0 to Name= field in order to distinguish
      the menu entry from the default entry
      - update debian/firefox-3.0-final.desktop

 -- Alexander Sack <email address hidden>   Mon, 10 Aug 2009 17:16:17 +0200
Superseded in hardy-updates on 2009-09-10
Superseded in hardy-security on 2009-09-10
firefox-3.0 (3.0.13+nobinonly-0ubuntu0.8.04.1) hardy-security; urgency=low

  * security/stability v3.0.13 (FIREFOX_3_0_13_RELEASE)
    - see USN-811-1

 -- Alexander Sack <email address hidden>   Mon, 03 Aug 2009 13:35:31 +0200
Superseded in intrepid-updates on 2009-09-10
Superseded in intrepid-security on 2009-09-10
firefox-3.0 (3.0.13+nobinonly-0ubuntu0.8.10.1) intrepid-security; urgency=low

  * security/stability v3.0.13 (FIREFOX_3_0_13_RELEASE)
    - see USN-811-1

 -- Alexander Sack <email address hidden>   Mon, 03 Aug 2009 13:31:41 +0200
Superseded in jaunty-updates on 2009-09-10
Superseded in jaunty-security on 2009-09-10
firefox-3.0 (3.0.13+nobinonly-0ubuntu0.9.04.1) jaunty-security; urgency=low

  * security/stability v3.0.13 (FIREFOX_3_0_13_RELEASE)
    - see USN-811-1

 -- Alexander Sack <email address hidden>   Mon, 03 Aug 2009 13:27:05 +0200
Superseded in karmic-release on 2009-08-10
firefox-3.0 (3.0.13+nobinonly-0ubuntu1) karmic; urgency=low

  * security/stability v3.0.13 (FIREFOX_3_0_13_RELEASE)
    - see USN-811-1

 -- Alexander Sack <email address hidden>   Mon, 03 Aug 2009 13:22:21 +0200
Superseded in karmic-release on 2009-08-05
firefox-3.0 (3.0.12+build1+nobinonly-0ubuntu2) karmic; urgency=low

  * security/stability v3.0.12 build1 (FIREFOX_3_0_12_BUILD1)
    - see USN-798-1
  * fix LP: #384120 - apport package hook not used for 'ubuntu-bug firefox'; we
    ship a link in the firefox "metapackage" that points to the proper apport
    hook version (e.g. firefox-3.0.py, firefox-3.5.py, etc.)
    add debian/firefox.links
  * fix LP: #398121 - firefox-3.5-gnome-support failed to install/upgrade; we
    make the postinst script more failsafe
    - update debian/firefox-3.0-gnome-support.postinst.in
  * add me001 multisearch feature for karmic alpha3
    - add debian/extensions/*
  * drop patches applied upstream
    - delete debian/patches/bz412610_att335369_realpath_overflow.patch
    - update debian/patches/series

 -- Alexander Sack <email address hidden>   Wed, 22 Jul 2009 16:07:02 +0200
Superseded in karmic-release on 2009-07-23
firefox-3.0 (3.0.11+build2+nobinonly-0ubuntu2.me001) karmic; urgency=low

  * add me001 multisearch feature for karmic alpha3
    - add debian/extensions/*

 -- Alexander Sack <email address hidden>   Tue, 21 Jul 2009 18:13:45 +0200
Superseded in hardy-updates on 2009-08-05
Superseded in hardy-security on 2009-08-05
firefox-3.0 (3.0.12+build1+nobinonly-0ubuntu0.8.04.1) hardy-security; urgency=low

  * security/stability v3.0.12 build1 (FIREFOX_3_0_12_BUILD1)
    - see USN-798-1
  * fix build-depends syntax
    - update debian/control

 -- Alexander Sack <email address hidden>   Wed, 08 Jul 2009 14:07:33 +0200
Superseded in intrepid-updates on 2009-08-05
Superseded in intrepid-security on 2009-08-05
firefox-3.0 (3.0.12+build1+nobinonly-0ubuntu0.8.10.1) intrepid-security; urgency=low

  * security/stability v3.0.12 build1 (FIREFOX_3_0_12_BUILD1)
    - see USN-798-1
  * drop patches applied upstream
    - delete debian/patches/bz412610_att335369_realpath_overflow.patch
    - update debian/patches/series
  * fix build-depends syntax
    - update debian/control

 -- Alexander Sack <email address hidden>   Wed, 08 Jul 2009 13:51:40 +0200
Superseded in jaunty-updates on 2009-08-05
Superseded in jaunty-security on 2009-08-05
firefox-3.0 (3.0.12+build1+nobinonly-0ubuntu0.9.04.1) jaunty-security; urgency=low

  * security/stability v3.0.12 build1 (FIREFOX_3_0_12_BUILD1)
    - see USN-798-1
  * drop patches applied upstream
    - delete debian/patches/bz412610_att335369_realpath_overflow.patch
    - update debian/patches/series

 -- Alexander Sack <email address hidden>   Wed, 08 Jul 2009 13:23:04 +0200
Superseded in karmic-release on 2009-07-21
firefox-3.0 (3.0.11+build2+nobinonly-0ubuntu2) karmic; urgency=low

  * security/stability v3.0.11 build2 (FIREFOX_3_0_11_BUILD2)
    - see USN-779-1
  * adjust patches to changed upstream codebase
    - update debian/patches/bzXXX_reload_new_plugins.patch
  * update client code for google searchplugin
    - add debian/patches/google_code.patch
    - update debian/patches/series

 -- Alexander Sack <email address hidden>   Wed, 03 Jun 2009 11:20:41 +0200
Superseded in hardy-updates on 2009-07-22
Superseded in hardy-security on 2009-07-22
firefox-3.0 (3.0.11+build2+nobinonly-0ubuntu0.8.04.1) hardy-security; urgency=low

  * security/stability v3.0.11 build2 (FIREFOX_3_0_11_BUILD2)
    - see USN-779-1
  * adjust patches to changed upstream codebase
    - update debian/patches/bzXXX_reload_new_plugins.patch

 -- Alexander Sack <email address hidden>   Wed, 03 Jun 2009 11:55:45 +0200
Superseded in intrepid-updates on 2009-07-22
Superseded in intrepid-security on 2009-07-22
firefox-3.0 (3.0.11+build2+nobinonly-0ubuntu0.8.10.1) intrepid-security; urgency=low

  * security/stability v3.0.11 build2 (FIREFOX_3_0_11_BUILD2)
    - see USN-779-1
  * adjust patches to changed upstream codebase
    - update debian/patches/bzXXX_reload_new_plugins.patch

 -- Alexander Sack <email address hidden>   Wed, 03 Jun 2009 11:30:55 +0200
Superseded in jaunty-updates on 2009-07-22
Superseded in jaunty-security on 2009-07-22
firefox-3.0 (3.0.11+build2+nobinonly-0ubuntu0.9.04.1) jaunty-security; urgency=low

  * security/stability v3.0.11 build2 (FIREFOX_3_0_11_BUILD2)
    - see USN-779-1
  * adjust patches to changed upstream codebase
    - update debian/patches/bzXXX_reload_new_plugins.patch

 -- Alexander Sack <email address hidden>   Wed, 03 Jun 2009 11:27:38 +0200
Superseded in karmic-release on 2009-06-12
firefox-3.0 (3.0.10+nobinonly-0ubuntu1) karmic; urgency=low

  * security/stability v3.0.10 (FIREFOX_3_0_10_RELEASE)
    - see USN-765-1

Superseded in jaunty-updates on 2009-06-13
Superseded in jaunty-security on 2009-06-12
firefox-3.0 (3.0.10+nobinonly-0ubuntu0.9.04.1) jaunty-security; urgency=low

  * security/stability v3.0.10 (FIREFOX_3_0_10_RELEASE)
    - see USN-765-1

 -- Alexander Sack <email address hidden>   Sat, 25 Apr 2009 14:43:43 +0200
Superseded in intrepid-updates on 2009-06-13
Superseded in intrepid-security on 2009-06-12
firefox-3.0 (3.0.10+nobinonly-0ubuntu0.8.10.1) intrepid-security; urgency=low

  * security/stability v3.0.10 (FIREFOX_3_0_10_RELEASE)
    - see USN-765-1

 -- Alexander Sack <email address hidden>   Sat, 25 Apr 2009 14:44:58 +0200
Superseded in hardy-updates on 2009-06-13
Superseded in hardy-security on 2009-06-12
firefox-3.0 (3.0.10+nobinonly-0ubuntu0.8.04.1) hardy-security; urgency=low

  * security/stability v3.0.10 (FIREFOX_3_0_10_RELEASE)
    - see USN-765-1

 -- Alexander Sack <email address hidden>   Sat, 25 Apr 2009 14:46:08 +0200
Superseded in jaunty-updates on 2009-04-28
Superseded in jaunty-security on 2009-04-28
firefox-3.0 (3.0.9+nobinonly-0ubuntu0.9.04.1) jaunty-security; urgency=low

  * security/stability v3.0.9 (FIREFOX_3_0_9_RELEASE)
    - see USN-764-1

 -- Alexander Sack <email address hidden>   Tue, 21 Apr 2009 12:39:21 +0200
Superseded in intrepid-updates on 2009-04-28
Superseded in intrepid-security on 2009-04-28
firefox-3.0 (3.0.9+nobinonly-0ubuntu0.8.10.1) intrepid-security; urgency=low

  * security/stability v3.0.9 (FIREFOX_3_0_9_RELEASE)
    - see USN-764-1

 -- Alexander Sack <email address hidden>   Tue, 21 Apr 2009 13:51:29 +0200
Superseded in hardy-updates on 2009-04-28
Superseded in hardy-security on 2009-04-28
firefox-3.0 (3.0.9+nobinonly-0ubuntu0.8.04.1) hardy-security; urgency=low

  * security/stability v3.0.9 (FIREFOX_3_0_9_RELEASE)
    - see USN-764-1

 -- Alexander Sack <email address hidden>   Tue, 21 Apr 2009 13:52:29 +0200
Superseded in karmic-release on 2009-04-29
Obsolete in jaunty-release on 2013-02-28
firefox-3.0 (3.0.8+nobinonly-0ubuntu3) jaunty; urgency=low

  * drop google code again
    - remove debian/patches/google_code.patch
    - update debian/patches/series

 -- Alexander Sack <email address hidden>   Tue, 07 Apr 2009 10:58:55 +0200
Superseded in jaunty-release on 2009-04-07
firefox-3.0 (3.0.8+nobinonly-0ubuntu2) jaunty; urgency=low

  * security/stability v3.0.8 (FIREFOX_3_0_8_RELEASE)
    - see USN-745-1

 -- Alexander Sack <email address hidden>   Fri, 27 Mar 2009 10:51:07 +0100
Superseded in intrepid-updates on 2009-04-23
Superseded in intrepid-security on 2009-04-23
firefox-3.0 (3.0.8+nobinonly-0ubuntu0.8.10.2) intrepid-security; urgency=low

  * security/stability v3.0.8 (FIREFOX_3_0_8_RELEASE)
    - see USN-745-1

 -- Alexander Sack <email address hidden>   Fri, 27 Mar 2009 10:52:19 +0100
Superseded in hardy-updates on 2009-04-23
Superseded in hardy-security on 2009-04-23
firefox-3.0 (3.0.8+nobinonly-0ubuntu0.8.04.2) hardy-security; urgency=low

  * security/stability v3.0.8 (FIREFOX_3_0_8_RELEASE)
    - see USN-745-1

 -- Alexander Sack <email address hidden>   Fri, 27 Mar 2009 10:53:49 +0100
Superseded in jaunty-release on 2009-03-28
firefox-3.0 (3.0.7+nobinonly-0ubuntu2) jaunty; urgency=low

  * update client code for google searchplugin
    - add debian/patches/google_code.patch
    - update debian/patches/series

 -- Alexander Sack <email address hidden>   Tue, 24 Mar 2009 17:45:46 +0100
Superseded in jaunty-release on 2009-03-27
firefox-3.0 (3.0.7+nobinonly-0ubuntu1) jaunty; urgency=low

  * security/stability v3.0.7 (FIREFOX_3_0_7_RELEASE)
    - USN-728-1

 -- Alexander Sack <email address hidden>   Thu, 05 Mar 2009 17:20:33 +0100
Superseded in intrepid-updates on 2009-03-28
Superseded in intrepid-security on 2009-03-28
firefox-3.0 (3.0.7+nobinonly-0ubuntu0.8.10.1) intrepid-security; urgency=low

  * security/stability v3.0.7 (FIREFOX_3_0_7_RELEASE)
    - USN-728-1

 -- Alexander Sack <email address hidden>   Wed, 04 Mar 2009 22:34:55 +0100
Superseded in hardy-updates on 2009-03-28
Superseded in hardy-security on 2009-03-28
firefox-3.0 (3.0.7+nobinonly-0ubuntu0.8.04.1) hardy-security; urgency=low

  * security/stability v3.0.7 (FIREFOX_3_0_7_RELEASE)
    - USN-728-1

 -- Alexander Sack <email address hidden>   Wed, 04 Mar 2009 22:39:46 +0100
Superseded in intrepid-updates on 2009-03-06
Superseded in intrepid-security on 2009-03-06
firefox-3.0 (3.0.6+nobinonly-0ubuntu0.8.10.1) intrepid-security; urgency=low

  * security/stability update v3.0.6 (FIREFOX_3_0_6_RELEASE)
    - USN-717-1

 -- Alexander Sack <email address hidden>   Thu, 05 Feb 2009 09:22:39 +0100
Superseded in hardy-updates on 2009-03-06
Superseded in hardy-security on 2009-03-06
firefox-3.0 (3.0.6+nobinonly-0ubuntu0.8.04.1) hardy-security; urgency=low

  * security/stability update v3.0.6 (FIREFOX_3_0_6_RELEASE)
    - USN-717-1

 -- Alexander Sack <email address hidden>   Thu, 05 Feb 2009 09:24:11 +0100
Superseded in jaunty-release on 2009-03-05
firefox-3.0 (3.0.6+nobinonly-0ubuntu1) jaunty; urgency=low

  * security/stability v3.0.6 (FIREFOX_3_0_6_RELEASE)
    - USN-717-1

 -- Alexander Sack <email address hidden>   Thu, 05 Feb 2009 09:21:16 +0100
Superseded in jaunty-release on 2009-02-05
firefox-3.0 (3.0.5+nobinonly-0ubuntu1) jaunty; urgency=low

  New upstream security/stability update (v3.0.5 aka FIREFOX_3_0_5_RELEASE)
  - see USN-690-1

  [ Nick Ellery <email address hidden> ]
  * fix LP: #270477 - firefox-3.0-branding has errors in it's package description
    - update debian/control

  [ Alexander Sack <email address hidden> ]
  * do not install DEBIAN_NAME_OTHER chrome in binary-install/$(DEBIAN_NAME)::
    target.
    - update debian/rules
  * fix LP: #271524 - Firefox/Abrowser recommend ubufox; we demote ubufox to
    Suggests in order to prevent gnome stuff from being installed on kde
    systems
    - update debian/control
  * drop know your rights patch, which was replaced upstream by their own
    development
    - delete debian/patches/lp269656_know_your_rights.patch
    - update debian/patches/series

 -- Alexander Sack <email address hidden>   Tue, 16 Dec 2008 16:22:10 +0100
Superseded in intrepid-updates on 2009-02-10
Superseded in intrepid-security on 2009-02-10
firefox-3.0 (3.0.5+nobinonly-0ubuntu0.8.10.1) intrepid-security; urgency=low

  * new security/stability upstream release v3.0.5 (FIREFOX_3_0_5_RELEASE)
    - see USN-690-1
  * drop know your rights patch, which was replaced upstream by their own
    development
    - delete debian/patches/lp269656_know_your_rights.patch
    - update debian/patches/series

 -- Alexander Sack <email address hidden>   Tue, 16 Dec 2008 19:21:20 +0100
Superseded in hardy-updates on 2009-02-10
Superseded in hardy-security on 2009-02-10
firefox-3.0 (3.0.5+nobinonly-0ubuntu0.8.04.1) hardy-security; urgency=low

  * new security/stability upstream release v3.0.5 (FIREFOX_3_0_5_RELEASE)
    - see USN-690-1

 -- Alexander Sack <email address hidden>   Tue, 16 Dec 2008 19:19:19 +0100
Superseded in jaunty-release on 2008-12-17
firefox-3.0 (3.0.4+nobinonly-0ubuntu2) jaunty; urgency=low

  * ship $MOZ_APP_DIR/distribution/distribution.ini
    - add debian/distribution.ini
    - update debian/rules

 -- Alexander Sack <email address hidden>   Mon, 24 Nov 2008 12:40:07 +0100
Superseded in jaunty-release on 2008-11-24
firefox-3.0 (3.0.4+nobinonly-0ubuntu1) jaunty; urgency=low

  * new security/stability update FIREFOX_3_0_4_RELEASE (v3.0.4)
    - see USN-667-1

  [ Fabien Tassin <email address hidden> ]
  * Fix missing comma in Build-Depends breaking older dpkg-dev
    - update debian/control

 -- Alexander Sack <email address hidden>   Sun, 16 Nov 2008 17:12:57 +0100
175 of 113 results