Unified mime type handling

Bug #13373 reported by Jean Privat on 2005-02-28
30
Affects Status Importance Assigned to Milestone
firefox (Ubuntu)
Medium
Ian Jackson

Bug Description

Firefox don't use the same mime information that gnome.
Applications than can handle a certain kind of files are not the same.

I open a wiki page http://www.ubuntulinux.org/wiki/MimeManagement

Thom May (thombot) wrote :

*** Bug 13909 has been marked as a duplicate of this bug. ***

Jeff Waugh (jdub) wrote :

We have to do one, or both of the following: firstly, get the firefox/gnome-vfs
mime patches in, and secondly, synchronise mailcap with freedesktop mime
standard data.

My bug #13909 got marked as a duplicate of this... My original "bug" said:

> Gnome 2.10 comes with a new fancy "Open With..."-dialog. Why not let firefox use
> this when you clicked "Open With"->other... when saving/opening some file of the
> web?

It is definitely strongly related to this bug, but isn't the same is it? Maybe I
have hust misunderstood...

Juha Sahakangas (juhaz) wrote :

Firefox in Hoary can and does use gnome vfs mime system, _IF_ it doesn't find
suitable application in in mailcap.

I'd say using both is okay, especially if they will be synchronized, but the
preference order is certaily wrong... should check gnome first, and mailcap only
if it doesn't find anything.

Ian Jackson (ijackson) wrote :

This issue is definitely not going to be fixed in Breezy.

Matt Zimmerman (mdz) wrote :

*** Bug 24883 has been marked as a duplicate of this bug. ***

Dennis Kaarsemaker (dennis) wrote :

(In reply to comment #3)
> My bug #13909 got marked as a duplicate of this... My original "bug" said:
>
> > Gnome 2.10 comes with a new fancy "Open With..."-dialog. Why not let firefox use
> > this when you clicked "Open With"->other... when saving/opening some file of the
> > web?
>
> It is definitely strongly related to this bug, but isn't the same is it? Maybe I
> have hust misunderstood...

That fancy dialog is also part of the gnome/firefox patch :)

(In reply to comment #7)
> (In reply to comment #3)
> > My bug #13909 got marked as a duplicate of this... My original "bug" said:
> >
> > > Gnome 2.10 comes with a new fancy "Open With..."-dialog. Why not let
firefox use
> > > this when you clicked "Open With"->other... when saving/opening some file
of the
> > > web?
> >
> > It is definitely strongly related to this bug, but isn't the same is it? Maybe I
> > have hust misunderstood...
>
> That fancy dialog is also part of the gnome/firefox patch :)

Excuse me being confused :-) ... Are you implying that this is fixed? I still
see the old gtk-filechooser when I click Open With->Other...

Matt Zimmerman (mdz) wrote :
Changed in firefox:
status: Unconfirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.