Ubuntu

Flash plugin problem with ARGB visuals causes crash

Reported by LeitoMonk on 2005-04-03
480
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Mozilla Firefox
Invalid
Critical
firefox (Ubuntu)
Medium
Unassigned
flashplugin-nonfree (Ubuntu)
Medium
Unassigned

Bug Description

Firefox crash randomly when load some sites and the debug message is:

The program 'Gecko' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadMatch (invalid parameter attributes)'.
  (Details: serial 104 error_code 8 request_code 145 minor_code 3)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)

i've try with mozilla-firefox --sync and return the same result

bettlebrox (micktimony) wrote :

Created an attachment (id=2048)
Output from strace on firefox

I been having the same problems for the past 2 or 3 days. It seems to happen
after I open more than 4 tabs. Running firefox with the --sync and/or -debug
flags does not provide any more info.

I ran firefox with strace and it seems to be complaining about some fonts? I've
attached the partial out from strace, e-mail me if you need more info.

bettlebrox (micktimony) wrote :

(In reply to comment #1)
> Created an attachment (id=2048) [edit]
> Output from strace on firefox
>
> I been having the same problems for the past 2 or 3 days. It seems to happen
> after I open more than 4 tabs. Running firefox with the --sync and/or -debug
> flags does not provide any more info.
>
> I ran firefox with strace and it seems to be complaining about some fonts? I've
> attached the partial out from strace, e-mail me if you need more info.
>
I tracked the problem down to the flash plugin.

I removed all extensions and themes, and all plugins. With no plugins the
browser was stable. Then I added plugins back one by one, and the browser
started crashing on the Flash plugin (libflashplayer.so).

I'll try browsing with the libflash-mozplugin for a while and see how it behaves.

Daniel Robitaille (robitaille) wrote :

*** Bug 16135 has been marked as a duplicate of this bug. ***

Daniel Robitaille (robitaille) wrote :

*** Bug 16243 has been marked as a duplicate of this bug. ***

Gregory Oschwald (osch0001) wrote :

I had this same problem occur. In my case, it was due to the flash player
trying to play sounds and being unable to. I modified
/etc/mozilla-firefox/mozilla-firefoxrc and changed FIREFOX_DSP from "auto" to
"none". Since doing this, everything seems to work great. I did not verify if
this happened in other plugins that use sound or not.

Mathieu Leduc-Hamel (marrakis) wrote :

You may add the following line in your firefox starting script (/usr/bin/firefox):

export XLIB_SKIP_ARGB_VISUALS=1

It solve my problems too.

(In reply to comment #5)
> I had this same problem occur. In my case, it was due to the flash player
> trying to play sounds and being unable to. I modified
> /etc/mozilla-firefox/mozilla-firefoxrc and changed FIREFOX_DSP from "auto" to
> "none". Since doing this, everything seems to work great. I did not verify if
> this happened in other plugins that use sound or not.

bettlebrox (micktimony) wrote :

(In reply to comment #6)

Setting FIREFOX_DSP to none did not solve the problem but
XLIB_SKIP_ARGB_VISUALS=1 did solve it.

Thanks
Mick

> You may add the following line in your firefox starting script (/usr/bin/firefox):
>
> export XLIB_SKIP_ARGB_VISUALS=1
>
> It solve my problems too.
>
> (In reply to comment #5)
> > I had this same problem occur. In my case, it was due to the flash player
> > trying to play sounds and being unable to. I modified
> > /etc/mozilla-firefox/mozilla-firefoxrc and changed FIREFOX_DSP from "auto" to
> > "none". Since doing this, everything seems to work great. I did not verify if
> > this happened in other plugins that use sound or not.

Soren Hansen (soren) wrote :

Created an attachment (id=2613)
Adds the XLIB_SKIP_ARGB_VISUALS to the wrapper script

Attached a patch to add the XLIB_SKIP_ARGB_VISUALS environment variable to the
firefox wrapper script.

User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.10) Gecko/20050724 Firefox/1.0.6
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.10) Gecko/20050724 Firefox/1.0.6

If you display a webpage with a flash animation in it (for example
http://www.stadtplandienst.de) Firefox will crash.

This crash only appears when the following things are true:
XServer uses the composite extension und has the color-depth set to 16 bit.
If the composite extension is switched off or the color-depth is set to 24 bit,
the problem doesn´t occour.

If the flash-plugin itself is renamed or deleted, everything works only the
flash is not shown any more ("Click here to download the plugin").

Reproducible: Always

Steps to Reproduce:
1. Set x-server to use the composite extension and set the color depth to 16 bit
2. Start firefox, goto a webpage with flash e.g. www.stadtplandienst.de
3. Crash
Actual Results:
In the console, the following message is shown and the programm will die with
all remaining processes.

Errormessage:
The program 'Gecko' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadMatch (invalid parameter attributes)'.
  (Details: serial 164 error_code 8 request_code 147 minor_code 3)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)
firefox-bin exited with non-zero status (1)

Expected Results:
Not crash und show flash correct

Created an attachment (id=192427)
Buildconfig of firefox

Created an attachment (id=192428)
Plugins installed in firefox

Created an attachment (id=192429)
XOrg-configuration-file

Yes, the same problem.
My configuration is Pentium4, 512M RAM, Debian sid, Xorg 6.8.2 :
X Window System Version 6.8.2 (Debian 6.8.2.dfsg.1-5 20050810052028
<email address hidden>)
Release Date: 9 February 2005
X Protocol Version 11, Revision 0, Release 6.8.2
Build Operating System: Linux 2.6.12-1-686 i686 [ELF]
Current Operating System: Linux toshiba 2.6.12-1-686 #1 Tue Aug 9 13:00:08 UTC
2005 i686
Build Date: 10 August 2005
        Before reporting problems, check http://wiki.X.Org
        to make sure that you have the latest version.
Module Loader present
OS Kernel: Linux version 2.6.12-1-686 (buildd@ninsei) (gcc version 4.0.2
20050806 (prerelease) (Debian 4.0.1-4)) #1 Tue Aug 9 13:00:08 UTC 2005 T

Its was test in deekpark 2 and snapshot 20050815.
Flash version 7 (lastest).

Konqueror use the same plugin but does not crash and runs well in xorg.

If XFree (not xorg) everthing is OK.

To workaround this problem :
export XLIB_SKIP_ARGB_VISUALS=1
firefox&

in terminal.

Please provide a talkback ID for the crash. http://kb.mozillazine.org/Talkback

In my first installation I turn off the agent talkback, how can I turn on, again ?
(using deeppark)

This bug is happening to me also, according to the Xorg guys @
https://bugs.freedesktop.org/show_bug.cgi?id=1336 this is a bug in 'flash plugin'.

This isn't unconfirmed, as a number of people have this problem, and have had it
for some time (just look on google). It's still there in the 1.5 beta
(Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8b4) Gecko/20050908 Firefox/1.4)n too.

Is there anything that can be done to go forward with this ? I'd include a
talkback ID, but (on this linux box) it doesn't appear to generate one.

Ian Jackson (ijackson) wrote :

Can you confirm whether this problem still exists with breezy's firefox ?
(1.0.6-1ubuntu13, or the preview snapshot version)

If so, please provide a URL and recipe to reproduce the problem.

Thanks.

bettlebrox (micktimony) wrote :

(In reply to comment #9)
> Can you confirm whether this problem still exists with breezy's firefox ?
> (1.0.6-1ubuntu13, or the preview snapshot version)
>
> If so, please provide a URL and recipe to reproduce the problem.
>
> Thanks.
I do not see the problem with Breezy's Firefox. Please close this bug.

Thanks

Ian Jackson (ijackson) wrote :

Thank you for your reply. I'm closing the bug now.

*** Bug 308024 has been marked as a duplicate of this bug. ***

*** Bug 258497 has been marked as a duplicate of this bug. ***

*** Bug 265426 has been marked as a duplicate of this bug. ***

*** Bug 268060 has been marked as a duplicate of this bug. ***

*** Bug 279837 has been marked as a duplicate of this bug. ***

*** Bug 285008 has been marked as a duplicate of this bug. ***

*** Bug 309624 has been marked as a duplicate of this bug. ***

I am going to leave this unconfirmed Gavin said that this is likely an external
problem.

For all of you who are seeing this, do you see this in the latest version of Flash? http://plugindoc.mozdev.org/linux.html#Flash

 The plugin site referred to in the last comment lists the current version
of the flash plugin as 7.0r25, which I had, but the version one will get
if one pulls the thing down is 7.0 r61. I installed this and tested. The bug
is still present in Firefox 1.5-rc3 (and/or flash 7.0r61, and/or the xorg
server...).

So I was thinking... is there any reason why we can't add `export XLIB_SKIP_ARGB_VISUALS' to the Firefox mozilla.in file in order to stop this from happening? It sounds like Flash is abusing the "extra visuals". http://xorg.freedesktop.org/X11R6.8.0/doc/RELNOTES5.html

 It's pretty clear this is a flash problem. Hopefully someone has told them about
it.
  As a wishlist item: it would be nice if plugins could be encapsulated somehow
so that instead of the browser crashing, the plugin crashes and is disabled. It
looks like Firefox is getting an X error and just throwing in the towel. A little
more robustness and perseverance would be a good thing if possible.

Jim the last bit is Bug 156493 'Browser should tolerate plug-in (plugin) malfunctions, like with a separate (own) process' or bug 230017 'RFE: Run plugins in a separate thread'.

*** Bug 319548 has been marked as a duplicate of this bug. ***

Ian Jackson (ijackson) wrote :

In fact, I think this bug still exists for other people.

Ian Jackson (ijackson) wrote :

*** Bug 23392 has been marked as a duplicate of this bug. ***

Ian Jackson (ijackson) wrote :

*** Bug 25681 has been marked as a duplicate of this bug. ***

Sam Liddicott (sam-liddicott) wrote :

I do see this with breezy firefox, please see the comments on
http://bugzilla.ubuntu.com/show_bug.cgi?id=19565
where we show that it is an ALSA bug.

Hi

I did 'export XLIB_SKIP_ARGB_VISUALS=1 ; firefox' and then loaded some flash pages.

The patch didn't work :-(

An inmediate test is trying to play any Youtube.com video.

Commenting the Composite section in x.org solved my issue.

Michael R. Head (burner) on 2006-09-19
Changed in firefox:
status: Unconfirmed → Confirmed
Ian Jackson (ijackson) on 2006-09-19
Changed in firefox:
assignee: ijackson → nobody
Changed in firefox:
status: Unknown → Confirmed
Ian Jackson (ijackson) on 2006-10-31
Changed in firefox:
assignee: nobody → ijackson
51 comments hidden view all 131 comments
Michael R. Head (burner) wrote :

If flash is critical and you really need ARGB visuals for firefox, consider using the edgy-backports. The Flash beta 9 there works well.

Ian Jackson (ijackson) on 2006-12-12
Changed in firefox:
assignee: ijackson → nobody
David Farning (dfarning) on 2006-12-31
Changed in firefox:
assignee: nobody → mozillabugs
Rolf Leggewie (r0lf) wrote :

bug 62988 and bug 14911 are dupes. Both have quite a number of other reports marked as dupes to them which is why I don't feel like rectifying the situation (Malone is severely broken here and requires lots of manual intervention)

Changed in flashplugin-nonfree:
status: Unconfirmed → Confirmed

*** Bug 366805 has been marked as a duplicate of this bug. ***

SteveCoast (steve-asklater) wrote :

This is getting very stupid. :-)

I've just upgraded to FF 2.0.0.1 and it's overwritten the manual patch to fix it, and started crashing again.

When is this going to get fixed? Just imagine all the people without a web browser, or people I've installed ubuntu for who now thing it's rubbish because 'the internet crashes all the time'.

What has to be done to close this bug? How can I help? :-)

Timo Aaltonen (tjaalton) wrote :

SteveCoast: use the flashplugin-nonfree from backports.... this bug is really in flashplugin and fixed upstream since early November.

Changed in flashplugin-nonfree:
importance: Undecided → Medium
Daniel T Chen (crimsun) wrote :

The flashplugin-nonfree portion is already fixed in 7.04.

Changed in flashplugin-nonfree:
status: Confirmed → Fix Released

*** Bug 360835 has been marked as a duplicate of this bug. ***

*** Bug 368286 has been marked as a duplicate of this bug. ***

*** Bug 369325 has been marked as a duplicate of this bug. ***

CH (yogich) wrote :

The following was the case with Dapper, which also had the Firefox crash problem:

After seeing the problem, post-performance of 'apt-get dist-upgrade'... I saved all the downloads, recovered the previous day's backup and commenced, on a hunch, to manually upgrade Firefox, rather than upgrading the whole enchalada at once (as I usually do, with 'apt-get dist-upgrade'). Instead, I performed 'apt-get install firefox' after the downloads were all completed.

The result was that the 'mozilla-firefox' package was removed ...and with that, the flash plugin/Firefox bug was also removed. Subsequent 'apt-get dist-upgrade' then upgraded the remaining packages --minus mozilla-firefox, of course.

azteech (stevep.) wrote :

I am running stock 5.10 (breezy), with stock FF 1.5.0.9 (came on Breezy cd). I installed the flashplayer plugin 9 from labs.adobe.com site.
No upgrades to 5.10, or FF have been done, except for the flashplayer addition.
It was recommended I follow the fixes listed in http://ubuntuforums.org/showpost.php?p=1673725&postcount=23 , which I have done.
Color Depth was already set to "24" (Nvida GeForce4 mx 4000 (PCI) 128 mb card (using supplied drivers), running at 1280x1024/75hz resolution); and, there is no composit section listed in my /etc/X11/xorg.conf file, so there was no need to comment that out.
So only solution I could do was to add the extra line "export XLIB_SKIP_ARGB_VISUALS=1 " in the /etc/firefox/firefoxrc file. After rebooting computer, Firefox still crashes.

Waiting on my 6.06 LTS cds (on dial up do downloading is not an option). At this point, I am lost for possible solutions at this point. Any help will be appreciated.

David Farning (dfarning) on 2007-02-24
Changed in firefox:
assignee: mozillateam → mozilla-bugs

Howdy guys,

Can I ask if anyone is still experiencing any trouble with this bug under Flash 9 in a Support version of Ubuntu, (Dapper, Edgy or Feisty). This bug has been open for a while now and it would be amazing to show we have finally managed to close it.

I will check back in a month or so.

Thanks, Alex.

Changed in firefox:
assignee: mozilla-bugs → admin-yawnster
Michael R. Head (burner) wrote :

The Flash 9 packages and backports fixed it on all my systems.

Jolande Poel (phoeganleisha) wrote :

I'm running Ubuntu 7.04 and I still have this bug. I tried the fixes except Flash 9 packages and backports, since I don't know how to do that.

I have a AMD64 machine. Swiftfox (installed via automatix) and epiphany don't crash on flash sites.

Jolande Poel (phoeganleisha) wrote :

I take that back, epiphany crashed after a few minutes.

Hmm on Feisty Flash 9 is the default version.. Strange..

Can you please check which version of flash you are using Jolande, you can do this by typing 'about:plugins' in the address bar.

Thanks, Alex.

Jolande Poel (phoeganleisha) wrote :

My screen resolution is 800x600 and I can't change it back, the screen resolution thingy gives me the option 800x600 and 640x480.

My flashplayer is version 9 rc3, from what I recall. Firefox now refuses to open altogether. Every time I select it in the menu, it says it's starting up, and opens a swiftfox window.

Jolande Poel <email address hidden> writes:

> I'm running Ubuntu 7.04 and I still have this bug. I tried the fixes
> except Flash 9 packages and backports, since I don't know how to do
> that.
>
> I have a AMD64 machine. Swiftfox (installed via automatix) and epiphany
> don't crash on flash sites.

Sorry, we don't support automatix, nor 32bit versions of Firefox and
other browsers. Flash doesn't work on amd64 at all.

--
Gruesse/greetings,
Reinhard Tartler, KeyID 945348A4

Jolande Poel (phoeganleisha) wrote :

Can I disable it in any way so my browser won't crash?

Alexander Sack (asac) wrote :

On Mon, Apr 23, 2007 at 06:33:37AM -0000, Jolande Poel wrote:
> My screen resolution is 800x600 and I can't change it back, the screen
> resolution thingy gives me the option 800x600 and 640x480.
>
> My flashplayer is version 9 rc3, from what I recall. Firefox now refuses
> to open altogether. Every time I select it in the menu, it says it's
> starting up, and opens a swiftfox window.
>

Don't use flashplayer on amd64 ... if you installed from
adobe/macromedia site you probably have to manually remove flash
related files from ~/.mozilla/plugins.

Please remember not to install plugins from non-ubuntu sources in
future, as those will often make your system unstable.

 - Alexander

Alexander Sack (asac) wrote :

in progress for us as upstream bug is confirmed.

Changed in firefox:
status: Confirmed → In Progress
Jolande Poel (phoeganleisha) wrote :

I didn't install it from another source ( think), and I know that now (first few tries with ubuntu my system crashed).

Alexander Sack (asac) wrote :

On Mon, Apr 23, 2007 at 09:33:50AM -0000, Jolande Poel wrote:
> Can I disable it in any way so my browser won't crash?
>

You could uninstall flashplayer package. If it just happens on some
sites you could install the noflash (maybe named a bit different)
extension from addons.mozilla.org, which will allow you to enable
flash only on some pages.

 - Alexander

Enrico Pangan (eipangan) wrote :

This still happens on my Ubuntu 7.04 running Firefox 2.0.0.3 using Shockwave Flash 9.0 r31. This can get VERY irritating. I tried all those ARGB "fixes" and color depth fixes but it still doesn't work.

Drew Woodard (drew-woodard) wrote :

Like the person above me I am also still getting these crashes. I am on Kubuntu Feisty, clean install as of a few hours ago, nothing installed manually, all from the repos.

(relevant software)
Firefox 2.0.0.3
flash 9.0.31.0.2ubuntu1
nvidia-glx 1.0.9631

(relevant hardware)
nvidia geforce 7800gt
msi p6n sli-fi motherboard - nforce 650i chipset - realtek hda audio chipset

Everything is 32bit, I can trigger this fairly reliably by going to google video, loading a video, letting it play for a few seconds then hitting the page-back button while the video is still playing. This will lock the browser around 10% of the time. It also seems to be more of a flash problem than a Firefox problem since I can get the same crashing behavior in konqueror.

I have also tried the "XLIB_SKIP_ARGB_VISUALS=1" options without effect, and my xorg file has 24bit color as the default, and the only mode available uses 24bit. XGL/Beryl stuff has not been installed on this machine so there is nothing fancy in that regard.

Changed in firefox:
assignee: alex.latchford → mozilla-bugs
Drew Woodard (drew-woodard) wrote :

my previous post is probably unrelated to this specific bug, it appears other people are experiencing the same flash crashing issues as I am but it seems unrelated to the ARGB stuff. forum post of other people with this issue is at http://ubuntuforums.org/showthread.php?t=340811

Akkana Peck (akkzilla) wrote :

I've been having this problem since edgy, and still see it after upgrading to feisty (with a flash 7 plug-in that works in other OSes). Either the XLIB_SKIP_ARGB_VISUALS=1 or changing depth to 24 (which it should have been anyway, no idea why edgy set to 16) seems to fix it.

Vaio SR17, S3 Savage video card. Happened with a homebuilt firefox as well as in feisty's package.

*** Bug 359639 has been marked as a duplicate of this bug. ***

*** Bug 390303 has been marked as a duplicate of this bug. ***

*** Bug 390758 has been marked as a duplicate of this bug. ***

mechanized (mechanized) wrote :

yep the same thing here
ubuntu 7.04 and flash crashes much when on youtube.com my colordepth is by default 24

This was fixed in Flash 9, can we please close this bug if noone can still reproduce this?

John Vivirito (gnomefreak) wrote :

Closing bug due to no update on status from upstream or here in ~5 months Please reopen if you still have issues with this bug and can reproduce it steadily. this was fixed in flash so you should no longer see this because i think most of the issue was flash if i remember correctly.

John Vivirito (gnomefreak) wrote :

invalid due to no progress from fix commited.

Changed in firefox:
assignee: mozilla-bugs → nobody
status: In Progress → Invalid

yes i can repoduce it by doing following:

- start firefox

- go to youtube

- search for "crysis"

- click on the video titled "Crysis Physics - 3'000 barrel explosion made with SandBox 2"

- click on video titled "Crysis - Mass Physics" at the list right

- if firefox didnt crash then go back to the first video with "backspace" or the back-button and select the video "Crysis - Mass Physics" again

... now firefox should crash!

my specs: ubuntu hardy, firefox 3.0, flash-nonfree 9

philbert (philbert) wrote :

to reproduce the bug please follow the steps below:
- start firefox

- go to youtube

- search for "crysis"

- click on the video titled "Crysis Physics - 3'000 barrel explosion made with SandBox 2"

- click on video titled "Crysis - Mass Physics" at the list right

- if firefox didnt crash then go back to the first video with "backspace" or the back-button and select the video "Crysis - Mass Physics again

... now firefox should crash!

my specs: ubuntu hardy, firefox 3.0, flash-nonfree 9

does it fail with flash v10?

Originally, I had the same issue Dominik Dresel reported at the very top. The issue reported here:

XServer uses the composite extension und has the color-depth set to 16 bit.
If the composite extension is switched off or the color-depth is set to 24 bit,
the problem doesn´t occour.

Why is this important? Well, lots of people still have older hardware that they want to use, such as my old Toshiba notebook that still works good as long as it's in 16 bit color mode.

In any case, the plugin fails in this configuration and crashes the browser. Perhaps there is a way just to terminate the plugin without crashing the browser in this case (secondary issue)

Primary issue is the XServer settings vs compatibility with the plugin in 16 bit color mode.

Ofer Chen (oferchen) wrote :

Still crashing Ubuntu 9.10 AMD64 + Firefox 3.6

Changed in firefox:
importance: Unknown → Critical

this should have been resolved in FP9. closing>resolved>worksforme...

Changed in firefox:
status: Confirmed → Invalid
Displaying first 40 and last 40 comments. View all 131 comments or add a comment.