firefox32 for amd64 => support 32-bit plugins on amd64

Bug #28479 reported by Alexandre Otto Strube on 2006-01-13
28
Affects Status Importance Assigned to Milestone
firefox (Ubuntu)
Wishlist
Alexander Sack

Bug Description

firefox support for 32-bit plugins on amd64

this bug will be dealt with by spec

   https://blueprints.launchpad.net/ubuntu/+spec/firefox-nspluginwrapper

Changed in firefox:
assignee: nobody → ijackson
Reinhard Tartler (siretart) wrote :

java works fine for me in my 64bit firefox, using the java plugin from multiverse.

The missing flash doesn't make me that sad. better persuade macromedia to open flash, so that free implementations can provide a functional compatible replacement.

Alexandre Otto Strube (surak) wrote :

That's not a simple question of asking for them to open flash (which is quite improbable to happen). They didn't release flash even for windows 64-bit. (that's why people use internet explorer 32 on xp-64)

The people who saw the code (through a NDA) say that it isn't a simple matter of recompiling it.

While this doesn't happen (and we can't sit here just waiting), a firefox32 which wouldn't conflict with firefox64 (and which work with all widgets) is a considerable option to not cripple funtionality from x86-64's ubuntu.

I made myself a request for a 64-bit version of flash. Adobe said it will not be released soon.

Bandit (bandit) wrote :

For all pratical purposes Fx 32bit should be used on Ubuntu 64bit systems. Other distros like SuSE do this to retain as much compatability with flash and java as possible. Besides, what real purpose does having a 64bit brower have over a 32bit. Its just a web browser..

Changed in firefox:
status: Unconfirmed → Confirmed
Ian Jackson (ijackson) on 2006-09-27
Changed in firefox:
assignee: ijackson → nobody

Ok, this is a crash report from trying to log into my online bank, so you can guess just how much of a "non-issue" I think this is.

Now, the java test page on java sun works, so its apparent that it is not all java applets that crash.

I have downloaded and tested the 32-bit firefox (1.5 instead of 2.0 though) from mozilla.org and under that using 32-bit java my online bank's login-applet works flawlessly.

I'd be greatful if a 32-bit firefox version was made available for critical applications like this.

Thanks!

Changed in firefox:
assignee: nobody → mozilla-bugs

while i completely agree that it would be nice if adobe released the specs for flash, it doesn't address the core point of this bug: that ubuntu needs a 32-bit version of firefox like fedora, suse, et al already have.

maybe in the future all firefox plugins will be equally available on 64-bit systems, but we are nowhere close to that now. the single best solution is to use a 32-bit version of firefox. please add it.

Alexander Sack (asac) wrote :

this is now work in progress.

description: updated
Changed in firefox:
assignee: mozilla-bugs → asac
status: Confirmed → In Progress
description: updated
Alexander Sack (asac) wrote :

we have nspluginwrapper ... everything else we most likely won't do.

Changed in firefox:
status: In Progress → Won't Fix
Alexandre Otto Strube (surak) wrote :

The nane of the bug is "support 32-bit plugins". As it's stated on the other comments, it's a work in progress, with the nspluginwrapper. When it's working, the bug must be close, right? I see no point in putting a "wontfix" right now just to decrease the bug count.

Changed in firefox:
status: Won't Fix → In Progress
John Vivirito (gnomefreak) wrote :

nspluginwrapper has been released to gutsy. Marking as invalid due to it already being in the archives.

Changed in firefox:
status: In Progress → Invalid
Alexander Sack (asac) wrote :

nspluginwrapper does not support *all* plugins ... which is why this is only partially fixed. To support every 32-bit plugin we would need to ship 32 bit firefox, which is 'Won't fix' ...

Changed in firefox:
status: Invalid → Won't Fix
MariuszS (mariuszs) wrote :

I need firefox32 too, I dont want to use things like old swiftfox 2.0.4 32bit or Fedora Core 7, only because someone wont fix this.

Alexandre Otto Strube (surak) wrote :

See, there is people interested. This bug had one year and a half when it was simply ignored as "we won't fix it".

Perhaps a look at what people want - or need - wouldn't be bad.

Danson Joseph (nosnad) wrote :

How difficult is it to provide a 32bit firefox installation packaged for amd64.
It's not even that nswrapper doesn't support *all* plugins, it doesn't support one major one: JAVA

Just build a firefox installation as 32bit for 64bit systems, even as an optional package!!!

OR, write a replacement for Flash and Java plugins, whichever is easier for developers.

Regards,
Danson Joseph

Danson Joseph (nosnad) wrote :

It's pointless providing an incomplete system. Systems like LTSP servers with more than 4GB ram can't run 32bit ubuntu. So they cannot be crippled by not having a FULLY functional web browser in an environment that does support 4+GB ram. It's also not realistic to ask people to open a shell and then . . . . to manually place a 32bit version of firefox into their 64bit system. There is another package missing from the repositories, even though it is referenced. and it may help: ia32-sun-java6-plugin?

Changed in firefox:
status: Won't Fix → Confirmed
Alexander Sack (asac) wrote :

please stop bumping the bug status. This is wont fix. We have icedtea-java7 now in gutsy. Use that one as its basically suns java. The plugin works well, so this thing is actually resolved for all major use cases: flash + java.

Changed in firefox:
status: Confirmed → Won't Fix
Mahdi (mahdi-hates-spam) wrote :

I'm sorry to bump this one again, but ffox32 is really a must-have. Icedtea java7 plugin does not satisfy all users yet. Home banking authentication, for example, does not work (https://www2.bancobrasil.com.br/aapf/login.jsp?aapf.IDH=sim , for example. The virtual keyboard load and works, but the login does not complete! The page is reloaded wheter the password is right or not! And that's a major bank, of critical importance to a lot of brazilian users). Swiftfox + sun's java6 plugin, on the other hand works fine.
I believe that is not a work in progress, but a work done! Ubuntu pkgs can easily be found on google, and swiftfox is allright. It's just a matter of uploading it to the official repositories.

Ramesh Dharan (rrdharan) wrote :

Agreed with Mahdi, icedtea simply doesn't cut it for Java, and nspluginwrapper is unfortunately still quite broken in Hardy. It stops working after about 10 minutes, or anytime you have multiple tabs open using Flash simultaneously.

Just take a look at how many views and questions there are on the forums from people trying to do the chroot thing (which sucks too - I lived that way for about a year and it was awful).

Please don't tell us that the plugin simply "works well", when what you really mean is that it works well for you in a five minute sniff test.

Ramesh Dharan (rrdharan) wrote :

There are actually *73* open bugs in LaunchPad for nspluginwrapper:

https://bugs.launchpad.net/bugs/+bugs?field.searchtext=nspluginwrapper&search=Search+Bug+Reports&field.scope=all&field.scope.target=

How much longer are you guys going to keep pretending that it works?

Jarl (jarl-dk) wrote :

I completely agree with Mahdi and Alexandre.
Firefox 32bit on AMD64 is a must have for ubuntu being a user-freindly experience. Please live up to the Kubuntu slogan "Linux for human beings".
I am a convert from SuSE and I am quite disappointed with the lack of firefox 32bit on amd64 in (k)ubuntu. In SuSE you can have firefox 32 bit (plus plugins) in a couple of mouse clicks. And regarding alternatives; IcedTea and nspluginwrapper just don't work! If they did we wouldn't request firefox32.
IcedTea does not work on three (out of three tested) major banks in Denmark; EikBank.dk, Nordea.dk, and basisbank.dk.

Alexander Sack, you may disagree that Firefox 32 bit is the correct solution. But please propose a feasible solution to the real problem then; "Netbanking does not work on default ubuntu installation".

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers