Doesn't show thai language correctly

Bug #43393 reported by redeyes32 on 2006-05-07
30
Affects Status Importance Assigned to Milestone
firefox (Ubuntu)
Medium
Alexander Sack

Bug Description

To fix this: Install thaifonts-scalable 0.4.5-2 -> upgrade ubuntu package.

Binary package hint: firefox

I have a troble with firefox. It can't show thai language correctly, even I install thai language package.It's still the same.

(Important: I ran neither linux nor ubuntu while researching this)

I don't have any trouble at all seeing the thai language. Here's an example of what I see with plain old firefox
http://www.seasite.niu.edu/thai/home_page/dictionaries.htm
and I had the same success with four other googled pages with fair amounts of the language.

The problem was recreated, and confirmed by "persia" . Here's another example:

http://poonlap.blogspot.com/

Changed in firefox:
status: Unconfirmed → Confirmed
Roys Hengwatanakul (roysheng) wrote :

the problem I found is only on text field,droplist etc of form or when add bookmark with thai title

it display the thai character o.k but vowel not in the correct position

the rest can read o.k.

Timokl (timokl) wrote :

I have the same problem. Vowels and tone markers are not rendered at the right place making Thai text (nearly) impossible to read.

It's a font problem. If you have a website with Thai encoding (http://www.thairath.co.th/) like TIS-620 - everything looks nice. But if you have a UTF-8 encoded page, the rendering is not correct.

And there is another thing: Text renders correctly in any time, when you it's italic and/or bold!

thank

  Achitasak Boonthumcharoen

Timokl <email address hidden> wrote: I have the same problem. Vowels and tone markers are not rendered at the
right place making Thai text (nearly) impossible to read.

It's a font problem. If you have a website with Thai encoding
(http://www.thairath.co.th/) like TIS-620 - everything looks nice. But
if you have a UTF-8 encoded page, the rendering is not correct.

And there is another thing: Text renders correctly in any time, when you
it's italic and/or bold!

--
Doesn't show thai language correctly
https://launchpad.net/bugs/43393

---------------------------------
Sponsored Link

Mortgage rates near 39yr lows. $420,000 Mortgage for $1,399/mo - Calculate new house payment

David Farning (dfarning) wrote :

Will one of you who speaks Thai verify that this issue exists in an upstream release of firefox which can be found at http://www.mozilla.com

If the problem exists upstream would you open a issuse report at https://bugzilla.mozilla.org/ for it.

Thanks
David

Alexander Sack (asac) wrote :

does this issue still apply? We have a patch applied that should cure most cases of wrong thai language presentation. Can you confirm that this issue is ok for you?

Changed in firefox:
assignee: nobody → mozillateam
status: Confirmed → Needs Info
Timokl (timokl) wrote :

I have Firefox 2.0.0.1+0dfsg-0ubuntu0.6.10 installed on my machine. I don't know, whether this is the version that you applied the patch to, but at least Synaptic tells me it's the most recent version.

However, with this version, still Thai is not rendered correctly on a UTF-8 encoded website and within Firefox's GUI. On TIS-620 encoded websites, the rendering looks ok.

I found one workaround: In "Settings", just dis-allow a website to use its own fonts, so that Firefox always uses the default fonts.

Within the GNOME-GUI, Thai is rendered correctly. But the same issue as with Firefox also occurs with Thunderbird.

I haven't seen a screenshot demonstrating the symptom. But I guess it's the same problem as I heard in local communities, which is caused by too high rank of TlwgMono font in fontconfig matching. That makes Thai text to always be displayed with Monospace font by default.

If so, it could be fixed by syncing thaifonts-scalable 0.4.5-2 from Debian Etch. In that package, I have provided fontconfig info so that correct Thai fonts are selected.

Alexander Sack (asac) wrote :

we want to help thai users to get the best possible experience on ubuntu. So I am taking this one ... .moving it to state Confirmed.

Changed in firefox:
assignee: mozillateam → asac
status: Needs Info → Confirmed
Timokl (timokl) wrote :

I included here a screenshot. In the main text, there are more aesthetic issues (like tone markers set too high), but the ticker text shows the more annoying problem.

The website is: http://www.dailynews.co.th/, it's UTF-8 encoded.

Timokl (timokl) wrote :

With Theppitak's help, I installed this Debian package thaifonts-scalable 0.4.5-2 by hand on my machine - and this solved the problem.

Alexander Sack (asac) wrote :

setting milestone to feisty

description: updated
Alexander Sack (asac) wrote :

first step done. Requested syncs for needed packages:

bug 92486 - libdatrie
bug 92252 - thaifonts-scalable

next will be update of libthai to latest and finally new firefox.

Stay tuned.

Alexander Sack (asac) on 2007-03-15
Changed in firefox:
status: Confirmed → In Progress
Alexander Sack (asac) on 2007-03-24
Changed in firefox:
status: In Progress → Fix Committed
Alexander Sack (asac) wrote :

firefox (2.0.0.2+1-0ubuntu2) feisty; urgency=low

  * reworked patchset and updated thai patch to latest
  * debian/firefox.desktop: updated finnish translation for
    .desktop file (Contributed by Timo Jyrinki <email address hidden>)
  * browser/app/profile/firefox.js: set pref browser.startup.homepage_override.mstone
    to "ignore" (Closes LP#91798)
  * browser/components/nsBrowserContentHandler.js: disable welcome and update
    url feature completely (LP#91798)
  * use pref distributionID only ... don't hard code this anymore
  * produce chromelist.txt files again (e.g. drop patch that prevents that)
  * exclude patch that disabled mangle dir in
    security/nss/cmd/shlibsign/manifest.mn

  [ Theppitak Karoonboonyanan <email address hidden> ]
   * Update Thai line breaker patch based on libthai.
     - Replace old patch with componentized mozlibthai patch extracted and
       adapted from submitted patch in Debian #366306, which was backported
       from patch against HEAD proposed in bz#7969.
     - debian/control, debian/firefox-libthai.{install,postinst,prerm}:
       + Add firefox-libthai sub-package and Build-Depends: libthai-dev
       + Remove Suggests: libthai0 from firefox (we don't need PR_LoadLibrary()
         hack any more), and Suggests: firefox-libthai instead
     - debian/rules:
       + Add --enable-libthai configure option
       + Exclude mozlibthai component from firefox
       + Add dh_install -pfirefox-libthai.

 -- Alexander Sack <email address hidden> Tue, 13 Mar 2007 20:00:00 +0100

Changed in firefox:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Bug attachments