Ubuntu

firefox - the connection was reset - Fiesty

Reported by damagedspline on 2007-03-23
52
This bug affects 1 person
Affects Status Importance Assigned to Milestone
firefox (Ubuntu)
Low
Mozilla Bugs

Bug Description

Binary package hint: firefox

when trying to connect to some sites firefox gives the following message:
The connection was reset
The connection to the server was reset while the page was loading.
    * The site could be temporarily unavailable or too busy. Try again in a few
          moments.
    * If you are unable to load any pages, check your computer's network
          connection.
    * If your computer or network is protected by a firewall or proxy, make sure
          that Firefox is permitted to access the Web.

sites are up and running. same goes with epiphany.
sites work ok with firefox 2.0.0.3 (downloaded from getfirefox.com)

ProblemType: Bug
Architecture: i386
Date: Sat Mar 24 00:37:42 2007
DistroRelease: Ubuntu 7.04
Uname: Linux asaf-laptop 2.6.20-12-generic #2 SMP Wed Mar 21 20:55:46 UTC 2007 i686 GNU/Linux

I tried integrating the firefox downloaded from the official website to the ubuntu /usr/lib/firefox & /usr/share/firefox and the most peculiar thing happend - the site became blocked again...
I've extracted the firefox tar.gz and retried lauching from the local folder - worked like a charm...

Summary: same version of firefox - local folder working, ubuntu /usr tree not working.

there must be a something I've missed...

John Vivirito (gnomefreak) wrote :

Ubuntu hasnt released 2.0.0.3 yet due to main freeze so it might have been fixed upstream and ours hasnt landed yet. I will leave this bug open until you can try to reproduce this on ubuntu's firefox version 2.0.0.3 and get back to us.

Changed in firefox:
assignee: nobody → mozilla-bugs
importance: Undecided → Low
status: Unconfirmed → Needs Info

the latest version of firefox 2.0.0.3 should be repositories now.

HMX (matej-horvat) wrote :

I can confirm this bug on Feisty with firefox 2.0.0.2. I am unable to connect to _any_ web page. I always get the "connection reset by peer" response.

I've tried updating firefox, but 2.0.0.3 is not in any repository mirror I've checked (2007-03-26).

Moreover, galeon exhibits the same behavior, giving a "dropped the connection" error. Epiphany does this as well.

On the other hand, konqueror works without problems.

Some additional info: booting the 6.10 livecd firefox works, but with 7.04 herd 5 livecd I get these same errors (connection reset).

HMX (matej-horvat) wrote :

I just want to add that the same thing happens on firefox 2.0.0.3.

Curiously though, this problem only appears at my work place.

When using firefox on the same computer from a different network (home) everything works as expected.

What makes this bug so strange is that there is no firewall or proxy at work, which could interfere. Maybe there is some strange kernel tcp/ip & router interaction going on here, which is only triggered by gecko based browsers? Hard to imagine, but I am not an expert...

Zafster (z-leylek) wrote :

I am also having the same problem. I upgraded to Ubuntu 7.04 and now firefox is not working properly. The weird thing is Gmail Notifier not only works, I can access my gmail account thru firefox but can not do anything else.

Opera on the other hand workd perfectly!!!!

Any suggestions?

On Wed, Mar 28, 2007 at 02:00:21PM -0000, Zafster wrote:
> I am also having the same problem. I upgraded to Ubuntu 7.04 and now
> firefox is not working properly. The weird thing is Gmail Notifier not
> only works, I can access my gmail account thru firefox but can not do
> anything else.
>
> Opera on the other hand workd perfectly!!!!
>
> Any suggestions?
>

Be sure that you have properly restarted firefox ... e.g. relogin to
your desktop.

 - Alexander

Zafster (z-leylek) wrote :

See:

https://answers.launchpad.net/ubuntu/+ticket/4472

Installing the user agent switcher add-on in Firefox and changing the user agent solved the problem for me (although I still don't know what the cause of the problem is!!!

Alan Pope ㋛ (popey) wrote :

As pointed out on the above ticket i suspect there is something odd going on at the proxy server, reacting in some bad way to something Firefox 2.0.0.3 does.

The GMail notifier wont be sending the same UA string, neither will opera or firefox on windows or any other browser or http client. And given other reports also talk about this being an issue "at work", points more and more to a firefox<->proxy interaction in my opinion.

Ralph Janke (txwikinger) wrote :

Is it known what kind of proxy is involved with this problem? I tried it with squid and was so far not able to reproduce it with a squid proxy.

Alan Pope ㋛ (popey) wrote :

In the vast majority of corporate environments the proxy server in use is not squid in my experience. Most often it is a microsoft based proxy server incorporating NTLM based authentication. I would not expect you to be able to reproduce this with squid.

Zafster (z-leylek) wrote :

I just tried Allan's suggestion and changed the user-agent string in Windows firefox to the Linux firefox user-agent string which replicated the problem. Changing the user-agent string in Linux firefox to Windows firefox user-agent string fixed the problem which means that the problem is the proxy-server itself.

I then played around with the user-agent string and this may seem strange but whenever I had the "ist" string combination in the (for example "Ubuntu-feisty) the proxy server would fail. I inserted ""ist" into ubuntu-edgy and internet explorer user-agent strings and I get the same error.

Alan Pope ㋛ (popey) wrote :

Shown not to be a firefox issue, but most likely a proxy server problem. Problem replicated under Windows version of Firefox by changing UA string to the Linux Firefox UA string.

Changed in firefox:
status: Needs Info → Rejected

If you still wish to use firefox and bypass the error, you can:
1) To the following file /etc/issue add the next string(save a backup, we will restore it):
6.10
2) run as sudo the firefox install script from http://pykeylogger.sourceforge.net/installnewfirefox.sh
this script will install firefox 2.0.0.3 (http://www.psychocats.net/ubuntu/firefox)
3) restore the /etc/issue file

Worked for me.

Please note: by doing this you are damageding the ubuntu maintained firefox on your computer, so be advised about updating firefox related packages - use at your own risk.

John Vivirito (gnomefreak) wrote :

Please dont advise users to do something that is unsafe.

moozes (nirkkone) wrote :

To my knowledge i'm not behind any proxy and I have this problem too. Changing general.useragent.extra.firefoxComment to (Ubuntu) instead of (Ubuntu-feisty) in about:config fixes this problem. I found this solution on some other section of launchpad and someone there implied that using string "ist" in that the above mentioned key.

Changed in firefox:
status: Rejected → Confirmed
moozes (nirkkone) wrote :

To my knowledge i'm not behind any proxy and I have this problem too. Changing general.useragent.extra.firefoxComment to (Ubuntu) instead of (Ubuntu-feisty) in about:config fixes this problem. I found this solution on some other section of launchpad and someone there implied that using string "ist" in that the above mentioned key has something to do with this.

Changed in firefox:
status: Confirmed → Rejected
Akshat Aranya (aaranya+ubuntu) wrote :

I had the same problem and I am not behind an HTTP proxy. Perhaps there is some proxy software in the picture that my company uses that causes this. Changing the user agent string to remove "Feisty" fixes the problem.

Unfortunately, I faced the same problem with liferea that uses mozilla as backend. Changing the user agent string for liferea is more involved because you have to dig through .liferea directory to find prefs.js and edit it.

Confirmed with Ubuntu 7.04, Firefox 2.0.0.3 and squid 2.5.9.10sarge2 as a proxy server.
Message in Firefox: (104) Connection reset by peer
Message in squid: TCP_MISS/502

Changing general.useragent.extra.firefoxComment as described above fixes the problem.

PS to the above: it is probably Check Point firewall Smart Defence problem.
https://bugs.launchpad.net/bugs/99759

Changed in firefox:
status: Rejected → Unconfirmed

This is still an issue, so I'm reopening it.

If Firefox isn't the right place for this bug, change the package
instead of just rejecting it :) but as it seems that it happens either
with a proxy or without it, this looks like a firefox issue.

Alexander Sack (asac) wrote :

still need to figure out, if this can be worked around without removing feisty from user-agent.

Changed in firefox:
status: Unconfirmed → Confirmed

I've found the source of this anomaly: at least in my case was CheckPoint firewall (NGX 6.2) and one of the SmartDefence's rules:

SmartDefence -> WebIntelligence -> HTTP Protocol Inspection -> Header Rejection
The connections containing a string "IST" in User-agent parameter are rejected by the firewall.

Deactivating this rule solves the problem.

Alexander Sack (asac) wrote :

if there is anyone with a smartdefence support contract, please push this to smartdefence provider as we can not do anything.

Please see the thread on the Ubuntu forum:

http://ubuntuforums.org/showthread.php?t=445018

I have also reported this upstream to the Mozilla project, but heard nothing back so far.

To resolve this issue completely would require agreement on the correct format of an agent string. How does one get agreement on that?

Alan Pope ㋛ (popey) wrote :

I attempted to open a case with the people who make smartdefense but just got automated helpdesk responders back.

On Mon, May 21, 2007 at 12:21:31PM -0000, Mark Madsen wrote:
> Please see the thread on the Ubuntu forum:
>
> http://ubuntuforums.org/showthread.php?t=445018
>
> I have also reported this upstream to the Mozilla project, but heard
> nothing back so far.

Mozilla is the wrong place to report that. If you opened a bug in
bugzilla, please close it.

 - Alexander

Mark Madsen (mark-madsen) wrote :

> Mozilla is the wrong place to report that.

It's the right place to use the "report broken web site" tool in the Firefox menu.

I leave it up to them to decide who id the breaking.

> If you opened a bug in bugzilla, please close it.

Not what I said. Be happy.

Capineiro Capaz (paulogotardo) wrote :

Changing the about:config entry to remove "feisty" didn't work here. Tried (Ubuntu), Ubuntu, (Ubuntu 7.04), ... and it didn't help. I can browser the internet with no problem, except this website:

www.ureg.ohio-state.edu

I can also remember another page on the same domain (ohio-state.edu) that I couldn't open. Konqueror didn't work either. However, that page DOES LOAD on my desktop computer running Ubuntu LTS (my two computer are on the same network).

Jin (wjfjin) wrote :

>Changing the about:config entry to remove "feisty" didn't work here. Tried (Ubuntu), Ubuntu, (Ubuntu 7.04), ... and it didn't help. I can browser the internet with no problem, except this website:

>www.ureg.ohio-state.edu

>I can also remember another page on the same domain (ohio-state.edu) that I couldn't open. Konqueror didn't work either. However, that page DOES LOAD on my desktop computer running Ubuntu LTS (my two >computer are on the same network).

I have the same problem - the general.useragent.extra.firefoxComment or user agent trick does not work. Does anyone have more tip for the problem?

Marcel (mpgsmeets) wrote :

Hi,

Here a same sort of problem, maybe not the right forum, but the problem is very similar and maybe it will help the developers solve some bug.

Firefox 2.0.0.4 on windows XP SP2. Firefox is working for .com , .nl and other domains. But not for .net domains, like e-messenger.net or e-tones.net, server not found (which do work if using IE 6). Tried to change the useragent-String as stated above but nothing helped. Installed the User Agent switcher extension, but no solution there.

Here in the company they are using Checkpoint firewall, so something is going wrong with Firefox and Checkpoint firewall. Do not know what exactly....

Hope this will be solved between checkpoint and firefox

regards Marcel

Marcel (mpgsmeets) wrote :

Disregard the last post.

It looks like the problem was caused by a import error. The IE settings were imported in Firefox automatically. All proxy settings were imported correctly except one of the proxy exceptions:

......,localhost, .... was imported as ......,localho,t,.....

As a result of this all domains with a 't' weren't proxied, duhhhhh

Remains the question? Why was this rule imported like this, because IE 6 worked fine with the 't' domains

Marcel

Emilio Pozuelo Monfort (pochu) wrote :

Marcel,

This is not a place to report bugs on Firefox's windows build, so please don't be offtopic.

Thanks

Jin,
   I reported this bug originally. What was happening was when surfing
through a Check Point VPN-1 Edge device (haven't check it with
full-blown Firewall-1 yet). SmartDefense was picking up on the "ist"
substring of "feisty" in the user-agent field and identifying it as
IST-Bar adware. I changed the user-agent string from "feisty" to
"festy" and have not had any problems since.
   I also submitted this bug to Check Point but as yet I have not heard
anything back.

Jin wrote:
>> Changing the about:config entry to remove "feisty" didn't work here.
>>
> Tried (Ubuntu), Ubuntu, (Ubuntu 7.04), ... and it didn't help. I can
> browser the internet with no problem, except this website:
>
>
>> www.ureg.ohio-state.edu
>>
>
>
>> I can also remember another page on the same domain (ohio-state.edu)
>>
> that I couldn't open. Konqueror didn't work either. However, that page
> DOES LOAD on my desktop computer running Ubuntu LTS (my two >computer
> are on the same network).
>
> I have the same problem - the general.useragent.extra.firefoxComment or
> user agent trick does not work. Does anyone have more tip for the
> problem?
>
>

Jin (wjfjin) wrote :

Hi guys,

Thanks for the quick reply. However "ist" user-agent trick did not work.
Possibly, it is a different but similar problem, as Capaz said and this thread http://ubuntuforums.org/showthread.php?t=445018&page=2.
When I am on the campus network, I cannot get response from the HTTP authentication page for WiFi.
And when at home with VPN connected to campus, I cannot visit any none-local-campus websites, but for google(???).
When at home directly connected to internet, things are fine, except for I can not connect to the www.ureg.ohio-state.edu, which Capaz metioned either.
3TCP handshakes -> Http Request -> RST after some waiting.
I have not heard from the webmaster yet.

ubutu 7.04, Firefox 2.0.0.4

>Capineiro Capaz said on 2007-06-07: (permalink)

>Changing the about:config entry to remove "feisty" didn't work here. Tried (Ubuntu), Ubuntu, (Ubuntu 7.04), ... and it didn't help. I can browser the internet with no problem, except this website:

>www.ureg.ohio-state.edu

>I can also remember another page on the same domain (ohio-state.edu) that I couldn't open. Konqueror didn't work either. However, that page DOES LOAD on my desktop computer running Ubuntu LTS (my two >computer are on the same network).

Aman (aman-amn) wrote :

I have Ubuntu 7.10 and Firefox 2.0.0.13 and I am having the same problem
It keeps giving me these errors with some sites that are always up

However, It does that with some sites only

John Vivirito (gnomefreak) wrote :

If removing or changing Feisty did not fix your issue please file a seperate bug report as your problem isnt the same as reported.
Alexander is it possible to change the user-agent to use the code numbers? example 7.04 7.10 ect.. if this isnt possible i dont see an easy way of working around this as its smart deffense that is viewing the "ist" is listed as something else in thier code or whatever its seeing it as.

Alexander Sack (asac) wrote :

On Fri, Apr 11, 2008 at 01:39:07PM -0000, John Vivirito wrote:
> If removing or changing Feisty did not fix your issue please file a seperate bug report as your problem isnt the same as reported.
> Alexander is it possible to change the user-agent to use the code numbers? example 7.04 7.10 ect.. if this isnt possible i dont see an easy way of working around this as its smart deffense that is viewing the "ist" is listed as something else in thier code or whatever its seeing it as.
>

we won't touch the user-agent string in stable releases. there might
be web-apps depending on it.

 status wontfix

 - Alexander

Changed in firefox:
status: Confirmed → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions