[Edgy] BadMatch (invalid parameter attributes)

Bug #62988 reported by Andreas Husch on 2006-09-29
14
Affects Status Importance Assigned to Milestone
Mozilla Firefox
Confirmed
Unknown
firefox (Debian)
Fix Released
Unknown
flashplugin-nonfree (Ubuntu)
Low
Daniel T Chen

Bug Description

Binary package hint: firefox

The Firefox Browser in Edgy (2.0b2) crashes on a regular base if you try to open specific web pages.

Example URL: http://www.spiegel.de/sport/fussball/0,1518,440040,00.html
http://gmail.com

Steps to reproduce:
1. Set 16 bit color depth and composite extension in /etc/X11/xorg.conf.
2. Open Example URL in Firefox

Result:
Firefox will crash immedialty

Used Versions:
Ubuntu Edgy Eft with orginal Ubuntu Package of Firefox

Workarounds:
* Add at the beginning of your /usr/bin/firefox:
export XLIB_SKIP_ARGB_VISUALS=1
* Switch off composite or 16 bit color depth.

John Vivirito (gnomefreak) wrote :

Can you try it without any plugins being enabled. I am not able to repoduce this bug. You can try to remove the flash plugin and try that site. Also there should be an apport log in /var/crash/ on the crash can you please attach it to this bug report.
Thank You for reporting this bug.

Changed in firefox:
status: Unconfirmed → Needs Info
Simon Law (sfllaw) wrote :

Hello,

Could you please follow the instructions in https://wiki.ubuntu.com/DebuggingProgramCrash and attach the output of the backtrace to this bug report.

Thanks.

Changed in firefox:
assignee: nobody → sfllaw
Andreas Husch (downanup) wrote :

Hi,

thanks for your quick response.

I checked the pages where the Error occurs on the Plugins used: The Error It is definitively related to the Flash Plugin.

Fixefox crashes at the moment the Flash plugin is initialized. This occurs on all pages using flash as far as i can see at the moment. I will do some more testing.

Regards
Andreas

Andreas Husch (downanup) wrote :

Hi,

i installed firefox-gdb now and i ran it within gdb, unfortunately the output is not very informative:

(gdb) run --sync
Starting program: /usr/lib/firefox/firefox-bin --sync
[Thread debugging using libthread_db enabled]
[New Thread -1220813952 (LWP 21122)]
[New Thread -1224229984 (LWP 21125)]
[New Thread -1234330720 (LWP 21126)]
[New Thread -1255855200 (LWP 21130)]
[New Thread -1265689696 (LWP 21132)]
[New Thread -1274082400 (LWP 21133)]
[New Thread -1282684000 (LWP 21134)]
[New Thread -1294763104 (LWP 21135)]
[New Thread -1303155808 (LWP 21136)]
[Thread -1303155808 (LWP 21136) exited]
[New Thread -1311548512 (LWP 21137)]
[Thread -1311548512 (LWP 21137) exited]
[New Thread -1311548512 (LWP 21140)]
[New Thread -1303155808 (LWP 21141)]
[New Thread -1323185248 (LWP 21142)]
[New Thread -1332089952 (LWP 21146)]
[New Thread -1342178400 (LWP 21149)]
[Thread -1342178400 (LWP 21149) exited]
The program 'Gecko' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadMatch (invalid parameter attributes)'.
  (Details: serial 118 error_code 8 request_code 143 minor_code 3)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)

Program exited with code 01.
(gdb) bt
No stack.
(gdb) quit

I have searched the Web a bit and found that someone has reported the same bug to the Debian Project already (Debian Bug #388169 http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=388169), so i'm no the only one affected by this.

Regards
Andreas

Andreas Husch (downanup) wrote :

Hi,

the Bug is also listed at Bugzilla https://bugzilla.mozilla.org/show_bug.cgi?id=304370

Theres a workaround mentioned, setting:

export XLIB_SKIP_ARGB_VISUALS=1

before starting Firefox makes Flash work for me :-)

Maybe this variable can be set as a default in the Ubuntu firefox startscript (/usr/lib/firefox) so other users dont have to cope with this...

Regards and Tanks again
Andreas

Loïc Martin (loic-martin3) wrote :

Adding export XLIB_SKIP_ARGB_VISUALS=1 to /usr/lib/firefox/firefox didn't work for me.

However, since flah-plugin crashes under a 16 bit colordepth X session, editing /etc/X11/xorg.conf and changing the colordepth to 24 solves the problem for me.

Simon Law (sfllaw) wrote :

Confirmed that this is a bug in Flash Plugin 7.

Changed in flashplugin-nonfree:
assignee: sfllaw → nobody
importance: Undecided → Low
status: Needs Info → Confirmed
Changed in firefox:
status: Unknown → Unconfirmed
Bart Martens (bartm) wrote :

I cannot reproduce the described problem on Debian with these packages:

firefox 1.5.dfsg+1.5.0.7-1
flashplugin-nonfree 9.0.21.55.1

Andreas Husch (downanup) wrote :

I tested with Flash Player 9 and the Bug does still exist for me.

KyleAnderson (kyleanderson) wrote :

I can confirm that Firefox stopped crashing as soon as I changed the color bitdepth from 16 to 24.

It is interesting that some people have the same problem with GMail (that doesn't seem to use any flash) and XLIB_SKIP_ARGB_VISUALS=1 helps.

Could you confirm that the bug occurs without Flash player in GMail?

Changed in firefox:
status: Unknown → Confirmed

When surfing www.centrum.cz got : "This content requires a more recent version of Macromedia Flash player" followed closing tab.

(Could access so far:
http://www.pixmania.com/ie/uk/home.html?sess=cba1c5e19aa2b8a4744a73f7a503e541 )

So decided installed flash as written on : http://ubuntuguide.org/wiki/Ubuntu_Edgy#How_to_install_Flash_Player_.28Macromedia_Flash.29_Plug-in_for_Mozilla_Firefox

Result:

access to www.centrum.cz but when on pixmania websites such as
 http://www.pixmania.com/ie/uk/home.html?sess=cba1c5e19aa2b8a4744a73f7a503e541
always getting crash.

I have tried to update flash 9 without result.
Any idea someone, please?

On Wed, 2006-11-01 at 21:54 +0000, amanita wrote:
> When surfing www.centrum.cz got : "This content requires a more recent
> version of Macromedia Flash player" followed closing tab.

Does not happen on Debian with these packages:

firefox 1.5.dfsg+1.5.0.7-1
flashplugin-nonfree 9.0.21.55.1

> So decided installed flash as written on :
> http://ubuntuguide.org/wiki/Ubuntu_Edgy#How_to_install_Flash_Player_.28Macromedia_Flash
> .29_Plug-in_for_Mozilla_Firefox
> Result:
> access to www.centrum.cz but when on pixmania websites such as
> http://www.pixmania.com/ie/uk/home.html?sess=cba1c5e19aa2b8a4744a73f7a503e541
> always getting crash.

No crash on Debian with the packages mentioned above.

> I have tried to update flash 9 without result.

The flashplugin-nonfree package mentioned above installs Flash 9.
http://wiki.debian.org/FlashPlayer
http://packages.debian.org/experimental/web/flashplugin-nonfree

> Any idea someone, please?

I have not tested on Ubuntu, but comparing Ubuntu with Debian might help
to get the problem fixed in Ubuntu.

David Jaša (dejv) wrote :

IMO isn't problem in Firefox, but somewhere in X. In my case all apps are told, that ARGB visuals are present, but they aren't (I've had a small problem with this before). I was told at #67806 that I should switch off composite, but I neither enabled explicitly composite nor did so some post-install script.

description: updated
amanita (a-pokrupa) wrote :

Added at the beginning of my /usr/bin/firefox: export 1)XLIB_SKIP_ARGB_VISUALS=1
2)Checked 24 bit color depth (was default) in /etc/X11/xorg.conf

None of them with success. FireFox still crashes (closes without warning) when access to www.pixmania.com websites. I can get first page with flags, but when chose country (flag) FireFox goes down.

Any problems with Example URL observed:

http://www.spiegel.de/sport/fussball/0,1518,440040,00.html
http://gmail.com

FireFox still completly goes down.

John Vivirito (gnomefreak) wrote :

Bart Martens if you are going to test the packages that are having issues atleast use the right packages. edgy does not use firefox 1.5. so commenting as this doesnt happen in debian with ff1.5 is no help, and it has nothing to do with this bug report at all.

dominik (dilorenzo) wrote :

Same problem here.

I changed color depth from 16 to 24 and now pages like www.wetter.de don't crash firefox anymore.

But it would be nice if this also worked with color depth 16, because this is the default depth after installing edgy edge.

It seems that Adobe engineer confirmed the problem and wrote a fix.
http://www.kaourantin.net/#116224299860645174
The fix is expected to appear in the next release of Flash Player 9.

Cheers mate, good luck

On 11/8/06, mgajda <email address hidden> wrote:
> It seems that Adobe engineer confirmed the problem and wrote a fix.
> http://www.kaourantin.net/#116224299860645174
> The fix is expected to appear in the next release of Flash Player 9.
>
> --
> [Edgy] BadMatch (invalid parameter attributes)
> https://launchpad.net/bugs/62988
>

Daniel T Chen (crimsun) on 2006-11-18
Changed in flashplugin-nonfree:
assignee: nobody → crimsun
status: Confirmed → Fix Committed
Daniel T Chen (crimsun) wrote :

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Format: 1.7
Date: Tue, 21 Nov 2006 00:48:57 -0500
Source: flashplugin-nonfree
Binary: flashplugin-nonfree
Architecture: source
Version: 9.0.21.78~ubuntu1
Distribution: feisty
Urgency: low
Maintainer: Bart Martens <email address hidden>
Changed-By: Daniel T Chen <email address hidden>
Description:
 flashplugin-nonfree - Adobe Flash Player plugin installer
Changes:
 flashplugin-nonfree (9.0.21.78~ubuntu1) feisty; urgency=low
 .
   * New upstream beta Closes Ubuntu: #62988, #64867, #68552, #68554,
     #71590.
Files:
 952784aea31628c7144d150c2593547f 549 contrib/web optional flashplugin-nonfree_9.0.21.78~ubuntu1.dsc
 6b2024ff4c9d3121e5bbb3fa2b468b0e 18178 contrib/web optional flashplugin-nonfree_9.0.21.78~ubuntu1.tar.gz

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.5 (GNU/Linux)

iD8DBQFFYpSQe9GwFciKvaMRAm3PAJ9UoD/7ThfqiJj6uc/5opCC12rJ+wCfcYic
f3RRokvRb1tVflUXR2uVTps=
=04f5
-----END PGP SIGNATURE-----

Daniel T Chen (crimsun) on 2006-11-21
Changed in flashplugin-nonfree:
status: Fix Committed → Fix Released
Rolf Leggewie (r0lf) wrote :

bug 62988 and bug 14911 are dupes. Both have quite a number of other reports marked as dupes to them which is why I don't feel like rectifying the situation (Malone is severely broken here and requires lots of manual intervention)

Changed in firefox:
status: Unconfirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.