Change log for flexml package in Ubuntu

115 of 15 results
Published in hirsute-release on 2020-10-23
Published in groovy-release on 2020-04-24
Published in focal-release on 2019-10-18
Published in eoan-release on 2019-04-18
Obsolete in disco-release on 2020-07-14
Obsolete in cosmic-release on 2020-07-13
Published in bionic-release on 2017-10-24
Obsolete in artful-release on 2020-07-10
Obsolete in zesty-release on 2018-06-22
Obsolete in yakkety-release on 2018-01-23
Deleted in yakkety-proposed (Reason: moved to release)
flexml (1.9.6-5) unstable; urgency=medium

  * Do not produce code with sprintf (security vulnerability).
  * d/ctrl: Update the standard-version to 3.9.8 (no change needed)

 -- Martin Quinson <email address hidden>  Wed, 01 Jun 2016 11:36:26 +0200

Available diffs

Superseded in yakkety-release on 2016-06-03
Published in xenial-release on 2016-02-09
Deleted in xenial-proposed (Reason: moved to release)
flexml (1.9.6-4) unstable; urgency=medium

  * Rework how the output is sorted, so that it still compiles SimGrid.
  * d/p/FTBFS-pedantic: remove -ansi -pedantic flag as Flex parsers
    don't compile with these flags on modern compilers (Closes: #813462).

 -- Martin Quinson <email address hidden>  Mon, 08 Feb 2016 17:16:45 +0100

Available diffs

Superseded in xenial-release on 2016-02-09
Obsolete in wily-release on 2018-01-22
Obsolete in vivid-release on 2018-01-18
Deleted in vivid-proposed on 2018-01-22 (Reason: moved to release)
flexml (1.9.6-3) unstable; urgency=medium


  * Produce reproducible files by explicitly sorting the elements.
    This greatly reduces the diffs' size when regenerating the files.
  * d/control: Update Standards-Version to 3.9.6 (no change needed).

 -- Martin Quinson <email address hidden>  Mon, 26 Jan 2015 15:20:17 +0100

Available diffs

Superseded in vivid-release on 2015-01-27
Deleted in vivid-proposed on 2015-01-28 (Reason: moved to release)
flexml (1.9.6-2) unstable; urgency=medium


  * d/ctrl: Update the standard-version to 3.9.6 (no change needed)
  * d/p/privacy_breach: don't fetch any logo dynamically from SF as it
    may be seen (e.g., by Lintian) as a privacy breach.

 -- Martin Quinson <email address hidden>  Thu, 20 Nov 2014 08:47:44 +0100

Available diffs

Superseded in vivid-release on 2014-11-20
Obsolete in utopic-release on 2016-11-03
Published in trusty-release on 2013-10-18
Obsolete in saucy-release on 2015-04-24
Obsolete in raring-release on 2015-04-24
Deleted in raring-proposed (Reason: moved to release)
flexml (1.9.6-1) unstable; urgency=low


  * New upstream release:
    Don't install any file under /usr/share/doc/flexml/flexml/* 
    Thanks lintian for noticing, and sorry for the short lived v1.9.5.

 -- Martin Quinson <email address hidden>  Tue, 29 Jan 2013 16:12:03 +0100

Available diffs

Superseded in raring-release on 2013-01-30
Deleted in raring-proposed on 2013-01-31 (Reason: moved to release)
flexml (1.9.4-2) unstable; urgency=low


  * Update Standards-Version to 3.9.4 (no change)
  * Switch to debhelper compatibility level 9
    This brings neat hardening features that lintian were asking for

 -- Martin Quinson <email address hidden>  Thu, 27 Dec 2012 21:21:37 +0100

Available diffs

Superseded in raring-release on 2012-12-28
Deleted in raring-proposed on 2012-12-29 (Reason: moved to release)
flexml (1.9.4-1) unstable; urgency=low


  * New upstream release:
    - avoid ambiguous C identifiers even if XML names contain
      underscores [Thx Arnaud Giersch for report and patch]

 -- Martin Quinson <email address hidden>  Thu, 20 Dec 2012 01:26:05 +0100

Available diffs

Superseded in raring-release on 2012-12-20
Deleted in raring-proposed on 2012-12-21 (Reason: moved to release)
flexml (1.9.3-1) unstable; urgency=low


  * New upstream release:
    - Avoid undefined behaviors breaking clang's optimizations
      [Thx Arnaug Giersch for the BR and patch] (Closes: #674524)

 -- Martin Quinson <email address hidden>  Thu, 05 Jul 2012 16:36:02 +0200

Available diffs

Superseded in raring-release on 2012-10-29
Obsolete in quantal-release on 2015-04-24
Published in precise-release on 2011-11-18
flexml (1.9.2-1) unstable; urgency=low

  * New upstream release:
    - Declare *_isset variables properly, even when they are in a header
      [Thx Arnaug Giersch for the BR and patch] Closes: #647605)
  * debian/control: 
    - add VCS fields, and improve short description
    - update Standard-Version to 3.9.2 (no change needed)

Available diffs

Superseded in precise-release on 2011-11-18
Obsolete in oneiric-release on 2015-04-24
Obsolete in natty-release on 2013-06-04
Obsolete in maverick-release on 2013-03-05
flexml (1.8-1.1) unstable; urgency=low

  [ Jari Aalto ]
  * Non-maintainer upload.
  * debian/control
    - Update to debhelper 7.1.
  * debian/rules
    - Add target 'get-changelog'.
  * debian/source/format
    - New file; fix Lintian missing-debian-source-format.
  * debian/watch
    - New file; fix Lintian debian-watch-file-is-missing.
  * flexml.pl
    - Fix spelling error (Lintian).
  * ChangeLog
    - New file. Downloaded from development site.

  [ Jan Hauke Rahm ]
  * Updating the flexml Uploaders list (Closes: #521446)
  * Change doc-base section to "Programming"
  * Add examples directory
  * Add Homepage field
  * Slight modification of debian/copyright to be more precise
  * Switch to debhelper 7 and by that
    + acknowledge DEB_BUILD_OPTIONS
    + use doc-base trigger instead of generating debian/post*
  * As a consequence, bump standards-version to 3.8.4
 -- Ubuntu Archive Auto-Sync <email address hidden>   Tue,  18 May 2010 11:16:08 +0100

Available diffs

Superseded in maverick-release on 2010-05-18
Obsolete in lucid-release on 2016-10-26
Obsolete in karmic-release on 2013-03-04
Obsolete in jaunty-release on 2013-02-28
Obsolete in intrepid-release on 2013-02-20
Obsolete in hardy-release on 2015-04-24
flexml (1.8-1) unstable; urgency=low

  * Do not load unistd on windows platforms since this does not exist
  * Improve the error message when receiving an opening tag instead of
    the expected closing tag. This happens at least when the DTD
    enforces the tag order and this order is not followed.

 -- Ubuntu Archive Auto-Sync <email address hidden>   Tue,  23 Oct 2007 16:09:00 +0100
Superseded in hardy-release on 2007-10-23
Obsolete in gutsy-release on 2011-09-16
Obsolete in feisty-release on 2009-08-20
flexml (1.7-1) unstable; urgency=low

  [William Dowling]
  * Change the static buffstack into two dynamically allocated stacks.
    This get rids of any stack size limitation;
    This also solves #1529930 (parsing mixed content fails on sparc/solaris,
    which were caused by misaligned pointers)
  * Fix #1538171: Only display the stacknames when they are defined (they
    are not in the prolog)
  * Fix a bufferstack memleak. This fixes both leaks of attributes and leaks
    of pcdata. People using large XML files shouldn't have to use insane
    buffsizes anymore.
  * Fix bug #1558023 'REQUIRED attributes not validated correctly'.
  * Add -i command-line param to #include given file in output .l.
  * Add a proper regression testing infrastructure and some test cases.

Superseded in feisty-release on 2006-11-08
Obsolete in edgy-release on 2008-06-19
flexml (1.4.1-1) unstable; urgency=low

  * More fixes to get several parsers in the same C code:
    - pass bufferstack to static too
    - prefix the pcdata variable (WARNING: go fix your code using it)
    Interesingly enough, this seems to be needed on Mac OSX somehow

Superseded in edgy-release on 2006-06-15
Obsolete in dapper-release on 2011-09-06
Superseded in dapper-release on 2006-02-03
Obsolete in breezy-release on 2008-03-25
flexml (1.3-1) unstable; urgency=low


  [William Dowling]
  (infrastructure)
  * Enhance main makefile to allow versionned installs
  * Various cleanups to the makefiles
  * Get a working "make test" (some of the tests themselves are still to be
    fixed)
  (generated parsers)
  * Don't allocate the statenames array over and over (plug memleak)
  * Try not to exaust the stack when possible

  [Ulrik Petersen]
  * Fix statenames array on terminaison (plug memleak)

  [Martin Quinson]
  (flexml.pl script)
  * Get paranoid on file open()/close().
  (infrastructure)
  * Let FleXML.html be valid XHTML1.1 (so that it can be used in tests)
  * Install the paper as documentation
  (debian package)
  * Fix the doc-base file (Closes: #303220).

 -- Martin Quinson <email address hidden>  Wed,  6 Apr 2005 12:27:04 +0200
Obsolete in hoary-release on 2008-03-19
Obsolete in warty-release on 2008-01-09
flexml (1-6.1) unstable; urgency=low


  * Non-maintainer upload
  * Change the build-dep to flex-old 

 -- Pierre Machard <email address hidden>  Wed, 25 Jun 2003 10:25:24 +0200
115 of 15 results