Change log for flycheck package in Ubuntu

113 of 13 results
Published in eoan-release on 2019-05-22
Deleted in eoan-proposed (Reason: moved to release)
flycheck (31-3) unstable; urgency=medium

  * Team upload.

  [ Denis Danilov ]
  * disable intersphinx and info extensions (Closes: #929232)

 -- Sean Whitton <email address hidden>  Tue, 21 May 2019 13:23:38 -0700

Available diffs

Superseded in eoan-release on 2019-05-22
Published in disco-release on 2019-01-11
Deleted in disco-proposed (Reason: moved to release)
flycheck (31-2) unstable; urgency=medium

  * enable GitLab CI at salsa.d.o
  * adopt package: remove Sean from uploaders and add myself (closes: #904240)
  * update Standards-Version to 4.3.0 (no changes required)
  * Build-Depend on debhelper-compat 12
    - drop obsolete debian/compat
    - drop --parallel from debian/rules (it is enabled by default)
  * update project homepage
  * set Vcs-* to salsa.d.o
  * cleanup Build-Depends field
    - sort the list of package
    - drop redundant pyton3-docutils and python3-requests because
      python3-sphinx itself depends on them directly

 -- Denis Danilov <email address hidden>  Thu, 03 Jan 2019 20:20:26 +0100

Available diffs

Superseded in disco-release on 2019-01-11
Published in cosmic-release on 2018-05-01
Published in bionic-release on 2017-11-04
Deleted in bionic-proposed (Reason: moved to release)
flycheck (31-1) unstable; urgency=medium

  * New upstream release (Closes: #877411).
    - Updates to d/copyright.
  * Update dependency dash-el => elpa-dash (Closes: #865910).
    Thanks to Mykola Nikishov for reporting the problem.
    - Bump dh-elpa build dependency to (>= 1.7).
      Ensures that elpa-dash is included in ${elpa:Depends}.
  * Bump debhelper build-dep to match compat.
    - Drop Lintian override package-needs-versioned-debhelper-build-depends.
  * Drop fix-flake8-expected-values.patch
    Obsoleted by upstream changes.
  * Refresh patches.
  * Bump standards version to 4.1.1 (no changes required).

 -- Sean Whitton <email address hidden>  Sat, 07 Oct 2017 08:42:58 -0700

Available diffs

Superseded in bionic-release on 2017-11-04
Published in artful-release on 2017-04-20
Obsolete in zesty-release on 2018-06-22
Deleted in zesty-proposed (Reason: moved to release)
flycheck (30-3) unstable; urgency=low

  * Add disable-flaky-tests.patch
    At present, it is not feasible to keep the expected values of these
    tests up-to-date.  See patch header.
  * Stop skipping the ERT tests during the package build.
    The particular tests that necessitated skipping the ERT test suite
    altogether are now disabled by disable-flaky-tests.patch.
    - Remove ERT skipping code & comments from d/ert-helper.el
    - Add build-deps on haskell-mode, python-minimal
    - Set Testsuite: autopkgtest-pkg-elpa
    - Drop d/tests/control
      This file was needed to list the extensive dependencies of the tests
      disabled by disable-flaky-tests.patch, plus the general dependencies
      of the ERT test suite.  The latter are now folded into d/control.

 -- Sean Whitton <email address hidden>  Wed, 18 Jan 2017 21:45:22 -0700

Available diffs

Superseded in zesty-release on 2017-01-19
Deleted in zesty-proposed on 2017-01-20 (Reason: moved to release)
flycheck (30-2) unstable; urgency=medium

  * Drop gnupg1 build dependency (Closes: #848868).
    This was added so the "recognizes an encrypted buffer" test could pass
    under emacs24.  However, upstream has since disabled that test for
    emacs24 and below.
  * Drop use-gpg1.patch
    Similarly obsoleted by upstream change.

 -- Sean Whitton <email address hidden>  Thu, 22 Dec 2016 08:24:57 +0000

Available diffs

Superseded in zesty-release on 2016-12-22
Deleted in zesty-proposed on 2016-12-24 (Reason: moved to release)
flycheck (30-1) unstable; urgency=medium

  * New upstream release.
  * Quilt patch changes:
    - Drop fix-autoload-tests.patch
      Merged upstream.
    - Drop remove-references-to-legacy-manual.patch
      Merged upstream.
    - Drop remove-todolist.patch
      Merged upstream.
    - Drop patch-test-runner.patch
      Obsolete: the logic we were patching has moved to the Makefile,
      which we bypass anyway.
    - Update use-gpg1.patch to apply to test-gpg.el, not test-util.el.
    - Add Don-t-fail-if-stack-path-project-root-fails.patch
    - Some other patches refreshed.
  * Set flycheck-doc Built-Using.
    - Tighten python3-sphinx build-dep for ${sphinxdoc:Built-Using}.
  * Drop d/source/local-options for dgit.

 -- Sean Whitton <email address hidden>  Tue, 25 Oct 2016 07:56:41 -0700

Available diffs

Superseded in zesty-release on 2016-11-03
Obsolete in yakkety-release on 2018-01-23
Deleted in yakkety-proposed on 2018-01-23 (Reason: moved to release)
flycheck (28-6) unstable; urgency=medium

  * Skip ERT tests during package build.
    See comments in debian/ert-helper.el.
  * Add d/tests/control & move ERT build dependencies there from d/control.
  * Add Testsuite: field to d/control.
  * Delete obsolete README.source.

 -- Sean Whitton <email address hidden>  Tue, 23 Aug 2016 17:59:42 -0700

Available diffs

Superseded in yakkety-proposed on 2016-09-02
flycheck (28-4) unstable; urgency=medium

  * Add 0018-update-expected-values-for-gcc-6.patch.
  * Move dh_elpa_test config to d/elpa-test.
    - Tighten build-dep on dh-elpa.

 -- Sean Whitton <email address hidden>  Thu, 04 Aug 2016 12:06:08 -0700

Available diffs

Superseded in yakkety-proposed on 2016-08-05
flycheck (28-3) unstable; urgency=medium

  * Add 0017-update-expected-values-for-rustc-1.10.patch

 -- Sean Whitton <email address hidden>  Wed, 03 Aug 2016 17:26:38 -0700

Available diffs

Superseded in yakkety-proposed on 2016-08-04
flycheck (28-2) unstable; urgency=medium

  * Set DH_ELPA_TEST_AUTOPKGTEST_KEEP in d/rules.
  * Add 0014-Update-expected-values-for-cppcheck-1.74.patch.
    Fixes build in current sid.

 -- Sean Whitton <email address hidden>  Thu, 07 Jul 2016 13:24:32 +0900

Available diffs

Superseded in yakkety-proposed on 2016-07-07
flycheck (28-1) unstable; urgency=medium

  * Package new upstream release.
  * Drop 0012-update-rustc-expected-values.patch.
    Obsolete with latest rustc.
  * Drop 0014-Fix-cppcheck-test.patch.
    Included in this upstream release.
  * Refresh patches.

 -- Sean Whitton <email address hidden>  Fri, 10 Jun 2016 16:13:54 +0900

Available diffs

Superseded in yakkety-proposed on 2016-06-11
flycheck (27-1) unstable; urgency=medium

  * Package new upstream release.
  * Run test suite with dh_elpa_test.
    - Bump debhelper compat level to 10.
    - Override Lintian tag due to using experimental compat level:
      package-needs-versioned-debhelper-build-depends.
  * Build dependency changes:
    - New build-dep for testsuite: cppcheck.
    - New build dependency on elpa-buttercup for dh_elpa_test.
    - Build dependency on dh-elpa tightened for dh_elpa_test.
    - Tighten build dependencies on hlint and rustc to ensure test suite passes.
  * Quilt patch changes:
    - Drop 0004-update-pylint-expected-values.patch.
      Merged upstream.
    - Drop 0010-skip-haskell-stack-tests-when-homedir-nonexistent.patch.
      Merged upstream.
    - Drop 0011-hack-Makefile-to-silence-cmd-not-found-errors.patch.
      No longer required.
    - Add 0010-disable-MELPA-tests.patch.
    - Add 0011-disable-code-style-spec-test.patch.
    - Add 0013-patch-test-runner.patch.
    - Add 0014-Fix-cppcheck-test.patch.
    - Add 0015-pass-epg-gpg-home-directory-to-gpg-invocation.patch.
    - Add 0016-update-expected-values-for-rustc-version-1.9.0.patch.
    - Refresh remaining patches.
  * Documentation changes:
    - Remove d/copyright entry for obsoleted file test/flycheck-checkdoc.el.
    - Add d/copyright entry for new file test/test-code-style.el.
    - Drop debian/info since upstream's info manual no longer exists.
    - Don't install CREDITS.md since upstream's credits file no longer exists.
    - Merge and install two upstream changelogs.
  * Override dh_auto_build to avoid Cask.
  * Remove comments from d/control due to #823708.
  * Create README.source with information from comments.
  * Run wrap-and-sort -abst.
  * Bump standards version to 3.9.8 (no changes required).

 -- Sean Whitton <email address hidden>  Mon, 06 Jun 2016 12:59:44 +0900

Available diffs

Superseded in yakkety-release on 2016-09-02
Deleted in yakkety-proposed on 2016-09-03 (Reason: moved to release)
flycheck (0.25.1-1) unstable; urgency=medium

  * Initial release. (Closes: #796652)

 -- Sean Whitton <email address hidden>  Thu, 10 Mar 2016 20:56:15 -0700
113 of 13 results