Change log for freecad package in Ubuntu

175 of 75 results
Published in eoan-proposed on 2019-04-21
freecad (0.18.1+dfsg1-1) unstable; urgency=medium

  * [cab285b] Correct suggested packages
  * [576bf03] New upstream version 0.18.1+dfsg1
  * [7cec221] Update rules for 0.18.1
  * [39bac84] Add patch to display 0.18.1 version

 -- Kurt Kremitzki <email address hidden>  Sat, 06 Apr 2019 13:52:45 -0500
Deleted in disco-proposed on 2019-04-06 (Reason: autopkgtests fail)
freecad (0.18+dfsg1-1) unstable; urgency=medium

  * [64167ef] New upstream version 0.18+dfsg1
  * [8c882c8] Remove upstreamed patches fix-start-workbench and
    fix_qt-5.11_build
  * [7d77b28] Add NEWS file to announce Python 3 switch

 -- Kurt Kremitzki <email address hidden>  Thu, 14 Mar 2019 21:43:55 -0500
Superseded in disco-proposed on 2019-04-02
freecad (0.18~pre1+dfsg1-5) unstable; urgency=medium

  * [e91ae47] Fix update-alternatives problem (Closes: #923465 #923412)
  * [a7f46c7] Update OpenCASCADE path
  * [958e27f] Add patch to fix Start WB
  * [ba149a5] Add lintian override for freecad virtual package

 -- Kurt Kremitzki <email address hidden>  Sat, 02 Mar 2019 03:42:57 -0600
Superseded in disco-proposed on 2019-03-20
freecad (0.18~pre1+dfsg1-4) unstable; urgency=medium

  * [7865394] Use libqt5opengl5-dev instead of -desktop-dev for armel/armhf
    builds

 -- Kurt Kremitzki <email address hidden>  Fri, 15 Feb 2019 14:15:18 -0600
Superseded in disco-proposed on 2019-02-16
freecad (0.18~pre1+dfsg1-3) unstable; urgency=medium

  * [f852948] Re-add allow-stderr restriction on autopkgtest

 -- Kurt Kremitzki <email address hidden>  Mon, 11 Feb 2019 13:59:14 -0600
Superseded in disco-proposed on 2019-02-12
freecad (0.18~pre1+dfsg1-2) unstable; urgency=medium

  * [4f80ffc] Undo accidental autopkgtest reversion

 -- Kurt Kremitzki <email address hidden>  Sun, 10 Feb 2019 16:48:53 -0600
Superseded in disco-proposed on 2019-02-11
freecad (0.18~pre1+dfsg1-1) unstable; urgency=medium

  * [e648c8e] Add Breaks+Conflicts+Replaces to smooth upgrade

 -- Kurt Kremitzki <email address hidden>  Sat, 09 Feb 2019 17:56:53 -0600
Superseded in disco-proposed on 2019-02-10
freecad (0.17+dfsg1-8) unstable; urgency=medium

  * [9d6a8a1] Add allow-stderr restriction on autopkgtest (Closes: #920525)

 -- Kurt Kremitzki <email address hidden>  Sat, 26 Jan 2019 18:04:22 -0600
Superseded in disco-proposed on 2019-01-31
Deleted in disco-proposed on 2019-01-27 (Reason: autopkgtest regressions and blocking readline)
freecad (0.17+dfsg1-7ubuntu1) disco; urgency=medium

  * Run the autopkg tests with the allow-stderr restriction.

 -- Matthias Klose <email address hidden>  Sat, 26 Jan 2019 19:01:23 +0100

Available diffs

Deleted in disco-proposed on 2019-01-28 (Reason: remove old freecad binaries from proposed)
freecad (0.17+dfsg1-7) unstable; urgency=medium

  * [86c1410] Fix autopkgtest command (Closes: #918479)
  * [d5ee7ff] Update VTK dep to v7

 -- Kurt Kremitzki <email address hidden>  Fri, 25 Jan 2019 20:33:35 -0600

Available diffs

Deleted in disco-release on 2019-01-27 (Reason: depends on deprecated qt4 stack and new version fails aut...)
Deleted in disco-proposed on 2019-01-27 (Reason: moved to release)
freecad (0.16.6712+dfsg1-3build2) disco; urgency=medium

  * No-change rebuild against libcoin80c.

 -- Steve Langasek <email address hidden>  Fri, 25 Jan 2019 11:50:30 -0800
Deleted in disco-proposed on 2019-01-26 (Reason: regressed autopkgtests; Debian bug #918479)
freecad (0.17+dfsg1-6build2) disco; urgency=medium

  * No-change rebuild.

 -- Matthias Klose <email address hidden>  Fri, 25 Jan 2019 18:26:37 +0100
Superseded in disco-proposed on 2019-01-25
freecad (0.17+dfsg1-6build1) disco; urgency=medium

  * No-change rebuild against med-fichier 4.0.0

 -- Graham Inggs <email address hidden>  Sat, 05 Jan 2019 08:33:30 +0000
Superseded in disco-proposed on 2019-01-05
freecad (0.17+dfsg1-6) unstable; urgency=medium

  * [af5bdfa] Update coin/pivy deps for Coin transition

 -- Kurt Kremitzki <email address hidden>  Fri, 21 Dec 2018 08:11:47 -0600
Superseded in disco-proposed on 2018-12-21
freecad (0.17+dfsg1-5build1) disco; urgency=medium

  * Rebuild against new libhdf5-103.

 -- Gianfranco Costamagna <email address hidden>  Wed, 12 Dec 2018 12:59:20 +0100
Superseded in disco-proposed on 2018-12-12
freecad (0.17+dfsg1-5) unstable; urgency=medium

  * Upload to unstable

 -- Kurt Kremitzki <email address hidden>  Thu, 11 Oct 2018 08:14:49 -0500
Superseded in disco-release on 2019-01-26
Published in cosmic-release on 2018-07-18
Deleted in cosmic-proposed (Reason: moved to release)
freecad (0.16.6712+dfsg1-3build1) cosmic; urgency=medium

  * No-change rebuild for boost soname change.

 -- Matthias Klose <email address hidden>  Tue, 17 Jul 2018 12:55:46 +0000
Superseded in cosmic-release on 2018-07-18
Deleted in cosmic-proposed on 2018-07-19 (Reason: moved to release)
freecad (0.16.6712+dfsg1-3) unstable; urgency=medium

  * Team upload
  * Close Teemu's bug in previous changelog entry
  * Fix autopkgtest on architectures where char is unsigned by default,
    thanks Frédéric Bonnard (Closes: #836983)
  * Install copies of icons since AppStream does not recognize symlinks
    (Closes: #850965)
  * Update Uploaders: add Sebastian Kuzminsky
                      remove Adam C. Powell, IV

 -- Graham Inggs <email address hidden>  Mon, 28 May 2018 08:55:04 +0000
Superseded in cosmic-release on 2018-05-28
Published in bionic-release on 2017-12-08
Deleted in bionic-proposed (Reason: moved to release)
freecad (0.16.6712+dfsg1-1ubuntu2) bionic; urgency=medium

  * Fix autopkgtest on architectures where char is unsigned by default,
    thanks Frédéric Bonnard (Closes: #836983)
  * Build everywhere

 -- Graham Inggs <email address hidden>  Thu, 07 Dec 2017 19:01:39 +0000
Superseded in bionic-release on 2017-12-08
Deleted in bionic-proposed on 2017-12-09 (Reason: moved to release)
freecad (0.16.6712+dfsg1-1ubuntu1) bionic; urgency=medium

  * Don't build the package on ppc64el and s390x, test failures.

 -- Matthias Klose <email address hidden>  Mon, 20 Nov 2017 11:57:53 +0100
Superseded in bionic-proposed on 2017-11-20
freecad (0.16.6712+dfsg1-1build1) bionic; urgency=medium

  * No-change rebuild for libxerces soname change.

 -- Matthias Klose <email address hidden>  Thu, 16 Nov 2017 11:58:56 +0000
Superseded in bionic-release on 2017-11-14
Deleted in bionic-proposed on 2017-11-15 (Reason: moved to release)
freecad (0.16+dfsg2-3build3) bionic; urgency=medium

  * No-change rebuild against OpenCV 3.2.

 -- Mattia Rizzolo <email address hidden>  Sun, 29 Oct 2017 12:44:26 +0100
Superseded in bionic-proposed on 2017-10-29
freecad (0.16+dfsg2-3build2) bionic; urgency=medium

  * No-change rebuild against liboce-foundation11

 -- Steve Langasek <email address hidden>  Sun, 29 Oct 2017 05:59:19 +0000
Superseded in bionic-proposed on 2017-10-29
freecad (0.16+dfsg2-3build1) bionic; urgency=medium

  * No-change rebuild for boost soname change.

 -- Matthias Klose <email address hidden>  Thu, 26 Oct 2017 17:13:29 +0000
Superseded in bionic-release on 2017-11-22
Deleted in bionic-proposed on 2017-11-23 (Reason: moved to release)
freecad (0.16.6712+dfsg1-1) unstable; urgency=medium

  * [c631550] New upstream version 0.16.6712+dfsg1
  * [70d3ebc] Refresh patches
  * [c2f67a5] Remove dependency on Qt4 Webkit. (Closes: #784464)
  * [31d5630] Set Standards-Version: 4.1.0
  * [85cc9d9] Change priority to optional
  * [dc32b52] Set maximal hardening option
  * [c56abf6] Drop "alpha" from description. (Closes: #868727)

 -- Anton Gladky <email address hidden>  Fri, 08 Sep 2017 22:55:20 +0200
Superseded in bionic-release on 2017-10-31
Published in artful-release on 2017-04-20
Obsolete in zesty-release on 2018-06-22
Deleted in zesty-proposed (Reason: moved to release)
freecad (0.16+dfsg2-3) unstable; urgency=medium

  [ Graham Inggs ]
  * [06c5066] Use PNG and SVG icons instead of XPM (Closes: #850965)
  * [d40a6a3] Drop debian/menu and do not install XPM icon, see #741573
  * [d616835] Add Suggests on graphviz and povray (Closes: #849644)
  * [e25f6a6] Switch to debhelper 10
  * [f02e70f] Add debian/clean to fix FTBFSx2

  [ Anton Gladky ]
  * [245dccf] Fix d/copyright.
  * [3f389af] Apply cme fix dpkg.

 -- Anton Gladky <email address hidden>  Fri, 20 Jan 2017 20:05:18 +0100

Available diffs

Superseded in zesty-release on 2017-02-03
Deleted in zesty-proposed on 2017-02-04 (Reason: moved to release)
freecad (0.16+dfsg2-2) unstable; urgency=medium

  * Team upload.
  [ Anton Gladky ]
  * Remove freecad-doc from suggests. (Closes: #827734)

  [ Nobuhiro Iwamatsu ]
  * Fix FTBFS with opencv 3.1. (Closes: #841416)

 -- Anton Gladky <email address hidden>  Wed, 23 Nov 2016 05:20:31 +0900
Superseded in zesty-release on 2016-11-29
Deleted in zesty-proposed on 2016-11-30 (Reason: moved to release)
freecad (0.16+dfsg2-1ubuntu2) zesty; urgency=high

  * No change rebuild against boost1.62.

 -- Dimitri John Ledkov <email address hidden>  Tue, 01 Nov 2016 16:19:57 +0000
Superseded in zesty-release on 2016-11-02
Obsolete in yakkety-release on 2018-01-23
Deleted in yakkety-proposed on 2018-01-23 (Reason: moved to release)
freecad (0.16+dfsg2-1ubuntu1) yakkety; urgency=medium

  * Disable tests failing on ppc64el and s390x.

 -- Graham Inggs <email address hidden>  Wed, 07 Sep 2016 15:24:15 +0200
Superseded in yakkety-proposed on 2016-09-07
freecad (0.16+dfsg2-1build2) yakkety; urgency=medium

  * No-change rebuild for boost soname change.

 -- Matthias Klose <email address hidden>  Thu, 04 Aug 2016 08:42:02 +0000
Superseded in yakkety-proposed on 2016-08-04
freecad (0.16+dfsg2-1build1) yakkety; urgency=medium

  * Rebuild against libode6.

 -- Gianfranco Costamagna <email address hidden>  Thu, 19 May 2016 18:25:15 +0200
Superseded in yakkety-proposed on 2016-05-20
freecad (0.16+dfsg2-1) unstable; urgency=medium

  * [4f08de5] Remove data/examples. (Closes: #745237)
  * [7434cc4] Imported Upstream version 0.16+dfsg2

 -- Anton Gladky <email address hidden>  Sun, 15 May 2016 12:29:42 +0200

Available diffs

Superseded in yakkety-proposed on 2016-05-15
freecad (0.16+dfsg1-1) unstable; urgency=medium

  * [9e69a23] Update d/watch.
  * [bf22c89] Drop copying of Version.h explicitly.
  * [010b5c8] Refresh/Remove patches.
  * [24a4f7d] Update d/copyright.
  * [0547be9] Apply cme fix dpkg-control.
  * [fc9b859] Update d/copyright.
  * [6e5df4d] Imported Upstream version 0.16+dfsg1. (Closes: #823816)
  * [06ed39b] Remove freecad-dev and freecad-doc binaries.
  * [94c3ac2] Update d/copyright. (Closes: #726805 #745237)

 -- Anton Gladky <email address hidden>  Thu, 12 May 2016 20:48:30 +0200
Superseded in yakkety-release on 2016-09-07
Deleted in yakkety-proposed on 2016-09-09 (Reason: moved to release)
freecad (0.15.4671+dfsg1-4ubuntu1) yakkety; urgency=medium

  * Rebuild against fixed OCE. (see LP #1556680)
  * Fix build with Boost 1.60.

 -- Graham Inggs <email address hidden>  Mon, 09 May 2016 16:22:34 +0200
Superseded in yakkety-proposed on 2016-05-09
freecad (0.15.4671+dfsg1-4build1) yakkety; urgency=medium

  * No-change rebuild for boost soname change.

 -- Matthias Klose <email address hidden>  Sat, 23 Apr 2016 18:38:38 +0000
Superseded in yakkety-release on 2016-05-09
Published in xenial-release on 2016-02-15
Deleted in xenial-proposed (Reason: moved to release)
freecad (0.15.4671+dfsg1-4) unstable; urgency=medium

  * [a934100] Add strict dependency on oce>=0.17.1. (Closes: #802517)

 -- Anton Gladky <email address hidden>  Fri, 29 Jan 2016 13:10:48 +0100
Superseded in xenial-release on 2016-02-15
Deleted in xenial-proposed on 2016-02-16 (Reason: moved to release)
freecad (0.15.4671+dfsg1-3) unstable; urgency=medium

  [ Abdullah Tahiri ]
  * [f4d259b] Fix Sketcher: Solver: FullPivLU::compute for Eigen-3.3.
              (Closes: #811239)

 -- Anton Gladky <email address hidden>  Sun, 17 Jan 2016 13:44:36 +0100
Superseded in xenial-release on 2016-01-17
Deleted in xenial-proposed on 2016-01-19 (Reason: moved to release)
freecad (0.15.4671+dfsg1-2) unstable; urgency=medium

  * [0c78ef5] Remove EIGEN2_SUPPORT. (Closes: #786356)

 -- Anton Gladky <email address hidden>  Sun, 25 Oct 2015 18:51:47 +0100
Superseded in xenial-release on 2015-10-26
Deleted in xenial-proposed on 2015-10-27 (Reason: moved to release)
freecad (0.15.4671+dfsg1-1) unstable; urgency=medium

  * [4b6e554] Update d/copyright.
  * [dd370f0] Update d/watch.
  * [a70bba6] Imported Upstream version 0.15.4671+dfsg1. (Closes: #789105)
  * [80ccaac] Refresh patches.
  * [c868df9] Add pyside-tools as dependency.
  * [ab8015b] Drop the load of news-page. (Closes: #787948)

 -- Anton Gladky <email address hidden>  Thu, 27 Aug 2015 22:54:47 +0200
Superseded in xenial-release on 2015-10-24
Obsolete in wily-release on 2018-01-22
Deleted in wily-proposed on 2018-01-22 (Reason: moved to release)
freecad (0.14.3702+dfsg-4) unstable; urgency=medium

  [ Anton Gladky ]
  * [7dbbdb6] Set Standards-Version: 3.9.6. No changes.
  * [99c5e82] Apply cme fix dpkg-control.

  [ Martin Pitt ]
  * [91ef5e9] Work around Qt4 not being compatible with boost+gcc5.
              (Closes: #795069)

 -- Anton Gladky <email address hidden>  Wed, 12 Aug 2015 20:34:02 +0200
Superseded in wily-release on 2015-08-18
Deleted in wily-proposed on 2015-08-19 (Reason: moved to release)
freecad (0.14.3702+dfsg-3ubuntu1) wily; urgency=medium

  * debian/patches/gcc5.patch:
    - Work around Qt4 not being compatible with boost+gcc5, fixing FTBFS

 -- Michael Terry <email address hidden>  Tue, 11 Aug 2015 16:06:30 -0400
Superseded in wily-proposed on 2015-08-11
freecad (0.14.3702+dfsg-3build1) wily; urgency=medium

  * No-change rebuild against libcoin80v5.

 -- Martin Pitt <email address hidden>  Mon, 10 Aug 2015 07:44:38 +0200
Superseded in wily-release on 2015-08-17
Obsolete in vivid-release on 2018-01-18
Deleted in vivid-proposed on 2018-01-19 (Reason: moved to release)
freecad (0.14.3702+dfsg-3) unstable; urgency=medium


  [ Yorik van Havre ]
  * [9ddbf15] Disable automatic DXF library download. (Closes: #764814)

 -- Anton Gladky <email address hidden>  Fri, 24 Oct 2014 18:59:03 +0200
Superseded in vivid-release on 2014-10-25
Deleted in vivid-proposed on 2014-10-26 (Reason: moved to release)
freecad (0.14.3702+dfsg-2) unstable; urgency=medium


  [ Anton Gladky ]
  * [aafcc31] Remove libswscale-dev from BD. (Closes: #757282)
  * [81d4b6e] Fix installing of som Mods. (Closes: #736273)
  * [1a4492e] Remove deprecated lines from d/copyright. (Closes: #745237)

  [ Alexander ]
  * [efc7d53] Fix compilation with clang. (Closes: #755305)

 -- Anton Gladky <email address hidden>  Sun, 24 Aug 2014 08:12:43 +0200
Superseded in vivid-release on 2014-10-24
Obsolete in utopic-release on 2016-11-03
Deleted in utopic-proposed on 2016-11-03 (Reason: moved to release)
freecad (0.14.3702+dfsg-1) unstable; urgency=medium


  * [7fc727b] Imported Upstream version 0.14.3702
  * [3edf0de] Refresh patches.
  * [077b63a] Redirect unittest output into stdout. Fixes autopkgtests.

 -- Anton Gladky <email address hidden>  Tue, 22 Jul 2014 20:15:18 +0200
Superseded in utopic-release on 2014-07-29
Deleted in utopic-proposed on 2014-07-30 (Reason: moved to release)
freecad (0.13.3637-dfsg-1) unstable; urgency=medium


  * [ddeee1c] Imported Upstream version 0.13.3637-dfsg
  * [0fe87be] Update/remove patches.
  * [60ad7cc] Update install files, dependencies.
  * [9f9cca3] Add autopkgtest.

 -- Anton Gladky <email address hidden>  Sun, 25 May 2014 19:05:13 +0200
Superseded in utopic-release on 2014-05-27
Deleted in utopic-proposed on 2014-05-28 (Reason: moved to release)
freecad (0.13.2935-dfsg-1.1build2) utopic; urgency=high

  * No change rebuild against boost1.55.
 -- Dimitri John Ledkov <email address hidden>   Mon, 28 Apr 2014 04:33:59 +0100
Superseded in utopic-release on 2014-04-28
Published in trusty-release on 2014-03-21
Deleted in trusty-proposed (Reason: moved to release)
freecad (0.13.2935-dfsg-1.1build1) trusty; urgency=medium

  * Rebuild against oce 0.15.
 -- Colin Watson <email address hidden>   Fri, 21 Mar 2014 14:51:02 +0000
Superseded in trusty-release on 2014-03-21
Deleted in trusty-proposed on 2014-03-23 (Reason: moved to release)
freecad (0.13.2935-dfsg-1.1) unstable; urgency=low


  * Non-maintainer upload.
  * Update xerces build dependency to libxerces-c-dev. (Closes: #733072)

 -- Jay Berkenbilt <email address hidden>  Wed, 15 Jan 2014 12:19:37 -0500
Superseded in trusty-release on 2014-01-17
Deleted in trusty-proposed on 2014-01-18 (Reason: moved to release)
freecad (0.13.2935-dfsg-1) unstable; urgency=medium


  * [824153f] Move python-collada and python-ply from Recommends to Depends.
  * [3047a6b] Imported Upstream version 0.13.2935-dfsg
  * [36a4082] Bump Standards-Version: 3.9.5. No changes.

 -- Anton Gladky <email address hidden>  Wed, 01 Jan 2014 20:29:15 +0100
Superseded in trusty-release on 2014-01-02
Deleted in trusty-proposed on 2014-01-03 (Reason: moved to release)
freecad (0.13.2800-dfsg-1) unstable; urgency=low


  * [e051565] Imported Upstream version 0.13.2800-dfsg. (Closes: #730952)
  * [a2f0187] Update debian/copyright. (Closes: #726805)

 -- Anton Gladky <email address hidden>  Mon, 02 Dec 2013 22:11:10 +0100
Superseded in trusty-release on 2013-12-03
Deleted in trusty-proposed on 2013-12-04 (Reason: moved to release)
freecad (0.13.2580-dfsg-2) unstable; urgency=low


  * [2aab6f0] Update and re-enable disable_memory_check.patch.
  * [4d36847] Use wrap-and-sort.

 -- Anton Gladky <email address hidden>  Mon, 30 Sep 2013 18:49:23 +0200
Superseded in trusty-release on 2013-10-25
Obsolete in saucy-release on 2015-04-24
Deleted in saucy-proposed on 2015-04-28 (Reason: moved to release)
freecad (0.13.1830-dfsg-3) unstable; urgency=low


  [ Simon Ruderich ]
  * [71fd1c2] Hardening CPPFLAGS and LDFLAGS. (Closes: #711243)

  [ Peter Michael Green ]
  * [36d7879] Fix build failures with new oce by forcing occ include directory. 
              (Closes: 718545, 717034)
  * [7fa3e69] Remove some stuff left behind by build process in clean target 
              to prevent errors from dpkg-source when building multiple times 
              in a row. 
                - obj-* 
                - src/Mod/Start/Gui/share 
                - src/Mod/Drawing/App/share

  [ Anton Gladky ]
  * [5906d0e] Update debian-copyright-file.
  * [07d04d1] Move python-collada from Depends to Recommends-section.
  * [cf6cb9f] Add python-collada to Depends.
  * [36b4bc0] Add versioned dependency on libsoqt4-20. (Closes: #711812)
  * [32738be] Use canonical VCS.

 -- Anton Gladky <email address hidden>  Wed, 07 Aug 2013 23:43:36 +0200
Superseded in saucy-proposed on 2013-08-11
freecad (0.13.1830-dfsg-2build1) saucy; urgency=low

  * Rebuild for oce 0.12.
 -- Colin Watson <email address hidden>   Wed, 17 Jul 2013 12:56:29 +0100
Superseded in saucy-release on 2013-08-22
Deleted in saucy-proposed on 2013-08-24 (Reason: moved to release)
freecad (0.13.1830-dfsg-2) unstable; urgency=low


  * [800a2d9] Compile freecad against libcoin80. (Closes: #617613)
  * [abee4e5] Compile against fltk1.3 instead of fltk1.1
  * [23916ae] Raise the minimal version of soqt4-dev due to coin80.
  * [87207ba] Update homepage.
  * [224f12d] Add versioned dependency on python-pivy.

 -- Anton Gladky <email address hidden>  Thu, 30 May 2013 19:48:30 +0200
Superseded in saucy-release on 2013-06-02
Deleted in saucy-proposed on 2013-06-04 (Reason: moved to release)
freecad (0.13.1830-dfsg-1) unstable; urgency=low


  [ Boris Pek ]
  * [fbdfc08] Update debian/rules: use src/Build/Version.h provided by upstream.
              (Closes: #706578)
  * [eb29048] Update scripts/get_git_orig_src.sh: - change version format.

 -- Anton Gladky <email address hidden>  Thu, 02 May 2013 23:05:20 +0200
Superseded in saucy-release on 2013-05-14
Obsolete in raring-release on 2015-04-24
Obsolete in quantal-release on 2015-04-24
freecad (0.12.5284-dfsg-7ubuntu1) quantal; urgency=low

  * Sync with Debian. This upload is to fix an error (missing/broken changelog)
    in the previous upload. There are no changes from the Debian package.
 -- Mathieu Trudel-Lapierre <email address hidden>   Tue, 29 May 2012 17:19:30 -0400
Superseded in quantal-release on 2012-05-29
freecad (0.12.5284-dfsg-7build1) quantal; urgency=low

  *
 -- Mathieu Trudel-Lapierre <email address hidden>   Tue, 29 May 2012 13:50:26 -0400
Superseded in quantal-release on 2012-05-29
Published in precise-release on 2012-03-21
freecad (0.12.5284-dfsg-5ubuntu1) precise; urgency=low

  * Comment out fix_FTBFS_with_oce-0.9.1.patch in debian/patches/series to fix
    FTBFS (precise has an older oce and this patch isn't needed/breaks the
    build)
    - Thanks to Anton Gladky for pointing this out
 -- Scott Kitterman <email address hidden>   Wed, 21 Mar 2012 17:30:58 -0400
Superseded in precise-release on 2012-03-21
freecad (0.12.5284-dfsg-5) unstable; urgency=low


  * [4d3e1c0] Do not build freecad parallel, it causes FTBFS sometimes ( -j5).
  * [d749637] Fix FTBFS during compiling against oce-0.9.1. 
              Thanks to Denis Barbier. (Closes: #664207)
  * [28cb8ba] Fix bug of identifying SWIG version. 
              Thanks to Werner Mayer <email address hidden>. 
              (Closes: #646374)
  * [fde200f] Use Standards-Version 3.9.3. No changes.
  * [595a19e] Minor update of copyright file due to released DEP-5.
  * [65ef554] Enable HAVE_SWIG option.
  * [1af4c8a] Fix crash in Help->About menu. (Closes: #663704)

 -- Anton Gladky <email address hidden>  Sun, 18 Mar 2012 08:51:19 +0100
Superseded in precise-release on 2012-03-21
freecad (0.12.5284-dfsg-4) unstable; urgency=low


  * [84c5407] Add needed #include. Fix compilation on Ubuntu Precise.
  * [7b3d15a] Move python-pivy from recommends to depends section. 
              (Closes: #646374)
  * [9136519] Update homepage section.
  * [da53f03] Raise dh-compat to version 8.

 -- Anton Gladky <email address hidden>  Fri, 17 Feb 2012 19:59:20 +0100
Superseded in precise-release on 2012-02-22
Obsolete in oneiric-release on 2015-04-24
freecad (0.11.4446-dfsg-2build1) oneiric; urgency=low

  * No change rebuild for libopencascade transition
 -- Scott Kitterman <email address hidden>   Sat, 27 Aug 2011 12:30:38 -0400
Superseded in oneiric-release on 2011-08-27
freecad (0.11.4446-dfsg-2) unstable; urgency=low

  * [93347cc] Switch off SWIG to fix FTBFS (closes: #632348)

Superseded in oneiric-release on 2011-07-25
Obsolete in natty-release on 2013-06-04
freecad (0.10.3247.dfsg-2ubuntu3) natty; urgency=low

  * Fix build failure with ld --as-needed.
 -- Matthias Klose <email address hidden>   Wed, 15 Dec 2010 01:12:39 +0100
Superseded in natty-release on 2010-12-15
freecad (0.10.3247.dfsg-2ubuntu2) natty; urgency=low

  * Rebuild with python 2.7 as the python default.
 -- Matthias Klose <email address hidden>   Thu, 09 Dec 2010 16:46:45 +0000
Superseded in natty-release on 2010-12-09
freecad (0.10.3247.dfsg-2ubuntu1) natty; urgency=low

  * Merge from debian unstable. Remaining changes:
    - build on libqtwebkit-dev for qtwebkit transition

Superseded in natty-release on 2010-10-20
Obsolete in maverick-release on 2013-03-05
freecad (0.10.3247.dfsg-1ubuntu2) maverick; urgency=low

  * Rebuild on libqtwebkit-dev for qtwebkit transition
 -- Jonathan Riddell <email address hidden>   Wed, 21 Jul 2010 10:06:31 +0100
Superseded in maverick-release on 2010-07-21
freecad (0.10.3247.dfsg-1ubuntu1) maverick; urgency=low

  * Merge from Debian unstable, remaining changes:
    - debian/control: Build-Depends on libqt4-webkit-dev due to
      QtWebKit is no longer part of libqt4-dev (LP: #604078)
 -- Artur Rona <email address hidden>   Sat, 10 Jul 2010 21:06:47 +0200
Superseded in maverick-release on 2010-07-11
freecad (0.9.2646.5.dfsg-1ubuntu1) maverick; urgency=low

  * Add build-dep on libqt4-webkit-dev to fix FTBFS with Qt 4.7
 -- Scott Kitterman <email address hidden>   Sat, 19 Jun 2010 00:37:12 -0400
Superseded in maverick-release on 2010-06-19
freecad (0.9.2646.5.dfsg-1) unstable; urgency=low

  * Add 'dfsg' extension to upstream version, upstream sources are unchanged.
  * Remove libgl1-mesa-dev build-dep, rely on libcoin to pull in GL libraries.
  * Change build-dep libatlas-headers to libatlas-dev (closes: #577309).
 -- Ubuntu Archive Auto-Sync <email address hidden>   Tue,  18 May 2010 11:16:11 +0100

Available diffs

Superseded in maverick-release on 2010-05-18
Obsolete in lucid-release on 2016-10-26
freecad (0.9.2646.5-1) unstable; urgency=low

  * New upstream version (closes: #561696).
  * Added swig to Build-Depends (closes: #563523, #563772).
  * Removed python-opencv from Build-Depends and Recommends (closes: #560768).

Superseded in lucid-release on 2010-02-03
freecad (0.8.2237-2ubuntu2) lucid; urgency=low

  * Fix opencv build-depends to require version 2 or newer
 -- Luka Renko <email address hidden>   Tue, 22 Dec 2009 23:44:11 +0100
Superseded in lucid-release on 2009-12-22
freecad (0.8.2237-2ubuntu1) lucid; urgency=low

  * Library transition for opencv 2.0
    - add build-depend on libcvaux-dev & libhighgui-dev
 -- Luka Renko <email address hidden>   Sun, 20 Dec 2009 19:28:35 +0100

Available diffs

Superseded in lucid-release on 2009-12-22
freecad (0.8.2237-2) unstable; urgency=low

  * Added libboost-python-dev to Build-Depends (closes: #549738).
  * Added myself to uploaders list.
  * Bumped Standards-Version.
 -- Ubuntu Archive Auto-Sync <email address hidden>   Mon,  30 Nov 2009 19:06:04 +0000

Available diffs

Superseded in lucid-release on 2009-11-30
freecad (0.8.2237-1) unstable; urgency=low

  * New Upstream release

175 of 75 results