Konqueror renders embolden characters strangely

Bug #5560 reported by atie on 2005-12-09
10
Affects Status Importance Assigned to Milestone
freetype (Ubuntu)
Medium
Unassigned

Bug Description

Please take a look at the screenshot here
http://bbs.kldp.org/viewtopic.php?p=336668#336668

And, here is a patch which may solve this problem. In the patch M_Y is redefined.
http://lists.freebsd.org/pipermail/freebsd-gnome/2005-July/011838.html

FYI, this problem happens with Konqueror 3.5 and Opera 9.0 preview, but not with Firefox 1.5

Also I had added this problem on https://wiki.ubuntu.com/BetterCJKSupportSpecification

Ming Hua (minghua) wrote :

As freetype is in main, the bug probably should be filed in bugzilla instead, but I'm not sure.

Daniel Holbach (dholbach) wrote :

I'd be happier to have a diff to review and not to let the buildsystem download random patches. atie, is the patch you're talking about this one: http://bbs.ilc.edu.tw/~chinsan/cjk-freetype-2.1.10-20050728.patch.gz ? Did you test-build it? Can we have screenshots (with and without), tests we can do?

atie (atie-at-matrix) wrote :

Applied the patch attached here and rebuilt libfreetype6_2.1.10 deb for testing, problem was fixed as you might see from this link (second screenshot called Embolden-Konqueror-patched.png) http://bbs.kldp.org/viewtopic.php?p=337510#337510

Good news! However, I was just feeling Bitstream vera sans on menu looked little bit ugly than before. I don't know it's because of this patch or something else, please take a look further.

atie (atie-at-matrix) wrote :

A KLDP member pointed out Bitstream thing above is probably due to usegamma patch. (Don't know what is difference between -#define xxxGRAYS_USE_GAMMA and +#define GRAYS_USE_GAMMA.)

Fedora also put the firefly's patch and more into cvs.
https://www.redhat.com/archives/fedora-cvs-commits/2005-October/msg00281.html

atie (atie-at-matrix) wrote :

If you don't use "usegamma" patch from firefly's patch and apply the others, this konqueror problem also gone but can see little bit of yellow color for characters of Bitstream fonts.

So I tested Fedora's patches which not using "usegamma" patch, but including the "M_Y" patch same as firefly's one and antialiasing, memoryleak and some more. Result was really good to me, I could see this Konqueror issue was fixed, there was no downside for characters from Bitstream fonts.

Please test Fedora's patches.

Japanese Font embolden strangely on Konqueror.

Japanese Font embolden correctly on Konqueror with patches downloaded from http://cvs.mandriva.com/cgi-bin/cvsweb.cgi/SPECS/freetype2/.
I uploaded source package includes these patches to REVU - http://revu.tauware.de/details.py?upid=1512

this problem will display when I use chinese either .

2006/1/17, Jun Kobayashi <email address hidden>:
> Public bug report changed:
> https://launchpad.net/malone/bugs/5560
>
> - Changed attachments:
> Added: fixed demonstration
> http://librarian.launchpad.net/1518185/JapaneseFont_patched.png
>

atie (atie-at-matrix) wrote :

freetype 2.1.10-1ubuntu1 contains the patches above.

Jonathan Riddell (jr) wrote :

new freetype uploaded, thanks.

Jonathan Riddell (jr) on 2006-01-19
Changed in freetype:
status: Unconfirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers