Change log for fyba package in Ubuntu

17 of 7 results
Published in eoan-release on 2019-04-18
Published in disco-release on 2018-10-30
Published in cosmic-release on 2018-08-03
Deleted in cosmic-proposed (Reason: moved to release)
fyba (4.1.1-6) unstable; urgency=medium

  * Add a sensible autopkgtest which verifies that it is possible to
    link with libfyba.
    - Added these files:
        debian/tests/control
        debian/tests/link-to-library
  * Remove lintian override for testsuite-autopkgtest-missing.

 -- Ruben Undheim <email address hidden>  Thu, 02 Aug 2018 20:28:34 +0200

Available diffs

Superseded in cosmic-release on 2018-08-03
Deleted in cosmic-proposed on 2018-08-04 (Reason: moved to release)
fyba (4.1.1-5) unstable; urgency=medium

  * Team upload.
  * Drop autopkgtest to test installability.
    (closes: #905117)
  * Add lintian override for testsuite-autopkgtest-missing.

 -- Bas Couwenberg <email address hidden>  Tue, 31 Jul 2018 14:13:20 +0200

Available diffs

Superseded in cosmic-release on 2018-07-31
Deleted in cosmic-proposed on 2018-08-02 (Reason: moved to release)
fyba (4.1.1-4) unstable; urgency=medium

  * Team upload.
  * Change Maintainer to Debian GIS project, move Ruben to Uploaders.
  * Restructure control file with cme.
  * Drop autoconf & libtool build dependencies, pulled in via dh-autoreconf.
  * Update watch file to handle common issues.
  * Drop incorrect Forwarded header from patches.
  * Add upstream metadata.
  * Bump Standards-Version to 4.1.5, no changes.
  * Strip trailing whitespace from control file.
  * Update copyright-format URL to use HTTPS.
  * Update Vcs-* URLs for Salsa.
  * Don't use autotools-dev explicitly.
  * Drop obsolete dbg package.
  * Add autopkgtest to test installability.
  * Enable all hardening buildflags.
  * Don't limit dh_strip to libfyba0.
  * Override dh_makeshlibs to use -V.
  * Fix capitalization error in description synopsis.

 -- Bas Couwenberg <email address hidden>  Sun, 29 Jul 2018 21:10:50 +0200
Superseded in cosmic-release on 2018-07-30
Deleted in cosmic-proposed on 2018-07-31 (Reason: moved to release)
fyba (4.1.1-3build1) cosmic; urgency=medium

  * Rebuild against new gcc.

 -- Gianfranco Costamagna <email address hidden>  Fri, 29 Jun 2018 10:53:48 +0200
Superseded in cosmic-release on 2018-06-29
Published in bionic-release on 2017-10-24
Published in artful-release on 2017-04-20
Obsolete in zesty-release on 2018-06-22
Obsolete in yakkety-release on 2018-01-23
Deleted in yakkety-proposed (Reason: moved to release)
fyba (4.1.1-3) unstable; urgency=medium

  * debian/control:
    - Set Vcs URLs to https
    - Updated standards to 3.9.8 (no changes)
  * debian/patches/fix_issue.patch
    - Don't define min/max macros
      Fixes FTBFS with GCC 6 (Closes: #831206)

 -- Ruben Undheim <email address hidden>  Fri, 19 Aug 2016 17:59:12 +0000

Available diffs

Superseded in yakkety-release on 2016-08-25
Published in xenial-release on 2015-10-22
Obsolete in wily-release on 2018-01-22
Deleted in wily-proposed (Reason: moved to release)
fyba (4.1.1-2) unstable; urgency=low

  * debian/control:
    - Fixed debhelper version 9.0.0 -> 9
    - Set "Multi-Arch: same" to enable multiarch for library
    - Standards version to 3.9.6
  * Added debian/gbp.conf to automatically enable pristine-tar build

 -- Ruben Undheim <email address hidden>  Sat, 23 May 2015 12:20:40 +0200

Available diffs

Superseded in wily-release on 2015-05-23
Obsolete in vivid-release on 2018-01-18
Deleted in vivid-proposed on 2018-01-19 (Reason: moved to release)
fyba (4.1.1-1) unstable; urgency=low


  * Initial release (Closes: #760544)

 -- Ruben Undheim <email address hidden>  Thu, 04 Sep 2014 21:41:19 +0200
17 of 7 results