Regression in gawk 3.1.5 from 3.1.4

Bug #35571 reported by Robert Collins
6
Affects Status Importance Assigned to Milestone
gawk (Debian)
Fix Released
Unknown
gawk (Ubuntu)
Medium
Unassigned

Bug Description

This is somewhat vague - sorry.

awk 3.1.5 crashes trying to run the gtkproprocessor scripts in gnu smalltalk 2.2-unstable. 3.1.4 works fine. I'm going to attach the key script that fails here:
cpp.awk - this preprocesses all the gtk headers to create class descriptions for the gnu smalltalk language bindings for gnome.

run it as
!xargs cpp.awk < order
with the gtk and gnome dev headers installed and if you trigger the crash you will see
....
typedef int GPid;

G_END_DECLS

gawk: node.c:515: unref: Assertion `(tmp->flags & 4096) != 0' failed.

Related branches

Revision history for this message
Robert Collins (lifeless) wrote : order

the file ordering to trigger cpp.awk failures

Revision history for this message
Robert Collins (lifeless) wrote : cpp.awk

the cpp.awk script that causes the assertion.

Revision history for this message
Gary Coady (garycoady) wrote :

I've had problems trying to reproduce this - getting gnu-smalltalk to compile at all is a bit of a hassle.

There's a similar issue reported upstream,
http://lists.gnu.org/archive/html/bug-gnu-utils/2006-04/msg00045.html

Possible fix attached, though it'll need testing to confirm that it fixes this particular assertion.

Revision history for this message
Gary Coady (garycoady) wrote : Possible patch for this issue

Possible patch from upstream mailing list for this issue.

Revision history for this message
Robert Collins (lifeless) wrote : Re: [Bug 35571] Re: Regression in gawk 3.1.5 from 3.1.4

On Mon, 2006-05-15 at 00:28 +0000, Gary Coady wrote:
> I've had problems trying to reproduce this - getting gnu-smalltalk to
> compile at all is a bit of a hassle.

Huh? Should be trivial. apt-get source gnu-smalltalk && cd
gnu-smalltalk-* && debuild -us -uc -nc

> There's a similar issue reported upstream,
> http://lists.gnu.org/archive/html/bug-gnu-utils/2006-04/msg00045.html
>
> Possible fix attached, though it'll need testing to confirm that it
> fixes this particular assertion.
>
> ** Attachment added: "Possible patch for this issue"
> http://librarian.launchpad.net/2626471/25_wide_assertion.dpatch

That certainly looks like a good candidate.

Rob

--
GPG key available at: <http://www.robertcollins.net/keys.txt>.

Revision history for this message
Gary Coady (garycoady) wrote : Re: [Bug 35571] Re: [Bug 35571] Re: Regression in gawk 3.1.5 from 3.1.4

Robert Collins wrote:
> On Mon, 2006-05-15 at 00:28 +0000, Gary Coady wrote:
>
>> I've had problems trying to reproduce this - getting gnu-smalltalk to
>> compile at all is a bit of a hassle.
>>
>
> Huh? Should be trivial. apt-get source gnu-smalltalk && cd
> gnu-smalltalk-* && debuild -us -uc -nc
>
Hm.
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=326355

After that:
make[1]: Entering directory `/home/gary/tmp100/gnu-smalltalk-2.1.8'
 cd . && /bin/sh /home/gary/tmp100/gnu-smalltalk-2.1.8/config/missing
--run automake-1.8 --gnu
configure.ac:20: version mismatch. This is Automake 1.8.5,
configure.ac:20: but the definition used by this AM_INIT_AUTOMAKE
configure.ac:20: comes from Automake 1.8. You should recreate
configure.ac:20: aclocal.m4 with aclocal and run automake again.
make[1]: *** [Makefile.in] Error 1

Here, rerunning the build seems to work, as long as "-nc" is specified.
It's great to see a package that depends on autoconf to build... sigh.

But that's getting away from the point. I've reproduced the problem with
smalltalk 2.2, and the patch does fix it.

Gary Coady (garycoady)
Changed in gawk:
status: Unconfirmed → Confirmed
Revision history for this message
Matthias Klose (doko) wrote :

fixed in 1:3.1.5.dfsg-4ubuntu1

Changed in gawk:
status: Confirmed → Fix Released
Changed in gawk (Debian):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments

Remote bug watches

Bug watches keep track of this bug in other bug trackers.