Change log for gdb package in Ubuntu

175 of 179 results
Published in disco-proposed on 2019-01-14
gdb (8.2.1-0ubuntu1) disco; urgency=medium

  * gdb 8.2.1 release.

 -- Matthias Klose <email address hidden>  Mon, 14 Jan 2019 19:41:45 +0100

Available diffs

Published in disco-release on 2018-11-02
Deleted in disco-proposed (Reason: moved to release)
gdb (8.2-0ubuntu2) disco; urgency=medium

  * No-change rebuild to build for python3.7 as the default.

 -- Matthias Klose <email address hidden>  Wed, 31 Oct 2018 12:34:33 +0000

Available diffs

Superseded in disco-release on 2018-11-02
Published in cosmic-release on 2018-09-13
Deleted in cosmic-proposed (Reason: moved to release)
gdb (8.2-0ubuntu1) cosmic; urgency=medium

  * gdb 8.2 release.

 -- Matthias Klose <email address hidden>  Wed, 12 Sep 2018 12:41:04 +0200
Superseded in cosmic-release on 2018-09-13
Deleted in cosmic-proposed on 2018-09-14 (Reason: moved to release)
gdb (8.1.90.20180904-0ubuntu1) cosmic; urgency=medium

  * Snapshot, taken from the gdb-8.1-branch.

 -- Matthias Klose <email address hidden>  Tue, 04 Sep 2018 16:41:10 +0200
Superseded in cosmic-release on 2018-09-05
Deleted in cosmic-proposed on 2018-09-06 (Reason: moved to release)
gdb (8.1-0ubuntu8) cosmic; urgency=medium

  * Enable Intel PT recording format on x86 architectures. Closes: #872800.

 -- Matthias Klose <email address hidden>  Fri, 20 Jul 2018 22:15:11 +0200
Superseded in cosmic-proposed on 2018-07-21
gdb (8.1-0ubuntu7) cosmic; urgency=medium

  * Enable Intel PT recording format on amd64. Closes: #872800.

 -- Matthias Klose <email address hidden>  Fri, 20 Jul 2018 22:15:11 +0200

Available diffs

Superseded in cosmic-release on 2018-08-31
Deleted in cosmic-proposed on 2018-09-01 (Reason: moved to release)
gdb (8.1-0ubuntu6) cosmic; urgency=medium

  * gdb: Provide gdb-minimal.

 -- Matthias Klose <email address hidden>  Sat, 12 May 2018 18:21:38 -0400

Available diffs

Superseded in cosmic-release on 2018-05-13
Deleted in cosmic-proposed on 2018-05-15 (Reason: moved to release)
gdb (8.1-0ubuntu5) cosmic; urgency=medium

  * debian/control: Update libncurses build-deps to the new scheme.

 -- Adam Conrad <email address hidden>  Fri, 04 May 2018 09:58:50 -0600

Available diffs

Superseded in cosmic-release on 2018-05-05
Deleted in cosmic-proposed on 2018-05-06 (Reason: moved to release)
gdb (8.1-0ubuntu4) cosmic; urgency=medium

  * No-change rebuild for ncurses soname changes.

 -- Matthias Klose <email address hidden>  Thu, 03 May 2018 15:19:42 +0000

Available diffs

Superseded in cosmic-release on 2018-05-04
Published in bionic-release on 2018-04-09
Deleted in bionic-proposed (Reason: moved to release)
gdb (8.1-0ubuntu3) bionic; urgency=medium

  * Update, taken from the gdb-8.1-branch 20180409.
  * Use bash instead of /bin/sh as this script uses arrays which require bash.
    (Trent Lloyd). LP: #1762320.

 -- Matthias Klose <email address hidden>  Mon, 09 Apr 2018 11:31:42 +0200

Available diffs

Superseded in bionic-release on 2018-04-09
Deleted in bionic-proposed on 2018-04-10 (Reason: moved to release)
gdb (8.1-0ubuntu2) bionic; urgency=medium

  * Remove build dependency on gcj-jdk.

 -- Matthias Klose <email address hidden>  Mon, 26 Mar 2018 09:19:36 +0800

Available diffs

Superseded in bionic-release on 2018-03-26
Deleted in bionic-proposed on 2018-03-27 (Reason: moved to release)
gdb (8.1-0ubuntu1) bionic; urgency=medium

  * gdb 8.1 release.

 -- Matthias Klose <email address hidden>  Thu, 01 Feb 2018 09:34:03 +0100
Superseded in bionic-proposed on 2018-02-01
gdb (8.0.90.20180111-0ubuntu3) bionic; urgency=medium

  * No-change rebuild for mpfr soname change.

 -- Matthias Klose <email address hidden>  Wed, 24 Jan 2018 21:40:24 +0000
Superseded in bionic-proposed on 2018-01-24
gdb (8.0.90.20180111-0ubuntu2) bionic; urgency=medium

  * Snapshot, taken from the gdb-8.1-branch.

 -- Matthias Klose <email address hidden>  Thu, 11 Jan 2018 17:29:12 +0100
Superseded in bionic-proposed on 2018-01-11
gdb (8.0.90.20180111-0ubuntu1) bionic; urgency=medium

  * Snapshot, taken from the gdb-8.1-branch.

 -- Matthias Klose <email address hidden>  Thu, 11 Jan 2018 17:29:12 +0100
Superseded in bionic-release on 2018-02-12
Deleted in bionic-proposed on 2018-02-14 (Reason: moved to release)
gdb (8.0.1-0ubuntu3) bionic; urgency=medium

  * Now that we don't buil gdb64 anymore, stop depending on lib64expat1
    altogether.

 -- Ɓukasz 'sil2100' Zemczak <email address hidden>  Wed, 03 Jan 2018 11:42:27 +0100

Available diffs

Superseded in bionic-release on 2018-01-06
Deleted in bionic-proposed on 2018-01-07 (Reason: moved to release)
gdb (8.0.1-0ubuntu2) bionic; urgency=medium

  * Stop building gdb64.

 -- Matthias Klose <email address hidden>  Fri, 22 Dec 2017 16:37:06 +0100

Available diffs

Superseded in bionic-release on 2017-12-22
Published in artful-release on 2017-09-14
Deleted in artful-proposed (Reason: moved to release)
gdb (8.0.1-0ubuntu1) artful; urgency=medium

  * New upstream bug fix release.

 -- Matthias Klose <email address hidden>  Wed, 13 Sep 2017 12:21:48 +0200

Available diffs

Superseded in artful-release on 2017-09-14
Deleted in artful-proposed on 2017-09-15 (Reason: moved to release)
gdb (8.0-0ubuntu6) artful; urgency=medium

  * Fix build dependencies for the gdb64 build.

 -- Matthias Klose <email address hidden>  Fri, 01 Sep 2017 09:00:04 +0200
Superseded in artful-proposed on 2017-09-01
gdb (8.0-0ubuntu5) artful; urgency=medium

  * Build using ncursesw. LP: #1275210.

 -- Matthias Klose <email address hidden>  Fri, 01 Sep 2017 08:50:14 +0200

Available diffs

Superseded in artful-release on 2017-09-01
Deleted in artful-proposed on 2017-09-03 (Reason: moved to release)
gdb (8.0-0ubuntu4) artful; urgency=medium

  * Add patch to support Infinity notes.

 -- Matthias Klose <email address hidden>  Mon, 21 Aug 2017 15:18:17 +0200

Available diffs

Superseded in artful-release on 2017-08-21
Deleted in artful-proposed on 2017-08-23 (Reason: moved to release)
gdb (8.0-0ubuntu3) artful; urgency=medium

  * SECURITY UPDATE: denial of service via infinite recursion
    - debian/patches/CVE-2016-4491-2.patch: limit more recursion in
      libiberty/cp-demangle.c.
    - CVE-2016-4491

 -- Marc Deslauriers <email address hidden>  Wed, 26 Jul 2017 13:17:18 -0400

Available diffs

Superseded in artful-release on 2017-08-08
Deleted in artful-proposed on 2017-08-09 (Reason: moved to release)
gdb (8.0-0ubuntu2) artful; urgency=medium

  * No-change rebuild to build with python3.6.

 -- Matthias Klose <email address hidden>  Mon, 24 Jul 2017 14:07:49 +0000

Available diffs

Published in trusty-updates on 2017-07-26
Published in trusty-security on 2017-07-26
gdb (7.7.1-0ubuntu5~14.04.3) trusty-security; urgency=medium

  * SECURITY UPDATE: DoS via invalid value in NumberOfRvaAndSizes field
    - debian/patches/CVE-2014-8501.patch: add check to bfd/peXXigen.c.
    - CVE-2014-8501
  * SECURITY UPDATE: stack overflow when printing bad bytes
    - debian/patches/CVE-2014-9939.patch: fix escape sequences in
      bfd/ihex.c, bfd/srec.c.
    - CVE-2014-9939
  * SECURITY UPDATE: integer overflow in string_appends
    - debian/patches/CVE-2016-2226.patch: check for overflow in
      libiberty/cplus-dem.c, added xmalloc_failed to
      gdb/common/common-utils.c.
    - CVE-2016-2226
  * SECURITY UPDATE: use-after-free vulberabilities
    - debian/patches/CVE-2016-4487_4488.patch: set bsize and ksize in
      libiberty/cplus-dem.c, added test to
      libiberty/testsuite/demangle-expected.
    - CVE-2016-4487
    - CVE-2016-4488
  * SECURITY UPDATE: integer overflow in gnu_special
    - debian/patches/CVE-2016-4489.patch: handle case where consume_count
      returns -1 in libiberty/cplus-dem.c.
    - CVE-2016-4489
  * SECURITY UPDATE: integer overflow after sanity checks
    - debian/patches/CVE-2016-4490.patch: parse numbers as integer instead
      of long in libiberty/cp-demangle.c, added test to
      libiberty/testsuite/demangle-expected.
    - CVE-2016-4490
  * SECURITY UPDATE: denial of service via infinite recursion
    - debian/patches/CVE-2016-4491-1.patch: limit recursion in
      include/demangle.h, libiberty/cp-demangle.c, libiberty/cp-demint.c,
      added test to libiberty/testsuite/demangle-expected.
    - debian/patches/CVE-2016-4491-2.patch: limit more recursion in
      libiberty/cp-demangle.c.
    - debian/patches/CVE-2016-4491-3.patch: initialize d_printing in
      gdb/cp-name-parser.y, libiberty/cp-demangle.c.
    - CVE-2016-4491
  * SECURITY UPDATE: buffer overflow in do_type
    - debian/patches/CVE-2016-4492_4493.patch: properly handle large values
      and overflow in libiberty/cplus-dem.c, added test to
      libiberty/testsuite/demangle-expected.
    - CVE-2016-4492
    - CVE-2016-4493
  * SECURITY UPDATE: denial of service via infinite recursion
    - debian/patches/CVE-2016-6131.patch: prevent infinite recursion in
      libiberty/cplus-dem.c, added test to
      libiberty/testsuite/demangle-expected.
    - CVE-2016-6131

 -- Marc Deslauriers <email address hidden>  Fri, 09 Jun 2017 10:42:55 -0400
Published in xenial-updates on 2017-07-26
Published in xenial-security on 2017-07-26
gdb (7.11.1-0ubuntu1~16.5) xenial-security; urgency=medium

  * SECURITY UPDATE: integer overflow in string_appends
    - debian/patches/CVE-2016-2226.patch: check for overflow in
      libiberty/cplus-dem.c, added xmalloc_failed to
      gdb/common/common-utils.c.
    - CVE-2016-2226
  * SECURITY UPDATE: use-after-free vulberabilities
    - debian/patches/CVE-2016-4487_4488.patch: set bsize and ksize in
      libiberty/cplus-dem.c, added test to
      libiberty/testsuite/demangle-expected.
    - CVE-2016-4487
    - CVE-2016-4488
  * SECURITY UPDATE: integer overflow in gnu_special
    - debian/patches/CVE-2016-4489.patch: handle case where consume_count
      returns -1 in libiberty/cplus-dem.c.
    - CVE-2016-4489
  * SECURITY UPDATE: integer overflow after sanity checks
    - debian/patches/CVE-2016-4490.patch: parse numbers as integer instead
      of long in libiberty/cp-demangle.c, added test to
      libiberty/testsuite/demangle-expected.
    - CVE-2016-4490
  * SECURITY UPDATE: denial of service via infinite recursion
    - debian/patches/CVE-2016-4491-1.patch: limit recursion in
      include/demangle.h, libiberty/cp-demangle.c, libiberty/cp-demint.c,
      added test to libiberty/testsuite/demangle-expected.
    - debian/patches/CVE-2016-4491-2.patch: limit more recursion in
      libiberty/cp-demangle.c.
    - debian/patches/CVE-2016-4491-3.patch: initialize d_printing in
      gdb/cp-name-parser.y, libiberty/cp-demangle.c.
    - CVE-2016-4491
  * SECURITY UPDATE: buffer overflow in do_type
    - debian/patches/CVE-2016-4492_4493.patch: properly handle large values
      and overflow in libiberty/cplus-dem.c, added test to
      libiberty/testsuite/demangle-expected.
    - CVE-2016-4492
    - CVE-2016-4493
  * SECURITY UPDATE: denial of service via infinite recursion
    - debian/patches/CVE-2016-6131.patch: prevent infinite recursion in
      libiberty/cplus-dem.c, added test to
      libiberty/testsuite/demangle-expected.
    - CVE-2016-6131

 -- Marc Deslauriers <email address hidden>  Fri, 09 Jun 2017 10:41:47 -0400
Obsolete in zesty-updates on 2018-06-22
Obsolete in zesty-security on 2018-06-22
gdb (7.12.50.20170314-0ubuntu1.1) zesty-security; urgency=medium

  * SECURITY UPDATE: denial of service via infinite recursion
    - debian/patches/CVE-2016-4491-2.patch: limit more recursion in
      libiberty/cp-demangle.c.
    - CVE-2016-4491

 -- Marc Deslauriers <email address hidden>  Thu, 08 Jun 2017 07:47:17 -0400
Superseded in artful-release on 2017-07-25
Deleted in artful-proposed on 2017-07-26 (Reason: moved to release)
gdb (8.0-0ubuntu1) artful; urgency=medium

  * gdb 8.0 release.

 -- Matthias Klose <email address hidden>  Wed, 07 Jun 2017 09:22:21 -0700
Superseded in artful-release on 2017-06-22
Deleted in artful-proposed on 2017-06-23 (Reason: moved to release)
gdb (7.99.90.20170502-0ubuntu1) artful; urgency=medium

  * Snapshot, taken from the gdb-8-branch.

 -- Matthias Klose <email address hidden>  Tue, 02 May 2017 13:00:05 +0200
Superseded in artful-release on 2017-05-03
Obsolete in zesty-release on 2018-06-22
Deleted in zesty-proposed on 2018-06-22 (Reason: moved to release)
gdb (7.12.50.20170314-0ubuntu1) zesty; urgency=medium

  * Snapshot, taken from the trunk.

 -- Matthias Klose <email address hidden>  Tue, 14 Mar 2017 14:12:54 +0100
Superseded in zesty-release on 2017-03-14
Deleted in zesty-proposed on 2017-03-16 (Reason: moved to release)
gdb (7.12.50.20170207-0ubuntu2) zesty; urgency=medium

  * Configure with --disable-werror.

 -- Matthias Klose <email address hidden>  Tue, 07 Feb 2017 10:22:15 +0100
Superseded in zesty-proposed on 2017-02-07
gdb (7.12.50.20170207-0ubuntu1) zesty; urgency=medium

  * Snapshot, taken from the trunk.

 -- Matthias Klose <email address hidden>  Tue, 07 Feb 2017 07:03:04 +0100
Obsolete in yakkety-updates on 2018-01-23
Deleted in yakkety-proposed on 2018-01-23 (Reason: moved to -updates)
gdb (7.11.90.20161005-0ubuntu2) yakkety; urgency=medium

  * Add debian/patches/armhf-fpregset.patch. LP: #1645501.

 -- Brian Murray <email address hidden>  Wed, 18 Jan 2017 12:41:08 -0800
Superseded in zesty-release on 2017-02-07
Deleted in zesty-proposed on 2017-02-09 (Reason: moved to release)
gdb (7.12-0ubuntu4) zesty; urgency=medium

  * Modify debian/patches/armhf-fpregset.patch per upstream. LP: #1645501.

 -- Brian Murray <email address hidden>  Wed, 18 Jan 2017 11:51:42 -0800

Available diffs

Superseded in zesty-release on 2017-01-26
Deleted in zesty-proposed on 2017-01-27 (Reason: moved to release)
gdb (7.12-0ubuntu3) zesty; urgency=medium

  * Add debian/patches/armhf-fpregset.patch. LP: #1645501.

 -- Kees Cook <email address hidden>  Tue, 29 Nov 2016 15:30:20 -0800

Available diffs

Superseded in zesty-release on 2016-12-06
Deleted in zesty-proposed on 2016-12-07 (Reason: moved to release)
gdb (7.12-0ubuntu2) zesty; urgency=medium

  * Add Power ISA 3.0/POWER9 instructions record support. LP: #1642304.

 -- Matthias Klose <email address hidden>  Wed, 16 Nov 2016 19:58:53 +0100

Available diffs

Superseded in zesty-release on 2016-11-20
Deleted in zesty-proposed on 2016-11-21 (Reason: moved to release)
Deleted in yakkety-proposed on 2016-11-21 (Reason: Moved to zesty-proposed)
gdb (7.12-0ubuntu1) yakkety; urgency=medium

  * New upstream release.

 -- Matthias Klose <email address hidden>  Tue, 11 Oct 2016 16:33:24 +0200
Superseded in zesty-release on 2016-10-20
Obsolete in yakkety-release on 2018-01-23
Deleted in yakkety-proposed on 2018-01-23 (Reason: moved to release)
gdb (7.11.90.20161005-0ubuntu1) yakkety; urgency=medium

  * Snapshot, taken from the gdb-7.12 branch.

 -- Matthias Klose <email address hidden>  Wed, 05 Oct 2016 23:55:15 +0200
Superseded in yakkety-release on 2016-10-06
Deleted in yakkety-proposed on 2016-10-07 (Reason: moved to release)
gdb (7.11.90.20160927-0ubuntu1) yakkety; urgency=medium

  * Snapshot, taken from the gdb-7.12 branch.

 -- Matthias Klose <email address hidden>  Tue, 27 Sep 2016 18:42:57 +0200
Superseded in yakkety-release on 2016-09-30
Deleted in yakkety-proposed on 2016-10-02 (Reason: moved to release)
gdb (7.11.90.20160917-0ubuntu2) yakkety; urgency=medium

  * Build again the gdb64 package.
  * Configure with --with-babeltrace on every architecture.

 -- Matthias Klose <email address hidden>  Sun, 18 Sep 2016 19:46:33 +0200
Superseded in yakkety-proposed on 2016-09-18
gdb (7.11.90.20160917-0ubuntu1) yakkety; urgency=medium

  * Snapshot, taken from the gdb-7.12 branch.

 -- Matthias Klose <email address hidden>  Sat, 17 Sep 2016 15:49:50 +0200
Superseded in yakkety-release on 2016-09-19
Deleted in yakkety-proposed on 2016-09-20 (Reason: moved to release)
gdb (7.11.90.20160906-0ubuntu1) yakkety; urgency=medium

  * Snapshot, taken from the gdb-7.12 branch.

 -- Matthias Klose <email address hidden>  Tue, 06 Sep 2016 12:39:48 +0200
Superseded in yakkety-release on 2016-09-07
Deleted in yakkety-proposed on 2016-09-08 (Reason: moved to release)
gdb (7.11.90.20160824-0ubuntu2) yakkety; urgency=medium

  * Don't build gdb64 for now.

 -- Matthias Klose <email address hidden>  Mon, 29 Aug 2016 11:11:26 +0200
Superseded in yakkety-proposed on 2016-08-29
gdb (7.11.90.20160824-0ubuntu1) yakkety; urgency=medium

  * Snapshot, taken from the gdb-7.12 branch.

 -- Matthias Klose <email address hidden>  Wed, 24 Aug 2016 14:54:04 +0200
Superseded in xenial-updates on 2017-07-26
gdb (7.11.1-0ubuntu1~16.04) xenial-updates; urgency=medium

  * SRU: LP: #1588066, backport 7.11.1 to 16.04 LTS.

Superseded in yakkety-release on 2016-08-30
Deleted in yakkety-proposed on 2016-08-31 (Reason: moved to release)
gdb (7.11.1-0ubuntu1) yakkety; urgency=medium

  * New upstream bug fix release.
    - Fix PR gdb/19828, PR gdb/20045, PR gdb/18077, PR gdb/20039,
      PR python/20037, PR remote/19840, PR gdb/19858, PR gdb/19829,
      PR gdb/19676.

 -- Matthias Klose <email address hidden>  Wed, 01 Jun 2016 17:05:58 +0200

Available diffs

Superseded in yakkety-release on 2016-06-03
Published in xenial-release on 2016-02-24
Deleted in xenial-proposed (Reason: moved to release)
gdb (7.11-0ubuntu1) xenial; urgency=medium

  * New upstream release.

 -- Matthias Klose <email address hidden>  Wed, 24 Feb 2016 18:27:39 +0100
Superseded in xenial-release on 2016-02-24
Deleted in xenial-proposed on 2016-02-26 (Reason: moved to release)
gdb (7.10.90.20160220-0ubuntu1) xenial; urgency=medium

  * Snapshot, taken from the gdb-7.11 branch.
  * Build again the pdf docs with fixed texinfo.
  * Fix OverflowError in backtrace command on 32bit kernels. LP: #1513922.

 -- Matthias Klose <email address hidden>  Sat, 20 Feb 2016 17:52:18 +0100
Superseded in xenial-release on 2016-02-20
Deleted in xenial-proposed on 2016-02-22 (Reason: moved to release)
gdb (7.10.90.20160215-0ubuntu2) xenial; urgency=medium

  * Don't build the pdf docs, broken with recent texinfo.

 -- Matthias Klose <email address hidden>  Mon, 15 Feb 2016 20:50:26 +0100
Superseded in xenial-proposed on 2016-02-15
gdb (7.10.90.20160215-0ubuntu1) xenial; urgency=medium

  * Snapshot, taken from the gdb-7.11 branch.

 -- Matthias Klose <email address hidden>  Mon, 15 Feb 2016 17:40:33 +0100
Superseded in xenial-release on 2016-02-16
Deleted in xenial-proposed on 2016-02-17 (Reason: moved to release)
gdb (7.10.1-0ubuntu1) xenial; urgency=medium

  * New upstream release.

 -- Matthias Klose <email address hidden>  Sat, 16 Jan 2016 11:33:19 +0100

Available diffs

Superseded in xenial-release on 2016-01-18
Deleted in xenial-proposed on 2016-01-19 (Reason: moved to release)
gdb (7.10-1ubuntu3) xenial; urgency=medium

  * No-change rebuild for python3 defaults change.

 -- Matthias Klose <email address hidden>  Fri, 23 Oct 2015 10:51:49 +0000

Available diffs

Superseded in xenial-release on 2015-10-26
Obsolete in wily-release on 2018-01-22
Deleted in wily-proposed on 2018-01-22 (Reason: moved to release)
gdb (7.10-1ubuntu2) wily; urgency=medium

  * Fix build dependencies on i386 and powerpc for gdb64.

 -- Matthias Klose <email address hidden>  Sun, 13 Sep 2015 14:59:07 +0200
Superseded in wily-proposed on 2015-09-13
gdb (7.10-1ubuntu1) wily; urgency=medium

  * Merge with Debian; remaining changes:
  * Remaining changes:
    - Keep building the gdb64 package.
    - Build from the upstream sources.
    - Build the gdb-doc package.
    - Include the man pages in the gdb package.
    - Build-depend on gcj-jdk.
    - Drop build dependency on python-dev.
    - Additional patches branch-updates, gdb-strings, ptrace-error-verbosity,
      ppc64el-gdbserver, ppc64el-attach-jvm.
    - Don't build a gdb-python2 package.
    - Configure with babeltrace on ppc64 and ppc64el.
    - gdb: Add a replaces to gdb-doc, which used to ship the manual pages.
    - Again, stop building the gdb-minimal package, not used anymore on any
      image.
    - Add build dependencies for the gdb-doc package.
    - Make gdb Multi-Arch: allowed again.
    - gdb: Recommend libcc1-0.
  * Update to the 7.9 branch 20150321.
    - Fix undefined behavior in TUI's TAB expansion.

 -- Matthias Klose <email address hidden>  Sun, 13 Sep 2015 13:47:01 +0200

Available diffs

Superseded in wily-release on 2015-09-14
Deleted in wily-proposed on 2015-09-15 (Reason: moved to release)
gdb (7.10-0ubuntu1) wily; urgency=medium

  * Gdb 7.10.

 -- Matthias Klose <email address hidden>  Sun, 30 Aug 2015 14:40:47 +0200
Superseded in wily-release on 2015-08-31
Deleted in wily-proposed on 2015-09-01 (Reason: moved to release)
gdb (7.9.90.20150809-0ubuntu1) wily; urgency=medium

  * Snapshot, taken from the 7.10 branch.

 -- Matthias Klose <email address hidden>  Mon, 10 Aug 2015 00:35:59 +0200
Superseded in wily-release on 2015-08-10
Deleted in wily-proposed on 2015-08-12 (Reason: moved to release)
gdb (7.9.1-0ubuntu1) wily; urgency=medium

  * New upstream (bug fix) version.

 -- Matthias Klose <email address hidden>  Wed, 22 Jul 2015 18:33:52 +0200

Available diffs

Superseded in wily-release on 2015-07-24
Obsolete in vivid-release on 2018-01-18
Deleted in vivid-proposed on 2018-01-19 (Reason: moved to release)
gdb (7.9-1ubuntu1) vivid; urgency=medium

  * Merge in the Debian packaging changes for 7.9.
  * Remaining changes:
    - Keep building the gdb64 package.
    - Build from the upstream sources.
    - Build the gdb-doc package.
    - Include the man pages in the gdb package.
    - Build-depend on gcj-jdk.
    - Drop build dependency on python-dev.
    - Additional patches branch-updates, gdb-strings, ptrace-error-verbosity,
      ppc64el-gdbserver, ppc64el-attach-jvm.
    - Don't build a gdb-python2 package.
    - Configure with babeltrace on ppc64 and ppc64el.
    - gdb: Add a replaces to gdb-doc, which used to ship the manual pages.
    - Again, stop building the gdb-minimal package, not used anymore on any
      image.
    - Add build dependencies for the gdb-doc package.
    - Make gdb Multi-Arch: allowed again.
  * gdb: Suggest libcc1-0 (should really be a recommends, but it is
    still in universe, same as the needed gcc-5/gccgo-5).
  * Don't look for the libcc1.so symlink, but for the real library name.
  * Fix the regexp for searching the compiler, so that it recognizes
    triplets as well.
  * Update to the 7.9 branch 20150321.
    - Fix undefined behavior in TUI's TAB expansion.
 -- Matthias Klose <email address hidden>   Sat, 21 Mar 2015 17:07:37 +0100

Available diffs

Superseded in vivid-release on 2015-03-21
Deleted in vivid-proposed on 2015-03-23 (Reason: moved to release)
gdb (7.9-0ubuntu1) vivid; urgency=medium

  * GDB 7.9 release.
 -- Matthias Klose <email address hidden>   Wed, 25 Feb 2015 22:27:54 +0100

Available diffs

Superseded in vivid-release on 2015-02-26
Deleted in vivid-proposed on 2015-02-27 (Reason: moved to release)
gdb (7.8.2-0ubuntu1) vivid; urgency=medium

  * GDB 7.8.2 release.
 -- Matthias Klose <email address hidden>   Tue, 20 Jan 2015 20:34:21 +0100

Available diffs

Superseded in vivid-release on 2015-01-22
Deleted in vivid-proposed on 2015-01-23 (Reason: moved to release)
gdb (7.8.1-1ubuntu2) vivid; urgency=medium

  * Fix PR ld/17677, performance regression compared to 7.7.
    LP: #1388999.
 -- Matthias Klose <email address hidden>   Tue, 09 Dec 2014 10:25:17 +0100

Available diffs

Superseded in vivid-release on 2014-12-09
Deleted in vivid-proposed on 2014-12-11 (Reason: moved to release)
gdb (7.8.1-1ubuntu1) vivid; urgency=medium

  * Merge with Debian; remaining changes:
    - Build from the upstream sources.
    - Build the gdb-doc package.
    - Include the man pages in the gdb package.
    - Build-depend on gcj-jdk.
    - Drop build dependency on python-dev.
    - Additional patches branch-updates, gdb-strings, ptrace-error-verbosity,
      ppc64el-gdbserver, ppc64el-attach-jvm.
    - Don't build a gdb-python2 package.
    - Configure with babeltrace on ppc64 and ppc64el.
    - gdb: Add a replaces to gdb-doc, which used to ship the manual pages.
    - Again, stop building the gdb-minimal package, not used anymore on any
      image.
    - Add build dependencies for the gdb-doc package.
    - Make gdb Multi-Arch: allowed again.
  * Upstream fixes LP: #1348275.

Available diffs

Superseded in trusty-updates on 2017-07-26
Deleted in trusty-proposed on 2017-07-27 (Reason: moved to -updates)
gdb (7.7.1-0ubuntu5~14.04.2) trusty-proposed; urgency=medium

  * SRU: Update for trusty. LP: #1351646.
  * Build the gdb-doc package from the gdb sources.
 -- Matthias Klose <email address hidden>   Wed, 08 Oct 2014 20:48:14 +0200
Superseded in vivid-release on 2014-11-20
Obsolete in utopic-release on 2016-11-03
Deleted in utopic-proposed on 2016-11-03 (Reason: moved to release)
gdb (7.8-1ubuntu4) utopic; urgency=medium

  * Make gdb Multi-Arch: allowed again.
 -- Matthias Klose <email address hidden>   Thu, 09 Oct 2014 08:23:49 +0200
Superseded in utopic-proposed on 2014-10-09
gdb (7.8-1ubuntu3) utopic; urgency=medium

  * Add build dependencies for the gdb-doc package.
 -- Matthias Klose <email address hidden>   Tue, 07 Oct 2014 18:20:50 +0200

Available diffs

Superseded in utopic-proposed on 2014-10-07
gdb (7.8-1ubuntu2) utopic; urgency=medium

  * Drop build dependency on gccgo (universe).
 -- Matthias Klose <email address hidden>   Tue, 07 Oct 2014 17:48:27 +0200

Available diffs

Superseded in utopic-proposed on 2014-10-07
gdb (7.8-1ubuntu1) utopic; urgency=medium

  * Merge with Debian; remaining changes:
    - Build from the upstream sources.
    - Build the gdb-doc package.
    - Include the man pages in the gdb package.
    - Build-depend on gcj-jdk.
    - Drop build dependency on python-dev.
    - Additional patches branch-updates, gdb-strings, ptrace-error-verbosity,
      ppc64el-gdbserver, ppc64el-attach-jvm.
  * Don't build a gdb-python2 package.
  * Configure with babeltrace on ppc64 and ppc64el.
  * gdb: Add a replaces to gdb-doc, which used to ship the manual pages.
    LP: #1370690.
  * Build-depend on gccgo to run the Go tests during the build.
  * Again, stop building the gdb-minimal package, not used anymore on any
    image.

Available diffs

Superseded in utopic-release on 2014-10-14
Deleted in utopic-proposed on 2014-10-16 (Reason: moved to release)
gdb (7.8-0ubuntu2) utopic; urgency=medium

  * Update gdb from the 7.8 release branch.
    - Fix regression for Linux vDSO in GDB (PR gdb/17407).
    - Fix regression, GDB stopped on run with attached process (PR gdb/17347).
    - Fix PR guile/17367, PR guile/17247.
    - Fix crash on Python frame filters with unreadable arg.
    - Fix xmethod Python so that it works with Python3.
    - Fix 'gcore' with exited threads.
    - Fix Fix build/17104, build configured with --with-babeltrace.
    - Aarch64: Make CPSR a 32-bit register again in the target description.
  * Build-depend on binutils 2.24.51.20141001 for running the tests.
    LP: #1365664.
  * Fix gdbserver conditionals on ppc64le. LP: #1367832.
  * Fix attaching to a java process on ppc64el.
 -- Matthias Klose <email address hidden>   Wed, 01 Oct 2014 22:41:51 +0200

Available diffs

Superseded in utopic-release on 2014-10-02
Deleted in utopic-proposed on 2014-10-03 (Reason: moved to release)
gdb (7.8-0ubuntu1) utopic; urgency=medium

  * gdb-7.8 release.
 -- Matthias Klose <email address hidden>   Thu, 31 Jul 2014 21:54:05 +0200
Superseded in utopic-release on 2014-07-31
Deleted in utopic-proposed on 2014-08-02 (Reason: moved to release)
gdb (7.7.91.20140723-0ubuntu1) utopic; urgency=medium

  * Snapshot, taken from the 7.8 branch.
 -- Matthias Klose <email address hidden>   Wed, 23 Jul 2014 16:01:10 +0200
Superseded in utopic-release on 2014-07-23
Deleted in utopic-proposed on 2014-07-24 (Reason: moved to release)
gdb (7.7.1-0ubuntu5) utopic; urgency=medium

  * Fix regression introduced in previous upload, again supporting
    powerpc64le in the multilib build. LP: #1233185.
 -- Matthias Klose <email address hidden>   Wed, 23 Jul 2014 15:19:13 +0200

Available diffs

Superseded in trusty-proposed on 2014-10-30
gdb (7.7-0ubuntu3.2) trusty; urgency=medium

  [ Martin Pitt ]
  * debian/rules: Revert configuring with "MULTIARCH_TARGET=all" and go back
    to static list of targets. "all" is broken and does not work at least on
    ARM. (LP: #1233185)
 -- Brian Murray <email address hidden>   Mon, 30 Jun 2014 11:22:03 -0700

Available diffs

Superseded in utopic-release on 2014-07-23
Deleted in utopic-proposed on 2014-07-24 (Reason: moved to release)
gdb (7.7.1-0ubuntu4) utopic; urgency=medium

  [ Martin Pitt ]
  * debian/rules: Revert configuring with "MULTIARCH_TARGET=all" and go back
    to static list of targets. "all" is broken and does not work at least on
    ARM. (LP: #1233185)
 -- Brian Murray <email address hidden>   Mon, 30 Jun 2014 15:28:20 -0700

Available diffs

Superseded in utopic-release on 2014-07-01
Deleted in utopic-proposed on 2014-07-02 (Reason: moved to release)
gdb (7.7.1-0ubuntu3) utopic; urgency=medium

  * Fix PR 14963, infinite recursion in the demangler. LP: #1315590.
 -- Matthias Klose <email address hidden>   Thu, 12 Jun 2014 21:14:58 +0200

Available diffs

Superseded in utopic-release on 2014-06-12
Deleted in utopic-proposed on 2014-06-14 (Reason: moved to release)
gdb (7.7.1-0ubuntu2) utopic; urgency=medium

  * Add the ARM change from the gdb-linaro 7.7-2014.05 release.
  * Build-depend on systemtap-sdt-test (test dependency).
 -- Matthias Klose <email address hidden>   Tue, 27 May 2014 16:53:09 +0200

Available diffs

Superseded in utopic-release on 2014-05-27
Deleted in utopic-proposed on 2014-05-29 (Reason: moved to release)
gdb (7.7.1-0ubuntu1) utopic; urgency=medium

  * GDB 7.7.1 release.
 -- Matthias Klose <email address hidden>   Tue, 13 May 2014 02:23:53 +0200

Available diffs

  • diff from 7.7.1-1~nico1 (in Ubuntu) to 7.7.1-0ubuntu1 (pending)
  • diff from 7.7-0ubuntu2.1~aroth~ppa1~saucy1 (in Ubuntu) to 7.7.1-0ubuntu1 (pending)
  • diff from 7.7-0ubuntu4 to 7.7.1-0ubuntu1 (41.4 KiB)
175 of 179 results