gdm3 3.38.0-1ubuntu1 source package in Ubuntu

Changelog

gdm3 (3.38.0-1ubuntu1) groovy; urgency=medium

  * Merge with debian, containing new upstream release:
    - Crasher fix
    - build goo updates
    - systemd unit file improvements
    - Translation updates
  * debian/patches: Refreshed (removing applied one)
  * Remaining changes with debian:
    + README.Debian: update for correct paths in Ubuntu
    + control.in:
      - Don't recommend desktop-base
      - Build depend on libgudev-1.0-dev
      - Depend on bash for config_error_dialog.patch
      - Update Vcs field
      - Recomends libpam-fprintd (instead of Suggests)
    + rules:
      - Don't override default user/group
      - -Dgdm-xsession=true to install upstream Xsession script
      - override dh_installinit with --no-start to avoid session being killed
    + rules, README.Debian, gdm3.8.pod:
      Use upstream custom.conf instead of daemon.conf
    + gdm3.{postinst,postrm}: rename user and group back to gdm
    + gdm3.postinst, gdm3.prerm: don't kill gdm on upgrade
    + gdm3.*.pam: Make pam_env read ~/.pam_environment
    + gdm3.install:
      - Stop installing default.desktop. It adds unnecessary clutter
        ("System Default") to the session chooser.
      - Don't install debian/Xsession
    + Add run_xsession.d.patch
    + Add xresources_is_a_dir.patch
      - Fix loading from /etc/X11/Xresources/*
    + Add nvidia_prime.patch:
      - Add hook to run prime-offload (as root) and prime-switch if
        nvidia-prime is installed
    + Add revert_override_LANG_with_accountservices.patch:
      - On Ubuntu accountservices only stores the language and not the
        full locale as needed by LANG.
    + Add dont_set_language_env.patch:
      - Don't run the set_up_session_language() function, since it
        overrides variable values set by ~/.pam_environment
    + Add config_error_dialog.patch:
      - Show warning dialog in case of error in ~/.profile etc. and
        don't let a syntax error make the login fail
    + Add debian/patches/revert_nvidia_wayland_blacklist.patch:
      - Don't blacklist nvidia for wayland
    + Add gdm3.service-wait-for-drm-device-before-trying-to-start-i.patch:
      - Wait for the first valid gdm device on pre-start
    + Add debian/default.pa
      - Disable Bluetooth audio devices in PulseAudio from gdm3.
    + debian/gdm3.install
      - Added details of the default.pa file
    + debian/gdm3.postinst
      - Added installation of default.pa and creation of dir if it doesn't
        exist.
    + debian/greeter.dconf-defaults: Don't set Debian settings in the
      greeter's dconf DB

gdm3 (3.38.0-1) experimental; urgency=medium

  * Team upload
  * New upstream release
  * Remove patches that were applied upstream (in some cases differently)
  * Remove special case for s390x.
    gjs and gnome-shell now exist there, so we no longer need to avoid
    depending on them. In particular this makes the GNOME metapackages
    installable on that architecture again. (Closes: #970245)

gdm3 (3.37.90-2) experimental; urgency=medium

  * Team upload

  [ Simon McVittie ]
  * Add patch to remove deprecated StandardOutput=syslog from systemd unit
  * Build-Depend on systemd, for /usr/share/pkgconfig/systemd.pc

  [ Iain Lane ]
  * debian/control: Bump depends on gnome-{session,settings-daemon,shell}
    We require the newly rearranged systemd units that are in these
    versions.
  * debian/control: Make gdm depend on gnome-session-common ≥ 3.37.0-2~
    This is where the systemd units live now.

 -- Marco Trevisan (Treviño) <email address hidden>  Wed, 16 Sep 2020 11:01:05 +0200

Upload details

Uploaded by:
Marco Trevisan (Treviño) on 2020-09-16
Uploaded to:
Groovy
Original maintainer:
Ubuntu Developers
Architectures:
linux-any
Section:
gnome
Urgency:
Medium Urgency

See full publishing history Publishing

Series Pocket Published Component Section

Downloads

File Size SHA-256 Checksum
gdm3_3.38.0.orig.tar.xz 768.6 KiB 46d4415c39c94ccee81fbac21102e2ebcd284d39858c893e759900b1e88435ba
gdm3_3.38.0-1ubuntu1.debian.tar.xz 97.1 KiB 3901ae3db575e7ccd3c8b4558aeed99892562c1b7be52840a9e8e9cda8205660
gdm3_3.38.0-1ubuntu1.dsc 3.0 KiB 408940d02a5ff7603141d7a8d1c03ee1dfc09856e3f4cc52f03212b223fab45d

View changes file

Binary packages built by this source

gdm3: GNOME Display Manager

 GDM provides the equivalent of a "login:" prompt for X displays: it
 asks for a login and starts graphical sessions.
 .
 It supports multiple seats and switching between multiple users.
 .
 The greeter is based on the GNOME libraries and applications, and its
 look and design are the same as those of a GNOME session.

gdm3-dbgsym: debug symbols for gdm3
gir1.2-gdm-1.0: GObject introspection data for the GNOME Display Manager

 GDM provides the equivalent of a "login:" prompt for X displays: it
 asks for a login and starts graphical sessions.
 .
 It supports multiple seats and switching between multiple users.
 .
 The greeter is based on the GNOME libraries and applications, and its
 look and design are the same as those of a GNOME session.
 .
 This package contains introspection data for the GNOME Display Manager.

libgdm-dev: GNOME Display Manager (development files)

 GDM provides the equivalent of a "login:" prompt for X displays: it
 asks for a login and starts graphical sessions.
 .
 It supports multiple seats and switching between multiple users.
 .
 The greeter is based on the GNOME libraries and applications, and its
 look and design are the same as those of a GNOME session.
 .
 This package contains header and development files.

libgdm1: GNOME Display Manager (shared library)

 GDM provides the equivalent of a "login:" prompt for X displays: it
 asks for a login and starts graphical sessions.
 .
 It supports multiple seats and switching between multiple users.
 .
 The greeter is based on the GNOME libraries and applications, and its
 look and design are the same as those of a GNOME session.
 .
 This package contains the shared library required by gnome-shell.

libgdm1-dbgsym: debug symbols for libgdm1